- Remove unneeded else from for/else loop. It confuses pylint (bcl@redhat.com)
- Turn off pylint warning about docstring with backslash (bcl@redhat.com) - Turn off smartquotes in Sphinx documentation (bcl@redhat.com) - fixes #543 qemu -nodefconfig deprecated (afm404@gmail.com) - fix spinx build warnings (afm404@gmail.com) - Revert "lorax-composer: Cancel running Anaconda process" (bcl@redhat.com) - set inst.stage2 for ppc64le image (rhbz#1577587) (dan@danny.cz) - Allow customizations to be specified as a toml list (dshea@redhat.com) - Make sure cancel_func is not None (bcl@redhat.com) - drop ppc/ppc64 from tests (dan@danny.cz) - drop ppc/ppc64 from spec (dan@danny.cz) - all supported arches have docker (dan@danny.cz) - drop big endian ppc/ppc64 support (dan@danny.cz) - add qemu command mapping for ppc64le (dan@danny.cz) - don't reduce initrd size on ppc64/ppc64le (dan@danny.cz) - fbset has been retired (dan@danny.cz) - Add timestamps to program.log and dnf.log (bcl@redhat.com)
This commit is contained in:
parent
cbcdf63ec1
commit
238111ee20
1
.gitignore
vendored
1
.gitignore
vendored
@ -150,3 +150,4 @@
|
|||||||
/lorax-30.7.tar.gz
|
/lorax-30.7.tar.gz
|
||||||
/lorax-30.8.tar.gz
|
/lorax-30.8.tar.gz
|
||||||
/lorax-30.9.tar.gz
|
/lorax-30.9.tar.gz
|
||||||
|
/lorax-30.10.tar.gz
|
||||||
|
@ -1,68 +0,0 @@
|
|||||||
From a7c2d7d66b1a4df5b06a0c5b401558531199f791 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Adam Williamson <awilliam@redhat.com>
|
|
||||||
Date: Wed, 26 Sep 2018 18:14:06 -0700
|
|
||||||
Subject: [PATCH] Don't try to append to DNF config value that can't take it
|
|
||||||
|
|
||||||
See https://bugzilla.redhat.com/show_bug.cgi?id=1595917 and
|
|
||||||
https://github.com/rpm-software-management/dnf/pull/1200 for
|
|
||||||
more on this. Briefly, DNF before 3.0 presented this config
|
|
||||||
value as a list...and mutating it worked. DNF from 3.0 until
|
|
||||||
3.6 presented it as a list...mutating it didn't work, but also
|
|
||||||
didn't *fail*, so this has actually not been doing anything on
|
|
||||||
DNF 3.x but we haven't noticed.
|
|
||||||
|
|
||||||
In DNF 3.6 values like this are presented as tuples instead of
|
|
||||||
lists, to try and catch usages like this, and it worked! We
|
|
||||||
need to change this one.
|
|
||||||
|
|
||||||
There is an additional weirdness here. tsflags is actually, in
|
|
||||||
libdnf terms, an OptionStringListAppend option: that means that
|
|
||||||
when something tries to *set* its value, the new value is just
|
|
||||||
appended to the existing list of values. This is very weird
|
|
||||||
behaviour when you're interacting with it like this, but
|
|
||||||
happens to be quite useful, as we can just 'set' the value to
|
|
||||||
a list like this and it will actually get appended (which is
|
|
||||||
what we want), and this one syntax happens to work correctly in
|
|
||||||
DNF 2.x, 3.0 through 3.5.1, and 3.6.
|
|
||||||
|
|
||||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
|
||||||
---
|
|
||||||
src/pylorax/api/dnfbase.py | 5 ++++-
|
|
||||||
src/sbin/lorax | 5 ++++-
|
|
||||||
2 files changed, 8 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/pylorax/api/dnfbase.py b/src/pylorax/api/dnfbase.py
|
|
||||||
index b7a4d1c6..1d7f32cc 100644
|
|
||||||
--- a/src/pylorax/api/dnfbase.py
|
|
||||||
+++ b/src/pylorax/api/dnfbase.py
|
|
||||||
@@ -56,7 +56,10 @@ def get_base_object(conf):
|
|
||||||
dbc.reposdir = [repodir]
|
|
||||||
dbc.install_weak_deps = False
|
|
||||||
dbc.prepend_installroot('persistdir')
|
|
||||||
- dbc.tsflags.append('nodocs')
|
|
||||||
+ # this is a weird 'AppendOption' thing that, when you set it,
|
|
||||||
+ # actually appends. Doing this adds 'nodocs' to the existing list
|
|
||||||
+ # of values, over in libdnf, it does not replace the existing values.
|
|
||||||
+ dbc.tsflags = ['nodocs']
|
|
||||||
|
|
||||||
if conf.get_default("dnf", "proxy", None):
|
|
||||||
dbc.proxy = conf.get("dnf", "proxy")
|
|
||||||
diff --git a/src/sbin/lorax b/src/sbin/lorax
|
|
||||||
index 30b9cadc..2729757d 100755
|
|
||||||
--- a/src/sbin/lorax
|
|
||||||
+++ b/src/sbin/lorax
|
|
||||||
@@ -212,7 +212,10 @@ def get_dnf_base_object(installroot, sources, mirrorlists=None, repos=None,
|
|
||||||
conf.releasever = releasever
|
|
||||||
conf.installroot = installroot
|
|
||||||
conf.prepend_installroot('persistdir')
|
|
||||||
- conf.tsflags.append('nodocs')
|
|
||||||
+ # this is a weird 'AppendOption' thing that, when you set it,
|
|
||||||
+ # actually appends. Doing this adds 'nodocs' to the existing list
|
|
||||||
+ # of values, over in libdnf, it does not replace the existing values.
|
|
||||||
+ conf.tsflags = ['nodocs']
|
|
||||||
|
|
||||||
if proxy:
|
|
||||||
conf.proxy = proxy
|
|
||||||
--
|
|
||||||
2.19.0
|
|
||||||
|
|
23
lorax.spec
23
lorax.spec
@ -3,7 +3,7 @@
|
|||||||
%define debug_package %{nil}
|
%define debug_package %{nil}
|
||||||
|
|
||||||
Name: lorax
|
Name: lorax
|
||||||
Version: 30.9
|
Version: 30.10
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Tool for creating the anaconda install images
|
Summary: Tool for creating the anaconda install images
|
||||||
|
|
||||||
@ -62,7 +62,7 @@ Requires: hfsplus-tools
|
|||||||
Requires: syslinux >= 6.02-4
|
Requires: syslinux >= 6.02-4
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ifarch ppc ppc64 ppc64le
|
%ifarch ppc64le
|
||||||
Requires: grub2
|
Requires: grub2
|
||||||
Requires: grub2-tools
|
Requires: grub2-tools
|
||||||
%endif
|
%endif
|
||||||
@ -232,6 +232,25 @@ getent passwd weldr >/dev/null 2>&1 || useradd -r -g weldr -d / -s /sbin/nologin
|
|||||||
%{_sysconfdir}/bash_completion.d/composer-cli
|
%{_sysconfdir}/bash_completion.d/composer-cli
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 08 2019 Brian C. Lane <bcl@redhat.com> 30.10-1
|
||||||
|
- Remove unneeded else from for/else loop. It confuses pylint (bcl@redhat.com)
|
||||||
|
- Turn off pylint warning about docstring with backslash (bcl@redhat.com)
|
||||||
|
- Turn off smartquotes in Sphinx documentation (bcl@redhat.com)
|
||||||
|
- fixes #543 qemu -nodefconfig deprecated (afm404@gmail.com)
|
||||||
|
- fix spinx build warnings (afm404@gmail.com)
|
||||||
|
- Revert "lorax-composer: Cancel running Anaconda process" (bcl@redhat.com)
|
||||||
|
- set inst.stage2 for ppc64le image (rhbz#1577587) (dan@danny.cz)
|
||||||
|
- Allow customizations to be specified as a toml list (dshea@redhat.com)
|
||||||
|
- Make sure cancel_func is not None (bcl@redhat.com)
|
||||||
|
- drop ppc/ppc64 from tests (dan@danny.cz)
|
||||||
|
- drop ppc/ppc64 from spec (dan@danny.cz)
|
||||||
|
- all supported arches have docker (dan@danny.cz)
|
||||||
|
- drop big endian ppc/ppc64 support (dan@danny.cz)
|
||||||
|
- add qemu command mapping for ppc64le (dan@danny.cz)
|
||||||
|
- don't reduce initrd size on ppc64/ppc64le (dan@danny.cz)
|
||||||
|
- fbset has been retired (dan@danny.cz)
|
||||||
|
- Add timestamps to program.log and dnf.log (bcl@redhat.com)
|
||||||
|
|
||||||
* Mon Dec 17 2018 Brian C. Lane <bcl@redhat.com> 30.9-1
|
* Mon Dec 17 2018 Brian C. Lane <bcl@redhat.com> 30.9-1
|
||||||
- lorax: Save information about rootfs filesystem size and usage (bcl@redhat.com)
|
- lorax: Save information about rootfs filesystem size and usage (bcl@redhat.com)
|
||||||
- Turn on signed tags when using tito. (bcl@redhat.com)
|
- Turn on signed tags when using tito. (bcl@redhat.com)
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (lorax-30.9.tar.gz) = 0f980d50c47340858ff5df35ced078573960f15788e3a8d9003dd72025104af3635955eecc0f617781f79d2a7a5e5c50ace95d261ee2f28c1281f9408a5166b4
|
SHA512 (lorax-30.10.tar.gz) = 1f096778584e656e3fc3b9787264f5170219d7d0d4876430df536d420c24efd72efd6113da2f95edefc76cda5949e67da2a5aa7bba9171fc372cdfff49b25f07
|
||||||
|
Loading…
Reference in New Issue
Block a user