- Update to upstream 34.5 from rhel9-branch

NOTE: This branch includes the extra patches that were in this repo
- Add README.md describing how this package is maintained
This commit is contained in:
Brian C. Lane 2020-12-02 11:46:37 -08:00
parent ec25461099
commit 12113ae612
6 changed files with 32 additions and 69 deletions

1
.gitignore vendored
View File

@ -189,3 +189,4 @@
/lorax-34.1.tar.gz
/lorax-34.2.tar.gz
/lorax-34.3.tar.gz
/lorax-34.5.tar.gz

View File

@ -1,32 +0,0 @@
From 787ac30c410e342b496d589bed142e474a467d54 Mon Sep 17 00:00:00 2001
From: Stephen Gallagher <sgallagh@redhat.com>
Date: Wed, 28 Oct 2020 08:41:04 -0400
Subject: [PATCH] Change rootfs default size to 3GiB
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
---
src/pylorax/cmdline.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/pylorax/cmdline.py b/src/pylorax/cmdline.py
index 59e851d3d46523f6cb82cd2796309f13c38d44c8..4ac7934b74667884f0be41df58f2762cd9a79081 100644
--- a/src/pylorax/cmdline.py
+++ b/src/pylorax/cmdline.py
@@ -101,12 +101,12 @@ def lorax_parser(dracut_default=""):
help="Directory containing all the templates. Overrides config file sharedir")
optional.add_argument("--enablerepo", action="append", default=[], dest="enablerepos",
metavar="[repo]", help="Names of repos to enable")
optional.add_argument("--disablerepo", action="append", default=[], dest="disablerepos",
metavar="[repo]", help="Names of repos to disable")
- optional.add_argument("--rootfs-size", type=int, default=2,
- help="Size of root filesystem in GiB. Defaults to 2.")
+ optional.add_argument("--rootfs-size", type=int, default=3,
+ help="Size of root filesystem in GiB. Defaults to 3.")
optional.add_argument("--noverifyssl", action="store_true", default=False,
help="Do not verify SSL certificates")
optional.add_argument("--dnfplugin", action="append", default=[], dest="dnfplugins",
help="Enable a DNF plugin by name/glob, or * to enable all of them.")
optional.add_argument("--squashfs-only", action="store_true", default=False,
--
2.28.0

View File

@ -1,28 +0,0 @@
From fe44b3013b732c6523f673cd65e6ab2bf83760b7 Mon Sep 17 00:00:00 2001
From: "Brian C. Lane" <bcl@redhat.com>
Date: Thu, 29 Oct 2020 09:00:16 -0700
Subject: [PATCH] lorax: Strip ' from product cmdline argument
Temporary work around pungi issue:
https://pagure.io/pungi/pull-request/1463
---
src/sbin/lorax | 3 +++
1 file changed, 3 insertions(+)
diff --git a/src/sbin/lorax b/src/sbin/lorax
index 5f8fb882..ea3ba28a 100755
--- a/src/sbin/lorax
+++ b/src/sbin/lorax
@@ -97,6 +97,9 @@ def main():
parser = lorax_parser(DRACUT_DEFAULT)
opts = parser.parse_args()
+ # XXX Temporary workaround for https://pagure.io/pungi/pull-request/1463
+ opts.product = opts.product.strip("'")
+
log.info("Lorax v%s", pylorax.vernum)
if not opts.source and not opts.repos:
--
2.26.2

9
README.md Normal file
View File

@ -0,0 +1,9 @@
12/2/2020 bcl
lorax is now being manually updated from the rhel9-branch of the project, found here:
https://github.com/weldr/lorax
Builds will have .el9 added to their tag to differentiate them from Fedora builds.
Eventually we will branch from fedora and start using a .Z version the same way we do for RHEL8,
but currently we are not doing that.

View File

@ -3,8 +3,8 @@
%define debug_package %{nil}
Name: lorax
Version: 34.3
Release: 4%{?dist}
Version: 34.5
Release: 1%{?dist}
Summary: Tool for creating the anaconda install images
License: GPLv2+
@ -15,11 +15,6 @@ URL: https://github.com/weldr/lorax
# tito build --tgz
Source0: %{name}-%{version}.tar.gz
# Increase boot.iso rootfs to 3GiB rhbz#1661169
Patch0000: 0001-Change-rootfs-default-size-to-3GiB.patch
# Work around pungi bug https://pagure.io/pungi/pull-request/1463
Patch0001: 0002-lorax-Strip-from-product-cmdline-argument.patch
BuildRequires: python3-devel
BuildRequires: make
BuildRequires: systemd-rpm-macros
@ -81,6 +76,7 @@ Requires: grub2-tools
%ifarch s390 s390x
Requires: openssh
Requires: s390utils >= 2.15.0-2
%endif
%ifarch %{arm}
@ -174,7 +170,6 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
%{_sbindir}/livemedia-creator
%{_sbindir}/mkksiso
%{_bindir}/image-minimizer
%{_bindir}/mk-s390-cdboot
%dir %{_sysconfdir}/lorax
%config(noreplace) %{_sysconfdir}/lorax/lorax.conf
%dir %{_datadir}/lorax
@ -201,6 +196,24 @@ make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
%{_mandir}/man1/composer-cli.1*
%changelog
* Mon Nov 30 2020 Brian C. Lane <bcl@redhat.com> 34.5-1
- Don't remove libldap_r libraries during runtime-cleanup.tmpl (spichugi@redhat.com)
- Do not use '--loglevel' option when running Anaconda (vtrefny@redhat.com)
- Makefile: quiet rsync use in testing (bcl@redhat.com)
- Switch to using GitHub Actions instead of Travis CI (bcl@redhat.com)
* Mon Nov 02 2020 Brian C. Lane <bcl@redhat.com> 34.4-1
- Update the default release version to 34 (bcl@redhat.com)
- Remove mdmonitor service from boot.iso (bcl@redhat.com)
- Switch to using upstream mk-s390image for s390 cdboot.img creation (bcl@redhat.com)
- sshd_config: Apply suggested changes (bcl@redhat.com)
- lorax.spec: Add BuildRequires on systemd-rpm-macros for tmpfilesdir macro (bcl@redhat.com)
* Wed Dec 02 2020 Brian C. Lane <bcl@redhat.com> 34.3-4
- lorax.spec: Update for RHEL 9 Alpha changes (bcl@redhat.com)
- lorax: Strip ' from product cmdline argument (bcl@redhat.com)
- Change rootfs default size to 3GiB (sgallagh@redhat.com)
* Thu Oct 29 2020 Brian C. Lane <bcl@redhat.com> - 34.3-4
- Drop unused proc/mount patch
- lorax: Strip ' from product cmdline argument

View File

@ -1 +1 @@
SHA512 (lorax-34.3.tar.gz) = 7953664ca44c2591b2245ffdd58c004a623135ee540d4835f737f90361cc53ae903ba7f8f5d0ae45f6eff7d64144b3301e6cc16930c68c20d8d6fed91e1e9179
SHA512 (lorax-34.5.tar.gz) = a5507727c8d333cbae6362bf21e69f419ec7a211c2d5039fceae51207e4a95161b522c46932b5e7148ec308eb676cc83240f9cae6685934687e9d3048d2bd881