Merge branch 'master' of ssh://pkgs.fedoraproject.org/logrotate

Conflicts:
	logrotate.spec
This commit is contained in:
Jan Kaluza 2011-08-01 09:00:26 +02:00
commit a6b37c7f6b
2 changed files with 53 additions and 4 deletions

View File

@ -0,0 +1,44 @@
Index: trunk/config.c
===================================================================
--- trunk/config.c (revision 334)
+++ trunk/config.c (working copy)
@@ -891,7 +891,6 @@
if ((key = isolateValue(configFile, lineNum, opt, &start,
&buf, length)) != NULL) {
- free(opt);
int l = strlen(key) - 1;
if (key[l] == 'k') {
key[l] = '\0';
@@ -903,6 +902,7 @@
key[l] = '\0';
multiplier = 1024 * 1024 * 1024;
} else if (!isdigit(key[l])) {
+ free(opt);
message(MESS_ERROR, "%s:%d unknown unit '%c'\n",
configFile, lineNum, key[l]);
if (newlog != defConfig) {
@@ -919,6 +919,7 @@
if (*chptr) {
message(MESS_ERROR, "%s:%d bad size '%s'\n",
configFile, lineNum, key);
+ free(opt);
if (newlog != defConfig) {
state = STATE_ERROR;
continue;
@@ -926,11 +927,13 @@
goto error;
}
}
- if (!strncmp(key, "size", 4)) {
+ if (!strncmp(opt, "size", 4)) {
newlog->criterium = ROT_SIZE;
newlog->threshhold = size;
- } else
+ } else {
newlog->minsize = size;
+ }
+ free(opt);
}
else {
free(opt);

View File

@ -1,13 +1,14 @@
Summary: Rotates, compresses, removes and mails system log files
Name: logrotate
Version: 3.8.0
Release: 3%{?dist}
Release: 4%{?dist}
License: GPL+
Group: System Environment/Base
Url: https://fedorahosted.org/logrotate/
Source: https://fedorahosted.org/releases/l/o/logrotate/logrotate-%{version}.tar.gz
Patch0: logrotate-3.8.0-no-cron-redirection.patch
Patch1: logrotate-3.8.0-handle-acl-not-supported.patch
Patch1: logrotate-3.8.0-rot-size.patch
Patch2: logrotate-3.8.0-handle-acl-not-supported.patch
Requires: coreutils >= 5.92 libsepol libselinux popt libacl
BuildRequires: libselinux-devel popt-devel libacl-devel
@ -28,7 +29,8 @@ log files on your system.
%setup -q
%patch0 -p1
%patch1
%patch1 -p1
%patch2
%build
make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" WITH_SELINUX=yes WITH_ACL=yes
@ -59,10 +61,13 @@ rm -rf $RPM_BUILD_ROOT
%attr(0644, root, root) %verify(not size md5 mtime) %config(noreplace) %{_localstatedir}/lib/logrotate.status
%changelog
* Wed Aug 01 2011 Jan Kaluza <jkaluza@redhat.com> 3.8.0-3
* Wed Aug 01 2011 Jan Kaluza <jkaluza@redhat.com> 3.8.0-4
- fix #726980 - work properly when acl_get_fd is supported,
but acl_set_fd is not
* Fri Jul 22 2011 Jan Kaluza <jkaluza@redhat.com> 3.8.0-3
- fix #723547 - fixed size directive parsing
* Wed Jul 20 2011 Jan Kaluza <jkaluza@redhat.com> 3.8.0-2
- fix #722825 - do not redirect logrotate output in cron script