new upstream version 3.11.0

This commit is contained in:
Kamil Dudka 2016-12-02 15:10:06 +01:00
parent 3799546edf
commit 71254b3676
4 changed files with 24 additions and 99 deletions

View File

@ -1,90 +0,0 @@
From eba6c5376e707d2ca0b9c40ea2387c19e8db1c5c Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Wed, 23 Nov 2016 17:55:20 +0100
Subject: [PATCH] configure --with-state-file: specify default state file
Closes #85
Upstream-commit: 72827266598b7c1c58e785069e955dea3523cc59
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
---
config.h | 6 +++---
configure.ac | 17 +++++++++++++++++
logrotate.8 | 2 +-
3 files changed, 21 insertions(+), 4 deletions(-)
diff --git a/config.h b/config.h
index d715c5a..6740878 100644
--- a/config.h
+++ b/config.h
@@ -8,23 +8,23 @@
#define DEFAULT_MAIL_COMMAND "/usr/bin/mailx"
#define COMPRESS_COMMAND "/usr/contrib/bin/gzip"
#define UNCOMPRESS_COMMAND "/usr/contrib/bin/gunzip"
+#ifndef STATEFILE
#define STATEFILE "/var/run/logrotate.status"
+#endif /* STATEFILE */
#endif
#ifdef SunOS
#define DEFAULT_MAIL_COMMAND "/usr/bin/mailx"
-#define STATEFILE "/var/log/logrotate.status"
#endif
#ifdef __NetBSD__
#define DEFAULT_MAIL_COMMAND "/usr/bin/mail -s"
#define COMPRESS_COMMAND "/usr/bin/gzip"
#define UNCOMPRESS_COMMAND "/usr/bin/gunzip"
-#define STATEFILE "/var/log/logrotate.status"
#endif
/*
- * Default settings for Linux - leave these last.
+ * Default settings (mainly for Linux) - leave these last.
*/
#ifndef DEFAULT_MAIL_COMMAND
#define DEFAULT_MAIL_COMMAND "/bin/mail"
diff --git a/configure.ac b/configure.ac
index a6580f1..63c016c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,23 @@ AS_CASE(["$with_acl"],
AS_IF([test "$ac_cv_lib_acl_acl_get_file" = yes],
echo "1" > ./test/test.ACL;, echo "0" > ./test/test.ACL;)
+AC_ARG_WITH([state-file-path],
+ AC_HELP_STRING([--with-state-file-path=PATH],
+ [path to state file (/var/lib/logrotate.status by default)]),
+ [
+ case "$withval" in
+ yes|no)
+ AC_MSG_ERROR([--with-state-file-path=PATH requires a path to be specified])
+ ;;
+ *)
+ STATE_FILE_PATH="$withval"
+ ;;
+ esac
+ ],
+ [
+ STATE_FILE_PATH="/var/lib/logrotate.status"
+ ])
+AC_DEFINE_UNQUOTED([STATEFILE], "$STATE_FILE_PATH")
AC_CHECK_FUNCS([strptime qsort fork vfork madvise vsyslog])
diff --git a/logrotate.8 b/logrotate.8
index 3f30472..77fdd4b 100644
--- a/logrotate.8
+++ b/logrotate.8
@@ -558,7 +558,7 @@ Log files are rotated if the current year is not the same as the last rotation.
.SH FILES
.PD 0
.TP 27
-\fI/var/lib/logrotate.status\fR
+\fI/var/lib/logrotate/logrotate.status\fR
Default state file.
.TP 27
\fI/etc/logrotate.conf\fR
--
2.7.4

View File

@ -0,0 +1,16 @@
-----BEGIN PGP SIGNATURE-----
iQIcBAABCAAGBQJYQXeHAAoJEIc9s3Vyo3s2PMEQAJqsOc64nt25Ngzy5csTZmbL
xzfi7qh29Ook3BSpa/FOcXBi0wVFXqjNag/9lkiefs5XbQItIJieQFraEBzc/Q9g
HU4wwdRKirkrUO2OkUASTs0UBkleGtuIKk1mfkbg/xKYTzfWYGFBuDUvqe4wRBfc
DGZXrRfl8be/xDL+o1nxwGe3AFbM6ZLr902G++shWECs8RhBwPiKSG+MZxCfCLvP
+7sHujZmPeDJ++Sl15XWOAsSHaz2+AX5fIpjeHmIkkPFi21XX0uKpwgXqGV2+yQ/
ERXEl1xG2HELeXdwA61/zklOwopDSym/I8//wOBmUeuP1KkbwWWpYTHp+0yCasK7
3ei7NzgOMJTi9WyyEoWzeJzVDdJhNQMpEcaLNlgADETqlm4KtUuHOHdJNSWT7NXN
R8a/RCQS2EXuqYBl5cQ7CdPxFKM4drHn4UeDlb8ZeiBsyF2PC8YAnHJ0eDzJrrh2
JpmJ8B8bLEEbD1TKTEyVtHtUEtstjnj3kibnL7tiCnR0KiAohm53bSuWt4ICDXZ4
Pk30FKH2UeoHLADVNyBcb1rTgruzmuAbWSr5hNXK7H4ikcsv3UULD4Py1//ktPUb
vbvWD54wcIn1m44qGHtyU9hd2e1Ozr60xsNzbbn4g8UjNbSlXHpXBhYLWPWpqtHj
43HYc2GBZa9dhj7LLvcf
=Jofv
-----END PGP SIGNATURE-----

View File

@ -1,15 +1,12 @@
Summary: Rotates, compresses, removes and mails system log files
Name: logrotate
Version: 3.10.0
Release: 4%{?dist}
Version: 3.11.0
Release: 1%{?dist}
License: GPL+
Url: https://github.com/logrotate/logrotate
Source: https://github.com/logrotate/logrotate/releases/download/%{version}/logrotate-%{version}.tar.xz
Source1: rwtab
# implement the --with-state-file-path option of configure (upstream patch)
Patch0: logrotate-3.10.0-state-file-path.patch
BuildRequires: acl
BuildRequires: automake
BuildRequires: git
@ -38,8 +35,7 @@ git commit -m "update .gitignore"
autoreconf -fiv
git add configure
git checkout INSTALL
git commit -m "regenerate ./configure"
git commit -m "force autoreconf" --allow-empty
%build
%configure --with-state-file-path=%{_localstatedir}/lib/logrotate/logrotate.status
@ -75,7 +71,7 @@ fi
%files
%{!?_licensedir:%global license %%doc}
%license COPYING
%doc CHANGES
%doc ChangeLog.md
%{_sbindir}/logrotate
%{_mandir}/man8/logrotate.8*
%{_mandir}/man5/logrotate.conf.5*
@ -87,6 +83,9 @@ fi
%config(noreplace) %{_sysconfdir}/rwtab.d/logrotate
%changelog
* Fri Dec 02 2016 Kamil Dudka <kdudka@redhat.com> - 3.11.0-1
- new upstream version 3.11.0
* Thu Nov 24 2016 Kamil Dudka <kdudka@redhat.com> - 3.10.0-4
- make /var/lib/logrotate/logrotate.status the default state file (#1381719)

View File

@ -1 +1 @@
812705ff58ad308c82b1a6fac1031949 logrotate-3.10.0.tar.xz
3a9280e4caeb837427a2d54518fbcdac logrotate-3.11.0.tar.xz