lockdev/lockdev-1.0.0-shared.patch
kzak ef050c9098 - refresh patches (due --fuzz=0)
- fix compiler warnings
2008-10-06 09:37:43 +00:00

22 lines
681 B
Diff

Index: lockdev-1.0.1/Makefile
===================================================================
--- lockdev-1.0.1.orig/Makefile
+++ lockdev-1.0.1/Makefile
@@ -12,7 +12,7 @@ VER = $(shell expr `pwd` : '.*-\([0-9.]*
MVER = ${shell expr `pwd` : '.*-\([0-9]*\).[0-9]*'}
static = ${libname}.a
-shared = ${libname}.${VER}.so
+shared = ${libname}.so.${VER}
soname = ${libname}.so.${MVER}
# overwritten by caller (e.g.: debian/rules)
@@ -77,6 +77,7 @@ install_doc: docs/lockdev.3
install_run: ${shared}
install -m755 -d ${libdir}
install -m755 ${shared} ${libdir}
+ ln -s ${shared} ${libdir}/liblockdev.so
install -m755 -d ${sbindir}
install -m755 lockdev ${sbindir}