auto-import changelog data from lockdev-1.0.1-1.3.src.rpm
Tue Sep 09 2003 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-1.3 - rebuild Mon Sep 08 2003 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-1.2 - rebuild Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 1.0.1-1.1 - bump n-v-r for 3.0E Fri Aug 15 2003 Adrian Havill <havill@redhat.com> 1.0.1-1 - bumped version - make the dev rewrite work with ttys in the /dev/input subdir, not just the base level dir (#98160) Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> - rebuilt
This commit is contained in:
parent
6136e045be
commit
e29365d576
@ -1 +1 @@
|
||||
lockdev_1.0.0.tar.gz
|
||||
lockdev_1.0.1.orig.tar.gz
|
||||
|
28
lockdev-1.0.1-checkname.patch
Normal file
28
lockdev-1.0.1-checkname.patch
Normal file
@ -0,0 +1,28 @@
|
||||
--- lockdev-1.0.1/src/lockdev.c.orig 2003-08-18 17:13:31.000000000 -0400
|
||||
+++ lockdev-1.0.1/src/lockdev.c 2003-08-18 17:13:43.000000000 -0400
|
||||
@@ -487,17 +487,18 @@
|
||||
* maybe we should check it and do something if not?
|
||||
*/
|
||||
p = devname; /* only a filename */
|
||||
- while ( (m=strrchr( p, '/')) != 0 ) {
|
||||
- p = m+1; /* was pointing to the slash */
|
||||
+ p += strspn(p, " \t\r\n\v\f\a"); /* skip leading whitespace */
|
||||
+ if (strncmp(p, DEV_PATH, strlen(DEV_PATH)) == 0) {
|
||||
+ p += strlen(DEV_PATH); /* 1st char after slash */
|
||||
_debug( 3, "_dl_check_devname(%s) name = %s\n", devname, p);
|
||||
if ( strcmp( p, "tty") == 0 )
|
||||
p = ttyname( 0); /* this terminal, if it exists */
|
||||
}
|
||||
- if ( ((l=strlen( p)) == 0 ) || ( l > (MAXPATHLEN - strlen(LOCK_PATH)) ))
|
||||
- return 0;
|
||||
- if ( ! (m = malloc( 1 + l)) )
|
||||
- return 0;
|
||||
- return strcpy( m, p);
|
||||
+ if (((l = strlen(p)) == 0) || (l > (MAXPATHLEN - strlen(LOCK_PATH))))
|
||||
+ return NULL;
|
||||
+ if ((m = malloc(++l)) == NULL)
|
||||
+ return NULL;
|
||||
+ return strcpy(m, p);
|
||||
}
|
||||
|
||||
|
25
lockdev.spec
25
lockdev.spec
@ -1,14 +1,15 @@
|
||||
Summary: A library for locking devices.
|
||||
Name: lockdev
|
||||
Version: 1.0.0
|
||||
Release: 23
|
||||
Version: 1.0.1
|
||||
Release: 1.3
|
||||
License: LGPL
|
||||
Group: System Environment/Libraries
|
||||
Source: ftp://ftp.debian.org/debian/dists/woody/main/source/libs/lockdev_1.0.0.tar.gz
|
||||
Source: http://ftp.debian.org/debian/pool/main/l/lockdev/%{name}_%{version}.orig.tar.gz
|
||||
Patch0: lockdev-1.0.0-rh.patch
|
||||
Patch1: lockdev-1.0.0-shared.patch
|
||||
Patch2: lockdev-1.0.0-signal.patch
|
||||
Patch3: lockdev-1.0.0-cli.patch
|
||||
Patch4: lockdev-1.0.1-checkname.patch
|
||||
Prereq: shadow-utils, filesystem >= 2.1.4-1
|
||||
BuildRoot: %{_tmppath}/%{name}-root
|
||||
|
||||
@ -32,6 +33,7 @@ package contains the development headers and a static library.
|
||||
%patch1 -p1 -b .shared
|
||||
%patch2 -p1 -b .signal
|
||||
%patch3 -p1 -b .jbj
|
||||
%patch4 -p1 -b .checkname
|
||||
|
||||
%build
|
||||
make "CFLAGS=${RPM_OPT_FLAGS} -fPIC"
|
||||
@ -71,6 +73,23 @@ rm -fr $RPM_BUILD_ROOT
|
||||
%{_includedir}/*
|
||||
|
||||
%changelog
|
||||
* Tue Sep 9 2003 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-1.3
|
||||
- rebuild
|
||||
|
||||
* Mon Sep 8 2003 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-1.2
|
||||
- rebuild
|
||||
|
||||
* Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 1.0.1-1.1
|
||||
- bump n-v-r for 3.0E
|
||||
|
||||
* Fri Aug 15 2003 Adrian Havill <havill@redhat.com> 1.0.1-1
|
||||
- bumped version
|
||||
- make the dev rewrite work with ttys in the /dev/input subdir, not just
|
||||
the base level dir (#98160)
|
||||
|
||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Tue Feb 04 2003 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- add symlink to shared lib
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user