Update to 0.9.17
This commit is contained in:
parent
42b87f5d34
commit
feea73e75d
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
|||||||
/lmdb-0.9.13.tar.gz
|
/lmdb-0.9.13.tar.gz
|
||||||
/lmdb-0.9.14.tar.gz
|
/lmdb-0.9.14.tar.gz
|
||||||
/LMDB_0.9.16.tar.gz
|
/LMDB_0.9.16.tar.gz
|
||||||
|
/LMDB_0.9.17.tar.gz
|
||||||
|
@ -1,14 +1,15 @@
|
|||||||
# Patch the main Makefile to allow for a build that complies to packaging guidelines.
|
# Patch the main Makefile to allow for a build that complies to packaging guidelines.
|
||||||
|
|
||||||
diff -up lmdb-LMDB_0.9.16/libraries/liblmdb/Makefile.upstream lmdb-LMDB_0.9.16/libraries/liblmdb/Makefile
|
diff -up lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile.orig lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile
|
||||||
--- lmdb-LMDB_0.9.16/libraries/liblmdb/Makefile.upstream 2015-08-14 10:59:31.179144608 +0200
|
--- lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile.orig 2015-11-30 17:55:33.000000000 +0100
|
||||||
+++ lmdb-LMDB_0.9.16/libraries/liblmdb/Makefile 2015-08-14 11:05:57.763026045 +0200
|
+++ lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile 2015-12-03 09:31:02.901378809 +0100
|
||||||
@@ -24,25 +24,30 @@ OPT = -O2 -g
|
@@ -26,13 +26,17 @@ OPT = -O2 -g
|
||||||
CFLAGS = $(THREADS) $(OPT) $(W) $(XCFLAGS)
|
CFLAGS = $(THREADS) $(OPT) $(W) $(XCFLAGS)
|
||||||
LDLIBS =
|
LDLIBS =
|
||||||
SOLIBS =
|
SOLIBS =
|
||||||
+SOVERSION = 0.0.0
|
+SOVERSION = 0.0.0
|
||||||
prefix = /usr/local
|
prefix = /usr/local
|
||||||
|
-mandir = $(prefix)/man
|
||||||
+binprefix = $(prefix)/bin
|
+binprefix = $(prefix)/bin
|
||||||
+libprefix = $(prefix)/lib
|
+libprefix = $(prefix)/lib
|
||||||
+includeprefix = $(prefix)/include
|
+includeprefix = $(prefix)/include
|
||||||
@ -22,15 +23,16 @@ diff -up lmdb-LMDB_0.9.16/libraries/liblmdb/Makefile.upstream lmdb-LMDB_0.9.16/l
|
|||||||
IPROGS = mdb_stat mdb_copy mdb_dump mdb_load
|
IPROGS = mdb_stat mdb_copy mdb_dump mdb_load
|
||||||
IDOCS = mdb_stat.1 mdb_copy.1 mdb_dump.1 mdb_load.1
|
IDOCS = mdb_stat.1 mdb_copy.1 mdb_dump.1 mdb_load.1
|
||||||
PROGS = $(IPROGS) mtest mtest2 mtest3 mtest4 mtest5
|
PROGS = $(IPROGS) mtest mtest2 mtest3 mtest4 mtest5
|
||||||
all: $(ILIBS) $(PROGS)
|
@@ -43,13 +47,13 @@ install: $(ILIBS) $(IPROGS) $(IHDRS)
|
||||||
|
mkdir -p $(DESTDIR)$(prefix)/lib
|
||||||
install: $(ILIBS) $(IPROGS) $(IHDRS)
|
mkdir -p $(DESTDIR)$(prefix)/include
|
||||||
|
mkdir -p $(DESTDIR)$(prefix)/man/man1
|
||||||
- for f in $(IPROGS); do cp $$f $(DESTDIR)$(prefix)/bin; done
|
- for f in $(IPROGS); do cp $$f $(DESTDIR)$(prefix)/bin; done
|
||||||
- for f in $(ILIBS); do cp $$f $(DESTDIR)$(prefix)/lib; done
|
- for f in $(ILIBS); do cp $$f $(DESTDIR)$(prefix)/lib; done
|
||||||
- for f in $(IHDRS); do cp $$f $(DESTDIR)$(prefix)/include; done
|
- for f in $(IHDRS); do cp $$f $(DESTDIR)$(prefix)/include; done
|
||||||
- for f in $(IDOCS); do cp $$f $(DESTDIR)$(prefix)/man/man1; done
|
- for f in $(IDOCS); do cp $$f $(DESTDIR)$(mandir)/man1; done
|
||||||
+ for f in $(IPROGS); do cp $$f $(DESTDIR)$(binprefix); done
|
+ for f in $(IPROGS); do cp $$f $(DESTDIR)$(binprefix); done
|
||||||
+ for f in $(ILIBS); do cp -d $$f $(DESTDIR)$(libprefix); done
|
+ for f in $(ILIBS); do cp $$f $(DESTDIR)$(libprefix); done
|
||||||
+ for f in $(IHDRS); do cp $$f $(DESTDIR)$(includeprefix); done
|
+ for f in $(IHDRS); do cp $$f $(DESTDIR)$(includeprefix); done
|
||||||
+ for f in $(IDOCS); do cp $$f $(DESTDIR)$(manprefix)/man1; done
|
+ for f in $(IDOCS); do cp $$f $(DESTDIR)$(manprefix)/man1; done
|
||||||
|
|
||||||
@ -40,9 +42,9 @@ diff -up lmdb-LMDB_0.9.16/libraries/liblmdb/Makefile.upstream lmdb-LMDB_0.9.16/l
|
|||||||
|
|
||||||
test: all
|
test: all
|
||||||
rm -rf testdb && mkdir testdb
|
rm -rf testdb && mkdir testdb
|
||||||
@@ -51,20 +56,24 @@ test: all
|
@@ -58,20 +62,24 @@ test: all
|
||||||
liblmdb.a: mdb.o midl.o
|
liblmdb.a: mdb.o midl.o
|
||||||
ar rs $@ mdb.o midl.o
|
$(AR) rs $@ mdb.o midl.o
|
||||||
|
|
||||||
-liblmdb.so: mdb.lo midl.lo
|
-liblmdb.so: mdb.lo midl.lo
|
||||||
+liblmdb.so: liblmdb.so.$(SOVERSION)
|
+liblmdb.so: liblmdb.so.$(SOVERSION)
|
||||||
|
@ -1,9 +1,9 @@
|
|||||||
# The s390 architecture needs a pause before accessing the test DB.
|
# The s390 architecture needs a pause before accessing the test DB.
|
||||||
|
|
||||||
diff -up lmdb-LMDB_0.9.16/libraries/liblmdb/Makefile.old lmdb-LMDB_0.9.16/libraries/liblmdb/Makefile
|
diff -up lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile.orig lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile
|
||||||
--- lmdb-LMDB_0.9.16/libraries/liblmdb/Makefile.old 2015-08-14 11:08:02.226631788 +0200
|
--- lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile.orig 2015-12-03 09:21:35.621480706 +0100
|
||||||
+++ lmdb-LMDB_0.9.16/libraries/liblmdb/Makefile 2015-08-14 11:08:58.618906240 +0200
|
+++ lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile 2015-12-03 09:22:10.069644210 +0100
|
||||||
@@ -51,7 +51,7 @@ clean:
|
@@ -57,7 +57,7 @@ clean:
|
||||||
|
|
||||||
test: all
|
test: all
|
||||||
rm -rf testdb && mkdir testdb
|
rm -rf testdb && mkdir testdb
|
||||||
@ -11,4 +11,4 @@ diff -up lmdb-LMDB_0.9.16/libraries/liblmdb/Makefile.old lmdb-LMDB_0.9.16/librar
|
|||||||
+ ./mtest && sleep 1 && ./mdb_stat testdb
|
+ ./mtest && sleep 1 && ./mdb_stat testdb
|
||||||
|
|
||||||
liblmdb.a: mdb.o midl.o
|
liblmdb.a: mdb.o midl.o
|
||||||
ar rs $@ mdb.o midl.o
|
$(AR) rs $@ mdb.o midl.o
|
||||||
|
@ -2,8 +2,8 @@
|
|||||||
%global archive_path libraries/lib%{name}
|
%global archive_path libraries/lib%{name}
|
||||||
|
|
||||||
Name: lmdb
|
Name: lmdb
|
||||||
Version: 0.9.16
|
Version: 0.9.17
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Memory-mapped key-value database
|
Summary: Memory-mapped key-value database
|
||||||
|
|
||||||
License: OpenLDAP
|
License: OpenLDAP
|
||||||
@ -104,6 +104,9 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 03 2015 Jan Staněk <jstanek@redhat.com> - 0.9.17-1
|
||||||
|
- Update to 0.9.17
|
||||||
|
|
||||||
* Wed Nov 25 2015 Jan Staněk <jstanek@redhat.com> - 0.9.16-2
|
* Wed Nov 25 2015 Jan Staněk <jstanek@redhat.com> - 0.9.16-2
|
||||||
- Return the name 'Symas' into description
|
- Return the name 'Symas' into description
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user