Update to 0.9.18
This commit is contained in:
parent
f4bde928dc
commit
f9f9caccc7
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
|||||||
/lmdb-0.9.14.tar.gz
|
/lmdb-0.9.14.tar.gz
|
||||||
/LMDB_0.9.16.tar.gz
|
/LMDB_0.9.16.tar.gz
|
||||||
/LMDB_0.9.17.tar.gz
|
/LMDB_0.9.17.tar.gz
|
||||||
|
/LMDB_0.9.18.tar.gz
|
||||||
|
@ -1,20 +1,17 @@
|
|||||||
# Patch the main Makefile to allow for a build that complies to packaging guidelines.
|
# Patch the main Makefile to allow for a build that complies to packaging guidelines.
|
||||||
|
|
||||||
diff -up lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile.orig lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile
|
diff -up lmdb-LMDB_0.9.18/libraries/liblmdb/Makefile.oldmake lmdb-LMDB_0.9.18/libraries/liblmdb/Makefile
|
||||||
--- lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile.orig 2015-11-30 17:55:33.000000000 +0100
|
--- lmdb-LMDB_0.9.18/libraries/liblmdb/Makefile.oldmake 2016-02-10 11:25:58.609614905 +0100
|
||||||
+++ lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile 2015-12-03 09:31:02.901378809 +0100
|
+++ lmdb-LMDB_0.9.18/libraries/liblmdb/Makefile 2016-02-10 11:28:27.100398910 +0100
|
||||||
@@ -26,13 +26,17 @@ OPT = -O2 -g
|
@@ -26,6 +26,7 @@ OPT = -O2 -g
|
||||||
CFLAGS = $(THREADS) $(OPT) $(W) $(XCFLAGS)
|
CFLAGS = $(THREADS) $(OPT) $(W) $(XCFLAGS)
|
||||||
LDLIBS =
|
LDLIBS =
|
||||||
SOLIBS =
|
SOLIBS =
|
||||||
+SOVERSION = 0.0.0
|
+SOVERSION = 0.0.0
|
||||||
prefix = /usr/local
|
prefix = /usr/local
|
||||||
-mandir = $(prefix)/man
|
exec_prefix = $(prefix)
|
||||||
+binprefix = $(prefix)/bin
|
bindir = $(exec_prefix)/bin
|
||||||
+libprefix = $(prefix)/lib
|
@@ -37,7 +38,7 @@ mandir = $(datarootdir)/man
|
||||||
+includeprefix = $(prefix)/include
|
|
||||||
+manprefix = $(prefix)/man
|
|
||||||
|
|
||||||
########################################################################
|
########################################################################
|
||||||
|
|
||||||
IHDRS = lmdb.h
|
IHDRS = lmdb.h
|
||||||
@ -23,18 +20,18 @@ diff -up lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile.orig lmdb-LMDB_0.9.17/libra
|
|||||||
IPROGS = mdb_stat mdb_copy mdb_dump mdb_load
|
IPROGS = mdb_stat mdb_copy mdb_dump mdb_load
|
||||||
IDOCS = mdb_stat.1 mdb_copy.1 mdb_dump.1 mdb_load.1
|
IDOCS = mdb_stat.1 mdb_copy.1 mdb_dump.1 mdb_load.1
|
||||||
PROGS = $(IPROGS) mtest mtest2 mtest3 mtest4 mtest5
|
PROGS = $(IPROGS) mtest mtest2 mtest3 mtest4 mtest5
|
||||||
@@ -43,13 +47,13 @@ install: $(ILIBS) $(IPROGS) $(IHDRS)
|
@@ -48,13 +49,13 @@ install: $(ILIBS) $(IPROGS) $(IHDRS)
|
||||||
mkdir -p $(DESTDIR)$(prefix)/lib
|
mkdir -p $(DESTDIR)$(libdir)
|
||||||
mkdir -p $(DESTDIR)$(prefix)/include
|
mkdir -p $(DESTDIR)$(includedir)
|
||||||
mkdir -p $(DESTDIR)$(prefix)/man/man1
|
mkdir -p $(DESTDIR)$(mandir)/man1
|
||||||
- for f in $(IPROGS); do cp $$f $(DESTDIR)$(prefix)/bin; done
|
- for f in $(IPROGS); do cp $$f $(DESTDIR)$(bindir); done
|
||||||
- for f in $(ILIBS); do cp $$f $(DESTDIR)$(prefix)/lib; done
|
- for f in $(ILIBS); do cp $$f $(DESTDIR)$(libdir); done
|
||||||
- for f in $(IHDRS); do cp $$f $(DESTDIR)$(prefix)/include; done
|
- for f in $(IHDRS); do cp $$f $(DESTDIR)$(includedir); done
|
||||||
- for f in $(IDOCS); do cp $$f $(DESTDIR)$(mandir)/man1; done
|
- for f in $(IDOCS); do cp $$f $(DESTDIR)$(mandir)/man1; done
|
||||||
+ for f in $(IPROGS); do cp -a $$f $(DESTDIR)$(binprefix); done
|
+ for f in $(IPROGS); do cp -a $$f $(DESTDIR)$(bindir); done
|
||||||
+ for f in $(ILIBS); do cp -a $$f $(DESTDIR)$(libprefix); done
|
+ for f in $(ILIBS); do cp -a $$f $(DESTDIR)$(libdir); done
|
||||||
+ for f in $(IHDRS); do cp -a $$f $(DESTDIR)$(includeprefix); done
|
+ for f in $(IHDRS); do cp -a $$f $(DESTDIR)$(includedir); done
|
||||||
+ for f in $(IDOCS); do cp -a $$f $(DESTDIR)$(manprefix)/man1; done
|
+ for f in $(IDOCS); do cp -a $$f $(DESTDIR)$(mandir)/man1; done
|
||||||
|
|
||||||
clean:
|
clean:
|
||||||
- rm -rf $(PROGS) *.[ao] *.[ls]o *~ testdb
|
- rm -rf $(PROGS) *.[ao] *.[ls]o *~ testdb
|
||||||
@ -42,7 +39,7 @@ diff -up lmdb-LMDB_0.9.17/libraries/liblmdb/Makefile.orig lmdb-LMDB_0.9.17/libra
|
|||||||
|
|
||||||
test: all
|
test: all
|
||||||
rm -rf testdb && mkdir testdb
|
rm -rf testdb && mkdir testdb
|
||||||
@@ -58,20 +62,24 @@ test: all
|
@@ -63,20 +64,24 @@ test: all
|
||||||
liblmdb.a: mdb.o midl.o
|
liblmdb.a: mdb.o midl.o
|
||||||
$(AR) rs $@ mdb.o midl.o
|
$(AR) rs $@ mdb.o midl.o
|
||||||
|
|
||||||
|
@ -2,8 +2,8 @@
|
|||||||
%global archive_path libraries/lib%{name}
|
%global archive_path libraries/lib%{name}
|
||||||
|
|
||||||
Name: lmdb
|
Name: lmdb
|
||||||
Version: 0.9.17
|
Version: 0.9.18
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Memory-mapped key-value database
|
Summary: Memory-mapped key-value database
|
||||||
|
|
||||||
License: OpenLDAP
|
License: OpenLDAP
|
||||||
@ -67,7 +67,7 @@ pushd %{archive_path}
|
|||||||
# make install expects existing directory tree
|
# make install expects existing directory tree
|
||||||
mkdir -m 0755 -p %{buildroot}%{_prefix}{/bin,/include}
|
mkdir -m 0755 -p %{buildroot}%{_prefix}{/bin,/include}
|
||||||
mkdir -m 0755 -p %{buildroot}{%{_libdir},%{_mandir}/man1}
|
mkdir -m 0755 -p %{buildroot}{%{_libdir},%{_mandir}/man1}
|
||||||
make DESTDIR=%{buildroot} prefix=%{_prefix} libprefix=%{_libdir} manprefix=%{_mandir} install
|
make DESTDIR=%{buildroot} prefix=%{_prefix} libdir=%{_libdir} mandir=%{_mandir} install
|
||||||
popd
|
popd
|
||||||
|
|
||||||
|
|
||||||
@ -104,6 +104,9 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 10 2016 Jan Stanek <jstanek@redhat.com> - 0.9.18-1
|
||||||
|
- Update to 0.9.18
|
||||||
|
|
||||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.17-3
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.17-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user