66 lines
2.7 KiB
Diff
66 lines
2.7 KiB
Diff
From 9d496e978f59e153bb76e92229d5a524d92dee04 Mon Sep 17 00:00:00 2001
|
|
From: Tom Stellard <tstellar@redhat.com>
|
|
Date: Tue, 10 Sep 2019 13:33:48 -0700
|
|
Subject: [PATCH] CMake: Split test binary exports into their own export file
|
|
|
|
---
|
|
llvm/cmake/modules/AddLLVM.cmake | 7 ++++++-
|
|
llvm/cmake/modules/CMakeLists.txt | 3 +++
|
|
llvm/cmake/modules/LLVMConfig.cmake.in | 1 +
|
|
3 files changed, 10 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/llvm/cmake/modules/AddLLVM.cmake b/llvm/cmake/modules/AddLLVM.cmake
|
|
index 200fc45..9eec7a7 100644
|
|
--- a/llvm/cmake/modules/AddLLVM.cmake
|
|
+++ b/llvm/cmake/modules/AddLLVM.cmake
|
|
@@ -953,7 +953,12 @@ macro(add_llvm_utility name)
|
|
set(export_to_llvmexports)
|
|
if (${name} IN_LIST LLVM_DISTRIBUTION_COMPONENTS OR
|
|
NOT LLVM_DISTRIBUTION_COMPONENTS)
|
|
- set(export_to_llvmexports EXPORT LLVMExports)
|
|
+ if (${name} STREQUAL "not" OR ${name} STREQUAL "count" OR
|
|
+ ${name} STREQUAL "yaml-bench" OR ${name} STREQUAL "lli-child-target")
|
|
+ set(export_to_llvmexports EXPORT LLVMTestExports)
|
|
+ else()
|
|
+ set(export_to_llvmexports EXPORT LLVMExports)
|
|
+ endif()
|
|
set_property(GLOBAL PROPERTY LLVM_HAS_EXPORTS True)
|
|
endif()
|
|
|
|
diff --git a/llvm/cmake/modules/CMakeLists.txt b/llvm/cmake/modules/CMakeLists.txt
|
|
index dc982d2..c861f45 100644
|
|
--- a/llvm/cmake/modules/CMakeLists.txt
|
|
+++ b/llvm/cmake/modules/CMakeLists.txt
|
|
@@ -106,6 +106,7 @@ set(LLVM_CONFIG_TOOLS_BINARY_DIR "\${LLVM_INSTALL_PREFIX}/bin")
|
|
set(LLVM_CONFIG_EXPORTS_FILE "\${LLVM_CMAKE_DIR}/LLVMExports.cmake")
|
|
set(LLVM_CONFIG_EXPORTS "${LLVM_EXPORTS}")
|
|
set(LLVM_CONFIG_STATIC_EXPORTS_FILE "\${LLVM_CMAKE_DIR}/LLVMStaticExports.cmake")
|
|
+set(LLVM_CONFIG_TEST_EXPORTS_FILE "\${LLVM_CMAKE_DIR}/LLVMTestExports.cmake")
|
|
configure_file(
|
|
LLVMConfig.cmake.in
|
|
${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/LLVMConfig.cmake
|
|
@@ -124,6 +125,8 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
|
|
COMPONENT cmake-exports)
|
|
install(EXPORT LLVMStaticExports DESTINATION ${LLVM_INSTALL_PACKAGE_DIR}
|
|
COMPONENT cmake-exports)
|
|
+ install(EXPORT LLVMTestExports DESTINATION ${LLVM_INSTALL_PACKAGE_DIR}
|
|
+ COMPONENT cmake-exports)
|
|
endif()
|
|
|
|
install(FILES
|
|
diff --git a/llvm/cmake/modules/LLVMConfig.cmake.in b/llvm/cmake/modules/LLVMConfig.cmake.in
|
|
index 6ef54a0..d81b09a 100644
|
|
--- a/llvm/cmake/modules/LLVMConfig.cmake.in
|
|
+++ b/llvm/cmake/modules/LLVMConfig.cmake.in
|
|
@@ -91,6 +91,7 @@ if(NOT TARGET LLVMSupport)
|
|
@llvm_config_include_buildtree_only_exports@
|
|
|
|
include("@LLVM_CONFIG_STATIC_EXPORTS_FILE@" OPTIONAL)
|
|
+ include("@LLVM_CONFIG_TEST_EXPORTS_FILE@" OPTIONAL)
|
|
endif()
|
|
|
|
# By creating intrinsics_gen here, subprojects that depend on LLVM's
|
|
--
|
|
1.8.3.1
|
|
|