Restore config.guess for host triple detection
The new detection method was omitting -gnu from the triples which caused some behavior changes in clang.
This commit is contained in:
parent
2b9d762f80
commit
f13f5d4d08
File diff suppressed because it is too large
Load Diff
@ -1,41 +0,0 @@
|
|||||||
From 160d464a192f25a7e69bf63f20bdfdffe036dd42 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tom Stellard <tstellar@redhat.com>
|
|
||||||
Date: Wed, 29 Sep 2021 16:20:47 -0700
|
|
||||||
Subject: [PATCH] test/ExecutionEngine: Clean up lit.local.cfg
|
|
||||||
|
|
||||||
Switch to using config.root.native_target to determine if tests are
|
|
||||||
supported. This is a canonical form of the arch from the target
|
|
||||||
triple.
|
|
||||||
|
|
||||||
Differential Revision: https://reviews.llvm.org/D110788
|
|
||||||
---
|
|
||||||
llvm/test/ExecutionEngine/lit.local.cfg | 16 +---------------
|
|
||||||
1 file changed, 1 insertion(+), 15 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/llvm/test/ExecutionEngine/lit.local.cfg b/llvm/test/ExecutionEngine/lit.local.cfg
|
|
||||||
index 88e3e9b23883..72b6a9ac269e 100644
|
|
||||||
--- a/llvm/test/ExecutionEngine/lit.local.cfg
|
|
||||||
+++ b/llvm/test/ExecutionEngine/lit.local.cfg
|
|
||||||
@@ -1,18 +1,4 @@
|
|
||||||
-if config.root.host_arch in ['Sparc', 'PowerPC', 'AArch64', 'SystemZ']:
|
|
||||||
- config.unsupported = True
|
|
||||||
-
|
|
||||||
-# CMake and autoconf diverge in naming or host_arch
|
|
||||||
-if 'powerpc64' in config.root.target_triple:
|
|
||||||
- config.unsupported = True
|
|
||||||
-
|
|
||||||
-if 'aarch64' in config.root.target_triple \
|
|
||||||
- or 'arm64' in config.root.target_triple:
|
|
||||||
- config.unsupported = True
|
|
||||||
-
|
|
||||||
-if 'hexagon' in config.root.target_triple:
|
|
||||||
- config.unsupported = True
|
|
||||||
-
|
|
||||||
-if 'sparc' in config.root.target_triple:
|
|
||||||
+if config.root.native_target in ['Sparc', 'PowerPC', 'AArch64', 'SystemZ', 'Hexagon']:
|
|
||||||
config.unsupported = True
|
|
||||||
|
|
||||||
# ExecutionEngine tests are not expected to pass in a cross-compilation setup.
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
14
llvm.spec
14
llvm.spec
@ -54,7 +54,7 @@
|
|||||||
|
|
||||||
Name: %{pkg_name}
|
Name: %{pkg_name}
|
||||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: The Low Level Virtual Machine
|
Summary: The Low Level Virtual Machine
|
||||||
|
|
||||||
License: NCSA
|
License: NCSA
|
||||||
@ -70,13 +70,6 @@ Source4: lit.fedora.cfg.py
|
|||||||
|
|
||||||
Patch0: 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
|
Patch0: 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
|
||||||
Patch2: 0001-XFAIL-missing-abstract-variable.ll-test-on-ppc64le.patch
|
Patch2: 0001-XFAIL-missing-abstract-variable.ll-test-on-ppc64le.patch
|
||||||
# Remove config.guess, so that we get a default triple that matches gcc.
|
|
||||||
# This ensures that clang always uses the system gcc install.
|
|
||||||
Patch3: 0001-cmake-Remove-config.guess.patch
|
|
||||||
# Patch3 has the effect of changing the arch triple on ppc64le from powerpc64le
|
|
||||||
# to ppc64le, which inadvertently enabled some ExecutionEngine tests that were
|
|
||||||
# supposed to be unsupported. Patch4 disables these tests on ppc64le.
|
|
||||||
Patch4: 0001-test-ExecutionEngine-Clean-up-lit.local.cfg.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -214,8 +207,6 @@ LLVM's modified googletest sources.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# force off shared libs as cmake macros turns it on.
|
# force off shared libs as cmake macros turns it on.
|
||||||
# We need to set LLVM_DEFAULT_TARGET_TRIPLE, because llvm fails to detect it
|
|
||||||
# correctly.
|
|
||||||
%cmake -G Ninja \
|
%cmake -G Ninja \
|
||||||
-DBUILD_SHARED_LIBS:BOOL=OFF \
|
-DBUILD_SHARED_LIBS:BOOL=OFF \
|
||||||
-DLLVM_PARALLEL_LINK_JOBS=1 \
|
-DLLVM_PARALLEL_LINK_JOBS=1 \
|
||||||
@ -541,6 +532,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 30 2021 Tom Stellard <tstellar@redhat.com> - 13.0.0~rc4-2
|
||||||
|
- Restore config.guess for host triple detection
|
||||||
|
|
||||||
* Fri Sep 24 2021 Tom Stellard <tstellar@redhat.com> - 13.0.0~rc4-1
|
* Fri Sep 24 2021 Tom Stellard <tstellar@redhat.com> - 13.0.0~rc4-1
|
||||||
- 13.0.0-rc4 Release
|
- 13.0.0-rc4 Release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user