update to llvm 3.4 release

This commit is contained in:
Dave Airlie 2014-01-14 10:15:26 +10:00
parent 230d47c2ff
commit bf2cfe23d5
5 changed files with 29 additions and 56 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@
/compiler-rt-*.src.tar.gz /compiler-rt-*.src.tar.gz
/lldb-*.src.tar.gz /lldb-*.src.tar.gz
/llvm-*.src.tar.gz /llvm-*.src.tar.gz
/clang-3.4.src.tar.gz

View File

@ -1,22 +1,12 @@
Hack the linker flags for shared libs for speed and memory usage diff -up llvm-3.4/tools/llvm-shlib/Makefile.orig llvm-3.4/tools/llvm-shlib/Makefile
--- llvm-3.4/tools/llvm-shlib/Makefile.orig 2013-11-01 00:35:00.000000000 +1000
--- +++ llvm-3.4/tools/llvm-shlib/Makefile 2014-01-14 10:13:20.069858909 +1000
tools/llvm-shlib/Makefile | 2 +- @@ -75,7 +75,7 @@ endif
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/llvm-shlib/Makefile b/tools/llvm-shlib/Makefile
index 6d6c6e9..4038df4 100644
--- a/tools/llvm-shlib/Makefile
+++ b/tools/llvm-shlib/Makefile
@@ -76,7 +76,7 @@ endif
ifeq ($(HOST_OS), $(filter $(HOST_OS), Linux GNU)) ifeq ($(HOST_OS), $(filter $(HOST_OS), Linux GNU GNU/kFreeBSD))
# Don't allow unresolved symbols. # Don't allow unresolved symbols.
- LLVMLibsOptions += -Wl,--no-undefined - LLVMLibsOptions += -Wl,--no-undefined
+ LLVMLibsOptions += -Wl,--no-undefined -Wl,-Bsymbolic + LLVMLibsOptions += -Wl,--no-undefined -Wl,-Bsymbolic
endif endif
ifeq ($(HOST_OS),SunOS) ifeq ($(HOST_OS),SunOS)
--
1.8.3.1

View File

@ -1,23 +0,0 @@
Fixes the build with gcc in gnu++98 and gnu++11 mode.
https://github.com/llvm-mirror/llvm/commit/d1bf52275daa86e838ebbffc71efd43fc8c416f4
---
lib/Support/Unix/Memory.inc | 1 +
1 file changed, 1 insertion(+)
diff --git a/lib/Support/Unix/Memory.inc b/lib/Support/Unix/Memory.inc
index 72a8af6..91dc7da 100644
--- a/lib/Support/Unix/Memory.inc
+++ b/lib/Support/Unix/Memory.inc
@@ -33,6 +33,7 @@
#endif
extern "C" void sys_icache_invalidate(const void *Addr, size_t len);
+extern "C" void __clear_cache(void *, void *);
namespace {
--
1.8.3.1

View File

@ -25,11 +25,12 @@
%global llvmdocdir() %{_docdir}/%1 %global llvmdocdir() %{_docdir}/%1
%endif %endif
%global downloadurl http://llvm.org/releases/%{version} #global prerel rc3
%global downloadurl http://llvm.org/%{?prerel:pre-}releases/%{version}%{?prerel:/%{prerel}}
Name: llvm Name: llvm
Version: 3.3 Version: 3.4
Release: 4%{?dist} Release: 1%{?dist}
Summary: The Low Level Virtual Machine Summary: The Low Level Virtual Machine
Group: Development/Languages Group: Development/Languages
@ -37,10 +38,12 @@ License: NCSA
URL: http://llvm.org/ URL: http://llvm.org/
# source archives # source archives
Source0: %{downloadurl}/llvm-%{version}.src.tar.gz Source0: %{downloadurl}/llvm-%{version}%{?prerel}.src.tar.gz
Source1: %{downloadurl}/cfe-%{version}.src.tar.gz Source1: %{downloadurl}/clang-%{version}%{?prerel}.src.tar.gz
Source2: %{downloadurl}/compiler-rt-%{version}.src.tar.gz Source2: %{downloadurl}/compiler-rt-%{version}%{?prerel}.src.tar.gz
Source3: %{downloadurl}/lldb-%{version}.src.tar.gz %if %{with lldb}
Source3: %{downloadurl}/lldb-%{version}%{?prerel}.src.tar.gz
%endif
# multilib fixes # multilib fixes
Source10: llvm-Config-config.h Source10: llvm-Config-config.h
@ -49,7 +52,6 @@ Source11: llvm-Config-llvm-config.h
# patches # patches
Patch1: 0001-data-install-preserve-timestamps.patch Patch1: 0001-data-install-preserve-timestamps.patch
Patch2: 0002-linker-flags-speedup-memory.patch Patch2: 0002-linker-flags-speedup-memory.patch
Patch3: 0003-fix-clear-cache-declaration.patch
BuildRequires: bison BuildRequires: bison
BuildRequires: chrpath BuildRequires: chrpath
@ -253,21 +255,20 @@ HTML documentation for LLVM's OCaml binding.
%prep %prep
%setup -q -n llvm-%{version}.src %{?with_clang:-a1} %{?with_crt:-a2} %{?with_lldb:-a3} %setup -q %{?with_clang:-a1} %{?with_crt:-a2} %{?with_lldb:-a3}
rm -rf tools/clang tools/lldb projects/compiler-rt rm -rf tools/clang tools/lldb projects/compiler-rt
%if %{with clang} %if %{with clang}
mv cfe-%{version}.src tools/clang mv clang-%{version} tools/clang
%endif %endif
%if %{with crt} %if %{with crt}
mv compiler-rt-%{version}.src projects/compiler-rt mv compiler-rt-%{version} projects/compiler-rt
%endif %endif
%if %{with lldb} %if %{with lldb}
mv lldb-%{version}.src tools/lldb mv lldb-%{version} tools/lldb
%endif %endif
%patch1 -p1 %patch1 -p1
%patch2 -p1 %patch2 -p1
%patch3 -p1
# fix library paths # fix library paths
sed -i 's|/lib /usr/lib $lt_ld_extra|%{_libdir} $lt_ld_extra|' ./configure sed -i 's|/lib /usr/lib $lt_ld_extra|%{_libdir} $lt_ld_extra|' ./configure
@ -521,6 +522,7 @@ exit 0
%{_bindir}/bugpoint %{_bindir}/bugpoint
%{_bindir}/llc %{_bindir}/llc
%{_bindir}/lli %{_bindir}/lli
%{_bindir}/lli-child-target
%exclude %{_bindir}/llvm-config-%{__isa_bits} %exclude %{_bindir}/llvm-config-%{__isa_bits}
%{_bindir}/llvm* %{_bindir}/llvm*
%{_bindir}/macho-dump %{_bindir}/macho-dump
@ -601,7 +603,7 @@ exit 0
%defattr(-,root,root,-) %defattr(-,root,root,-)
%{_libdir}/ocaml/*.cma %{_libdir}/ocaml/*.cma
%{_libdir}/ocaml/*.cmi %{_libdir}/ocaml/*.cmi
%{_libdir}/ocaml/META.llvm %{_libdir}/ocaml/META.llvm*
%files ocaml-devel %files ocaml-devel
%defattr(-,root,root,-) %defattr(-,root,root,-)
@ -627,6 +629,9 @@ exit 0
%endif %endif
%changelog %changelog
* Tue Jan 14 2014 Dave Airlie <airlied@redhat.com> 3.4-1
- update to llvm 3.4 release
* Fri Dec 20 2013 Jan Vcelak <jvcelak@fedoraproject.org> 3.3-4 * Fri Dec 20 2013 Jan Vcelak <jvcelak@fedoraproject.org> 3.3-4
- remove RPATHs - remove RPATHs
- run ldconfig when installing lldb (#1044431) - run ldconfig when installing lldb (#1044431)

View File

@ -1,4 +1,4 @@
8284891e3e311829b8e44ac813d0c9ef cfe-3.3.src.tar.gz b378f1e2c424e03289effc75268d3d2c clang-3.4.src.tar.gz
9c129ce24514467cfe492cf2fed8e2c4 compiler-rt-3.3.src.tar.gz 7ed60a0463f9fdfa20db7109d4624cee lldb-3.4.src.tar.gz
c583c80c25e56a41e3e5ae7c2f442929 lldb-3.3.src.tar.gz 7938353e3a3bda85733a165e7ac4bb84 compiler-rt-3.4.src.tar.gz
40564e1dc390f9844f1711c08b08e391 llvm-3.3.src.tar.gz 46ed668a1ce38985120dbf6344cf6116 llvm-3.4.src.tar.gz