clog
This commit is contained in:
parent
6668812d9f
commit
b302e35e85
@ -1,36 +0,0 @@
|
|||||||
--- llvm-2.7/tools/clang/lib/Frontend/InitHeaderSearch.cpp.cxx_includes 2010-03-06 20:38:10.000000000 +0100
|
|
||||||
+++ llvm-2.7/tools/clang/lib/Frontend/InitHeaderSearch.cpp 2010-06-05 13:43:03.150438148 +0200
|
|
||||||
@@ -524,10 +524,32 @@
|
|
||||||
AddGnuCPlusPlusIncludePaths("/usr/include/c++/4.4.2",
|
|
||||||
"i686-redhat-linux","", "", triple);
|
|
||||||
|
|
||||||
+ AddGnuCPlusPlusIncludePaths("/usr/include/c++/4.4.2",
|
|
||||||
+ "x86_64-redhat-linux", "32", "", triple);
|
|
||||||
+
|
|
||||||
+ AddGnuCPlusPlusIncludePaths("/usr/include/c++/4.4.2",
|
|
||||||
+ "ppc64-redhat-linux", "64", "", triple);
|
|
||||||
+
|
|
||||||
// Fedora 12 (February-2010+)
|
|
||||||
AddGnuCPlusPlusIncludePaths("/usr/include/c++/4.4.3",
|
|
||||||
"i686-redhat-linux","", "", triple);
|
|
||||||
-
|
|
||||||
+
|
|
||||||
+ AddGnuCPlusPlusIncludePaths("/usr/include/c++/4.4.3",
|
|
||||||
+ "x86_64-redhat-linux", "32", "", triple);
|
|
||||||
+
|
|
||||||
+ AddGnuCPlusPlusIncludePaths("/usr/include/c++/4.4.3",
|
|
||||||
+ "ppc64-redhat-linux", "64", "", triple);
|
|
||||||
+
|
|
||||||
+ // Fedora 13
|
|
||||||
+ AddGnuCPlusPlusIncludePaths("/usr/include/c++/4.4.4",
|
|
||||||
+ "i686-redhat-linux","", "", triple);
|
|
||||||
+
|
|
||||||
+ AddGnuCPlusPlusIncludePaths("/usr/include/c++/4.4.4",
|
|
||||||
+ "x86_64-redhat-linux", "32", "", triple);
|
|
||||||
+
|
|
||||||
+ AddGnuCPlusPlusIncludePaths("/usr/include/c++/4.4.4",
|
|
||||||
+ "ppc64-redhat-linux", "64", "", triple);
|
|
||||||
+
|
|
||||||
// openSUSE 11.1 32 bit
|
|
||||||
AddGnuCPlusPlusIncludePaths("/usr/include/c++/4.3",
|
|
||||||
"i586-suse-linux", "", "", triple);
|
|
19
llvm.spec
19
llvm.spec
@ -12,7 +12,7 @@
|
|||||||
|
|
||||||
Name: llvm
|
Name: llvm
|
||||||
Version: 2.7
|
Version: 2.7
|
||||||
Release: 8%{?dist}
|
Release: 9%{?dist}
|
||||||
Summary: The Low Level Virtual Machine
|
Summary: The Low Level Virtual Machine
|
||||||
|
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -22,10 +22,6 @@ Source0: http://llvm.org/releases/%{version}/llvm-%{version}.tgz
|
|||||||
Source1: http://llvm.org/releases/%{version}/clang-%{version}.tgz
|
Source1: http://llvm.org/releases/%{version}/clang-%{version}.tgz
|
||||||
# Data files should be installed with timestamps preserved
|
# Data files should be installed with timestamps preserved
|
||||||
Patch0: llvm-2.6-timestamp.patch
|
Patch0: llvm-2.6-timestamp.patch
|
||||||
# http://llvm.org/bugs/show_bug.cgi?id=7307
|
|
||||||
Patch1: llvm-2.7-cxx_includes.patch
|
|
||||||
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
|
||||||
|
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
@ -195,7 +191,6 @@ HTML documentation for LLVM's OCaml binding.
|
|||||||
mv clang-%{version} tools/clang
|
mv clang-%{version} tools/clang
|
||||||
|
|
||||||
%patch0 -p1 -b .timestamp
|
%patch0 -p1 -b .timestamp
|
||||||
%patch1 -p1 -b .cxx_includes
|
|
||||||
|
|
||||||
# Encoding fix
|
# Encoding fix
|
||||||
(cd tools/clang/docs && \
|
(cd tools/clang/docs && \
|
||||||
@ -216,7 +211,9 @@ mv clang-%{version} tools/clang
|
|||||||
--disable-assertions \
|
--disable-assertions \
|
||||||
--enable-debug-runtime \
|
--enable-debug-runtime \
|
||||||
--enable-jit \
|
--enable-jit \
|
||||||
--enable-shared
|
--enable-shared \
|
||||||
|
--with-cxx-include-root=$(echo /usr/include/c++/*) \
|
||||||
|
--with-cxx-include-arch=%{_arch}-%{_vendor}-%{_os}
|
||||||
|
|
||||||
# FIXME file this
|
# FIXME file this
|
||||||
# configure does not properly specify libdir
|
# configure does not properly specify libdir
|
||||||
@ -299,10 +296,6 @@ chmod -x %{buildroot}%{_libdir}/%{name}/*.a
|
|||||||
find examples -name 'Makefile' | xargs -0r rm -f
|
find examples -name 'Makefile' | xargs -0r rm -f
|
||||||
|
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf %{buildroot}
|
|
||||||
|
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
@ -388,6 +381,10 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 20 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-9
|
||||||
|
- Dynamically determine C++ include path at compile time (# 630474)
|
||||||
|
- Remove unneeded BuildRoot field and clean section
|
||||||
|
|
||||||
* Wed Sep 15 2010 Dennis Gilmore <dennis@ausil.us> - 2.7-8
|
* Wed Sep 15 2010 Dennis Gilmore <dennis@ausil.us> - 2.7-8
|
||||||
- disable ocaml support on sparc64
|
- disable ocaml support on sparc64
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user