Update to LLVM 18.1.2
Resolves: RHEL-27724
This commit is contained in:
parent
39a5a55967
commit
a84dd57fd7
@ -1,26 +1,13 @@
|
||||
diff -Naur a/llvm/docs/conf.py b/llvm/docs/conf.py
|
||||
--- a/llvm/docs/conf.py 2020-09-15 09:12:24.318287611 +0000
|
||||
+++ b/llvm/docs/conf.py 2020-09-15 15:01:00.025893199 +0000
|
||||
@@ -36,21 +36,7 @@
|
||||
".rst": "restructuredtext",
|
||||
}
|
||||
diff --git a/llvm/docs/conf.py b/llvm/docs/conf.py
|
||||
index cf8a75980b53..b208ad138e89 100644
|
||||
--- a/llvm/docs/conf.py
|
||||
+++ b/llvm/docs/conf.py
|
||||
@@ -26,7 +26,7 @@ from datetime import date
|
||||
|
||||
-try:
|
||||
- import recommonmark
|
||||
-except ImportError:
|
||||
- # manpages do not use any .md sources
|
||||
- if not tags.has("builder-man"):
|
||||
- raise
|
||||
-else:
|
||||
- import sphinx
|
||||
-
|
||||
- if sphinx.version_info >= (3, 0):
|
||||
- # This requires 0.5 or later.
|
||||
- extensions.append("recommonmark")
|
||||
- else:
|
||||
- source_parsers = {".md": "recommonmark.parser.CommonMarkParser"}
|
||||
- source_suffix[".md"] = "markdown"
|
||||
+import sphinx
|
||||
# Add any Sphinx extension module names here, as strings. They can be extensions
|
||||
# coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
|
||||
-extensions = ["myst_parser", "sphinx.ext.intersphinx", "sphinx.ext.todo"]
|
||||
+extensions = ["sphinx.ext.intersphinx", "sphinx.ext.todo"]
|
||||
|
||||
# The encoding of source files.
|
||||
# source_encoding = 'utf-8-sig'
|
||||
# Automatic anchors for markdown titles
|
||||
from llvm_slug import make_slug
|
||||
|
46
D156379.diff
46
D156379.diff
@ -1,46 +0,0 @@
|
||||
diff --git a/llvm/lib/Target/SystemZ/SystemZTargetTransformInfo.cpp b/llvm/lib/Target/SystemZ/SystemZTargetTransformInfo.cpp
|
||||
--- a/llvm/lib/Target/SystemZ/SystemZTargetTransformInfo.cpp
|
||||
+++ b/llvm/lib/Target/SystemZ/SystemZTargetTransformInfo.cpp
|
||||
@@ -1152,6 +1152,11 @@
|
||||
}
|
||||
}
|
||||
|
||||
+ // Type legalization (via getNumberOfParts) can't handle structs
|
||||
+ if (TLI->getValueType(DL, Src, true) == MVT::Other)
|
||||
+ return BaseT::getMemoryOpCost(Opcode, Src, Alignment, AddressSpace,
|
||||
+ CostKind);
|
||||
+
|
||||
unsigned NumOps =
|
||||
(Src->isVectorTy() ? getNumVectorRegs(Src) : getNumberOfParts(Src));
|
||||
|
||||
diff --git a/llvm/test/Analysis/CostModel/SystemZ/struct-cost-crash.ll b/llvm/test/Analysis/CostModel/SystemZ/struct-cost-crash.ll
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/llvm/test/Analysis/CostModel/SystemZ/struct-cost-crash.ll
|
||||
@@ -0,0 +1,25 @@
|
||||
+; NOTE: Assertions have been autogenerated by utils/update_analyze_test_checks.py UTC_ARGS: --version 2
|
||||
+; RUN: opt -passes="print<cost-model>" 2>&1 -disable-output < %s | FileCheck %s
|
||||
+;
|
||||
+; Check that SystemZTTIImpl::getMemoryOpCost doesn't try to legalize structs,
|
||||
+; which was failing llvm_unreachable in MVT::getVT.
|
||||
+
|
||||
+target datalayout = "E-m:e-i1:8:16-i8:8:16-i64:64-f128:64-v128:64-a:8:16-n32:64"
|
||||
+target triple = "s390x-unknown-linux-gnu"
|
||||
+
|
||||
+declare { i64, i32 } @bar()
|
||||
+
|
||||
+define i8 @foo() {
|
||||
+; CHECK-LABEL: 'foo'
|
||||
+; CHECK-NEXT: Cost Model: Found an estimated cost of 1 for instruction: br label %1
|
||||
+; CHECK-NEXT: Cost Model: Found an estimated cost of 1 for instruction: %2 = call { i64, i32 } @bar()
|
||||
+; CHECK-NEXT: Cost Model: Found an estimated cost of 4 for instruction: store { i64, i32 } %2, ptr inttoptr (i64 16 to ptr), align 16
|
||||
+; CHECK-NEXT: Cost Model: Found an estimated cost of 1 for instruction: br label %1
|
||||
+;
|
||||
+ br label %1
|
||||
+
|
||||
+1: ; preds = %1, %0
|
||||
+ %2 = call { i64, i32 } @bar()
|
||||
+ store { i64, i32 } %2, ptr inttoptr (i64 16 to ptr), align 16
|
||||
+ br label %1
|
||||
+}
|
||||
|
197
llvm.spec
197
llvm.spec
@ -22,6 +22,7 @@
|
||||
%endif
|
||||
|
||||
%bcond_with compat_build
|
||||
%bcond_without bundle_compat_lib
|
||||
%bcond_without check
|
||||
|
||||
%ifarch %ix86
|
||||
@ -34,9 +35,14 @@
|
||||
%bcond_without lto_build
|
||||
%endif
|
||||
|
||||
%global maj_ver 17
|
||||
%global min_ver 0
|
||||
%global patch_ver 6
|
||||
%if %{with bundle_compat_lib}
|
||||
%global compat_maj_ver 17
|
||||
%global compat_ver %{compat_maj_ver}.0.6
|
||||
%endif
|
||||
|
||||
%global maj_ver 18
|
||||
%global min_ver 1
|
||||
%global patch_ver 2
|
||||
#global rc_ver 4
|
||||
|
||||
%if %{with snapshot_build}
|
||||
@ -93,7 +99,7 @@
|
||||
|
||||
Name: %{pkg_name}
|
||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}%{?llvm_snapshot_version_suffix:~%{llvm_snapshot_version_suffix}}
|
||||
Release: 6%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: The Low Level Virtual Machine
|
||||
|
||||
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
||||
@ -111,12 +117,14 @@ Source3: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ve
|
||||
Source4: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{third_party_srcdir}.tar.xz
|
||||
Source5: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{third_party_srcdir}.tar.xz.sig
|
||||
Source6: release-keys.asc
|
||||
|
||||
%if %{with bundle_compat_lib}
|
||||
Source7: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compat_ver}/llvm-%{compat_ver}.src.tar.xz
|
||||
Source8: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compat_ver}/llvm-%{compat_ver}.src.tar.xz.sig
|
||||
%endif
|
||||
%endif
|
||||
|
||||
# Backport of https://reviews.llvm.org/D156485 for rhbz#2262260.
|
||||
Patch0: 0001-PEI-Don-t-zero-out-noreg-operands.patch
|
||||
|
||||
# RHEL-specific patch to avoid unwanted recommonmark dep
|
||||
# RHEL-specific patch to avoid unwanted python3-myst-parser dep
|
||||
Patch101: 0101-Deactivate-markdown-doc.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
@ -130,7 +138,7 @@ BuildRequires: ncurses-devel
|
||||
BuildRequires: python3-psutil
|
||||
BuildRequires: python3-sphinx
|
||||
%if %{undefined rhel}
|
||||
BuildRequires: python3-recommonmark
|
||||
BuildRequires: python3-myst-parser
|
||||
%endif
|
||||
BuildRequires: multilib-rpm-config
|
||||
%if %{with gold}
|
||||
@ -174,10 +182,8 @@ Requires: libedit-devel
|
||||
# but this caused bugs (rhbz#1773678) and forced us to carry two non-upstream
|
||||
# patches.
|
||||
Requires: %{name}-static%{?_isa} = %{version}-%{release}
|
||||
%if %{without compat_build}
|
||||
Requires: %{name}-test%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-googletest%{?_isa} = %{version}-%{release}
|
||||
%endif
|
||||
|
||||
|
||||
Requires(post): %{_sbindir}/alternatives
|
||||
@ -199,6 +205,8 @@ Documentation for the LLVM compiler infrastructure.
|
||||
|
||||
%package libs
|
||||
Summary: LLVM shared libraries
|
||||
Requires(post): /sbin/ldconfig
|
||||
Requires(postun): /sbin/ldconfig
|
||||
|
||||
%description libs
|
||||
Shared libraries for the LLVM compiler infrastructure.
|
||||
@ -219,8 +227,6 @@ Summary: CMake utilities shared across LLVM subprojects
|
||||
CMake utilities shared across LLVM subprojects.
|
||||
This is for internal use by LLVM packages only.
|
||||
|
||||
%if %{without compat_build}
|
||||
|
||||
%package test
|
||||
Summary: LLVM regression tests
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
@ -237,13 +243,12 @@ Summary: LLVM's modified googletest sources
|
||||
%description googletest
|
||||
LLVM's modified googletest sources.
|
||||
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%if %{without snapshot_build}
|
||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE3}' --data='%{SOURCE2}'
|
||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE5}' --data='%{SOURCE4}'
|
||||
%if %{with bundle_compat_lib}
|
||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE8}' --data='%{SOURCE7}'
|
||||
%endif
|
||||
%setup -T -q -b 2 -n %{cmake_srcdir}
|
||||
# TODO: It would be more elegant to set -DLLVM_COMMON_CMAKE_UTILS=%{_builddir}/%{cmake_srcdir},
|
||||
@ -254,6 +259,10 @@ mv %{cmake_srcdir} cmake
|
||||
cd ..
|
||||
mv %{third_party_srcdir} third-party
|
||||
|
||||
%if %{with bundle_compat_lib}
|
||||
%setup -T -q -b 7 -n llvm-%{compat_ver}.src
|
||||
%endif
|
||||
|
||||
%setup -T -q -b 0 -n %{llvm_srcdir}
|
||||
%autopatch -M%{?!rhel:100}%{?rhel:200} -p2
|
||||
|
||||
@ -313,24 +322,16 @@ export ASMFLAGS="%{build_cflags}"
|
||||
\
|
||||
-DLLVM_INCLUDE_TESTS:BOOL=ON \
|
||||
-DLLVM_BUILD_TESTS:BOOL=ON \
|
||||
%if %{with compat_build}
|
||||
-DLLVM_INSTALL_GTEST:BOOL=OFF \
|
||||
%else
|
||||
-DLLVM_INSTALL_GTEST:BOOL=ON \
|
||||
%endif
|
||||
-DLLVM_LIT_ARGS=-v \
|
||||
\
|
||||
-DLLVM_INCLUDE_EXAMPLES:BOOL=ON \
|
||||
-DLLVM_BUILD_EXAMPLES:BOOL=OFF \
|
||||
\
|
||||
-DLLVM_INCLUDE_UTILS:BOOL=ON \
|
||||
%if %{with compat_build}
|
||||
-DLLVM_INSTALL_UTILS:BOOL=OFF \
|
||||
%else
|
||||
-DLLVM_INSTALL_UTILS:BOOL=ON \
|
||||
-DLLVM_UTILS_INSTALL_DIR:PATH=%{_bindir} \
|
||||
-DLLVM_UTILS_INSTALL_DIR:PATH=bin \
|
||||
-DLLVM_TOOLS_INSTALL_DIR:PATH=bin \
|
||||
%endif
|
||||
\
|
||||
-DLLVM_INCLUDE_DOCS:BOOL=ON \
|
||||
-DLLVM_BUILD_DOCS:BOOL=ON \
|
||||
@ -366,34 +367,65 @@ export ASMFLAGS="%{build_cflags}"
|
||||
%cmake_build --target LLVM
|
||||
%cmake_build
|
||||
|
||||
%if %{with bundle_compat_lib}
|
||||
|
||||
# TODO: Install all the tools?
|
||||
%cmake -S ../llvm-%{compat_ver}.src -B ../llvm-compat-libs -G Ninja \
|
||||
-DCMAKE_INSTALL_PREFIX=%{buildroot}%{_libdir}/llvm%{compat_maj_ver}/ \
|
||||
-DCMAKE_SKIP_RPATH:BOOL=ON \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DBUILD_SHARED_LIBS:BOOL=OFF \
|
||||
-DLLVM_BUILD_LLVM_DYLIB=ON \
|
||||
-DLLVM_ENABLE_RTTI:BOOL=ON \
|
||||
-DLLVM_TARGETS_TO_BUILD=%{targets_to_build} \
|
||||
-DLLVM_BUILD_EXAMPLES:BOOL=OFF \
|
||||
-DLLVM_INSTALL_UTILS:BOOL=OFF \
|
||||
-DLLVM_INCLUDE_BENCHMARKS=OFF
|
||||
|
||||
%ninja_build -C ../llvm-compat-libs LLVM
|
||||
|
||||
%endif
|
||||
|
||||
%install
|
||||
%cmake_install
|
||||
|
||||
%if %{with bundle_compat_lib}
|
||||
install -m 0755 ../llvm-compat-libs/lib/libLLVM-%{compat_maj_ver}.so %{buildroot}%{_libdir}
|
||||
%ninja_build -C ../llvm-compat-libs install-llvm-headers install-llvm-config
|
||||
# Delete build files to save disk space
|
||||
rm -Rf ../llvm-compat-libs
|
||||
%endif
|
||||
|
||||
mkdir -p %{buildroot}/%{_bindir}
|
||||
|
||||
%if %{without compat_build}
|
||||
|
||||
# Fix some man pages
|
||||
ln -s llvm-config.1 %{buildroot}%{_mandir}/man1/llvm-config%{exec_suffix}-%{__isa_bits}.1
|
||||
|
||||
# Install binaries needed for lit tests
|
||||
%global test_binaries llvm-isel-fuzzer llvm-opt-fuzzer
|
||||
|
||||
for f in %{test_binaries}
|
||||
do
|
||||
install -m 0755 %{_vpath_builddir}/bin/$f %{buildroot}%{_bindir}
|
||||
install -m 0755 %{_vpath_builddir}/bin/$f %{buildroot}%{install_bindir}
|
||||
done
|
||||
|
||||
# Remove testing of update utility tools
|
||||
rm -rf test/tools/UpdateTestChecks
|
||||
|
||||
%multilib_fix_c_header --file %{_includedir}/llvm/Config/llvm-config.h
|
||||
|
||||
# Install libraries needed for unittests
|
||||
%if %{without compat_build}
|
||||
%global build_libdir %{_vpath_builddir}/%{_lib}
|
||||
%else
|
||||
%global build_libdir %{_vpath_builddir}/lib
|
||||
%endif
|
||||
|
||||
install %{build_libdir}/libLLVMTestingSupport.a %{buildroot}%{_libdir}
|
||||
install %{build_libdir}/libLLVMTestingAnnotations.a %{buildroot}%{_libdir}
|
||||
install %{build_libdir}/libLLVMTestingSupport.a %{buildroot}%{install_libdir}
|
||||
install %{build_libdir}/libLLVMTestingAnnotations.a %{buildroot}%{install_libdir}
|
||||
|
||||
# Fix multi-lib
|
||||
%multilib_fix_c_header --file %{install_includedir}/llvm/Config/llvm-config.h
|
||||
|
||||
%if %{without compat_build}
|
||||
|
||||
# Fix some man pages
|
||||
ln -s llvm-config.1 %{buildroot}%{_mandir}/man1/llvm-config%{exec_suffix}-%{__isa_bits}.1
|
||||
|
||||
%if %{with gold}
|
||||
# Add symlink to lto plugin in the binutils plugin directory.
|
||||
@ -409,14 +441,6 @@ for f in %{buildroot}/%{install_bindir}/*; do
|
||||
ln -s ../../%{install_bindir}/$filename %{buildroot}/%{_bindir}/$filename%{exec_suffix}
|
||||
done
|
||||
|
||||
# Move header files
|
||||
mkdir -p %{buildroot}/%{pkg_includedir}
|
||||
ln -s ../../../%{install_includedir}/llvm %{buildroot}/%{pkg_includedir}/llvm
|
||||
ln -s ../../../%{install_includedir}/llvm-c %{buildroot}/%{pkg_includedir}/llvm-c
|
||||
|
||||
# Fix multi-lib
|
||||
%multilib_fix_c_header --file %{install_includedir}/llvm/Config/llvm-config.h
|
||||
|
||||
# Create ld.so.conf.d entry
|
||||
mkdir -p %{buildroot}/etc/ld.so.conf.d
|
||||
cat >> %{buildroot}/etc/ld.so.conf.d/%{name}-%{_arch}.conf << EOF
|
||||
@ -430,9 +454,6 @@ for f in %{build_install_prefix}/share/man/man1/*; do
|
||||
mv $f %{buildroot}%{_mandir}/man1/$filename%{exec_suffix}.1
|
||||
done
|
||||
|
||||
# Remove opt-viewer, since this is just a compatibility package.
|
||||
rm -Rf %{build_install_prefix}/share/opt-viewer
|
||||
|
||||
%endif
|
||||
|
||||
# llvm-config special casing. llvm-config is managed by update-alternatives.
|
||||
@ -465,7 +486,6 @@ mkdir -p %{buildroot}%{pkg_datadir}/llvm/cmake
|
||||
cp -Rv ../cmake/* %{buildroot}%{pkg_datadir}/llvm/cmake
|
||||
|
||||
%check
|
||||
|
||||
# non reproducible errors
|
||||
rm test/tools/dsymutil/X86/swift-interface.test
|
||||
|
||||
@ -474,7 +494,14 @@ rm test/tools/dsymutil/X86/swift-interface.test
|
||||
LD_LIBRARY_PATH=%{buildroot}/%{install_libdir} %{__ninja} check-all -C %{_vpath_builddir}
|
||||
%endif
|
||||
|
||||
%ldconfig_scriptlets libs
|
||||
%if %{with compat_build}
|
||||
# Packages that install files in /etc/ld.so.conf have to manually run
|
||||
# ldconfig.
|
||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=2001328 and
|
||||
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Scriptlets/#_linker_configuration_files
|
||||
%post -p /sbin/ldconfig libs
|
||||
%postun -p /sbin/ldconfig libs
|
||||
%endif
|
||||
|
||||
%post devel
|
||||
%{_sbindir}/update-alternatives --install %{_bindir}/llvm-config%{exec_suffix} llvm-config%{exec_suffix} %{install_bindir}/llvm-config%{exec_suffix}-%{__isa_bits} %{__isa_bits}
|
||||
@ -513,45 +540,44 @@ fi
|
||||
%license LICENSE.TXT
|
||||
%exclude %{_mandir}/man1/llvm-config*
|
||||
%{_mandir}/man1/*
|
||||
%{_bindir}/*
|
||||
%{install_bindir}/*
|
||||
%if %{with compat_build}
|
||||
# This is for all the binaries with the version suffix.
|
||||
%{_bindir}/*%{exec_suffix}
|
||||
%endif
|
||||
|
||||
%exclude %{_bindir}/llvm-config%{exec_suffix}
|
||||
%exclude %{install_bindir}/llvm-config%{exec_suffix}-%{__isa_bits}
|
||||
|
||||
%if %{without compat_build}
|
||||
%exclude %{_bindir}/llvm-config-%{maj_ver}
|
||||
%exclude %{install_bindir}/llvm-config-%{maj_ver}-%{__isa_bits}
|
||||
%exclude %{_bindir}/not
|
||||
%exclude %{_bindir}/count
|
||||
%exclude %{_bindir}/yaml-bench
|
||||
%exclude %{_bindir}/lli-child-target
|
||||
%exclude %{_bindir}/llvm-isel-fuzzer
|
||||
%exclude %{_bindir}/llvm-opt-fuzzer
|
||||
%{_datadir}/opt-viewer
|
||||
%else
|
||||
%{install_bindir}
|
||||
%endif
|
||||
%exclude %{install_bindir}/not
|
||||
%exclude %{install_bindir}/count
|
||||
%exclude %{install_bindir}/yaml-bench
|
||||
%exclude %{install_bindir}/lli-child-target
|
||||
%exclude %{install_bindir}/llvm-isel-fuzzer
|
||||
%exclude %{install_bindir}/llvm-opt-fuzzer
|
||||
%{pkg_datadir}/opt-viewer
|
||||
|
||||
%files libs
|
||||
%license LICENSE.TXT
|
||||
%{install_libdir}/libLLVM-%{maj_ver}%{?llvm_snapshot_version_suffix:%{llvm_snapshot_version_suffix}}.so
|
||||
%if %{without compat_build}
|
||||
%if %{with gold}
|
||||
%{_libdir}/LLVMgold.so
|
||||
%{install_libdir}/LLVMgold.so
|
||||
%if %{without compat_build}
|
||||
%{_libdir}/bfd-plugins/LLVMgold.so
|
||||
%endif
|
||||
%{_libdir}/libLLVM-%{maj_ver}.%{min_ver}*.so
|
||||
%{_libdir}/libLTO.so*
|
||||
%else
|
||||
%config(noreplace) /etc/ld.so.conf.d/%{name}-%{_arch}.conf
|
||||
%if %{with gold}
|
||||
%{_libdir}/%{name}/lib/LLVMgold.so
|
||||
%endif
|
||||
%{install_libdir}/libLLVM-%{maj_ver}.%{min_ver}*.so
|
||||
%{install_libdir}/libLLVM-%{maj_ver}.so
|
||||
%{install_libdir}/libLLVM.so.%{maj_ver}.%{min_ver}
|
||||
%{install_libdir}/libLTO.so*
|
||||
%exclude %{install_libdir}/libLTO.so
|
||||
%endif
|
||||
%{install_libdir}/libRemarks.so*
|
||||
%if %{with compat_build}
|
||||
%config(noreplace) /etc/ld.so.conf.d/%{name}-%{_arch}.conf
|
||||
%endif
|
||||
%if %{with bundle_compat_lib}
|
||||
%{_libdir}/libLLVM-%{compat_maj_ver}.so
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE.TXT
|
||||
@ -564,13 +590,10 @@ fi
|
||||
%{install_includedir}/llvm-c
|
||||
%{install_libdir}/libLLVM.so
|
||||
%{install_libdir}/cmake/llvm
|
||||
%if %{without compat_build}
|
||||
%{install_bindir}/llvm-config-%{maj_ver}-%{__isa_bits}
|
||||
%ghost %{_bindir}/llvm-config-%{maj_ver}
|
||||
%else
|
||||
%{pkg_includedir}/llvm
|
||||
%{pkg_includedir}/llvm-c
|
||||
%{install_libdir}/libLTO.so
|
||||
%if %{with bundle_compat_lib}
|
||||
%{_libdir}/llvm%{compat_maj_ver}/
|
||||
%endif
|
||||
|
||||
%files doc
|
||||
@ -580,27 +603,23 @@ fi
|
||||
%files static
|
||||
%license LICENSE.TXT
|
||||
%{install_libdir}/*.a
|
||||
%if %{without compat_build}
|
||||
%exclude %{install_libdir}/libLLVMTestingSupport.a
|
||||
%exclude %{install_libdir}/libLLVMTestingAnnotations.a
|
||||
%exclude %{install_libdir}/libllvm_gtest.a
|
||||
%exclude %{install_libdir}/libllvm_gtest_main.a
|
||||
%endif
|
||||
|
||||
%files cmake-utils
|
||||
%license LICENSE.TXT
|
||||
%{pkg_datadir}/llvm/cmake
|
||||
|
||||
%if %{without compat_build}
|
||||
|
||||
%files test
|
||||
%license LICENSE.TXT
|
||||
%{_bindir}/not
|
||||
%{_bindir}/count
|
||||
%{_bindir}/yaml-bench
|
||||
%{_bindir}/lli-child-target
|
||||
%{_bindir}/llvm-isel-fuzzer
|
||||
%{_bindir}/llvm-opt-fuzzer
|
||||
%{install_bindir}/not
|
||||
%{install_bindir}/count
|
||||
%{install_bindir}/yaml-bench
|
||||
%{install_bindir}/lli-child-target
|
||||
%{install_bindir}/llvm-isel-fuzzer
|
||||
%{install_bindir}/llvm-opt-fuzzer
|
||||
|
||||
%files googletest
|
||||
%license LICENSE.TXT
|
||||
@ -611,9 +630,11 @@ fi
|
||||
%{install_includedir}/llvm-gtest
|
||||
%{install_includedir}/llvm-gmock
|
||||
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Mar 27 2024 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 18.1.2-1
|
||||
- Update to LLVM 18.1.2 (RHEL-27724)
|
||||
|
||||
* Thu Feb 01 2024 Nikita Popov <npopov@redhat.com> - 17.0.6-6
|
||||
- Fix crash with -fzero-call-used-regs (rhbz#2262260)
|
||||
|
||||
@ -626,8 +647,6 @@ fi
|
||||
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 17.0.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
%{?llvm_snapshot_changelog_entry}
|
||||
|
||||
* Thu Nov 30 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 17.0.6-2
|
||||
- Fix rhbz #2248872
|
||||
|
||||
|
10
sources
10
sources
@ -1,6 +1,8 @@
|
||||
SHA512 (llvm-18.1.2.src.tar.xz) = 7cc429e21685b2b6123dfbbdb848d9ca2091acef4d0ad52a28054af06a228aa489551305a072692bb634b34b5ceb7373266ee973dc306a71b9b339fe05a77c25
|
||||
SHA512 (llvm-18.1.2.src.tar.xz.sig) = 8605109d6db1e88ea3a8a53e1288f77026392a41252fa4a84ef3ec817cc659a391c1795b39f258a5db49fac05adf5c6285ebac51979a8b42e72599ac55e4c0b3
|
||||
SHA512 (cmake-18.1.2.src.tar.xz) = 18df1b6d334757bc9c1c208f90a800d17905444055b49cb231cf80721b5e55f97d01d0102c931d278a138927ae64e6cb53d38dbc9bf93dea5b32c8a6a3f51d05
|
||||
SHA512 (cmake-18.1.2.src.tar.xz.sig) = afb10d0da43e51e6a403860d19de2bd906d335fcb8ce97fa7fd457b940aa5c166f7f6d99fbde5ea00515ca11be9d0f6cb02db3e3dae5c60ba8d84cb0fe528a93
|
||||
SHA512 (third-party-18.1.2.src.tar.xz) = 2378b4eb79701ead30b10d95f7f9ae632c5a1e83c2149ca687afeb9f80c2e8b4aeae12ebe431f41652fb9b8ea058c3ed1bad6716a2914056de94cd55d90cf680
|
||||
SHA512 (third-party-18.1.2.src.tar.xz.sig) = 379c6f98a064a46cc47c8049ff43c50193f140bbfe605c1146117ae4919abb10824674fadf45e71fff1e46478beaf5b48eafbf3a100d715691db06aab6c28659
|
||||
SHA512 (llvm-17.0.6.src.tar.xz) = bf9b04d0d45c67168b195c550cd8326e3a01176f92776705846aad3956a494bcb7a053b0b0bde19abd68dc0068e5c97ef99dee7eadfdb727bc0d758b2684f3bd
|
||||
SHA512 (llvm-17.0.6.src.tar.xz.sig) = 904066c34ec0adf5b9e789af640329cadc7919b111aca77fa3ce26450696bace20e299e2592251f96ee33fb83da603423cc0ca63a67ad627916fcab0bed59689
|
||||
SHA512 (cmake-17.0.6.src.tar.xz) = b2c5e404ca36542d44e1a7f2801bbcecbcf5f1e8c63b793bb2308228483406bdfe002720aadb913c0228cd2bbe5998465eaadc4a49fad6a5eb6ff907fa5fd45a
|
||||
SHA512 (cmake-17.0.6.src.tar.xz.sig) = fad2d91fc3e499dbd1b8c4acbc48ef748c106a04f7529232ea95abf3d006c4494e495643f77e653b1c96f7a0b79fe0706c5cdedd4f7dc4cbbab0ee5cf749c8ce
|
||||
SHA512 (third-party-17.0.6.src.tar.xz) = 242dada4800c5e558f5f243e6aa0905d90ca3f82cc81baf14c60de543a7e737d4c2f3471122f2c641dc4f0724e4ebf5cf137761a231b34aab2a12f1cfc902c53
|
||||
SHA512 (third-party-17.0.6.src.tar.xz.sig) = 6b72379b70a359a77f4d7d0922b0e80ff2a44d65178389b25edbc4a72029a91d50b3eb39a1185fac50dbba0a1972572eaadc7d82bb8e87d26f4e42c2bf676b75
|
||||
|
Loading…
Reference in New Issue
Block a user