import llvm-13.0.1-1.el9
This commit is contained in:
commit
a26338714f
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
SOURCES/llvm-13.0.1.src.tar.xz
|
||||||
|
SOURCES/tstellar-gpg-key.asc
|
2
.llvm.metadata
Normal file
2
.llvm.metadata
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
8e50e3e47b6a14a0848862c574fb0007db212482 SOURCES/llvm-13.0.1.src.tar.xz
|
||||||
|
b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc
|
25
SOURCES/0001-Deactivate-markdown-doc.patch
Normal file
25
SOURCES/0001-Deactivate-markdown-doc.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff -Naur a/llvm/docs/conf.py b/llvm/docs/conf.py
|
||||||
|
--- a/llvm/docs/conf.py 2020-09-15 09:12:24.318287611 +0000
|
||||||
|
+++ b/llvm/docs/conf.py 2020-09-15 15:01:00.025893199 +0000
|
||||||
|
@@ -36,20 +36,7 @@
|
||||||
|
'.rst': 'restructuredtext',
|
||||||
|
}
|
||||||
|
|
||||||
|
-try:
|
||||||
|
- import recommonmark
|
||||||
|
-except ImportError:
|
||||||
|
- # manpages do not use any .md sources
|
||||||
|
- if not tags.has('builder-man'):
|
||||||
|
- raise
|
||||||
|
-else:
|
||||||
|
- import sphinx
|
||||||
|
- if sphinx.version_info >= (3, 0):
|
||||||
|
- # This requires 0.5 or later.
|
||||||
|
- extensions.append('recommonmark')
|
||||||
|
- else:
|
||||||
|
- source_parsers = {'.md': 'recommonmark.parser.CommonMarkParser'}
|
||||||
|
- source_suffix['.md'] = 'markdown'
|
||||||
|
+import sphinx
|
||||||
|
|
||||||
|
# The encoding of source files.
|
||||||
|
#source_encoding = 'utf-8-sig'
|
@ -0,0 +1,33 @@
|
|||||||
|
From 9320ffeda3915c8f7be744c983a3470a89107bd7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tom Stellard <tstellar@redhat.com>
|
||||||
|
Date: Tue, 14 Sep 2021 20:21:20 -0700
|
||||||
|
Subject: [PATCH] XFAIL missing-abstract-variable.ll test on ppc64le
|
||||||
|
|
||||||
|
It's seems the strategy with this test is to XFAIL it on all
|
||||||
|
architectures that it fails on. I wonder if we should be passing
|
||||||
|
it a specific triple? Also, from what I can tell, this tests only
|
||||||
|
runs when llvm is configured with LLVM_DEFAULT_TARGET_TRIPLE set
|
||||||
|
to a non-empty value, which is why it may not fail in every build
|
||||||
|
configuration.
|
||||||
|
|
||||||
|
Differential Revision: https://reviews.llvm.org/D109806
|
||||||
|
---
|
||||||
|
llvm/test/DebugInfo/Generic/missing-abstract-variable.ll | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/llvm/test/DebugInfo/Generic/missing-abstract-variable.ll b/llvm/test/DebugInfo/Generic/missing-abstract-variable.ll
|
||||||
|
index bd0de60268b6..cc5d56b0c512 100644
|
||||||
|
--- a/llvm/test/DebugInfo/Generic/missing-abstract-variable.ll
|
||||||
|
+++ b/llvm/test/DebugInfo/Generic/missing-abstract-variable.ll
|
||||||
|
@@ -4,7 +4,7 @@
|
||||||
|
; powerpc64 (and on x86_64 at at least -O2). Presumably this is a SelectionDAG
|
||||||
|
; issue.
|
||||||
|
; FIXME: arm64 is an alias for aarch64 on macs, apparently?
|
||||||
|
-; XFAIL: powerpc64, aarch64, arm64, hexagon
|
||||||
|
+; XFAIL: powerpc64, aarch64, arm64, hexagon, ppc64le
|
||||||
|
|
||||||
|
; Build from the following source with clang -O2.
|
||||||
|
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
17
SOURCES/lit.fedora.cfg.py
Normal file
17
SOURCES/lit.fedora.cfg.py
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
|
||||||
|
config.llvm_tools_dir = '/usr/bin'
|
||||||
|
config.llvm_shlib_dir = '%(llvm_shlib_dir)s' % lit_config.params
|
||||||
|
|
||||||
|
if hasattr(config, 'host_triple'):
|
||||||
|
# This means we are running lit regression tests
|
||||||
|
|
||||||
|
# Regression tests write output to this directory, so we need to be able to specify
|
||||||
|
# a temp directory when invoking lit. e.g. lit -Dllvm_obj_root=/tmp/lit
|
||||||
|
config.llvm_obj_root = "%(llvm_obj_root)s" % lit_config.params
|
||||||
|
lit_config.load_config(config, '%(llvm_test_root)s/lit.cfg.py' % lit_config.params)
|
||||||
|
else:
|
||||||
|
# This means we are running lit unit tests
|
||||||
|
|
||||||
|
# For unit tests, llvm_obj_root is used to find the unit test binaries.
|
||||||
|
config.llvm_obj_root = '%(llvm_unittest_bindir)s' % lit_config.params
|
||||||
|
lit_config.load_config(config, '%(llvm_test_root)s/Unit/lit.cfg.py' % lit_config.params)
|
BIN
SOURCES/llvm-13.0.1.src.tar.xz.sig
Normal file
BIN
SOURCES/llvm-13.0.1.src.tar.xz.sig
Normal file
Binary file not shown.
59
SOURCES/run-lit-tests
Executable file
59
SOURCES/run-lit-tests
Executable file
@ -0,0 +1,59 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
usage() {
|
||||||
|
echo "usage: `basename $0` [OPTIONS]"
|
||||||
|
echo " --threads NUM The number of threads to use for running tests."
|
||||||
|
echo " --multilib-arch ARCH Use this option to test 32-bit libs/binaries on"
|
||||||
|
echo " 64-bit hosts."
|
||||||
|
}
|
||||||
|
|
||||||
|
threads_arg=''
|
||||||
|
|
||||||
|
while [ $# -gt 0 ]; do
|
||||||
|
case $1 in
|
||||||
|
--threads)
|
||||||
|
shift
|
||||||
|
threads_arg="--threads $1"
|
||||||
|
;;
|
||||||
|
--multilib-arch)
|
||||||
|
shift
|
||||||
|
ARCH=$1
|
||||||
|
;;
|
||||||
|
* )
|
||||||
|
echo "unknown option: $1"
|
||||||
|
echo ""
|
||||||
|
usage
|
||||||
|
exit 1
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
shift
|
||||||
|
done
|
||||||
|
|
||||||
|
set -xe
|
||||||
|
|
||||||
|
if [ -z "$ARCH" ]; then
|
||||||
|
ARCH=`rpm --eval '%_arch'`
|
||||||
|
fi
|
||||||
|
|
||||||
|
case $ARCH in
|
||||||
|
arm)
|
||||||
|
;&
|
||||||
|
i686)
|
||||||
|
LIB_DIR="/usr/lib/"
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
LIB_DIR="/usr/lib64/"
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
cd $(mktemp -d)
|
||||||
|
ln -s /usr/include include
|
||||||
|
ln -s /usr/share/llvm/src/docs docs
|
||||||
|
tar -xzf /usr/share/llvm/src/test.tar.gz
|
||||||
|
ln -s /usr/share/llvm/src/$ARCH.site.cfg.py test/lit.site.cfg.py
|
||||||
|
ln -s /usr/share/llvm/src/$ARCH.Unit.site.cfg.py test/Unit/lit.site.cfg.py
|
||||||
|
lit -v -s $threads_arg test \
|
||||||
|
-Dllvm_obj_root=`pwd` \
|
||||||
|
-Dllvm_test_root=`pwd`/test \
|
||||||
|
-Dllvm_unittest_bindir=$LIB_DIR/llvm \
|
||||||
|
-Dllvm_shlib_dir=$LIB_DIR
|
1155
SPECS/llvm.spec
Normal file
1155
SPECS/llvm.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user