llvm 3.9.1
This commit is contained in:
parent
ce8c38530f
commit
6448f2fb83
1
.gitignore
vendored
1
.gitignore
vendored
@ -29,3 +29,4 @@
|
|||||||
/llvm-3.8.0.src.tar.xz
|
/llvm-3.8.0.src.tar.xz
|
||||||
/llvm-3.8.1.src.tar.xz
|
/llvm-3.8.1.src.tar.xz
|
||||||
/llvm-3.9.0.src.tar.xz
|
/llvm-3.9.0.src.tar.xz
|
||||||
|
/llvm-3.9.1.src.tar.xz
|
||||||
|
13
llvm-r294646.patch
Normal file
13
llvm-r294646.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: docs/CommandGuide/lit.rst
|
||||||
|
===================================================================
|
||||||
|
--- docs/CommandGuide/lit.rst (revision 294645)
|
||||||
|
+++ docs/CommandGuide/lit.rst (revision 294646)
|
||||||
|
@@ -56,7 +56,7 @@
|
||||||
|
Search for :file:`{NAME}.cfg` and :file:`{NAME}.site.cfg` when searching for
|
||||||
|
test suites, instead of :file:`lit.cfg` and :file:`lit.site.cfg`.
|
||||||
|
|
||||||
|
-.. option:: -D NAME, -D NAME=VALUE, --param NAME, --param NAME=VALUE
|
||||||
|
+.. option:: -D NAME[=VALUE], --param NAME[=VALUE]
|
||||||
|
|
||||||
|
Add a user defined parameter ``NAME`` with the given ``VALUE`` (or the empty
|
||||||
|
string if not given). The meaning and use of these parameters is test suite
|
15
llvm.spec
15
llvm.spec
@ -6,8 +6,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: llvm
|
Name: llvm
|
||||||
Version: 3.9.0
|
Version: 3.9.1
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Low Level Virtual Machine
|
Summary: The Low Level Virtual Machine
|
||||||
|
|
||||||
License: NCSA
|
License: NCSA
|
||||||
@ -25,11 +25,12 @@ Patch3: 0001-fix-docs-3.patch
|
|||||||
Patch4: 0001-docs-fix-cmake-code-block-warning.patch
|
Patch4: 0001-docs-fix-cmake-code-block-warning.patch
|
||||||
# backport from upstream to fix lldb out of tree
|
# backport from upstream to fix lldb out of tree
|
||||||
Patch5: 0001-cmake-Install-CheckAtomic.cmake-needed-by-lldb.patch
|
Patch5: 0001-cmake-Install-CheckAtomic.cmake-needed-by-lldb.patch
|
||||||
|
# Upstream patch to fix doc build
|
||||||
|
# http://llvm.org/viewvc/llvm-project?view=revision&revision=294646
|
||||||
|
Patch6: llvm-r294646.patch
|
||||||
|
|
||||||
# backports cribbed from https://github.com/rust-lang/llvm/
|
# backports cribbed from https://github.com/rust-lang/llvm/
|
||||||
Patch47: rust-lang-llvm-pr47.patch
|
Patch47: rust-lang-llvm-pr47.patch
|
||||||
Patch48: rust-lang-llvm-pr48.patch
|
|
||||||
Patch51: rust-lang-llvm-pr51.patch
|
|
||||||
Patch53: rust-lang-llvm-pr53.patch
|
Patch53: rust-lang-llvm-pr53.patch
|
||||||
Patch54: rust-lang-llvm-pr54.patch
|
Patch54: rust-lang-llvm-pr54.patch
|
||||||
Patch55: rust-lang-llvm-pr55.patch
|
Patch55: rust-lang-llvm-pr55.patch
|
||||||
@ -91,9 +92,8 @@ Static libraries for the LLVM compiler infrastructure.
|
|||||||
%patch3 -p1 -b .docs3
|
%patch3 -p1 -b .docs3
|
||||||
%patch4 -p1 -b .docs4
|
%patch4 -p1 -b .docs4
|
||||||
%patch5 -p1 -b .lldbfix
|
%patch5 -p1 -b .lldbfix
|
||||||
|
%patch6 -p0 -b .doc-lit
|
||||||
%patch47 -p1 -b .rust47
|
%patch47 -p1 -b .rust47
|
||||||
%patch48 -p1 -b .rust48
|
|
||||||
%patch51 -p1 -b .rust51
|
|
||||||
%patch53 -p1 -b .rust53
|
%patch53 -p1 -b .rust53
|
||||||
%patch54 -p1 -b .rust54
|
%patch54 -p1 -b .rust54
|
||||||
%patch55 -p1 -b .rust55
|
%patch55 -p1 -b .rust55
|
||||||
@ -213,6 +213,9 @@ make check-all || :
|
|||||||
%{_libdir}/*.a
|
%{_libdir}/*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 10 2017 Orion Poplawski <orion@cora.nwra.com> - 3.9.1-1
|
||||||
|
- llvm 3.9.1
|
||||||
|
|
||||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.9.0-8
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.9.0-8
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
@ -1,84 +0,0 @@
|
|||||||
From eee68eafa7e8e4ce996b49f5551636639a6c331a Mon Sep 17 00:00:00 2001
|
|
||||||
From: David Majnemer <david.majnemer@gmail.com>
|
|
||||||
Date: Mon, 29 Aug 2016 17:14:08 +0000
|
|
||||||
Subject: [rust-lang/llvm#48] [SimplifyCFG] Hoisting invalidates metadata
|
|
||||||
|
|
||||||
We forgot to remove optimization metadata when performing hosting during
|
|
||||||
FoldTwoEntryPHINode.
|
|
||||||
|
|
||||||
This fixes PR29163.
|
|
||||||
|
|
||||||
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@279980 91177308-0d34-0410-b5e6-96231b3b80d8
|
|
||||||
---
|
|
||||||
lib/Transforms/Utils/SimplifyCFG.cpp | 10 ++++++++--
|
|
||||||
test/Transforms/SimplifyCFG/PR29163.ll | 31 +++++++++++++++++++++++++++++++
|
|
||||||
2 files changed, 39 insertions(+), 2 deletions(-)
|
|
||||||
create mode 100644 test/Transforms/SimplifyCFG/PR29163.ll
|
|
||||||
|
|
||||||
diff --git a/lib/Transforms/Utils/SimplifyCFG.cpp b/lib/Transforms/Utils/SimplifyCFG.cpp
|
|
||||||
index 0504646c304e..c197317ac771 100644
|
|
||||||
--- a/lib/Transforms/Utils/SimplifyCFG.cpp
|
|
||||||
+++ b/lib/Transforms/Utils/SimplifyCFG.cpp
|
|
||||||
@@ -2024,14 +2024,20 @@ static bool FoldTwoEntryPHINode(PHINode *PN, const TargetTransformInfo &TTI,
|
|
||||||
|
|
||||||
// Move all 'aggressive' instructions, which are defined in the
|
|
||||||
// conditional parts of the if's up to the dominating block.
|
|
||||||
- if (IfBlock1)
|
|
||||||
+ if (IfBlock1) {
|
|
||||||
+ for (auto &I : *IfBlock1)
|
|
||||||
+ I.dropUnknownNonDebugMetadata();
|
|
||||||
DomBlock->getInstList().splice(InsertPt->getIterator(),
|
|
||||||
IfBlock1->getInstList(), IfBlock1->begin(),
|
|
||||||
IfBlock1->getTerminator()->getIterator());
|
|
||||||
- if (IfBlock2)
|
|
||||||
+ }
|
|
||||||
+ if (IfBlock2) {
|
|
||||||
+ for (auto &I : *IfBlock2)
|
|
||||||
+ I.dropUnknownNonDebugMetadata();
|
|
||||||
DomBlock->getInstList().splice(InsertPt->getIterator(),
|
|
||||||
IfBlock2->getInstList(), IfBlock2->begin(),
|
|
||||||
IfBlock2->getTerminator()->getIterator());
|
|
||||||
+ }
|
|
||||||
|
|
||||||
while (PHINode *PN = dyn_cast<PHINode>(BB->begin())) {
|
|
||||||
// Change the PHI node into a select instruction.
|
|
||||||
diff --git a/test/Transforms/SimplifyCFG/PR29163.ll b/test/Transforms/SimplifyCFG/PR29163.ll
|
|
||||||
new file mode 100644
|
|
||||||
index 000000000000..65f9090dd135
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/test/Transforms/SimplifyCFG/PR29163.ll
|
|
||||||
@@ -0,0 +1,31 @@
|
|
||||||
+; RUN: opt -S -simplifycfg < %s | FileCheck %s
|
|
||||||
+target datalayout = "e-m:e-i64:64-f80:128-n8:16:32:64-S128"
|
|
||||||
+target triple = "x86_64-unknown-linux-gnu"
|
|
||||||
+
|
|
||||||
+@GV = external constant i64*
|
|
||||||
+
|
|
||||||
+define i64* @test1(i1 %cond, i8* %P) {
|
|
||||||
+entry:
|
|
||||||
+ br i1 %cond, label %if, label %then
|
|
||||||
+
|
|
||||||
+then:
|
|
||||||
+ %bc = bitcast i8* %P to i64*
|
|
||||||
+ br label %join
|
|
||||||
+
|
|
||||||
+if:
|
|
||||||
+ %load = load i64*, i64** @GV, align 8, !dereferenceable !0
|
|
||||||
+ br label %join
|
|
||||||
+
|
|
||||||
+join:
|
|
||||||
+ %phi = phi i64* [ %bc, %then ], [ %load, %if ]
|
|
||||||
+ ret i64* %phi
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+; CHECK-LABEL: define i64* @test1(
|
|
||||||
+; CHECK: %[[bc:.*]] = bitcast i8* %P to i64*
|
|
||||||
+; CHECK: %[[load:.*]] = load i64*, i64** @GV, align 8{{$}}
|
|
||||||
+; CHECK: %[[phi:.*]] = select i1 %cond, i64* %[[load]], i64* %[[bc]]
|
|
||||||
+; CHECK: ret i64* %[[phi]]
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+!0 = !{i64 8}
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
@ -1,55 +0,0 @@
|
|||||||
From 7801978ec1f3637fcda1b564048ebc732bf586af Mon Sep 17 00:00:00 2001
|
|
||||||
From: Simonas Kazlauskas <git@kazlauskas.me>
|
|
||||||
Date: Fri, 16 Sep 2016 00:32:20 +0300
|
|
||||||
Subject: [rust-lang/llvm#51] Backport rL281650
|
|
||||||
|
|
||||||
---
|
|
||||||
lib/Transforms/InstCombine/InstCombineCompares.cpp | 2 +-
|
|
||||||
test/Transforms/InstCombine/indexed-gep-compares.ll | 20 ++++++++++++++++++++
|
|
||||||
2 files changed, 21 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/lib/Transforms/InstCombine/InstCombineCompares.cpp b/lib/Transforms/InstCombine/InstCombineCompares.cpp
|
|
||||||
index bfd73f4bbac5..961497fe3c2d 100644
|
|
||||||
--- a/lib/Transforms/InstCombine/InstCombineCompares.cpp
|
|
||||||
+++ b/lib/Transforms/InstCombine/InstCombineCompares.cpp
|
|
||||||
@@ -634,7 +634,7 @@ static bool canRewriteGEPAsOffset(Value *Start, Value *Base,
|
|
||||||
}
|
|
||||||
|
|
||||||
if (!isa<IntToPtrInst>(V) && !isa<PtrToIntInst>(V) &&
|
|
||||||
- !isa<GEPOperator>(V) && !isa<PHINode>(V))
|
|
||||||
+ !isa<GetElementPtrInst>(V) && !isa<PHINode>(V))
|
|
||||||
// We've found some value that we can't explore which is different from
|
|
||||||
// the base. Therefore we can't do this transformation.
|
|
||||||
return false;
|
|
||||||
diff --git a/test/Transforms/InstCombine/indexed-gep-compares.ll b/test/Transforms/InstCombine/indexed-gep-compares.ll
|
|
||||||
index 495881549e25..64dff2712976 100644
|
|
||||||
--- a/test/Transforms/InstCombine/indexed-gep-compares.ll
|
|
||||||
+++ b/test/Transforms/InstCombine/indexed-gep-compares.ll
|
|
||||||
@@ -167,4 +167,24 @@ lpad:
|
|
||||||
; CHECK: ret i32* %[[PTR]]
|
|
||||||
}
|
|
||||||
|
|
||||||
+
|
|
||||||
+@pr30402 = constant i64 3
|
|
||||||
+define i1 @test7() {
|
|
||||||
+entry:
|
|
||||||
+ br label %bb7
|
|
||||||
+
|
|
||||||
+bb7: ; preds = %bb10, %entry-block
|
|
||||||
+ %phi = phi i64* [ @pr30402, %entry ], [ getelementptr inbounds (i64, i64* @pr30402, i32 1), %bb7 ]
|
|
||||||
+ %cmp = icmp eq i64* %phi, getelementptr inbounds (i64, i64* @pr30402, i32 1)
|
|
||||||
+ br i1 %cmp, label %bb10, label %bb7
|
|
||||||
+
|
|
||||||
+bb10:
|
|
||||||
+ ret i1 %cmp
|
|
||||||
+}
|
|
||||||
+; CHECK-LABEL: @test7(
|
|
||||||
+; CHECK: %[[phi:.*]] = phi i64* [ @pr30402, %entry ], [ getelementptr inbounds (i64, i64* @pr30402, i32 1), %bb7 ]
|
|
||||||
+; CHECK: %[[cmp:.*]] = icmp eq i64* %[[phi]], getelementptr inbounds (i64, i64* @pr30402, i32 1)
|
|
||||||
+; CHECK: ret i1 %[[cmp]]
|
|
||||||
+
|
|
||||||
+
|
|
||||||
declare i32 @__gxx_personality_v0(...)
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user