parent
b758d604f4
commit
0c1a6a6af9
26
0101-Deactivate-markdown-doc.patch
Normal file
26
0101-Deactivate-markdown-doc.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
diff -Naur a/llvm/docs/conf.py b/llvm/docs/conf.py
|
||||||
|
--- a/llvm/docs/conf.py 2020-09-15 09:12:24.318287611 +0000
|
||||||
|
+++ b/llvm/docs/conf.py 2020-09-15 15:01:00.025893199 +0000
|
||||||
|
@@ -36,21 +36,7 @@
|
||||||
|
".rst": "restructuredtext",
|
||||||
|
}
|
||||||
|
|
||||||
|
-try:
|
||||||
|
- import recommonmark
|
||||||
|
-except ImportError:
|
||||||
|
- # manpages do not use any .md sources
|
||||||
|
- if not tags.has("builder-man"):
|
||||||
|
- raise
|
||||||
|
-else:
|
||||||
|
- import sphinx
|
||||||
|
-
|
||||||
|
- if sphinx.version_info >= (3, 0):
|
||||||
|
- # This requires 0.5 or later.
|
||||||
|
- extensions.append("recommonmark")
|
||||||
|
- else:
|
||||||
|
- source_parsers = {".md": "recommonmark.parser.CommonMarkParser"}
|
||||||
|
- source_suffix[".md"] = "markdown"
|
||||||
|
+import sphinx
|
||||||
|
|
||||||
|
# The encoding of source files.
|
||||||
|
# source_encoding = 'utf-8-sig'
|
141
llvm.spec
141
llvm.spec
@ -1,3 +1,10 @@
|
|||||||
|
%bcond_with snapshot_build
|
||||||
|
|
||||||
|
%if %{with snapshot_build}
|
||||||
|
# Unlock LLVM Snapshot LUA functions
|
||||||
|
%{llvm_sb}
|
||||||
|
%endif
|
||||||
|
|
||||||
# We are building with clang for faster/lower memory LTO builds.
|
# We are building with clang for faster/lower memory LTO builds.
|
||||||
# See https://docs.fedoraproject.org/en-US/packaging-guidelines/#_compiler_macros
|
# See https://docs.fedoraproject.org/en-US/packaging-guidelines/#_compiler_macros
|
||||||
%global toolchain clang
|
%global toolchain clang
|
||||||
@ -12,25 +19,41 @@
|
|||||||
%bcond_with gold
|
%bcond_with gold
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%bcond_with compat_build
|
%bcond_without compat_build
|
||||||
%bcond_with bundle_compat_lib
|
%bcond_with bundle_compat_lib
|
||||||
%bcond_without check
|
%bcond_without check
|
||||||
|
|
||||||
|
%ifarch %ix86
|
||||||
|
# Disable LTO on x86 in order to reduce memory consumption
|
||||||
|
%bcond_with lto_build
|
||||||
|
%elif %{with snapshot_build}
|
||||||
|
# Disable LTO to speed up builds
|
||||||
|
%bcond_with lto_build
|
||||||
|
%else
|
||||||
|
%bcond_without lto_build
|
||||||
|
%endif
|
||||||
|
|
||||||
%if %{with bundle_compat_lib}
|
%if %{with bundle_compat_lib}
|
||||||
%global compat_maj_ver 15
|
%global compat_maj_ver 15
|
||||||
%global compat_ver %{compat_maj_ver}.0.7
|
%global compat_ver %{compat_maj_ver}.0.7
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%global llvm_libdir %{_libdir}/%{name}
|
%global maj_ver 17
|
||||||
%global build_llvm_libdir %{buildroot}%{llvm_libdir}
|
|
||||||
#global rc_ver 3
|
|
||||||
%global maj_ver 16
|
|
||||||
%global min_ver 0
|
%global min_ver 0
|
||||||
%global patch_ver 6
|
%global patch_ver 1
|
||||||
|
#global rc_ver 4
|
||||||
|
|
||||||
|
%if %{with snapshot_build}
|
||||||
|
%undefine rc_ver
|
||||||
|
%global maj_ver %{llvm_snapshot_version_major}
|
||||||
|
%global min_ver %{llvm_snapshot_version_minor}
|
||||||
|
%global patch_ver %{llvm_snapshot_version_patch}
|
||||||
|
%endif
|
||||||
|
|
||||||
%global llvm_srcdir llvm-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
%global llvm_srcdir llvm-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
%global cmake_srcdir cmake-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
%global cmake_srcdir cmake-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
%global third_party_srcdir third-party-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_
|
%global third_party_srcdir third-party-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
ver:rc%{rc_ver}}.src
|
%global _lto_cflags -flto=thin
|
||||||
|
|
||||||
%if %{with compat_build}
|
%if %{with compat_build}
|
||||||
%global pkg_name llvm%{maj_ver}
|
%global pkg_name llvm%{maj_ver}
|
||||||
@ -80,12 +103,18 @@ ver:rc%{rc_ver}}.src
|
|||||||
%undefine _py3_shebang_P
|
%undefine _py3_shebang_P
|
||||||
|
|
||||||
Name: %{pkg_name}
|
Name: %{pkg_name}
|
||||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}%{?llvm_snapshot_version_suffix:~%{llvm_snapshot_version_suffix}}
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Low Level Virtual Machine
|
Summary: The Low Level Virtual Machine
|
||||||
|
|
||||||
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
||||||
URL: http://llvm.org
|
URL: http://llvm.org
|
||||||
|
%if %{with snapshot_build}
|
||||||
|
Source0: %{llvm_snapshot_source_prefix}llvm-%{llvm_snapshot_yyyymmdd}.src.tar.xz
|
||||||
|
Source2: %{llvm_snapshot_source_prefix}cmake-%{llvm_snapshot_yyyymmdd}.src.tar.xz
|
||||||
|
Source4: %{llvm_snapshot_source_prefix}third-party-%{llvm_snapshot_yyyymmdd}.src.tar.xz
|
||||||
|
%{llvm_snapshot_extra_source_tags}
|
||||||
|
%else
|
||||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{llvm_srcdir}.tar.xz
|
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{llvm_srcdir}.tar.xz
|
||||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{llvm_srcdir}.tar.xz.sig
|
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{llvm_srcdir}.tar.xz.sig
|
||||||
Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz
|
Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz
|
||||||
@ -98,20 +127,10 @@ Source6: release-keys.asc
|
|||||||
Source7: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compat_ver}/llvm-%{compat_ver}.src.tar.xz
|
Source7: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compat_ver}/llvm-%{compat_ver}.src.tar.xz
|
||||||
Source8: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compat_ver}/llvm-%{compat_ver}.src.tar.xz.sig
|
Source8: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compat_ver}/llvm-%{compat_ver}.src.tar.xz.sig
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
# Backported from LLVM 17
|
# RHEL-specific patch to avoid unwanted recommonmark dep
|
||||||
Patch1: 0001-SystemZ-Improve-error-messages-for-unsupported-reloc.patch
|
Patch101: 0101-Deactivate-markdown-doc.patch
|
||||||
# See https://reviews.llvm.org/D137890 for the next two patches
|
|
||||||
Patch2: 0001-llvm-Add-install-targets-for-gtest.patch
|
|
||||||
# Backport of https://reviews.llvm.org/D156379 from LLVM 18.
|
|
||||||
Patch3: D156379.diff
|
|
||||||
|
|
||||||
# Patching third-party dir with a 200 offset in patch number
|
|
||||||
Patch201: 0201-third-party-Add-install-targets-for-gtest.patch
|
|
||||||
|
|
||||||
# RHEL-specific patches
|
|
||||||
Patch101: 0001-Deactivate-markdown-doc.patch
|
|
||||||
#Patch102: 1.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -163,14 +182,15 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
|||||||
# app that requires the libLLVMLineEditor, so we need to make sure
|
# app that requires the libLLVMLineEditor, so we need to make sure
|
||||||
# libedit-devel is available.
|
# libedit-devel is available.
|
||||||
Requires: libedit-devel
|
Requires: libedit-devel
|
||||||
# The installed cmake files reference binaries from llvm-test and llvm-static.
|
# The installed cmake files reference binaries from llvm-test, llvm-static, and
|
||||||
# We tried in the past to split the cmake exports for these binaries out into
|
# llvm-gtest. We tried in the past to split the cmake exports for these binaries
|
||||||
# separate files, so that llvm-devel would not need to Require these packages,
|
# out into separate files, so that llvm-devel would not need to Require these packages,
|
||||||
# but this caused bugs (rhbz#1773678) and forced us to carry two non-upstream
|
# but this caused bugs (rhbz#1773678) and forced us to carry two non-upstream
|
||||||
# patches.
|
# patches.
|
||||||
Requires: %{name}-static%{?_isa} = %{version}-%{release}
|
Requires: %{name}-static%{?_isa} = %{version}-%{release}
|
||||||
%if %{without compat_build}
|
%if %{without compat_build}
|
||||||
Requires: %{name}-test%{?_isa} = %{version}-%{release}
|
Requires: %{name}-test%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: %{name}-googletest%{?_isa} = %{version}-%{release}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
@ -206,6 +226,13 @@ Provides: llvm-static(major) = %{maj_ver}
|
|||||||
%description static
|
%description static
|
||||||
Static libraries for the LLVM compiler infrastructure.
|
Static libraries for the LLVM compiler infrastructure.
|
||||||
|
|
||||||
|
%package cmake-utils
|
||||||
|
Summary: CMake utilities shared across LLVM subprojects
|
||||||
|
|
||||||
|
%description cmake-utils
|
||||||
|
CMake utilities shared across LLVM subprojects.
|
||||||
|
This is for internal use by LLVM packages only.
|
||||||
|
|
||||||
%if %{without compat_build}
|
%if %{without compat_build}
|
||||||
|
|
||||||
%package test
|
%package test
|
||||||
@ -239,12 +266,14 @@ This is the main package for llvm-toolset.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
|
%if %{without snapshot_build}
|
||||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE3}' --data='%{SOURCE2}'
|
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE3}' --data='%{SOURCE2}'
|
||||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE5}' --data='%{SOURCE4}'
|
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE5}' --data='%{SOURCE4}'
|
||||||
%if %{with bundle_compat_lib}
|
%if %{with bundle_compat_lib}
|
||||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE8}' --data='%{SOURCE7}'
|
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE8}' --data='%{SOURCE7}'
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
%setup -T -q -b 2 -n %{cmake_srcdir}
|
%setup -T -q -b 2 -n %{cmake_srcdir}
|
||||||
# TODO: It would be more elegant to set -DLLVM_COMMON_CMAKE_UTILS=%{_builddir}/%{cmake_srcdir},
|
# TODO: It would be more elegant to set -DLLVM_COMMON_CMAKE_UTILS=%{_builddir}/%{cmake_srcdir},
|
||||||
@ -285,6 +314,7 @@ mv %{third_party_srcdir} third-party
|
|||||||
export ASMFLAGS="%{build_cflags}"
|
export ASMFLAGS="%{build_cflags}"
|
||||||
|
|
||||||
# force off shared libs as cmake macros turns it on.
|
# force off shared libs as cmake macros turns it on.
|
||||||
|
# TODO: Disable LLVM_UNREACHABLE_OPTIMIZE.
|
||||||
%cmake -G Ninja \
|
%cmake -G Ninja \
|
||||||
-DBUILD_SHARED_LIBS:BOOL=OFF \
|
-DBUILD_SHARED_LIBS:BOOL=OFF \
|
||||||
-DLLVM_PARALLEL_LINK_JOBS=1 \
|
-DLLVM_PARALLEL_LINK_JOBS=1 \
|
||||||
@ -347,18 +377,20 @@ export ASMFLAGS="%{build_cflags}"
|
|||||||
%if %{without compat_build}
|
%if %{without compat_build}
|
||||||
-DLLVM_VERSION_SUFFIX='' \
|
-DLLVM_VERSION_SUFFIX='' \
|
||||||
%endif
|
%endif
|
||||||
-DLLVM_UNREACHABLE_OPTIMIZE:BOOL=OFF \
|
-DLLVM_UNREACHABLE_OPTIMIZE:BOOL=ON \
|
||||||
-DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
|
-DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
|
||||||
-DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
|
-DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
|
||||||
-DLLVM_BUILD_EXTERNAL_COMPILER_RT:BOOL=ON \
|
-DLLVM_BUILD_EXTERNAL_COMPILER_RT:BOOL=ON \
|
||||||
-DLLVM_INSTALL_TOOLCHAIN_ONLY:BOOL=OFF \
|
-DLLVM_INSTALL_TOOLCHAIN_ONLY:BOOL=OFF \
|
||||||
\
|
|
||||||
-DLLVM_DEFAULT_TARGET_TRIPLE=%{llvm_triple} \
|
-DLLVM_DEFAULT_TARGET_TRIPLE=%{llvm_triple} \
|
||||||
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
|
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
|
||||||
-DCMAKE_INSTALL_PREFIX=%{install_prefix} \
|
-DCMAKE_INSTALL_PREFIX=%{install_prefix} \
|
||||||
-DLLVM_INSTALL_SPHINX_HTML_DIR=%{_pkgdocdir}/html \
|
-DLLVM_INSTALL_SPHINX_HTML_DIR=%{_pkgdocdir}/html \
|
||||||
-DSPHINX_EXECUTABLE=%{_bindir}/sphinx-build-3 \
|
-DSPHINX_EXECUTABLE=%{_bindir}/sphinx-build-3 \
|
||||||
-DLLVM_INCLUDE_BENCHMARKS=OFF \
|
-DLLVM_INCLUDE_BENCHMARKS=OFF \
|
||||||
|
%if %{with lto_build}
|
||||||
|
-DLLVM_UNITTEST_LINK_FLAGS="-Wl,-plugin-opt=O0" \
|
||||||
|
%endif
|
||||||
-DCMAKE_SHARED_LINKER_FLAGS="$LDFLAGS -Wl,-z,cet-report=error"
|
-DCMAKE_SHARED_LINKER_FLAGS="$LDFLAGS -Wl,-z,cet-report=error"
|
||||||
|
|
||||||
# Build libLLVM.so first. This ensures that when libLLVM.so is linking, there
|
# Build libLLVM.so first. This ensures that when libLLVM.so is linking, there
|
||||||
@ -419,11 +451,7 @@ rm -rf test/tools/UpdateTestChecks
|
|||||||
%multilib_fix_c_header --file %{_includedir}/llvm/Config/llvm-config.h
|
%multilib_fix_c_header --file %{_includedir}/llvm/Config/llvm-config.h
|
||||||
|
|
||||||
# Install libraries needed for unittests
|
# Install libraries needed for unittests
|
||||||
%if 0%{?__isa_bits} == 64
|
%global build_libdir %{_vpath_builddir}/%{_lib}
|
||||||
%global build_libdir %{_vpath_builddir}/lib64
|
|
||||||
%else
|
|
||||||
%global build_libdir %{_vpath_builddir}/lib
|
|
||||||
%endif
|
|
||||||
|
|
||||||
install %{build_libdir}/libLLVMTestingSupport.a %{buildroot}%{_libdir}
|
install %{build_libdir}/libLLVMTestingSupport.a %{buildroot}%{_libdir}
|
||||||
install %{build_libdir}/libLLVMTestingAnnotations.a %{buildroot}%{_libdir}
|
install %{build_libdir}/libLLVMTestingAnnotations.a %{buildroot}%{_libdir}
|
||||||
@ -453,7 +481,7 @@ ln -s ../../../%{install_includedir}/llvm-c %{buildroot}/%{pkg_includedir}/llvm-
|
|||||||
# Create ld.so.conf.d entry
|
# Create ld.so.conf.d entry
|
||||||
mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
||||||
cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/%{name}-%{_arch}.conf << EOF
|
cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/%{name}-%{_arch}.conf << EOF
|
||||||
%{pkg_libdir}
|
%{install_libdir}
|
||||||
EOF
|
EOF
|
||||||
|
|
||||||
# Add version suffix to man pages and move them to mandir.
|
# Add version suffix to man pages and move them to mandir.
|
||||||
@ -475,19 +503,19 @@ rm -Rf %{build_install_prefix}/share/opt-viewer
|
|||||||
|
|
||||||
%if %{without compat_build}
|
%if %{without compat_build}
|
||||||
|
|
||||||
mv %{buildroot}/%{pkg_bindir}/llvm-config %{buildroot}/%{pkg_bindir}/llvm-config%{exec_suffix}-%{__isa_bits}
|
mv %{buildroot}/%{install_bindir}/llvm-config %{buildroot}/%{install_bindir}/llvm-config%{exec_suffix}-%{__isa_bits}
|
||||||
# We still maintain a versionned symlink for consistency across llvm versions.
|
# We still maintain a versionned symlink for consistency across llvm versions.
|
||||||
# This is specific to the non-compat build and matches the exec prefix for
|
# This is specific to the non-compat build and matches the exec prefix for
|
||||||
# compat builds. An isa-agnostic versionned symlink is also maintained in the (un)install
|
# compat builds. An isa-agnostic versionned symlink is also maintained in the (un)install
|
||||||
# steps.
|
# steps.
|
||||||
(cd %{buildroot}/%{pkg_bindir} ; ln -s llvm-config%{exec_suffix}-%{__isa_bits} llvm-config-%{maj_ver}-%{__isa_bits} )
|
(cd %{buildroot}/%{install_bindir} ; ln -s llvm-config%{exec_suffix}-%{__isa_bits} llvm-config-%{maj_ver}-%{__isa_bits} )
|
||||||
# ghost presence
|
# ghost presence
|
||||||
touch %{buildroot}%{_bindir}/llvm-config-%{maj_ver}
|
touch %{buildroot}%{_bindir}/llvm-config-%{maj_ver}
|
||||||
|
|
||||||
%else
|
%else
|
||||||
|
|
||||||
rm %{buildroot}%{_bindir}/llvm-config%{exec_suffix}
|
rm %{buildroot}%{_bindir}/llvm-config%{exec_suffix}
|
||||||
(cd %{buildroot}/%{pkg_bindir} ; ln -s llvm-config llvm-config%{exec_suffix}-%{__isa_bits} )
|
(cd %{buildroot}/%{install_bindir} ; ln -s llvm-config llvm-config%{exec_suffix}-%{__isa_bits} )
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -495,7 +523,8 @@ rm %{buildroot}%{_bindir}/llvm-config%{exec_suffix}
|
|||||||
touch %{buildroot}%{_bindir}/llvm-config%{exec_suffix}
|
touch %{buildroot}%{_bindir}/llvm-config%{exec_suffix}
|
||||||
|
|
||||||
%if %{without compat_build}
|
%if %{without compat_build}
|
||||||
cp -Rv ../cmake/Modules/* %{buildroot}%{_libdir}/cmake/llvm
|
mkdir -p %{buildroot}%{pkg_datadir}/llvm/cmake
|
||||||
|
cp -Rv ../cmake/* %{buildroot}%{pkg_datadir}/llvm/cmake
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
@ -514,7 +543,7 @@ rm test/tools/dsymutil/X86/swift-interface.test
|
|||||||
|
|
||||||
%if %{with check}
|
%if %{with check}
|
||||||
# FIXME: use %%cmake_build instead of %%__ninja
|
# FIXME: use %%cmake_build instead of %%__ninja
|
||||||
LD_LIBRARY_PATH=%{buildroot}/%{pkg_libdir} %{__ninja} check-all -C %{_vpath_builddir}
|
LD_LIBRARY_PATH=%{buildroot}/%{install_libdir} %{__ninja} check-all -C %{_vpath_builddir}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -522,16 +551,16 @@ LD_LIBRARY_PATH=%{buildroot}/%{pkg_libdir} %{__ninja} check-all -C %{_vpath_bui
|
|||||||
%ldconfig_scriptlets libs
|
%ldconfig_scriptlets libs
|
||||||
|
|
||||||
%post devel
|
%post devel
|
||||||
%{_sbindir}/update-alternatives --install %{_bindir}/llvm-config%{exec_suffix} llvm-config%{exec_suffix} %{pkg_bindir}/llvm-config%{exec_suffix}-%{__isa_bits} %{__isa_bits}
|
%{_sbindir}/update-alternatives --install %{_bindir}/llvm-config%{exec_suffix} llvm-config%{exec_suffix} %{install_bindir}/llvm-config%{exec_suffix}-%{__isa_bits} %{__isa_bits}
|
||||||
%if %{without compat_build}
|
%if %{without compat_build}
|
||||||
%{_sbindir}/update-alternatives --install %{_bindir}/llvm-config-%{maj_ver} llvm-config-%{maj_ver} %{pkg_bindir}/llvm-config%{exec_suffix}-%{__isa_bits} %{__isa_bits}
|
%{_sbindir}/update-alternatives --install %{_bindir}/llvm-config-%{maj_ver} llvm-config-%{maj_ver} %{install_bindir}/llvm-config%{exec_suffix}-%{__isa_bits} %{__isa_bits}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%postun devel
|
%postun devel
|
||||||
if [ $1 -eq 0 ]; then
|
if [ $1 -eq 0 ]; then
|
||||||
%{_sbindir}/update-alternatives --remove llvm-config%{exec_suffix} %{pkg_bindir}/llvm-config%{exec_suffix}-%{__isa_bits}
|
%{_sbindir}/update-alternatives --remove llvm-config%{exec_suffix} %{install_bindir}/llvm-config%{exec_suffix}-%{__isa_bits}
|
||||||
%if %{without compat_build}
|
%if %{without compat_build}
|
||||||
%{_sbindir}/update-alternatives --remove llvm-config-%{maj_ver} %{pkg_bindir}/llvm-config%{exec_suffix}-%{__isa_bits}
|
%{_sbindir}/update-alternatives --remove llvm-config-%{maj_ver} %{install_bindir}/llvm-config%{exec_suffix}-%{__isa_bits}
|
||||||
%endif
|
%endif
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -542,11 +571,11 @@ fi
|
|||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
|
|
||||||
%exclude %{_bindir}/llvm-config%{exec_suffix}
|
%exclude %{_bindir}/llvm-config%{exec_suffix}
|
||||||
%exclude %{pkg_bindir}/llvm-config%{exec_suffix}-%{__isa_bits}
|
%exclude %{install_bindir}/llvm-config%{exec_suffix}-%{__isa_bits}
|
||||||
|
|
||||||
%if %{without compat_build}
|
%if %{without compat_build}
|
||||||
%exclude %{_bindir}/llvm-config-%{maj_ver}
|
%exclude %{_bindir}/llvm-config-%{maj_ver}
|
||||||
%exclude %{pkg_bindir}/llvm-config-%{maj_ver}-%{__isa_bits}
|
%exclude %{install_bindir}/llvm-config-%{maj_ver}-%{__isa_bits}
|
||||||
%exclude %{_bindir}/not
|
%exclude %{_bindir}/not
|
||||||
%exclude %{_bindir}/count
|
%exclude %{_bindir}/count
|
||||||
%exclude %{_bindir}/yaml-bench
|
%exclude %{_bindir}/yaml-bench
|
||||||
@ -555,12 +584,12 @@ fi
|
|||||||
%exclude %{_bindir}/llvm-opt-fuzzer
|
%exclude %{_bindir}/llvm-opt-fuzzer
|
||||||
%{_datadir}/opt-viewer
|
%{_datadir}/opt-viewer
|
||||||
%else
|
%else
|
||||||
%{pkg_bindir}
|
%{install_bindir}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%files libs
|
%files libs
|
||||||
%license LICENSE.TXT
|
%license LICENSE.TXT
|
||||||
%{pkg_libdir}/libLLVM-%{maj_ver}.so
|
%{install_libdir}/libLLVM-%{maj_ver}%{?llvm_snapshot_version_suffix:%{llvm_snapshot_version_suffix}}.so
|
||||||
%if %{without compat_build}
|
%if %{without compat_build}
|
||||||
%if %{with gold}
|
%if %{with gold}
|
||||||
%{_libdir}/LLVMgold.so
|
%{_libdir}/LLVMgold.so
|
||||||
@ -638,19 +667,19 @@ fi
|
|||||||
|
|
||||||
%files googletest
|
%files googletest
|
||||||
%license LICENSE.TXT
|
%license LICENSE.TXT
|
||||||
%{_libdir}/libLLVMTestingSupport.a
|
%{install_libdir}/libLLVMTestingSupport.a
|
||||||
%{_libdir}/libLLVMTestingAnnotations.a
|
%{install_libdir}/libLLVMTestingAnnotations.a
|
||||||
%{_libdir}/libllvm_gtest.a
|
%{install_libdir}/libllvm_gtest.a
|
||||||
%{_libdir}/libllvm_gtest_main.a
|
%{install_libdir}/libllvm_gtest_main.a
|
||||||
%{_includedir}/llvm-gtest
|
%{install_includedir}/llvm-gtest
|
||||||
%{_includedir}/llvm-gmock
|
%{install_includedir}/llvm-gmock
|
||||||
|
|
||||||
%files toolset
|
|
||||||
%license LICENSE.TXT
|
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 26 2023 Timm Bäder <tbaeder@redhat.com> - 17.0.1-1
|
||||||
|
- Update to 17.0.1
|
||||||
|
|
||||||
* Fri Aug 04 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 16.0.6-4
|
* Fri Aug 04 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 16.0.6-4
|
||||||
- Re-add LDFLAGS to shared libraries
|
- Re-add LDFLAGS to shared libraries
|
||||||
|
|
||||||
|
12
sources
12
sources
@ -1,6 +1,6 @@
|
|||||||
SHA512 (llvm-16.0.6.src.tar.xz) = 8d4cdadc9a1ad249fbf9248c8e56f3bcafab73a473a0b0ca73499ed8825c62e27668aac4f1d03341631e5ad93701621e834e9e196ca32eac3ef805cf1c860083
|
SHA512 (llvm-17.0.1.src.tar.xz) = 16f4f052444159613ef2be517646bfec71523020569966835948b70493c20f70740782b356938ef730a67746f22aa4ddde0489cab7c1d10c4afea4e729f8b520
|
||||||
SHA512 (llvm-16.0.6.src.tar.xz.sig) = 9adda28085f4a2e2a64dab1d8e4ff23c5629bbb0bb6b34afc081e44f6f85ac4f3c6cd0c3488af98c0fad939c33f9d2a8a0cbef67a577cd7fe3013bc2200452b1
|
SHA512 (third-party-17.0.1.src.tar.xz.sig) = 3256a0e8f3e7f910b67954c99fbab1fdb868c46afda2742b2dfc21b1ddef18b4536c6d86273a96bcc62b891e65744b944a85dd79ea4cc6d5f70e07caa1788d47
|
||||||
SHA512 (cmake-16.0.6.src.tar.xz) = 52ecd941d2d85a5b668caa5d0d40480cb6a97b3bf1174e634c2a93e9ef6d03670ca7e96abb0a60cb33ba537b93d5788754dab1f2f45c1f623f788162717d088b
|
SHA512 (third-party-17.0.1.src.tar.xz) = 33d7f80c2fc72c654e2605742d96b4dccc3876dd6328f6885f3f0e4f8652dc1e3f76c6c6c03856d34ee90e27e71acf8338d4dcf13957802bfd008e9d7770b592
|
||||||
SHA512 (cmake-16.0.6.src.tar.xz.sig) = d20c5e51315aa476775e6ce886684b9f882ce283fc40aa6c1b8f03964c77a1e745e2e1fb00b3488dddfe1a04378e2bfd090350de28e58088525a5305ecb1bea6
|
SHA512 (cmake-17.0.1.src.tar.xz.sig) = 3324dd7a76983d8fdf1d9201fb38cec643261556f461b706b9030ff64ba7d8819ecb4e2954e9a8c0b4181e0f2dadbcb3fb51181bc5885b87c11c9021addbdf71
|
||||||
SHA512 (third-party-16.0.6.src.tar.xz) = 51683e92953eb57ed36ebc8a43cb688863edf4f24ba71965d57016cfdc17bad10f8f3942e9597a729329f89489597e79bb4653445ff1ec36ec03077adb1dd7b9
|
SHA512 (llvm-17.0.1.src.tar.xz.sig) = e736d7175e293f515279bf0e47b478ed3b5bae803a522c70284228f2834222a33212dbca8d1837c3997444b83a80b4989c305ec6ac08336168d4393aa782455d
|
||||||
SHA512 (third-party-16.0.6.src.tar.xz.sig) = aefb22ee35b2299e77669d72557079630fba5df2c0031c72a025082de3c4ca56ea0e1ec870c42d9056752195ad0e5b68258b548caf801ef4269e2ec1cd9da513
|
SHA512 (cmake-17.0.1.src.tar.xz) = fdfa055cb1d605669efc7b4d72be512bf8eacf681dc34f3c5fbf3fd0c99c8eec9dd5ab8904aac1b8e96fef54b936e0d7bbf0f1868c9baa0893fdd97dd39d92f1
|
||||||
|
Loading…
Reference in New Issue
Block a user