0.9.43 bump
This commit is contained in:
parent
af3a878ec4
commit
e1e874c9cf
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
lldpad-0.9.38.tar.gz
|
lldpad-0.9.38.tar.gz
|
||||||
/lldpad-0.9.41.tar.bz2
|
/lldpad-0.9.41.tar.bz2
|
||||||
/lldpad-0.9.42.tar.gz
|
/lldpad-0.9.42.tar.gz
|
||||||
|
/lldpad-0.9.43.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff --git a/lldpad.c b/lldpad.c
|
|
||||||
index 3a4a721..2f8bc23 100644
|
|
||||||
--- a/lldpad.c
|
|
||||||
+++ b/lldpad.c
|
|
||||||
@@ -424,5 +424,7 @@ int main(int argc, char *argv[])
|
|
||||||
closelog();
|
|
||||||
unlink(PID_FILE);
|
|
||||||
eloop_destroy();
|
|
||||||
+ if (eloop_terminated())
|
|
||||||
+ exit(0);
|
|
||||||
exit(1);
|
|
||||||
}
|
|
@ -1,10 +0,0 @@
|
|||||||
[Unit]
|
|
||||||
Description=Link Layer Discovery Protocol Agent Daemon.
|
|
||||||
After=syslog.target network.target
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
Type=simple
|
|
||||||
ExecStart=/usr/sbin/lldpad
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
WantedBy=multi-user.target
|
|
13
lldpad.spec
13
lldpad.spec
@ -1,15 +1,13 @@
|
|||||||
Name: lldpad
|
Name: lldpad
|
||||||
Version: 0.9.42
|
Version: 0.9.43
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Intel LLDP Agent
|
Summary: Intel LLDP Agent
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://open-lldp.org/
|
URL: http://open-lldp.org/
|
||||||
Source0: %{name}-%{version}.tar.gz
|
Source0: %{name}-%{version}.tar.gz
|
||||||
Source1: %{name}.service
|
|
||||||
Patch0: lldpad-0.9.41-make.patch
|
Patch0: lldpad-0.9.41-make.patch
|
||||||
Patch1: lldpad-0.9.41-lldptool-invalid-pointer.patch
|
Patch1: lldpad-0.9.41-lldptool-invalid-pointer.patch
|
||||||
Patch2: lldpad-0.9.42-clean-exit.patch
|
|
||||||
|
|
||||||
Requires: kernel >= 2.6.32
|
Requires: kernel >= 2.6.32
|
||||||
BuildRequires: systemd-units
|
BuildRequires: systemd-units
|
||||||
@ -42,7 +40,6 @@ that use %{name}.
|
|||||||
%setup -q -n open-lldp
|
%setup -q -n open-lldp
|
||||||
%patch0 -p1 -b .make
|
%patch0 -p1 -b .make
|
||||||
%patch1 -p1 -b .invalid-pointer
|
%patch1 -p1 -b .invalid-pointer
|
||||||
%patch2 -p1 -b .clean-exit
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./bootstrap.sh
|
./bootstrap.sh
|
||||||
@ -53,7 +50,7 @@ make %{?_smp_mflags}
|
|||||||
make install DESTDIR=%{buildroot}
|
make install DESTDIR=%{buildroot}
|
||||||
rm -f %{buildroot}%{_mandir}/man8/dcbd.8
|
rm -f %{buildroot}%{_mandir}/man8/dcbd.8
|
||||||
mkdir -p %{buildroot}%{_unitdir}
|
mkdir -p %{buildroot}%{_unitdir}
|
||||||
install -m644 %{SOURCE1} %{buildroot}%{_unitdir}
|
install -m644 %{name}.service %{buildroot}%{_unitdir}
|
||||||
rm -rf %{buildroot}/etc/init.d
|
rm -rf %{buildroot}/etc/init.d
|
||||||
|
|
||||||
%post
|
%post
|
||||||
@ -101,6 +98,10 @@ fi
|
|||||||
%{_libdir}/pkgconfig/*.pc
|
%{_libdir}/pkgconfig/*.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 07 2011 Petr Sabata <contyk@redhat.com> - 0.9.43-1
|
||||||
|
- 0.9.43 bump
|
||||||
|
- Drop the the clean exit patch and our unit file, both are now included upstream
|
||||||
|
|
||||||
* Tue Jun 21 2011 Petr Sabata <contyk@redhat.com> - 0.9.42-2
|
* Tue Jun 21 2011 Petr Sabata <contyk@redhat.com> - 0.9.42-2
|
||||||
- Introduce systemd unit file, drop SysV support
|
- Introduce systemd unit file, drop SysV support
|
||||||
- Call systemctl instead of service and chkconfig
|
- Call systemctl instead of service and chkconfig
|
||||||
|
Loading…
Reference in New Issue
Block a user