rebased to 0.9.29 (better support for fcoe-utils)

This commit is contained in:
Jan Zeleny 2010-03-16 08:35:07 +00:00
parent a3e201ac48
commit 276491623a
5 changed files with 60 additions and 27 deletions

View File

@ -1 +1 @@
lldpad-0.9.26.tar.gz
lldpad-0.9.29.tar.gz

39
lldpad-0.9.29-make.patch Normal file
View File

@ -0,0 +1,39 @@
--- lldpad-0.9.29/Makefile.am.make 2010-03-09 20:09:09.000000000 +0100
+++ lldpad-0.9.29/Makefile.am 2010-03-15 10:01:56.000000000 +0100
@@ -28,6 +28,7 @@
## system has a shared libconfig, use it
AM_CFLAGS = $(LIBCONFIG_CFLAGS)
AM_LDFLAGS = $(LIBCONFIG_LIBS)
+lldpad_LDFLAGS = $(LIBCONFIG_LIBS)
endif
## header files to be installed, for programs using the client interface to lldpad
@@ -101,9 +102,6 @@
install-data-hook:
/sbin/chkconfig --add lldpad || true
- ## provide legacy support for apps that use the old dcbd interface.
- test -e $(includedir)/dcbd || `ln -T -s $(includedir)/lldpad $(includedir)/dcbd`
- test -e $(includedir)/dcbd/clif_cmds.h || `ln -T -s $(includedir)/lldpad/lldp_dcbx_cmds.h $(includedir)/dcbd/clif_cmds.h`
uninstall-local:
/sbin/chkconfig --del lldpad || true
--- lldpad-0.9.29/Makefile.in.make 2010-03-09 20:09:22.000000000 +0100
+++ lldpad-0.9.29/Makefile.in 2010-03-15 10:01:45.000000000 +0100
@@ -289,6 +289,7 @@
@BUILTIN_LIBCONFIG_TRUE@lldptool_LDADD = libconfig-1.3.2/libconfig.la
@BUILTIN_LIBCONFIG_FALSE@AM_CFLAGS = $(LIBCONFIG_CFLAGS)
@BUILTIN_LIBCONFIG_FALSE@AM_LDFLAGS = $(LIBCONFIG_LIBS)
+@BUILTIN_LIBCONFIG_FALSE@lldpad_LDFLAGS = $(LIBCONFIG_LIBS)
lldpad_includedir = ${includedir}/lldpad
lldpad_include_HEADERS = include/dcb_types.h include/dcbtool.h \
include/dcb_osdep.h include/clif.h include/lldp_dcbx_cmds.h include/common.h \
@@ -1092,8 +1093,6 @@
install-data-hook:
/sbin/chkconfig --add lldpad || true
- test -e $(includedir)/dcbd || `ln -T -s $(includedir)/lldpad $(includedir)/dcbd`
- test -e $(includedir)/dcbd/clif_cmds.h || `ln -T -s $(includedir)/lldpad/lldp_dcbx_cmds.h $(includedir)/dcbd/clif_cmds.h`
uninstall-local:
/sbin/chkconfig --del lldpad || true

View File

@ -1,20 +0,0 @@
--- lldpad-0.9.26/Makefile.am.orig 2010-02-25 11:11:35.000000000 +0100
+++ lldpad-0.9.26/Makefile.am 2010-02-25 11:10:19.000000000 +0100
@@ -28,6 +28,7 @@
## system has a shared libconfig, use it
AM_CFLAGS = $(LIBCONFIG_CFLAGS)
AM_LDFLAGS = $(LIBCONFIG_LIBS)
+lldpad_LDFLAGS = $(LIBCONFIG_LIBS)
endif
## header files to be installed, for programs using the client interface to lldpad
--- lldpad-0.9.26/Makefile.in.orig 2010-02-25 11:12:19.000000000 +0100
+++ lldpad-0.9.26/Makefile.in 2010-02-25 11:13:00.000000000 +0100
@@ -296,6 +296,7 @@
@BUILTIN_LIBCONFIG_TRUE@lldptool_LDADD = libconfig-1.3.2/libconfig.la
@BUILTIN_LIBCONFIG_FALSE@AM_CFLAGS = $(LIBCONFIG_CFLAGS)
@BUILTIN_LIBCONFIG_FALSE@AM_LDFLAGS = $(LIBCONFIG_LIBS)
+@BUILTIN_LIBCONFIG_FALSE@lldpad_LDFLAGS = $(LIBCONFIG_LIBS)
lldpad_includedir = ${includedir}/lldpad
lldpad_include_HEADERS = include/dcb_types.h include/dcbtool.h \
include/dcb_osdep.h include/clif.h include/lldp_dcbx_cmds.h include/common.h \

View File

@ -1,6 +1,6 @@
Name: lldpad
Version: 0.9.26
Release: 2%{?dist}
Version: 0.9.29
Release: 1%{?dist}
Summary: Intel LLDP Agent
Group: System Environment/Daemons
@ -8,15 +8,16 @@ License: GPLv2
URL: http://e1000.sourceforge.net
Source0: http://downloads.sourceforge.net/project/e1000/DCB%20Tools/%{name}/%{version}/%{name}-%{version}.tar.gz
# Patch updating Makefile.am and Makefile.in, so the package is compiled with system libconfig
Patch0: lldpad-0.9.7-make.patch
# - also data hooks were removed for clean build
Patch0: lldpad-0.9.29-make.patch
# Update of init script header
Patch1: lldpad-0.9.7-init.patch
# Patch modifying the init script, so the return codes match LSB
Patch2: lldpad-0.9.19-init-lsb.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: kernel >= 2.6.31
BuildRequires: libconfig-devel >= 1.3.2 kernel-headers >= 2.6.31
Requires: kernel >= 2.6.32
BuildRequires: libconfig-devel >= 1.3.2 kernel-headers >= 2.6.32
Requires(post): chkconfig
Requires(preun): chkconfig initscripts
Requires(postun): initscripts
@ -75,6 +76,15 @@ if [ "$1" -ge "1" ]; then
/sbin/service %{name} condrestart > /dev/null 2>&1 || :
fi
%post devel
## provide legacy support for apps that use the old dcbd interface.
test -e %{_includedir}/dcbd || `ln -T -s %{_includedir}/lldpad %{_includedir}/dcbd`
test -e %{_includedir}/dcbd/clif_cmds.h || `ln -T -s %{_includedir}/lldpad/lldp_dcbx_cmds.h %{_includedir}/dcbd/clif_cmds.h`
%preun devel
test -e %{_includedir}/dcbd/clif_cmds.h && `rm -f %{_includedir}/dcbd/clif_cmds.h`
test -e %{_includedir}/dcbd && `rm -f %{_includedir}/dcbd`
%files
%defattr(-,root,root,-)
@ -93,9 +103,13 @@ fi
%changelog
* Mon Mar 15 2010 Jan Zeleny <jzeleny@redhat.com> - 0.9.29-1
- updated package to 0.9.29, improved compatibility with fcoe-utils
* Fri Feb 26 2010 Jan Zeleny <jzeleny@redhat.com> - 0.9.26-2
- updated spec file and LSB init script patch for re-review
(#568641)
* Thu Feb 25 2010 Jan Zeleny <jzeleny@redhat.com> - 0.9.26-1
- rebased to 0.9.26
- package renamed to lldpad

View File

@ -1 +1 @@
96cfc9310336ad7f2614722146033857 lldpad-0.9.26.tar.gz
2e008b98e5d2583e980ef127a245aec7 lldpad-0.9.29.tar.gz