0.9.46 bump
- 802.1Qaz fixes to enable support on not CEE DCBX-enabled hardware - 802.1Qbg EVB module support - lldpad now supports bonded interfaces
This commit is contained in:
parent
1418290a8c
commit
20798d8c32
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
/lldpad-0.9.44.tar.gz
|
/lldpad-0.9.44.tar.gz
|
||||||
/lldpad-0.9.45.tar.gz
|
/lldpad-0.9.45.tar.gz
|
||||||
|
/lldpad-0.9.46.tar.gz
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/clif.c b/clif.c
|
|
||||||
index a6dc3d8..5fe9bd5 100644
|
|
||||||
--- a/clif.c
|
|
||||||
+++ b/clif.c
|
|
||||||
@@ -158,7 +158,7 @@ static int clif_attach_helper(struct clif *clif, char *tlvs_hex, int attach)
|
|
||||||
|
|
||||||
/* Allocate maximum buffer usage */
|
|
||||||
if (tlvs_hex && attach) {
|
|
||||||
- buf = malloc(sizeof(char)*(strlen(tlvs_hex) + 1));
|
|
||||||
+ buf = malloc(sizeof(char)*(strlen(tlvs_hex) + 2));
|
|
||||||
if (!buf)
|
|
||||||
return -1;
|
|
||||||
sprintf(buf, "%s%s","A",tlvs_hex);
|
|
@ -1,93 +0,0 @@
|
|||||||
From 327ef662eb08ca549c51a5e46b3fc6df5c36dee6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: John Fastabend <john.r.fastabend@intel.com>
|
|
||||||
Date: Mon, 13 Aug 2012 20:47:41 -0700
|
|
||||||
Subject: [PATCH] The display of the Management Address TLV had some errors.
|
|
||||||
Fixups include: - some TLV output not tabbed - passing bad
|
|
||||||
length to hexstr2bin when printing OID, resulting in
|
|
||||||
debug code (removed) printing out - print errors for
|
|
||||||
incorrect OID lengths. - add oid data length to TLV length
|
|
||||||
when creating the management address TLV (kind of a no-op
|
|
||||||
for now since no OID is currently sent).
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Signed-off-by: Eric Multanen <eric.w.multanen@intel.com>
|
|
||||||
Signed-off-by: Petr Šabata <contyk@redhat.com>
|
|
||||||
---
|
|
||||||
lldp_basman.c | 2 +-
|
|
||||||
lldp_basman_clif.c | 14 +++++++++-----
|
|
||||||
lldp_util.c | 4 +---
|
|
||||||
3 files changed, 11 insertions(+), 9 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lldp_basman.c b/lldp_basman.c
|
|
||||||
index b86bcee..4916e19 100644
|
|
||||||
--- a/lldp_basman.c
|
|
||||||
+++ b/lldp_basman.c
|
|
||||||
@@ -452,7 +452,7 @@ out_set:
|
|
||||||
length += sizeof(struct tlv_info_maif);
|
|
||||||
o = (struct tlv_info_maoid *)&data[length];
|
|
||||||
o->len = 0;
|
|
||||||
- length += sizeof(o->len);
|
|
||||||
+ length += sizeof(o->len) + o->len;
|
|
||||||
|
|
||||||
tlv = create_tlv();
|
|
||||||
if (!tlv)
|
|
||||||
diff --git a/lldp_basman_clif.c b/lldp_basman_clif.c
|
|
||||||
index ef245c6..7dba9d2 100644
|
|
||||||
--- a/lldp_basman_clif.c
|
|
||||||
+++ b/lldp_basman_clif.c
|
|
||||||
@@ -251,16 +251,16 @@ void print_mng_addr(u16 len, char *info)
|
|
||||||
|
|
||||||
switch (iftype) {
|
|
||||||
case IFNUM_UNKNOWN:
|
|
||||||
- printf("Unknown interface subtype: ");
|
|
||||||
+ printf("\tUnknown interface subtype: ");
|
|
||||||
break;
|
|
||||||
case IFNUM_IFINDEX:
|
|
||||||
printf("\tIfindex: ");
|
|
||||||
break;
|
|
||||||
case IFNUM_SYS_PORT_NUM:
|
|
||||||
- printf("System port number: ");
|
|
||||||
+ printf("\tSystem port number: ");
|
|
||||||
break;
|
|
||||||
default:
|
|
||||||
- printf("Bad interface numbering subtype: ");
|
|
||||||
+ printf("\tBad interface numbering subtype: ");
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
printf("%d\n", ifnum);
|
|
||||||
@@ -270,8 +270,12 @@ void print_mng_addr(u16 len, char *info)
|
|
||||||
|
|
||||||
if (oidlen && oidlen <= 128) {
|
|
||||||
memset(buf, 0, sizeof(buf));
|
|
||||||
- hexstr2bin(info+offset, (u8 *)&buf, sizeof(buf));
|
|
||||||
- printf("OID: %s", buf);
|
|
||||||
+ if (hexstr2bin(info+offset, (u8 *)&buf, oidlen))
|
|
||||||
+ printf("\tOID: Error parsing OID\n");
|
|
||||||
+ else
|
|
||||||
+ printf("\tOID: %s\n", buf);
|
|
||||||
+ } else if (oidlen > 128) {
|
|
||||||
+ printf("\tOID: Invalid length = %d\n", oidlen);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
diff --git a/lldp_util.c b/lldp_util.c
|
|
||||||
index 3d6e12b..4dc15d5 100644
|
|
||||||
--- a/lldp_util.c
|
|
||||||
+++ b/lldp_util.c
|
|
||||||
@@ -114,10 +114,8 @@ int hexstr2bin(const char *hex, u8 *buf, size_t len)
|
|
||||||
|
|
||||||
for (i = 0; i < len; i++) {
|
|
||||||
a = hex2byte(ipos);
|
|
||||||
- if (a < 0) {
|
|
||||||
- printf("ipos=%2.2s, a=%x\n", ipos, a);
|
|
||||||
+ if (a < 0)
|
|
||||||
return -1;
|
|
||||||
- }
|
|
||||||
*opos++ = a;
|
|
||||||
ipos += 2;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.7.11.4
|
|
||||||
|
|
@ -1,14 +0,0 @@
|
|||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 59cd8f6..f147e92 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -1,6 +1,9 @@
|
|
||||||
AC_INIT([lldpad], [0.9.45], [lldp-devel@open-lldp.org])
|
|
||||||
AM_INIT_AUTOMAKE([-Wall -Werror foreign])
|
|
||||||
|
|
||||||
+m4_pattern_allow([AM_PROG_AR])
|
|
||||||
+AM_PROG_AR
|
|
||||||
+
|
|
||||||
AC_ARG_ENABLE(debug,
|
|
||||||
AS_HELP_STRING([--enable-debug],[compile debug programs]),
|
|
||||||
[enable_debug=yes], [enable_debug=no])
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/lldp_8021qaz_cmds.c b/lldp_8021qaz_cmds.c
|
|
||||||
index 0db2c9c..4f23229 100644
|
|
||||||
--- a/lldp_8021qaz_cmds.c
|
|
||||||
+++ b/lldp_8021qaz_cmds.c
|
|
||||||
@@ -821,7 +821,7 @@ _set_arg_tsa(struct cmd *cmd, char *args, const char *arg_value,
|
|
||||||
toked_maps = strtok(NULL, ",");
|
|
||||||
}
|
|
||||||
} else if (!test) {
|
|
||||||
- memset(tsa, 0, sizeof(tsa));
|
|
||||||
+ memset(tsa, 0, sizeof(u8));
|
|
||||||
}
|
|
||||||
|
|
||||||
if (test) {
|
|
25
lldpad.spec
25
lldpad.spec
@ -2,24 +2,21 @@
|
|||||||
%define _hardened_build 1
|
%define _hardened_build 1
|
||||||
|
|
||||||
Name: lldpad
|
Name: lldpad
|
||||||
Version: 0.9.45
|
Version: 0.9.46
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Intel LLDP Agent
|
Summary: Intel LLDP Agent
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://open-lldp.org/
|
URL: http://open-lldp.org/
|
||||||
Source0: %{name}-%{version}.tar.gz
|
Source0: %{name}-%{version}.tar.gz
|
||||||
Patch0: lldpad-0.9.45-archiver.patch
|
|
||||||
Patch1: lldpad-0.9.41-lldptool-invalid-pointer.patch
|
|
||||||
Patch2: lldpad-0.9.45-The-display-of-the-Management-Address-TLV-had-some.patch
|
|
||||||
Patch3: lldpad-0.9.45-sizeof.patch
|
|
||||||
Requires: kernel >= 2.6.32
|
Requires: kernel >= 2.6.32
|
||||||
BuildRequires: systemd-units
|
|
||||||
BuildRequires: libconfig-devel >= 1.3.2 kernel-headers >= 2.6.32
|
|
||||||
BuildRequires: flex >= 2.5.33
|
|
||||||
BuildRequires: automake autoconf libtool
|
BuildRequires: automake autoconf libtool
|
||||||
|
BuildRequires: flex >= 2.5.33
|
||||||
|
BuildRequires: kernel-headers >= 2.6.32
|
||||||
|
BuildRequires: libconfig-devel >= 1.3.2
|
||||||
BuildRequires: libnl-devel
|
BuildRequires: libnl-devel
|
||||||
BuildRequires: readline-devel
|
BuildRequires: readline-devel
|
||||||
|
BuildRequires: systemd-units
|
||||||
Requires: readline
|
Requires: readline
|
||||||
Requires(post): systemd-units
|
Requires(post): systemd-units
|
||||||
Requires(preun): systemd-units
|
Requires(preun): systemd-units
|
||||||
@ -44,10 +41,6 @@ that use %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .archiver
|
|
||||||
%patch1 -p1 -b .invalid-pointer
|
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./bootstrap.sh
|
./bootstrap.sh
|
||||||
@ -107,6 +100,12 @@ fi
|
|||||||
%{_libdir}/liblldp_clif.so
|
%{_libdir}/liblldp_clif.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 04 2013 Petr Šabata <contyk@redhat.com> - 0.9.46-1
|
||||||
|
- 0.9.46 bump
|
||||||
|
- 802.1Qaz fixes to enable support on not CEE DCBX-enabled hardware
|
||||||
|
- 802.1Qbg EVB module support
|
||||||
|
- lldpad now supports bonded interfaces
|
||||||
|
|
||||||
* Tue Mar 05 2013 Petr Šabata <contyk@redhat.com> - 0.9.45-5
|
* Tue Mar 05 2013 Petr Šabata <contyk@redhat.com> - 0.9.45-5
|
||||||
- Fix build by patching the sizeof() call in lldp_8021qaz_cmds.c
|
- Fix build by patching the sizeof() call in lldp_8021qaz_cmds.c
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user