import CS lldb-17.0.6-1.module_el8+767+9fa966b8
This commit is contained in:
parent
6630dad143
commit
cbbcf19512
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
SOURCES/lldb-16.0.6.src.tar.xz
|
||||
SOURCES/lldb-16.0.6.src.tar.xz.sig
|
||||
SOURCES/lldb-17.0.6.src.tar.xz
|
||||
SOURCES/lldb-17.0.6.src.tar.xz.sig
|
||||
|
@ -1,2 +1,2 @@
|
||||
42e67369cd63a992369a638f289cc3a787d09c8f SOURCES/lldb-16.0.6.src.tar.xz
|
||||
bc87caa10c21c9e53a6afe4d191a299b4905495e SOURCES/lldb-16.0.6.src.tar.xz.sig
|
||||
fc7260e1768ad2ee3b9d5a91d90d17e58e20df14 SOURCES/lldb-17.0.6.src.tar.xz
|
||||
fe7372c59ada760ed06814ed92c24c47fb2a055d SOURCES/lldb-17.0.6.src.tar.xz.sig
|
||||
|
@ -1,30 +0,0 @@
|
||||
From fb389f0cd6b4e8996157fa7d7bc347fde7b43656 Mon Sep 17 00:00:00 2001
|
||||
From: Tulio Magno Quites Machado Filho <tuliom@redhat.com>
|
||||
Date: Thu, 23 Mar 2023 16:06:10 -0300
|
||||
Subject: [PATCH] [lldb] Change LLVM_COMMON_CMAKE_UTILS usage
|
||||
|
||||
Let LLVM_COMMON_CMAKE_UTILS store the directory where cmake modules are
|
||||
available and stop assuming its directory structure.
|
||||
---
|
||||
lldb/CMakeLists.txt | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
|
||||
index 20d584c48bad..7bad2a9928cd 100644
|
||||
--- a/lldb/CMakeLists.txt
|
||||
+++ b/lldb/CMakeLists.txt
|
||||
@@ -1,9 +1,9 @@
|
||||
cmake_minimum_required(VERSION 3.13.4)
|
||||
|
||||
if(NOT DEFINED LLVM_COMMON_CMAKE_UTILS)
|
||||
- set(LLVM_COMMON_CMAKE_UTILS ${CMAKE_CURRENT_SOURCE_DIR}/../cmake)
|
||||
+ set(LLVM_COMMON_CMAKE_UTILS ${CMAKE_CURRENT_SOURCE_DIR}/../cmake/Modules)
|
||||
endif()
|
||||
-include(${LLVM_COMMON_CMAKE_UTILS}/Modules/CMakePolicy.cmake
|
||||
+include(${LLVM_COMMON_CMAKE_UTILS}/CMakePolicy.cmake
|
||||
NO_POLICY_SCOPE)
|
||||
|
||||
# Add path for custom modules.
|
||||
--
|
||||
2.39.2
|
||||
|
@ -1,7 +1,10 @@
|
||||
%global lldb_version 16.0.6
|
||||
# Opt out of https://fedoraproject.org/wiki/Changes/fno-omit-frame-pointer
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2158587
|
||||
%undefine _include_frame_pointers
|
||||
|
||||
%global lldb_version 17.0.6
|
||||
#global rc_ver 4
|
||||
%global lldb_srcdir %{name}-%{lldb_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
%global cmake_srcdir cmake-%{lldb_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
%ifarch ppc64le
|
||||
# Too many threads on some systems causes OOM errors.
|
||||
@ -19,6 +22,14 @@ Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{lldb_v
|
||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{lldb_version}%{?rc_ver:-rc%{rc_ver}}/%{lldb_srcdir}.tar.xz.sig
|
||||
Source2: release-keys.asc
|
||||
|
||||
# There is a problem with the debug info generated by the
|
||||
# GCC version we ship in RHEL 8. It somehow makes it very
|
||||
# hard for lldb to inspect std::vector types.
|
||||
# Disable the pretty-printer for now, since otherwise
|
||||
# such vectors look empty to the developer even though
|
||||
# they aren't.
|
||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=2082508
|
||||
Patch002: 0001-lldb-Disable-std-vector-pretty-printer.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -26,6 +37,7 @@ BuildRequires: cmake
|
||||
BuildRequires: ninja-build
|
||||
BuildRequires: llvm-devel = %{version}
|
||||
BuildRequires: llvm-test = %{version}
|
||||
BuildRequires: llvm-cmake-utils = %{version}
|
||||
BuildRequires: clang-devel = %{version}
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: swig
|
||||
@ -39,16 +51,6 @@ BuildRequires: multilib-rpm-config
|
||||
|
||||
Requires: python3-lldb
|
||||
|
||||
Patch0: 0001-lldb-Change-LLVM_COMMON_CMAKE_UTILS-usage.patch
|
||||
# There is a problem with the debug info generated by the
|
||||
# GCC version we ship in RHEL 8. It somehow makes it very
|
||||
# hard for lldb to inspect std::vector types.
|
||||
# Disable the pretty-printer for now, since otherwise
|
||||
# such vectors look empty to the developer even though
|
||||
# they aren't.
|
||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=2082508
|
||||
Patch001: 0001-lldb-Disable-std-vector-pretty-printer.patch
|
||||
|
||||
# For origin certification
|
||||
BuildRequires: gnupg2
|
||||
|
||||
@ -82,19 +84,17 @@ The package contains the LLDB Python module.
|
||||
|
||||
%build
|
||||
|
||||
mkdir -p %{_vpath_builddir}
|
||||
cd %{_vpath_builddir}
|
||||
%undefine __cmake_in_source_build
|
||||
|
||||
CFLAGS="%{optflags} -Wno-error=format-security"
|
||||
CXXFLAGS="%{optflags} -Wno-error=format-security"
|
||||
|
||||
%cmake .. -GNinja \
|
||||
%cmake -GNinja \
|
||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
-DCMAKE_SKIP_RPATH:BOOL=ON \
|
||||
-DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
|
||||
-DLLVM_CONFIG:FILEPATH=/usr/bin/llvm-config-%{__isa_bits} \
|
||||
-DLLVM_COMMON_CMAKE_UTILS=%{_libdir}/cmake/llvm/ \
|
||||
\
|
||||
-DLLVM_COMMON_CMAKE_UTILS=%{_datadir}/llvm/cmake \
|
||||
-DLLDB_DISABLE_CURSES:BOOL=OFF \
|
||||
-DLLDB_DISABLE_LIBEDIT:BOOL=OFF \
|
||||
-DLLDB_DISABLE_PYTHON:BOOL=OFF \
|
||||
@ -109,13 +109,13 @@ CXXFLAGS="%{optflags} -Wno-error=format-security"
|
||||
-DPYTHON_VERSION_MINOR:STRING=$(%{__python3} -c "import sys; print(sys.version_info.minor)") \
|
||||
-DLLVM_EXTERNAL_LIT=%{_bindir}/lit \
|
||||
-DCLANG_LINK_CLANG_DYLIB=ON \
|
||||
-DCLANG_RESOURCE_DIR=$(realpath --relative-to=/usr/bin %{clang_resource_dir}) \
|
||||
-DLLVM_LIT_ARGS="-sv \
|
||||
--path %{_libdir}/llvm" \
|
||||
|
||||
%cmake_build
|
||||
|
||||
%install
|
||||
cd %{_vpath_builddir}
|
||||
%cmake_install
|
||||
|
||||
%multilib_fix_c_header --file %{_includedir}/lldb/Host/Config.h
|
||||
@ -150,6 +150,12 @@ rm -f %{buildroot}%{python3_sitearch}/six.*
|
||||
%{python3_sitearch}/lldb
|
||||
|
||||
%changelog
|
||||
* Wed Nov 29 2023 Nikita Popov <npopov@redhat.com> - 17.0.6-1
|
||||
- Update to LLVM 17.0.6
|
||||
|
||||
* Wed Oct 04 2023 Nikita Popov <npopov@redhat.com> - 17.0.2-1
|
||||
- Update to LLVM 17.0.2
|
||||
|
||||
* Fri Jun 23 2023 Tom Stellard <tstellar@redhat.com> - 16.0.6-1
|
||||
- 16.0.6 Release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user