6.0.1-rc1 Release
This commit is contained in:
parent
b0dee0d493
commit
cb0ac8988b
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
||||
/lldb-6.0.0rc1.src.tar.xz
|
||||
/lldb-6.0.0rc2.src.tar.xz
|
||||
/lldb-6.0.0.src.tar.xz
|
||||
/lldb-6.0.1rc1.src.tar.xz
|
||||
|
@ -1,37 +0,0 @@
|
||||
From 2c77a3551b39aa26268630d3b626b811f2cff029 Mon Sep 17 00:00:00 2001
|
||||
From: Tilmann Scheller <tschelle@redhat.com>
|
||||
Date: Thu, 8 Mar 2018 08:35:29 -0600
|
||||
Subject: [PATCH] Partially revert "[CMake] Cleanup unnecessary definition"
|
||||
|
||||
This reverts the part of r309021 that broke LLDB SB API header installation.
|
||||
|
||||
See rhbz#1548758 for more details.
|
||||
---
|
||||
cmake/modules/LLDBConfig.cmake | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/cmake/modules/LLDBConfig.cmake b/cmake/modules/LLDBConfig.cmake
|
||||
index 8f75880df..7846ec1bd 100644
|
||||
--- a/cmake/modules/LLDBConfig.cmake
|
||||
+++ b/cmake/modules/LLDBConfig.cmake
|
||||
@@ -284,8 +284,6 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
|
||||
PATTERN ".svn" EXCLUDE
|
||||
PATTERN ".cmake" EXCLUDE
|
||||
PATTERN "Config.h" EXCLUDE
|
||||
- PATTERN "lldb-*.h" EXCLUDE
|
||||
- PATTERN "API/*.h" EXCLUDE
|
||||
)
|
||||
|
||||
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/include/
|
||||
@@ -295,8 +293,6 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
|
||||
PATTERN "*.h"
|
||||
PATTERN ".svn" EXCLUDE
|
||||
PATTERN ".cmake" EXCLUDE
|
||||
- PATTERN "lldb-*.h" EXCLUDE
|
||||
- PATTERN "API/*.h" EXCLUDE
|
||||
)
|
||||
endif()
|
||||
|
||||
--
|
||||
2.14.3
|
||||
|
12
lldb.spec
12
lldb.spec
@ -1,12 +1,13 @@
|
||||
%global rc_ver 1
|
||||
|
||||
Name: lldb
|
||||
Version: 6.0.0
|
||||
Release: 4%{?dist}
|
||||
Version: 6.0.1
|
||||
Release: 0.1.rc%{rc_ver}%{?dist}
|
||||
Summary: Next generation high-performance debugger
|
||||
|
||||
License: NCSA
|
||||
URL: http://lldb.llvm.org/
|
||||
Source0: http://llvm.org/releases/%{version}/%{name}-%{version}%{?rc_ver:rc%{rc_ver}}.src.tar.xz
|
||||
Patch0: 0001-Partially-revert-CMake-Cleanup-unnecessary-definitio.patch
|
||||
|
||||
ExclusiveArch: %{arm} aarch64 %{ix86} x86_64
|
||||
|
||||
@ -46,8 +47,6 @@ The package contains the LLDB Python module.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
%patch0 -p1
|
||||
|
||||
# HACK so that lldb can find its custom readline.so, because we move it
|
||||
# after install.
|
||||
sed -i -e "s~import sys~import sys\nsys.path.insert\(1, '%{python2_sitearch}/lldb'\)~g" source/Interpreter/embedded_interpreter.py
|
||||
@ -118,6 +117,9 @@ rm -f %{buildroot}%{python2_sitearch}/six.*
|
||||
%{python2_sitearch}/lldb
|
||||
|
||||
%changelog
|
||||
* Mon May 21 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-0.1.rc1
|
||||
- 6.0.1-rc1 Release
|
||||
|
||||
* Sat May 05 2018 Miro Hrončok <mhroncok@redhat.com> - 6.0.0-4
|
||||
- Update Python macros to new packaging standards
|
||||
(See https://fedoraproject.org/wiki/Changes/Avoid_usr_bin_python_in_RPM_Build)
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (lldb-6.0.0.src.tar.xz) = 9679d1dda0c71681b1f8c5a22e775c0262de26dc5b091e1db189968b97ed3aed45991381d529b3fd4b3ab28112453f519045485708f97f765d3e3131b2a918b7
|
||||
SHA512 (lldb-6.0.1rc1.src.tar.xz) = 22aa7943aa8d85ae45c12fe03e877dad3c84ce15016fc0dc955d386466366dac7eea6626f11f2225552661ffd1bd02f6a25a42c985a2c10ea854add9b4b2fdb9
|
||||
|
Loading…
Reference in New Issue
Block a user