Update to 18.1.6
Related: RHEL-28670
This commit is contained in:
parent
2a333e43f4
commit
a4f556e375
@ -1,74 +0,0 @@
|
||||
From ed87035da34be675df7ea78bdf5f7631d81ab2db Mon Sep 17 00:00:00 2001
|
||||
From: Tulio Magno Quites Machado Filho <tuliom@redhat.com>
|
||||
Date: Wed, 25 Oct 2023 10:48:53 -0300
|
||||
Subject: [PATCH] [lldb] Adapt code to Python 3.13
|
||||
|
||||
1. Remove usage of PyEval_ThreadsInitialized and PyEval_InitThreads
|
||||
|
||||
Both of these functions were removed in Python 3.13 [1] after being
|
||||
deprecated since Python 3.9.
|
||||
|
||||
According to "What's new in Python 3.13" document [1]:
|
||||
|
||||
Since Python 3.7, Py_Initialize() always creates the GIL: calling
|
||||
PyEval_InitThreads() did nothing and PyEval_ThreadsInitialized()
|
||||
always returned non-zero.
|
||||
|
||||
2. Replace _Py_IsFinalizing() with Py_IsFinalizing().
|
||||
|
||||
[1] https://docs.python.org/3.13/whatsnew/3.13.html
|
||||
---
|
||||
.../ScriptInterpreter/Python/PythonDataObjects.cpp | 4 +++-
|
||||
.../ScriptInterpreter/Python/ScriptInterpreterPython.cpp | 9 +++++++++
|
||||
2 files changed, 12 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lldb/source/Plugins/ScriptInterpreter/Python/PythonDataObjects.cpp b/lldb/source/Plugins/ScriptInterpreter/Python/PythonDataObjects.cpp
|
||||
index 9ac840a4a102..fe3438c42471 100644
|
||||
--- a/lldb/source/Plugins/ScriptInterpreter/Python/PythonDataObjects.cpp
|
||||
+++ b/lldb/source/Plugins/ScriptInterpreter/Python/PythonDataObjects.cpp
|
||||
@@ -71,7 +71,9 @@ Expected<std::string> python::As<std::string>(Expected<PythonObject> &&obj) {
|
||||
}
|
||||
|
||||
static bool python_is_finalizing() {
|
||||
-#if PY_MAJOR_VERSION == 3 && PY_MINOR_VERSION < 7
|
||||
+#if (PY_MAJOR_VERSION == 3 && PY_MINOR_VERSION >= 13) || (PY_MAJOR_VERSION > 3)
|
||||
+ return Py_IsFinalizing();
|
||||
+#elif PY_MAJOR_VERSION == 3 && PY_MINOR_VERSION < 7
|
||||
return _Py_Finalizing != nullptr;
|
||||
#else
|
||||
return _Py_IsFinalizing();
|
||||
diff --git a/lldb/source/Plugins/ScriptInterpreter/Python/ScriptInterpreterPython.cpp b/lldb/source/Plugins/ScriptInterpreter/Python/ScriptInterpreterPython.cpp
|
||||
index a57c8e4984ad..968cc8ca0300 100644
|
||||
--- a/lldb/source/Plugins/ScriptInterpreter/Python/ScriptInterpreterPython.cpp
|
||||
+++ b/lldb/source/Plugins/ScriptInterpreter/Python/ScriptInterpreterPython.cpp
|
||||
@@ -179,18 +179,27 @@ private:
|
||||
return;
|
||||
#endif
|
||||
|
||||
+// `PyEval_ThreadsInitialized` was deprecated in Python 3.9 and removed in
|
||||
+// Python 3.13. It has been returning `true` always since Python 3.7.
|
||||
+#if (PY_MAJOR_VERSION == 3 && PY_MINOR_VERSION < 9) || (PY_MAJOR_VERSION < 3)
|
||||
if (PyEval_ThreadsInitialized()) {
|
||||
+#endif
|
||||
Log *log = GetLog(LLDBLog::Script);
|
||||
|
||||
m_was_already_initialized = true;
|
||||
m_gil_state = PyGILState_Ensure();
|
||||
LLDB_LOGV(log, "Ensured PyGILState. Previous state = {0}locked\n",
|
||||
m_gil_state == PyGILState_UNLOCKED ? "un" : "");
|
||||
+
|
||||
+// `PyEval_InitThreads` was deprecated in Python 3.9 and removed in
|
||||
+// Python 3.13.
|
||||
+#if (PY_MAJOR_VERSION == 3 && PY_MINOR_VERSION < 9) || (PY_MAJOR_VERSION < 3)
|
||||
return;
|
||||
}
|
||||
|
||||
// InitThreads acquires the GIL if it hasn't been called before.
|
||||
PyEval_InitThreads();
|
||||
+#endif
|
||||
}
|
||||
|
||||
PyGILState_STATE m_gil_state = PyGILState_UNLOCKED;
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,91 +0,0 @@
|
||||
From 16fd09f102eff20825847e32f225715960d1c082 Mon Sep 17 00:00:00 2001
|
||||
From: Tulio Magno Quites Machado Filho <tuliom@redhat.com>
|
||||
Date: Wed, 25 Oct 2023 10:48:53 -0300
|
||||
Subject: [PATCH] [lldb] Replace the usage of module imp with module importlib
|
||||
|
||||
imp got removed in Python 3.12 [1] and the community recommends using
|
||||
importlib in newer Python versions.
|
||||
|
||||
[1] https://docs.python.org/3.12/whatsnew/3.12.html#imp
|
||||
---
|
||||
lldb/scripts/use_lldb_suite.py | 30 ++++++++++++++++++++++--------
|
||||
lldb/test/API/use_lldb_suite.py | 29 +++++++++++++++++++++--------
|
||||
2 files changed, 43 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/lldb/scripts/use_lldb_suite.py b/lldb/scripts/use_lldb_suite.py
|
||||
index 6388d87b181c..4cedfa532cf9 100644
|
||||
--- a/lldb/scripts/use_lldb_suite.py
|
||||
+++ b/lldb/scripts/use_lldb_suite.py
|
||||
@@ -17,10 +17,25 @@ def find_lldb_root():
|
||||
return lldb_root
|
||||
|
||||
lldb_root = find_lldb_root()
|
||||
-import imp
|
||||
-fp, pathname, desc = imp.find_module("use_lldb_suite_root", [lldb_root])
|
||||
-try:
|
||||
- imp.load_module("use_lldb_suite_root", fp, pathname, desc)
|
||||
-finally:
|
||||
- if fp:
|
||||
- fp.close()
|
||||
+
|
||||
+# Module imp got removed in Python 3.12.
|
||||
+if (
|
||||
+ sys.version_info.major == 3 and sys.version_info.minor >= 12
|
||||
+) or sys.version_info.major > 3:
|
||||
+ import importlib.machinery
|
||||
+ import importlib.util
|
||||
+
|
||||
+ path = os.path.join(lldb_root, "use_lldb_suite_root.py")
|
||||
+ loader = importlib.machinery.SourceFileLoader("use_lldb_suite_root", path)
|
||||
+ spec = importlib.util.spec_from_loader("use_lldb_suite_root", loader=loader)
|
||||
+ module = importlib.util.module_from_spec(spec)
|
||||
+ loader.exec_module(module)
|
||||
+else:
|
||||
+ import imp
|
||||
+
|
||||
+ fp, pathname, desc = imp.find_module("use_lldb_suite_root", [lldb_root])
|
||||
+ try:
|
||||
+ imp.load_module("use_lldb_suite_root", fp, pathname, desc)
|
||||
+ finally:
|
||||
+ if fp:
|
||||
+ fp.close()
|
||||
diff --git a/lldb/test/API/use_lldb_suite.py b/lldb/test/API/use_lldb_suite.py
|
||||
index e237dd4b8a56..c9332d9921b4 100644
|
||||
--- a/lldb/test/API/use_lldb_suite.py
|
||||
+++ b/lldb/test/API/use_lldb_suite.py
|
||||
@@ -20,11 +20,24 @@ def find_lldb_root():
|
||||
|
||||
lldb_root = find_lldb_root()
|
||||
|
||||
-import imp
|
||||
-
|
||||
-fp, pathname, desc = imp.find_module("use_lldb_suite_root", [lldb_root])
|
||||
-try:
|
||||
- imp.load_module("use_lldb_suite_root", fp, pathname, desc)
|
||||
-finally:
|
||||
- if fp:
|
||||
- fp.close()
|
||||
+# Module imp got removed in Python 3.12.
|
||||
+if (
|
||||
+ sys.version_info.major == 3 and sys.version_info.minor >= 12
|
||||
+) or sys.version_info.major > 3:
|
||||
+ import importlib.machinery
|
||||
+ import importlib.util
|
||||
+
|
||||
+ path = os.path.join(lldb_root, "use_lldb_suite_root.py")
|
||||
+ loader = importlib.machinery.SourceFileLoader("use_lldb_suite_root", path)
|
||||
+ spec = importlib.util.spec_from_loader("use_lldb_suite_root", loader=loader)
|
||||
+ module = importlib.util.module_from_spec(spec)
|
||||
+ loader.exec_module(module)
|
||||
+else:
|
||||
+ import imp
|
||||
+
|
||||
+ fp, pathname, desc = imp.find_module("use_lldb_suite_root", [lldb_root])
|
||||
+ try:
|
||||
+ imp.load_module("use_lldb_suite_root", fp, pathname, desc)
|
||||
+ finally:
|
||||
+ if fp:
|
||||
+ fp.close()
|
||||
--
|
||||
2.41.0
|
||||
|
21
lldb.spec
21
lldb.spec
@ -1,7 +1,7 @@
|
||||
%global toolchain clang
|
||||
|
||||
%global gts_version 13
|
||||
%global lldb_version 17.0.6
|
||||
%global lldb_version 18.1.6
|
||||
#global rc_ver 4
|
||||
%global lldb_srcdir %{name}-%{lldb_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
@ -16,11 +16,6 @@ Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{lldb_v
|
||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{lldb_version}%{?rc_ver:-rc%{rc_ver}}/%{lldb_srcdir}.tar.xz.sig
|
||||
Source2: release-keys.asc
|
||||
|
||||
# Backport from https://github.com/llvm/llvm-project/pull/70443
|
||||
Patch: 0001-lldb-Replace-the-usage-of-module-imp-with-module-imp.patch
|
||||
# Backport from https://github.com/llvm/llvm-project/pull/70445
|
||||
Patch: 0001-lldb-Adapt-code-to-Python-3.13.patch
|
||||
|
||||
BuildRequires: clang
|
||||
BuildRequires: cmake
|
||||
BuildRequires: ninja-build
|
||||
@ -75,12 +70,7 @@ The package contains the LLDB Python module.
|
||||
%build
|
||||
%global _lto_cflags -flto=thin
|
||||
|
||||
%ifarch %ix86
|
||||
# Linking liblldb.so goes out of memory even with ThinLTO and a single link job.
|
||||
%global _lto_cflags %nil
|
||||
%endif
|
||||
|
||||
%cmake -GNinja \
|
||||
%cmake -GNinja \
|
||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
-DCMAKE_SKIP_RPATH:BOOL=ON \
|
||||
-DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
|
||||
@ -135,17 +125,22 @@ rm -f %{buildroot}%{python3_sitearch}/six.*
|
||||
%files
|
||||
%license LICENSE.TXT
|
||||
%{_bindir}/lldb*
|
||||
# Usually, *.so symlinks are kept in devel subpackages. However, the python
|
||||
# bindings depend on this symlink at runtime.
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/liblldb.so.*
|
||||
%{_libdir}/liblldbIntelFeatures.so.*
|
||||
|
||||
%files devel
|
||||
%{_includedir}/lldb
|
||||
%{_libdir}/*.so
|
||||
|
||||
%files -n python3-lldb
|
||||
%{python3_sitearch}/lldb
|
||||
|
||||
%changelog
|
||||
* Mon Jun 03 2024 Konrad Kleine <kkkleine@redhat.com> - 18.1.6-1
|
||||
- Update to 18.1.6
|
||||
|
||||
* Mon Dec 11 2023 Timm Bäder <tbaeder@redhat.com> - 17.0.6-1
|
||||
- Update to 17.0.6
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (lldb-17.0.6.src.tar.xz.sig) = d6f8edabc7d4d3ec1f7620c6166606abef4632e10f36244a8e5b76d66a94f1218742c86cd6445c7983353fc001d307709659709e9708a82c7a7042495492d9da
|
||||
SHA512 (lldb-17.0.6.src.tar.xz) = 80b327c89b160b1dcdbea1946a7c69514e797056629c0a7501c77e7557d6bb3a7ae6ecdd0d760d072b1f7c3f5b136838f76c8d75522cd84622a03b1b25ba6e6c
|
||||
SHA512 (lldb-18.1.6.src.tar.xz) = d2a46241333a81974720e63f5c38f53806a31ea59c530193258231bf07a419802580b2848796cbb8e9009561dacd726738c643fc1f723abef7d785854bf63c85
|
||||
SHA512 (lldb-18.1.6.src.tar.xz.sig) = 8cc7bb502d251b4866b154743910270ee1884e4e8bdead72d8844604170fdb32c736d98c8450c4b09c76103a1e4df689e21a40b3e88f1b376adcf4e49507a4a5
|
||||
|
6
tests/README.md
Normal file
6
tests/README.md
Normal file
@ -0,0 +1,6 @@
|
||||
# Gating testplans for lldb
|
||||
|
||||
The tests for lldb are in a separate repo: https://src.fedoraproject.org/tests/lldb
|
||||
This directory should contain only fmf plans (such as build-gating.fmf) which import
|
||||
the tests from the tests repo. This can be done using the "url" parameter of the
|
||||
plan's "discover" step. Reference: https://tmt.readthedocs.io/en/stable/spec/plans.html#fmf
|
Loading…
Reference in New Issue
Block a user