Update to LLVM 15.0.6
Resolves: rhbz#2118567
This commit is contained in:
parent
16f2c022d1
commit
511ce9d0c9
3
.gitignore
vendored
3
.gitignore
vendored
@ -89,3 +89,6 @@
|
||||
/lldb-15.0.1.src.tar.xz.sig
|
||||
/f0a25fe0b746f56295d5c02116ba28d2f965c175.diff
|
||||
/81fc5f7909a4ef5a8d4b5da2a10f77f7cb01ba63.diff
|
||||
/lldb-15.0.6.src.tar.xz
|
||||
/lldb-15.0.6.src.tar.xz.sig
|
||||
/6f59f302e4358b4dc869bc298c2b9c06aa716b60.diff
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -ruN lldb-13.0.1.src.orig/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h lldb-13.0.1.src/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h
|
||||
--- a/lldb-13.0.1.src.orig/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h 2022-01-20 22:31:59.000000000 +0100
|
||||
+++ b/lldb-13.0.1.src/source/Plugins/Process/Linux/NativeRegisterContextLinux_ppc64le.h 2022-03-30 08:02:16.292360951 +0200
|
||||
@@ -122,7 +122,7 @@
|
||||
int mode; // Defines if watchpoint is read/write/access.
|
||||
};
|
||||
|
||||
- std::array<DREG, 4> m_hwp_regs;
|
||||
+ std::array<DREG, 16> m_hwp_regs;
|
||||
|
||||
// 16 is just a maximum value, query hardware for actual watchpoint count
|
||||
uint32_t m_max_hwp_supported = 16;
|
14
lldb.spec
14
lldb.spec
@ -1,5 +1,5 @@
|
||||
%global toolchain clang
|
||||
%global lldb_version 15.0.1
|
||||
%global lldb_version 15.0.6
|
||||
#global rc_ver 2
|
||||
%global lldb_srcdir %{name}-%{lldb_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
@ -8,7 +8,7 @@
|
||||
|
||||
Name: lldb
|
||||
Version: %{lldb_version}%{?rc_ver:~rc%{rc_ver}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Next generation high-performance debugger
|
||||
|
||||
License: NCSA
|
||||
@ -17,11 +17,8 @@ Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{lldb_v
|
||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{lldb_version}%{?rc_ver:-rc%{rc_ver}}/%{lldb_srcdir}.tar.xz.sig
|
||||
Source2: release-keys.asc
|
||||
|
||||
# Workaround for https://bugzilla.redhat.com/show_bug.cgi?id=2052982
|
||||
Patch2: increase-m_hwp_regs-size.patch
|
||||
# Drop those two once 16.0.0 is out
|
||||
Patch0: https://github.com/llvm/llvm-project/commit/f0a25fe0b746f56295d5c02116ba28d2f965c175.diff
|
||||
Patch1: https://github.com/llvm/llvm-project/commit/81fc5f7909a4ef5a8d4b5da2a10f77f7cb01ba63.diff
|
||||
# TODO: Drop once 16.0.0 is out
|
||||
Patch0: https://github.com/llvm/llvm-project/commit/6f59f302e4358b4dc869bc298c2b9c06aa716b60.diff
|
||||
|
||||
|
||||
# RHEL only: We build LLVM with clang, which now defaults to using the
|
||||
@ -142,6 +139,9 @@ rm -f %{buildroot}%{python3_sitearch}/six.*
|
||||
%{python3_sitearch}/lldb
|
||||
|
||||
%changelog
|
||||
* Sat Dec 10 2022 Konrad Kleine <kkleine@redhat.com> - 15.0.6-1
|
||||
- Update to 15.0.6
|
||||
|
||||
* Thu Oct 20 2022 Konrad Kleine <kkleine@redhat.com> - 15.0.1-2
|
||||
- Bring back patch for rhbz#2052982
|
||||
|
||||
|
5
sources
5
sources
@ -1,4 +1,5 @@
|
||||
SHA512 (lldb-15.0.1.src.tar.xz) = 77824fe6c70760048d5c97e429185281530f5755cab859c08d857ce686f4a338896fd51cc29daec6718490e08e170840755993f38da7bdafaef1b3ba303d6fed
|
||||
SHA512 (lldb-15.0.1.src.tar.xz.sig) = 9b7d7d661c2c7db59f5266d08b1ae308273abb54c9867f469452521c426f649586fa37c6a914c04a564e0b11016c9759c04d8256ffeb905daed1fd68553dd0ad
|
||||
SHA512 (lldb-15.0.6.src.tar.xz) = 13d4cdd68f72c1b7bc6175e3f6b47edce069f48665837971f650fd679346ad2ced401a2e492c457f42469adb8fe6dc73c761be1a118db8229c55b769215cb720
|
||||
SHA512 (lldb-15.0.6.src.tar.xz.sig) = 6705d4b235156f976c212482954cd502d7b303696050ec6864879d3d342f538aa511ecd6f8d13594d9d8fe2996b811e19a880272999dfee34b5b334cf96042c6
|
||||
SHA512 (6f59f302e4358b4dc869bc298c2b9c06aa716b60.diff) = 07d1965d66f042b292a4c60bf0451a02b8b581a6318097a0cca19b32a3c1e1e586f781b5fd7a86214d16cb38b78037a17fec7e6348ea0d8887ead491776fb735
|
||||
SHA512 (f0a25fe0b746f56295d5c02116ba28d2f965c175.diff) = 0d69f1a1fd2532a505876276eb0bc3ce7be4d4c6799c8a5c0cf91ff3abc31977029bfcf953a5091f627489cea5e49198ce8ef97aa3142d187f29c1891293bae1
|
||||
SHA512 (81fc5f7909a4ef5a8d4b5da2a10f77f7cb01ba63.diff) = 4a4c406337d380c8646598fd2390ef070cd7b7024eb91b72752f126f84ff5f980800fad161237b269d369f9ba33e982260633db62d64b16c30b4af514cc4f38f
|
||||
|
Loading…
Reference in New Issue
Block a user