13.0.0-rc1 Release
This commit is contained in:
parent
49ed7a1009
commit
46cf49758c
2
.gitignore
vendored
2
.gitignore
vendored
@ -79,3 +79,5 @@
|
||||
/lldb-12.0.1rc3.src.tar.xz.sig
|
||||
/lldb-12.0.1.src.tar.xz
|
||||
/lldb-12.0.1.src.tar.xz.sig
|
||||
/lldb-13.0.0rc1.src.tar.xz
|
||||
/lldb-13.0.0rc1.src.tar.xz.sig
|
||||
|
@ -1,26 +0,0 @@
|
||||
From 6349965eccf12178cd4235e9f8996142d12ff607 Mon Sep 17 00:00:00 2001
|
||||
From: serge-sans-paille <sguelton@redhat.com>
|
||||
Date: Thu, 25 Feb 2021 14:27:43 +0100
|
||||
Subject: [PATCH 1/2] [PATCH][lldb] Portable asm/ptrace.h include
|
||||
|
||||
---
|
||||
lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_arm64.h | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_arm64.h b/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_arm64.h
|
||||
index 344eae2..c483abc 100644
|
||||
--- a/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_arm64.h
|
||||
+++ b/lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_arm64.h
|
||||
@@ -14,7 +14,8 @@
|
||||
#include "Plugins/Process/Linux/NativeRegisterContextLinux.h"
|
||||
#include "Plugins/Process/Utility/RegisterInfoPOSIX_arm64.h"
|
||||
|
||||
-#include <asm/ptrace.h>
|
||||
+#include <sys/ptrace.h>
|
||||
+#include <linux/ptrace.h>
|
||||
|
||||
namespace lldb_private {
|
||||
namespace process_linux {
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,131 +0,0 @@
|
||||
From 2e94dca0c2cedf0bdbcf8517db2f3750ba95513b Mon Sep 17 00:00:00 2001
|
||||
From: serge-sans-paille <sguelton@redhat.com>
|
||||
Date: Tue, 2 Mar 2021 14:08:02 +0100
|
||||
Subject: [PATCH 2/2] [PATCH][lldb] Support DWARF-5 DW_FORM_line_strp (used by
|
||||
GCC)
|
||||
|
||||
---
|
||||
.../SymbolFile/DWARF/DWARFDebugInfoEntry.cpp | 1 +
|
||||
.../Plugins/SymbolFile/DWARF/DWARFFormValue.cpp | 73 +++++++++++-----------
|
||||
2 files changed, 39 insertions(+), 35 deletions(-)
|
||||
|
||||
diff --git a/lldb/source/Plugins/SymbolFile/DWARF/DWARFDebugInfoEntry.cpp b/lldb/source/Plugins/SymbolFile/DWARF/DWARFDebugInfoEntry.cpp
|
||||
index 4212988..bce2529 100644
|
||||
--- a/lldb/source/Plugins/SymbolFile/DWARF/DWARFDebugInfoEntry.cpp
|
||||
+++ b/lldb/source/Plugins/SymbolFile/DWARF/DWARFDebugInfoEntry.cpp
|
||||
@@ -173,6 +173,7 @@ bool DWARFDebugInfoEntry::Extract(const DWARFDataExtractor &data,
|
||||
break;
|
||||
|
||||
case DW_FORM_strp:
|
||||
+ case DW_FORM_line_strp:
|
||||
case DW_FORM_sec_offset:
|
||||
data.GetU32(&offset);
|
||||
break;
|
||||
diff --git a/lldb/source/Plugins/SymbolFile/DWARF/DWARFFormValue.cpp b/lldb/source/Plugins/SymbolFile/DWARF/DWARFFormValue.cpp
|
||||
index 305f1cb..ec78c5b 100644
|
||||
--- a/lldb/source/Plugins/SymbolFile/DWARF/DWARFFormValue.cpp
|
||||
+++ b/lldb/source/Plugins/SymbolFile/DWARF/DWARFFormValue.cpp
|
||||
@@ -150,40 +150,40 @@ struct FormSize {
|
||||
uint8_t valid:1, size:7;
|
||||
};
|
||||
static FormSize g_form_sizes[] = {
|
||||
- {0,0}, // 0x00 unused
|
||||
- {0,0}, // 0x01 DW_FORM_addr
|
||||
- {0,0}, // 0x02 unused
|
||||
- {0,0}, // 0x03 DW_FORM_block2
|
||||
- {0,0}, // 0x04 DW_FORM_block4
|
||||
- {1,2}, // 0x05 DW_FORM_data2
|
||||
- {1,4}, // 0x06 DW_FORM_data4
|
||||
- {1,8}, // 0x07 DW_FORM_data8
|
||||
- {0,0}, // 0x08 DW_FORM_string
|
||||
- {0,0}, // 0x09 DW_FORM_block
|
||||
- {0,0}, // 0x0a DW_FORM_block1
|
||||
- {1,1}, // 0x0b DW_FORM_data1
|
||||
- {1,1}, // 0x0c DW_FORM_flag
|
||||
- {0,0}, // 0x0d DW_FORM_sdata
|
||||
- {1,4}, // 0x0e DW_FORM_strp
|
||||
- {0,0}, // 0x0f DW_FORM_udata
|
||||
- {0,0}, // 0x10 DW_FORM_ref_addr (addr size for DWARF2 and earlier, 4 bytes for
|
||||
- // DWARF32, 8 bytes for DWARF32 in DWARF 3 and later
|
||||
- {1,1}, // 0x11 DW_FORM_ref1
|
||||
- {1,2}, // 0x12 DW_FORM_ref2
|
||||
- {1,4}, // 0x13 DW_FORM_ref4
|
||||
- {1,8}, // 0x14 DW_FORM_ref8
|
||||
- {0,0}, // 0x15 DW_FORM_ref_udata
|
||||
- {0,0}, // 0x16 DW_FORM_indirect
|
||||
- {1,4}, // 0x17 DW_FORM_sec_offset
|
||||
- {0,0}, // 0x18 DW_FORM_exprloc
|
||||
- {1,0}, // 0x19 DW_FORM_flag_present
|
||||
- {0,0}, // 0x1a
|
||||
- {0,0}, // 0x1b
|
||||
- {0,0}, // 0x1c
|
||||
- {0,0}, // 0x1d
|
||||
- {0,0}, // 0x1e
|
||||
- {0,0}, // 0x1f
|
||||
- {1,8}, // 0x20 DW_FORM_ref_sig8
|
||||
+ {0, 0}, // 0x00 unused
|
||||
+ {0, 0}, // 0x01 DW_FORM_addr
|
||||
+ {0, 0}, // 0x02 unused
|
||||
+ {0, 0}, // 0x03 DW_FORM_block2
|
||||
+ {0, 0}, // 0x04 DW_FORM_block4
|
||||
+ {1, 2}, // 0x05 DW_FORM_data2
|
||||
+ {1, 4}, // 0x06 DW_FORM_data4
|
||||
+ {1, 8}, // 0x07 DW_FORM_data8
|
||||
+ {0, 0}, // 0x08 DW_FORM_string
|
||||
+ {0, 0}, // 0x09 DW_FORM_block
|
||||
+ {0, 0}, // 0x0a DW_FORM_block1
|
||||
+ {1, 1}, // 0x0b DW_FORM_data1
|
||||
+ {1, 1}, // 0x0c DW_FORM_flag
|
||||
+ {0, 0}, // 0x0d DW_FORM_sdata
|
||||
+ {1, 4}, // 0x0e DW_FORM_strp
|
||||
+ {0, 0}, // 0x0f DW_FORM_udata
|
||||
+ {0, 0}, // 0x10 DW_FORM_ref_addr (addr size for DWARF2 and earlier, 4 bytes
|
||||
+ // for DWARF32, 8 bytes for DWARF32 in DWARF 3 and later
|
||||
+ {1, 1}, // 0x11 DW_FORM_ref1
|
||||
+ {1, 2}, // 0x12 DW_FORM_ref2
|
||||
+ {1, 4}, // 0x13 DW_FORM_ref4
|
||||
+ {1, 8}, // 0x14 DW_FORM_ref8
|
||||
+ {0, 0}, // 0x15 DW_FORM_ref_udata
|
||||
+ {0, 0}, // 0x16 DW_FORM_indirect
|
||||
+ {1, 4}, // 0x17 DW_FORM_sec_offset
|
||||
+ {0, 0}, // 0x18 DW_FORM_exprloc
|
||||
+ {1, 0}, // 0x19 DW_FORM_flag_present
|
||||
+ {0, 0}, // 0x1a DW_FORM_strx (ULEB128)
|
||||
+ {0, 0}, // 0x1b DW_FORM_addrx (ULEB128)
|
||||
+ {1, 4}, // 0x1c DW_FORM_ref_sup4
|
||||
+ {0, 0}, // 0x1d DW_FORM_strp_sup (4 bytes for DWARF32, 8 bytes for DWARF64)
|
||||
+ {1, 16}, // 0x1e DW_FORM_data16
|
||||
+ {1, 4}, // 0x1f DW_FORM_line_strp
|
||||
+ {1, 8}, // 0x20 DW_FORM_ref_sig8
|
||||
};
|
||||
|
||||
llvm::Optional<uint8_t>
|
||||
@@ -286,6 +286,7 @@ bool DWARFFormValue::SkipValue(dw_form_t form,
|
||||
// 32 bit for DWARF 32, 64 for DWARF 64
|
||||
case DW_FORM_sec_offset:
|
||||
case DW_FORM_strp:
|
||||
+ case DW_FORM_line_strp:
|
||||
*offset_ptr += 4;
|
||||
return true;
|
||||
|
||||
@@ -398,7 +399,8 @@ void DWARFFormValue::Dump(Stream &s) const {
|
||||
case DW_FORM_udata:
|
||||
s.PutULEB128(uvalue);
|
||||
break;
|
||||
- case DW_FORM_strp: {
|
||||
+ case DW_FORM_strp:
|
||||
+ case DW_FORM_line_strp: {
|
||||
const char *dbg_str = AsCString();
|
||||
if (dbg_str) {
|
||||
s.QuotedCString(dbg_str);
|
||||
@@ -606,6 +608,7 @@ bool DWARFFormValue::FormIsSupported(dw_form_t form) {
|
||||
case DW_FORM_flag:
|
||||
case DW_FORM_sdata:
|
||||
case DW_FORM_strp:
|
||||
+ case DW_FORM_line_strp:
|
||||
case DW_FORM_strx:
|
||||
case DW_FORM_strx1:
|
||||
case DW_FORM_strx2:
|
||||
--
|
||||
1.8.3.1
|
||||
|
12
lldb.spec
12
lldb.spec
@ -1,10 +1,10 @@
|
||||
#global rc_ver 3
|
||||
%global lldb_version 12.0.1
|
||||
%global rc_ver 1
|
||||
%global lldb_version 13.0.0
|
||||
%global lldb_srcdir %{name}-%{lldb_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
Name: lldb
|
||||
Version: %{lldb_version}%{?rc_ver:~rc%{rc_ver}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Next generation high-performance debugger
|
||||
|
||||
License: NCSA
|
||||
@ -35,9 +35,6 @@ Requires: python3-lldb
|
||||
# For origin certification
|
||||
BuildRequires: gnupg2
|
||||
|
||||
Patch0: 0001-PATCH-lldb-Portable-asm-ptrace.h-include.patch
|
||||
Patch1: 0002-PATCH-lldb-Support-DWARF-5-DW_FORM_line_strp-used-by.patch
|
||||
|
||||
%description
|
||||
LLDB is a next generation, high-performance debugger. It is built as a set
|
||||
of reusable components which highly leverage existing libraries in the
|
||||
@ -131,6 +128,9 @@ rm -f %{buildroot}%{python3_sitearch}/six.*
|
||||
%{python3_sitearch}/lldb
|
||||
|
||||
%changelog
|
||||
* Mon Aug 09 2021 Tom Stellard <tstellar@redhat.com> - 13.0.0~rc1-1
|
||||
- 13.0.0-rc1 Release
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 12.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (lldb-12.0.1.src.tar.xz) = df3c8e088bf69fb843cd7365fd2df4cefb72c9a313511fb0d0fa3e06e7d12cada35a1d621ec4312c99799e68ff76955423993ce0310c58f74ccd5151984f38ee
|
||||
SHA512 (lldb-12.0.1.src.tar.xz.sig) = f11f9763213470a9041dedaea64e074f16854b7258543af58fb86c0a84aa8ee60cf4c36984f707276aa79ace7d4152a8b15079a6b50f55c156d3976d8b6b1eb9
|
||||
SHA512 (lldb-13.0.0rc1.src.tar.xz) = 96c8b87411c6d472b253bca82ee911a886fd7a2a0f8c923509d205956735d43a61eb803dd098301a1a70c6dec0179bdaea1ee7acc807914abbd654f2f207ef9b
|
||||
SHA512 (lldb-13.0.0rc1.src.tar.xz.sig) = 62157a31259aa054c8d2c93ebe74035f86be78fbfcf1e30ff163df9a540354842235e3ff970085c5fbb077d91b687156b35ba9351a4555978ae9e99f9766392d
|
||||
|
Loading…
Reference in New Issue
Block a user