Remove obsolete patch
This commit is contained in:
parent
bb67e50ea6
commit
cf34ae0536
@ -1,124 +0,0 @@
|
||||
diff -ru --new-file lld-8.0.0rc1.src.orig/ELF/InputFiles.cpp lld-8.0.0rc1.src/ELF/InputFiles.cpp
|
||||
--- lld-8.0.0rc1.src.orig/ELF/InputFiles.cpp 2019-02-12 08:09:21.746416886 +0000
|
||||
+++ lld-8.0.0rc1.src/ELF/InputFiles.cpp 2019-02-13 10:41:49.565275043 +0000
|
||||
@@ -320,17 +320,6 @@
|
||||
return Signature;
|
||||
}
|
||||
|
||||
-template <class ELFT>
|
||||
-ArrayRef<typename ObjFile<ELFT>::Elf_Word>
|
||||
-ObjFile<ELFT>::getShtGroupEntries(const Elf_Shdr &Sec) {
|
||||
- const ELFFile<ELFT> &Obj = this->getObj();
|
||||
- ArrayRef<Elf_Word> Entries =
|
||||
- CHECK(Obj.template getSectionContentsAsArray<Elf_Word>(&Sec), this);
|
||||
- if (Entries.empty() || Entries[0] != GRP_COMDAT)
|
||||
- fatal(toString(this) + ": unsupported SHT_GROUP format");
|
||||
- return Entries.slice(1);
|
||||
-}
|
||||
-
|
||||
template <class ELFT> bool ObjFile<ELFT>::shouldMerge(const Elf_Shdr &Sec) {
|
||||
// On a regular link we don't merge sections if -O0 (default is -O1). This
|
||||
// sometimes makes the linker significantly faster, although the output will
|
||||
@@ -440,18 +429,24 @@
|
||||
case SHT_GROUP: {
|
||||
// De-duplicate section groups by their signatures.
|
||||
StringRef Signature = getShtGroupSignature(ObjSections, Sec);
|
||||
- bool IsNew = ComdatGroups.insert(CachedHashStringRef(Signature)).second;
|
||||
this->Sections[I] = &InputSection::Discarded;
|
||||
|
||||
- // We only support GRP_COMDAT type of group. Get the all entries of the
|
||||
- // section here to let getShtGroupEntries to check the type early for us.
|
||||
- ArrayRef<Elf_Word> Entries = getShtGroupEntries(Sec);
|
||||
-
|
||||
- // If it is a new section group, we want to keep group members.
|
||||
- // Group leader sections, which contain indices of group members, are
|
||||
- // discarded because they are useless beyond this point. The only
|
||||
- // exception is the -r option because in order to produce re-linkable
|
||||
- // object files, we want to pass through basically everything.
|
||||
+ ArrayRef<Elf_Word> Entries =
|
||||
+ CHECK(Obj.template getSectionContentsAsArray<Elf_Word>(&Sec), this);
|
||||
+ if (Entries.empty())
|
||||
+ fatal(toString(this) + ": empty SHT_GROUP");
|
||||
+
|
||||
+ // The first word of a SHT_GROUP section contains flags. Currently,
|
||||
+ // the standard defines only "GRP_COMDAT" flag for the COMDAT group.
|
||||
+ // An group with the empty flag doesn't define anything; such sections
|
||||
+ // are just skipped.
|
||||
+ if (Entries[0] == 0)
|
||||
+ continue;
|
||||
+
|
||||
+ if (Entries[0] != GRP_COMDAT)
|
||||
+ fatal(toString(this) + ": unsupported SHT_GROUP format");
|
||||
+
|
||||
+ bool IsNew = ComdatGroups.insert(CachedHashStringRef(Signature)).second;
|
||||
if (IsNew) {
|
||||
if (Config->Relocatable)
|
||||
this->Sections[I] = createInputSection(Sec);
|
||||
@@ -459,7 +454,7 @@
|
||||
}
|
||||
|
||||
// Otherwise, discard group members.
|
||||
- for (uint32_t SecIndex : Entries) {
|
||||
+ for (uint32_t SecIndex : Entries.slice(1)) {
|
||||
if (SecIndex >= Size)
|
||||
fatal(toString(this) +
|
||||
": invalid section index in group: " + Twine(SecIndex));
|
||||
diff -ru --new-file lld-8.0.0rc1.src.orig/test/ELF/sht-group-empty.test lld-8.0.0rc1.src/test/ELF/sht-group-empty.test
|
||||
--- lld-8.0.0rc1.src.orig/test/ELF/sht-group-empty.test 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ lld-8.0.0rc1.src/test/ELF/sht-group-empty.test 2019-02-13 10:40:11.958253274 +0000
|
||||
@@ -0,0 +1,55 @@
|
||||
+# RUN: yaml2obj %s -o %t.o
|
||||
+# RUN: ld.lld %t.o %t.o -o %t -r
|
||||
+# RUN: llvm-readobj -s %t | FileCheck %s
|
||||
+
|
||||
+# CHECK: Name: .text.foo
|
||||
+# CHECK: Name: .rela.text.foo
|
||||
+
|
||||
+--- !ELF
|
||||
+FileHeader:
|
||||
+ Class: ELFCLASS64
|
||||
+ Data: ELFDATA2LSB
|
||||
+ Type: ET_REL
|
||||
+ Machine: EM_X86_64
|
||||
+Sections:
|
||||
+ - Name: .group
|
||||
+ Type: SHT_GROUP
|
||||
+ Link: .symtab
|
||||
+ Info: foo
|
||||
+ Members:
|
||||
+ - SectionOrType: GRP_COMDAT
|
||||
+ - SectionOrType: .text.foo
|
||||
+ - SectionOrType: .text.bar
|
||||
+ - SectionOrType: .note
|
||||
+ - Name: .note
|
||||
+ Type: SHT_NOTE
|
||||
+ Flags: [ SHF_GROUP ]
|
||||
+ - Name: .text.foo
|
||||
+ Type: SHT_PROGBITS
|
||||
+ Flags: [ SHF_ALLOC, SHF_EXECINSTR, SHF_GROUP ]
|
||||
+ - Name: .text.bar
|
||||
+ Type: SHT_PROGBITS
|
||||
+ Flags: [ SHF_ALLOC, SHF_EXECINSTR, SHF_GROUP ]
|
||||
+ - Name: .rela.text.foo
|
||||
+ Type: SHT_RELA
|
||||
+ Flags: [ SHF_INFO_LINK, SHF_GROUP ]
|
||||
+ Link: .symtab
|
||||
+ Info: .text.foo
|
||||
+ Relocations:
|
||||
+ - Offset: 0x0000000000000000
|
||||
+ Symbol: foo
|
||||
+ Type: R_X86_64_64
|
||||
+ - Name: .rela.text.bar
|
||||
+ Type: SHT_RELA
|
||||
+ Flags: [ SHF_INFO_LINK, SHF_GROUP ]
|
||||
+ Link: .symtab
|
||||
+ Info: .text.bar
|
||||
+ Relocations:
|
||||
+ - Offset: 0x0000000000000000
|
||||
+ Symbol: bar
|
||||
+ Type: R_X86_64_64
|
||||
+Symbols:
|
||||
+ Global:
|
||||
+ - Name: foo
|
||||
+ - Name: bar
|
||||
+
|
1
lld.spec
1
lld.spec
@ -12,7 +12,6 @@ Source0: http://%{?rc_ver:pre}releases.llvm.org/%{version}/%{?rc_ver:rc%{rc_ver}
|
||||
|
||||
Patch0: 0001-CMake-Check-for-gtest-headers-even-if-lit.py-is-not-.patch
|
||||
Patch1: 0001-lld-Prefer-using-the-newest-installed-python-version.patch
|
||||
Patch2: 0001-Partial-support-of-SHT_GROUP-without-flag.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
|
Loading…
Reference in New Issue
Block a user