import lld-12.0.1-1.module+el8.5.0+11871+08d0eab5
This commit is contained in:
parent
be8cad976a
commit
892a52a7b6
3
.gitignore
vendored
3
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
SOURCES/lld-11.0.1.src.tar.xz
|
SOURCES/lld-12.0.1.src.tar.xz
|
||||||
|
SOURCES/tstellar-gpg-key.asc
|
||||||
|
@ -1 +1,2 @@
|
|||||||
ef1679dd56bdab3fe8b2bb07721b0d99ee43ff5d SOURCES/lld-11.0.1.src.tar.xz
|
3b7e4908f6cf3a51590e37b4194180582cc1c32c SOURCES/lld-12.0.1.src.tar.xz
|
||||||
|
b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc
|
||||||
|
@ -1,19 +1,20 @@
|
|||||||
From e5bdf4580677da063abe8d3880fbab9eaa7a7efe Mon Sep 17 00:00:00 2001
|
From 760568cd24acd6ae9083b0dfea2c7c0ea6f0adc2 Mon Sep 17 00:00:00 2001
|
||||||
From: Tom Stellard <tstellar@redhat.com>
|
From: Tom Stellard <tstellar@redhat.com>
|
||||||
Date: Thu, 30 Aug 2018 08:53:56 -0700
|
Date: Thu, 30 Aug 2018 08:53:56 -0700
|
||||||
Subject: [PATCH] CMake: Check for gtest headers even if lit.py is not present
|
Subject: [PATCH 1/2] [PATCH][lld] CMake: Check for gtest headers even if
|
||||||
|
lit.py is not present
|
||||||
|
|
||||||
This makes it possible to build the unittests even withotu a full
|
This makes it possible to build the unittests even withotu a full
|
||||||
checkout of the llvm source tree.
|
checkout of the llvm source tree.
|
||||||
---
|
---
|
||||||
CMakeLists.txt | 15 +++++++++------
|
lld/CMakeLists.txt | 15 +++++++++------
|
||||||
1 file changed, 9 insertions(+), 6 deletions(-)
|
1 file changed, 9 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
diff --git a/lld/CMakeLists.txt b/lld/CMakeLists.txt
|
||||||
index e2fbdbf..c9b2927 100644
|
index d4e561b..a7406d1c 100644
|
||||||
--- a/CMakeLists.txt
|
--- a/lld/CMakeLists.txt
|
||||||
+++ b/CMakeLists.txt
|
+++ b/lld/CMakeLists.txt
|
||||||
@@ -75,6 +75,15 @@ Please install Python or specify the PYTHON_EXECUTABLE CMake variable.")
|
@@ -65,6 +65,15 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
|
||||||
set(LLVM_UTILS_PROVIDED ON)
|
set(LLVM_UTILS_PROVIDED ON)
|
||||||
endif()
|
endif()
|
||||||
|
|
||||||
@ -29,7 +30,7 @@ index e2fbdbf..c9b2927 100644
|
|||||||
if(EXISTS ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
|
if(EXISTS ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
|
||||||
# Note: path not really used, except for checking if lit was found
|
# Note: path not really used, except for checking if lit was found
|
||||||
set(LLVM_LIT ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
|
set(LLVM_LIT ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
|
||||||
@@ -84,12 +93,6 @@ Please install Python or specify the PYTHON_EXECUTABLE CMake variable.")
|
@@ -74,12 +83,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
|
||||||
set(LLVM_UTILS_PROVIDED ON)
|
set(LLVM_UTILS_PROVIDED ON)
|
||||||
set(LLD_TEST_DEPS FileCheck not)
|
set(LLD_TEST_DEPS FileCheck not)
|
||||||
endif()
|
endif()
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,498 @@
|
|||||||
|
From 43dfe54ce017c8d37eaec480a2f13a492bbc4203 Mon Sep 17 00:00:00 2001
|
||||||
|
From: serge-sans-paille <sguelton@redhat.com>
|
||||||
|
Date: Thu, 25 Feb 2021 14:24:14 +0100
|
||||||
|
Subject: [PATCH 2/2] [PATCH][lld] Import compact_unwind_encoding.h from
|
||||||
|
libunwind
|
||||||
|
|
||||||
|
This avoids an implicit cross package dependency
|
||||||
|
---
|
||||||
|
lld/include/mach-o/compact_unwind_encoding.h | 477 +++++++++++++++++++++++++++
|
||||||
|
1 file changed, 477 insertions(+)
|
||||||
|
create mode 100644 lld/include/mach-o/compact_unwind_encoding.h
|
||||||
|
|
||||||
|
diff --git a/lld/include/mach-o/compact_unwind_encoding.h b/lld/include/mach-o/compact_unwind_encoding.h
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..5301b10
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/lld/include/mach-o/compact_unwind_encoding.h
|
||||||
|
@@ -0,0 +1,477 @@
|
||||||
|
+//===------------------ mach-o/compact_unwind_encoding.h ------------------===//
|
||||||
|
+//
|
||||||
|
+// Part of the LLVM Project, under the Apache License v2.0 with LLVM Exceptions.
|
||||||
|
+// See https://llvm.org/LICENSE.txt for license information.
|
||||||
|
+// SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
|
||||||
|
+//
|
||||||
|
+//
|
||||||
|
+// Darwin's alternative to DWARF based unwind encodings.
|
||||||
|
+//
|
||||||
|
+//===----------------------------------------------------------------------===//
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+#ifndef __COMPACT_UNWIND_ENCODING__
|
||||||
|
+#define __COMPACT_UNWIND_ENCODING__
|
||||||
|
+
|
||||||
|
+#include <stdint.h>
|
||||||
|
+
|
||||||
|
+//
|
||||||
|
+// Compilers can emit standard DWARF FDEs in the __TEXT,__eh_frame section
|
||||||
|
+// of object files. Or compilers can emit compact unwind information in
|
||||||
|
+// the __LD,__compact_unwind section.
|
||||||
|
+//
|
||||||
|
+// When the linker creates a final linked image, it will create a
|
||||||
|
+// __TEXT,__unwind_info section. This section is a small and fast way for the
|
||||||
|
+// runtime to access unwind info for any given function. If the compiler
|
||||||
|
+// emitted compact unwind info for the function, that compact unwind info will
|
||||||
|
+// be encoded in the __TEXT,__unwind_info section. If the compiler emitted
|
||||||
|
+// DWARF unwind info, the __TEXT,__unwind_info section will contain the offset
|
||||||
|
+// of the FDE in the __TEXT,__eh_frame section in the final linked image.
|
||||||
|
+//
|
||||||
|
+// Note: Previously, the linker would transform some DWARF unwind infos into
|
||||||
|
+// compact unwind info. But that is fragile and no longer done.
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+//
|
||||||
|
+// The compact unwind endoding is a 32-bit value which encoded in an
|
||||||
|
+// architecture specific way, which registers to restore from where, and how
|
||||||
|
+// to unwind out of the function.
|
||||||
|
+//
|
||||||
|
+typedef uint32_t compact_unwind_encoding_t;
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+// architecture independent bits
|
||||||
|
+enum {
|
||||||
|
+ UNWIND_IS_NOT_FUNCTION_START = 0x80000000,
|
||||||
|
+ UNWIND_HAS_LSDA = 0x40000000,
|
||||||
|
+ UNWIND_PERSONALITY_MASK = 0x30000000,
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+//
|
||||||
|
+// x86
|
||||||
|
+//
|
||||||
|
+// 1-bit: start
|
||||||
|
+// 1-bit: has lsda
|
||||||
|
+// 2-bit: personality index
|
||||||
|
+//
|
||||||
|
+// 4-bits: 0=old, 1=ebp based, 2=stack-imm, 3=stack-ind, 4=DWARF
|
||||||
|
+// ebp based:
|
||||||
|
+// 15-bits (5*3-bits per reg) register permutation
|
||||||
|
+// 8-bits for stack offset
|
||||||
|
+// frameless:
|
||||||
|
+// 8-bits stack size
|
||||||
|
+// 3-bits stack adjust
|
||||||
|
+// 3-bits register count
|
||||||
|
+// 10-bits register permutation
|
||||||
|
+//
|
||||||
|
+enum {
|
||||||
|
+ UNWIND_X86_MODE_MASK = 0x0F000000,
|
||||||
|
+ UNWIND_X86_MODE_EBP_FRAME = 0x01000000,
|
||||||
|
+ UNWIND_X86_MODE_STACK_IMMD = 0x02000000,
|
||||||
|
+ UNWIND_X86_MODE_STACK_IND = 0x03000000,
|
||||||
|
+ UNWIND_X86_MODE_DWARF = 0x04000000,
|
||||||
|
+
|
||||||
|
+ UNWIND_X86_EBP_FRAME_REGISTERS = 0x00007FFF,
|
||||||
|
+ UNWIND_X86_EBP_FRAME_OFFSET = 0x00FF0000,
|
||||||
|
+
|
||||||
|
+ UNWIND_X86_FRAMELESS_STACK_SIZE = 0x00FF0000,
|
||||||
|
+ UNWIND_X86_FRAMELESS_STACK_ADJUST = 0x0000E000,
|
||||||
|
+ UNWIND_X86_FRAMELESS_STACK_REG_COUNT = 0x00001C00,
|
||||||
|
+ UNWIND_X86_FRAMELESS_STACK_REG_PERMUTATION = 0x000003FF,
|
||||||
|
+
|
||||||
|
+ UNWIND_X86_DWARF_SECTION_OFFSET = 0x00FFFFFF,
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+enum {
|
||||||
|
+ UNWIND_X86_REG_NONE = 0,
|
||||||
|
+ UNWIND_X86_REG_EBX = 1,
|
||||||
|
+ UNWIND_X86_REG_ECX = 2,
|
||||||
|
+ UNWIND_X86_REG_EDX = 3,
|
||||||
|
+ UNWIND_X86_REG_EDI = 4,
|
||||||
|
+ UNWIND_X86_REG_ESI = 5,
|
||||||
|
+ UNWIND_X86_REG_EBP = 6,
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+//
|
||||||
|
+// For x86 there are four modes for the compact unwind encoding:
|
||||||
|
+// UNWIND_X86_MODE_EBP_FRAME:
|
||||||
|
+// EBP based frame where EBP is push on stack immediately after return address,
|
||||||
|
+// then ESP is moved to EBP. Thus, to unwind ESP is restored with the current
|
||||||
|
+// EPB value, then EBP is restored by popping off the stack, and the return
|
||||||
|
+// is done by popping the stack once more into the pc.
|
||||||
|
+// All non-volatile registers that need to be restored must have been saved
|
||||||
|
+// in a small range in the stack that starts EBP-4 to EBP-1020. The offset/4
|
||||||
|
+// is encoded in the UNWIND_X86_EBP_FRAME_OFFSET bits. The registers saved
|
||||||
|
+// are encoded in the UNWIND_X86_EBP_FRAME_REGISTERS bits as five 3-bit entries.
|
||||||
|
+// Each entry contains which register to restore.
|
||||||
|
+// UNWIND_X86_MODE_STACK_IMMD:
|
||||||
|
+// A "frameless" (EBP not used as frame pointer) function with a small
|
||||||
|
+// constant stack size. To return, a constant (encoded in the compact
|
||||||
|
+// unwind encoding) is added to the ESP. Then the return is done by
|
||||||
|
+// popping the stack into the pc.
|
||||||
|
+// All non-volatile registers that need to be restored must have been saved
|
||||||
|
+// on the stack immediately after the return address. The stack_size/4 is
|
||||||
|
+// encoded in the UNWIND_X86_FRAMELESS_STACK_SIZE (max stack size is 1024).
|
||||||
|
+// The number of registers saved is encoded in UNWIND_X86_FRAMELESS_STACK_REG_COUNT.
|
||||||
|
+// UNWIND_X86_FRAMELESS_STACK_REG_PERMUTATION constains which registers were
|
||||||
|
+// saved and their order.
|
||||||
|
+// UNWIND_X86_MODE_STACK_IND:
|
||||||
|
+// A "frameless" (EBP not used as frame pointer) function large constant
|
||||||
|
+// stack size. This case is like the previous, except the stack size is too
|
||||||
|
+// large to encode in the compact unwind encoding. Instead it requires that
|
||||||
|
+// the function contains "subl $nnnnnnnn,ESP" in its prolog. The compact
|
||||||
|
+// encoding contains the offset to the nnnnnnnn value in the function in
|
||||||
|
+// UNWIND_X86_FRAMELESS_STACK_SIZE.
|
||||||
|
+// UNWIND_X86_MODE_DWARF:
|
||||||
|
+// No compact unwind encoding is available. Instead the low 24-bits of the
|
||||||
|
+// compact encoding is the offset of the DWARF FDE in the __eh_frame section.
|
||||||
|
+// This mode is never used in object files. It is only generated by the
|
||||||
|
+// linker in final linked images which have only DWARF unwind info for a
|
||||||
|
+// function.
|
||||||
|
+//
|
||||||
|
+// The permutation encoding is a Lehmer code sequence encoded into a
|
||||||
|
+// single variable-base number so we can encode the ordering of up to
|
||||||
|
+// six registers in a 10-bit space.
|
||||||
|
+//
|
||||||
|
+// The following is the algorithm used to create the permutation encoding used
|
||||||
|
+// with frameless stacks. It is passed the number of registers to be saved and
|
||||||
|
+// an array of the register numbers saved.
|
||||||
|
+//
|
||||||
|
+//uint32_t permute_encode(uint32_t registerCount, const uint32_t registers[6])
|
||||||
|
+//{
|
||||||
|
+// uint32_t renumregs[6];
|
||||||
|
+// for (int i=6-registerCount; i < 6; ++i) {
|
||||||
|
+// int countless = 0;
|
||||||
|
+// for (int j=6-registerCount; j < i; ++j) {
|
||||||
|
+// if ( registers[j] < registers[i] )
|
||||||
|
+// ++countless;
|
||||||
|
+// }
|
||||||
|
+// renumregs[i] = registers[i] - countless -1;
|
||||||
|
+// }
|
||||||
|
+// uint32_t permutationEncoding = 0;
|
||||||
|
+// switch ( registerCount ) {
|
||||||
|
+// case 6:
|
||||||
|
+// permutationEncoding |= (120*renumregs[0] + 24*renumregs[1]
|
||||||
|
+// + 6*renumregs[2] + 2*renumregs[3]
|
||||||
|
+// + renumregs[4]);
|
||||||
|
+// break;
|
||||||
|
+// case 5:
|
||||||
|
+// permutationEncoding |= (120*renumregs[1] + 24*renumregs[2]
|
||||||
|
+// + 6*renumregs[3] + 2*renumregs[4]
|
||||||
|
+// + renumregs[5]);
|
||||||
|
+// break;
|
||||||
|
+// case 4:
|
||||||
|
+// permutationEncoding |= (60*renumregs[2] + 12*renumregs[3]
|
||||||
|
+// + 3*renumregs[4] + renumregs[5]);
|
||||||
|
+// break;
|
||||||
|
+// case 3:
|
||||||
|
+// permutationEncoding |= (20*renumregs[3] + 4*renumregs[4]
|
||||||
|
+// + renumregs[5]);
|
||||||
|
+// break;
|
||||||
|
+// case 2:
|
||||||
|
+// permutationEncoding |= (5*renumregs[4] + renumregs[5]);
|
||||||
|
+// break;
|
||||||
|
+// case 1:
|
||||||
|
+// permutationEncoding |= (renumregs[5]);
|
||||||
|
+// break;
|
||||||
|
+// }
|
||||||
|
+// return permutationEncoding;
|
||||||
|
+//}
|
||||||
|
+//
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+//
|
||||||
|
+// x86_64
|
||||||
|
+//
|
||||||
|
+// 1-bit: start
|
||||||
|
+// 1-bit: has lsda
|
||||||
|
+// 2-bit: personality index
|
||||||
|
+//
|
||||||
|
+// 4-bits: 0=old, 1=rbp based, 2=stack-imm, 3=stack-ind, 4=DWARF
|
||||||
|
+// rbp based:
|
||||||
|
+// 15-bits (5*3-bits per reg) register permutation
|
||||||
|
+// 8-bits for stack offset
|
||||||
|
+// frameless:
|
||||||
|
+// 8-bits stack size
|
||||||
|
+// 3-bits stack adjust
|
||||||
|
+// 3-bits register count
|
||||||
|
+// 10-bits register permutation
|
||||||
|
+//
|
||||||
|
+enum {
|
||||||
|
+ UNWIND_X86_64_MODE_MASK = 0x0F000000,
|
||||||
|
+ UNWIND_X86_64_MODE_RBP_FRAME = 0x01000000,
|
||||||
|
+ UNWIND_X86_64_MODE_STACK_IMMD = 0x02000000,
|
||||||
|
+ UNWIND_X86_64_MODE_STACK_IND = 0x03000000,
|
||||||
|
+ UNWIND_X86_64_MODE_DWARF = 0x04000000,
|
||||||
|
+
|
||||||
|
+ UNWIND_X86_64_RBP_FRAME_REGISTERS = 0x00007FFF,
|
||||||
|
+ UNWIND_X86_64_RBP_FRAME_OFFSET = 0x00FF0000,
|
||||||
|
+
|
||||||
|
+ UNWIND_X86_64_FRAMELESS_STACK_SIZE = 0x00FF0000,
|
||||||
|
+ UNWIND_X86_64_FRAMELESS_STACK_ADJUST = 0x0000E000,
|
||||||
|
+ UNWIND_X86_64_FRAMELESS_STACK_REG_COUNT = 0x00001C00,
|
||||||
|
+ UNWIND_X86_64_FRAMELESS_STACK_REG_PERMUTATION = 0x000003FF,
|
||||||
|
+
|
||||||
|
+ UNWIND_X86_64_DWARF_SECTION_OFFSET = 0x00FFFFFF,
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+enum {
|
||||||
|
+ UNWIND_X86_64_REG_NONE = 0,
|
||||||
|
+ UNWIND_X86_64_REG_RBX = 1,
|
||||||
|
+ UNWIND_X86_64_REG_R12 = 2,
|
||||||
|
+ UNWIND_X86_64_REG_R13 = 3,
|
||||||
|
+ UNWIND_X86_64_REG_R14 = 4,
|
||||||
|
+ UNWIND_X86_64_REG_R15 = 5,
|
||||||
|
+ UNWIND_X86_64_REG_RBP = 6,
|
||||||
|
+};
|
||||||
|
+//
|
||||||
|
+// For x86_64 there are four modes for the compact unwind encoding:
|
||||||
|
+// UNWIND_X86_64_MODE_RBP_FRAME:
|
||||||
|
+// RBP based frame where RBP is push on stack immediately after return address,
|
||||||
|
+// then RSP is moved to RBP. Thus, to unwind RSP is restored with the current
|
||||||
|
+// EPB value, then RBP is restored by popping off the stack, and the return
|
||||||
|
+// is done by popping the stack once more into the pc.
|
||||||
|
+// All non-volatile registers that need to be restored must have been saved
|
||||||
|
+// in a small range in the stack that starts RBP-8 to RBP-2040. The offset/8
|
||||||
|
+// is encoded in the UNWIND_X86_64_RBP_FRAME_OFFSET bits. The registers saved
|
||||||
|
+// are encoded in the UNWIND_X86_64_RBP_FRAME_REGISTERS bits as five 3-bit entries.
|
||||||
|
+// Each entry contains which register to restore.
|
||||||
|
+// UNWIND_X86_64_MODE_STACK_IMMD:
|
||||||
|
+// A "frameless" (RBP not used as frame pointer) function with a small
|
||||||
|
+// constant stack size. To return, a constant (encoded in the compact
|
||||||
|
+// unwind encoding) is added to the RSP. Then the return is done by
|
||||||
|
+// popping the stack into the pc.
|
||||||
|
+// All non-volatile registers that need to be restored must have been saved
|
||||||
|
+// on the stack immediately after the return address. The stack_size/8 is
|
||||||
|
+// encoded in the UNWIND_X86_64_FRAMELESS_STACK_SIZE (max stack size is 2048).
|
||||||
|
+// The number of registers saved is encoded in UNWIND_X86_64_FRAMELESS_STACK_REG_COUNT.
|
||||||
|
+// UNWIND_X86_64_FRAMELESS_STACK_REG_PERMUTATION constains which registers were
|
||||||
|
+// saved and their order.
|
||||||
|
+// UNWIND_X86_64_MODE_STACK_IND:
|
||||||
|
+// A "frameless" (RBP not used as frame pointer) function large constant
|
||||||
|
+// stack size. This case is like the previous, except the stack size is too
|
||||||
|
+// large to encode in the compact unwind encoding. Instead it requires that
|
||||||
|
+// the function contains "subq $nnnnnnnn,RSP" in its prolog. The compact
|
||||||
|
+// encoding contains the offset to the nnnnnnnn value in the function in
|
||||||
|
+// UNWIND_X86_64_FRAMELESS_STACK_SIZE.
|
||||||
|
+// UNWIND_X86_64_MODE_DWARF:
|
||||||
|
+// No compact unwind encoding is available. Instead the low 24-bits of the
|
||||||
|
+// compact encoding is the offset of the DWARF FDE in the __eh_frame section.
|
||||||
|
+// This mode is never used in object files. It is only generated by the
|
||||||
|
+// linker in final linked images which have only DWARF unwind info for a
|
||||||
|
+// function.
|
||||||
|
+//
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+// ARM64
|
||||||
|
+//
|
||||||
|
+// 1-bit: start
|
||||||
|
+// 1-bit: has lsda
|
||||||
|
+// 2-bit: personality index
|
||||||
|
+//
|
||||||
|
+// 4-bits: 4=frame-based, 3=DWARF, 2=frameless
|
||||||
|
+// frameless:
|
||||||
|
+// 12-bits of stack size
|
||||||
|
+// frame-based:
|
||||||
|
+// 4-bits D reg pairs saved
|
||||||
|
+// 5-bits X reg pairs saved
|
||||||
|
+// DWARF:
|
||||||
|
+// 24-bits offset of DWARF FDE in __eh_frame section
|
||||||
|
+//
|
||||||
|
+enum {
|
||||||
|
+ UNWIND_ARM64_MODE_MASK = 0x0F000000,
|
||||||
|
+ UNWIND_ARM64_MODE_FRAMELESS = 0x02000000,
|
||||||
|
+ UNWIND_ARM64_MODE_DWARF = 0x03000000,
|
||||||
|
+ UNWIND_ARM64_MODE_FRAME = 0x04000000,
|
||||||
|
+
|
||||||
|
+ UNWIND_ARM64_FRAME_X19_X20_PAIR = 0x00000001,
|
||||||
|
+ UNWIND_ARM64_FRAME_X21_X22_PAIR = 0x00000002,
|
||||||
|
+ UNWIND_ARM64_FRAME_X23_X24_PAIR = 0x00000004,
|
||||||
|
+ UNWIND_ARM64_FRAME_X25_X26_PAIR = 0x00000008,
|
||||||
|
+ UNWIND_ARM64_FRAME_X27_X28_PAIR = 0x00000010,
|
||||||
|
+ UNWIND_ARM64_FRAME_D8_D9_PAIR = 0x00000100,
|
||||||
|
+ UNWIND_ARM64_FRAME_D10_D11_PAIR = 0x00000200,
|
||||||
|
+ UNWIND_ARM64_FRAME_D12_D13_PAIR = 0x00000400,
|
||||||
|
+ UNWIND_ARM64_FRAME_D14_D15_PAIR = 0x00000800,
|
||||||
|
+
|
||||||
|
+ UNWIND_ARM64_FRAMELESS_STACK_SIZE_MASK = 0x00FFF000,
|
||||||
|
+ UNWIND_ARM64_DWARF_SECTION_OFFSET = 0x00FFFFFF,
|
||||||
|
+};
|
||||||
|
+// For arm64 there are three modes for the compact unwind encoding:
|
||||||
|
+// UNWIND_ARM64_MODE_FRAME:
|
||||||
|
+// This is a standard arm64 prolog where FP/LR are immediately pushed on the
|
||||||
|
+// stack, then SP is copied to FP. If there are any non-volatile registers
|
||||||
|
+// saved, then are copied into the stack frame in pairs in a contiguous
|
||||||
|
+// range right below the saved FP/LR pair. Any subset of the five X pairs
|
||||||
|
+// and four D pairs can be saved, but the memory layout must be in register
|
||||||
|
+// number order.
|
||||||
|
+// UNWIND_ARM64_MODE_FRAMELESS:
|
||||||
|
+// A "frameless" leaf function, where FP/LR are not saved. The return address
|
||||||
|
+// remains in LR throughout the function. If any non-volatile registers
|
||||||
|
+// are saved, they must be pushed onto the stack before any stack space is
|
||||||
|
+// allocated for local variables. The stack sized (including any saved
|
||||||
|
+// non-volatile registers) divided by 16 is encoded in the bits
|
||||||
|
+// UNWIND_ARM64_FRAMELESS_STACK_SIZE_MASK.
|
||||||
|
+// UNWIND_ARM64_MODE_DWARF:
|
||||||
|
+// No compact unwind encoding is available. Instead the low 24-bits of the
|
||||||
|
+// compact encoding is the offset of the DWARF FDE in the __eh_frame section.
|
||||||
|
+// This mode is never used in object files. It is only generated by the
|
||||||
|
+// linker in final linked images which have only DWARF unwind info for a
|
||||||
|
+// function.
|
||||||
|
+//
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+////////////////////////////////////////////////////////////////////////////////
|
||||||
|
+//
|
||||||
|
+// Relocatable Object Files: __LD,__compact_unwind
|
||||||
|
+//
|
||||||
|
+////////////////////////////////////////////////////////////////////////////////
|
||||||
|
+
|
||||||
|
+//
|
||||||
|
+// A compiler can generated compact unwind information for a function by adding
|
||||||
|
+// a "row" to the __LD,__compact_unwind section. This section has the
|
||||||
|
+// S_ATTR_DEBUG bit set, so the section will be ignored by older linkers.
|
||||||
|
+// It is removed by the new linker, so never ends up in final executables.
|
||||||
|
+// This section is a table, initially with one row per function (that needs
|
||||||
|
+// unwind info). The table columns and some conceptual entries are:
|
||||||
|
+//
|
||||||
|
+// range-start pointer to start of function/range
|
||||||
|
+// range-length
|
||||||
|
+// compact-unwind-encoding 32-bit encoding
|
||||||
|
+// personality-function or zero if no personality function
|
||||||
|
+// lsda or zero if no LSDA data
|
||||||
|
+//
|
||||||
|
+// The length and encoding fields are 32-bits. The other are all pointer sized.
|
||||||
|
+//
|
||||||
|
+// In x86_64 assembly, these entry would look like:
|
||||||
|
+//
|
||||||
|
+// .section __LD,__compact_unwind,regular,debug
|
||||||
|
+//
|
||||||
|
+// #compact unwind for _foo
|
||||||
|
+// .quad _foo
|
||||||
|
+// .set L1,LfooEnd-_foo
|
||||||
|
+// .long L1
|
||||||
|
+// .long 0x01010001
|
||||||
|
+// .quad 0
|
||||||
|
+// .quad 0
|
||||||
|
+//
|
||||||
|
+// #compact unwind for _bar
|
||||||
|
+// .quad _bar
|
||||||
|
+// .set L2,LbarEnd-_bar
|
||||||
|
+// .long L2
|
||||||
|
+// .long 0x01020011
|
||||||
|
+// .quad __gxx_personality
|
||||||
|
+// .quad except_tab1
|
||||||
|
+//
|
||||||
|
+//
|
||||||
|
+// Notes: There is no need for any labels in the the __compact_unwind section.
|
||||||
|
+// The use of the .set directive is to force the evaluation of the
|
||||||
|
+// range-length at assembly time, instead of generating relocations.
|
||||||
|
+//
|
||||||
|
+// To support future compiler optimizations where which non-volatile registers
|
||||||
|
+// are saved changes within a function (e.g. delay saving non-volatiles until
|
||||||
|
+// necessary), there can by multiple lines in the __compact_unwind table for one
|
||||||
|
+// function, each with a different (non-overlapping) range and each with
|
||||||
|
+// different compact unwind encodings that correspond to the non-volatiles
|
||||||
|
+// saved at that range of the function.
|
||||||
|
+//
|
||||||
|
+// If a particular function is so wacky that there is no compact unwind way
|
||||||
|
+// to encode it, then the compiler can emit traditional DWARF unwind info.
|
||||||
|
+// The runtime will use which ever is available.
|
||||||
|
+//
|
||||||
|
+// Runtime support for compact unwind encodings are only available on 10.6
|
||||||
|
+// and later. So, the compiler should not generate it when targeting pre-10.6.
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+////////////////////////////////////////////////////////////////////////////////
|
||||||
|
+//
|
||||||
|
+// Final Linked Images: __TEXT,__unwind_info
|
||||||
|
+//
|
||||||
|
+////////////////////////////////////////////////////////////////////////////////
|
||||||
|
+
|
||||||
|
+//
|
||||||
|
+// The __TEXT,__unwind_info section is laid out for an efficient two level lookup.
|
||||||
|
+// The header of the section contains a coarse index that maps function address
|
||||||
|
+// to the page (4096 byte block) containing the unwind info for that function.
|
||||||
|
+//
|
||||||
|
+
|
||||||
|
+#define UNWIND_SECTION_VERSION 1
|
||||||
|
+struct unwind_info_section_header
|
||||||
|
+{
|
||||||
|
+ uint32_t version; // UNWIND_SECTION_VERSION
|
||||||
|
+ uint32_t commonEncodingsArraySectionOffset;
|
||||||
|
+ uint32_t commonEncodingsArrayCount;
|
||||||
|
+ uint32_t personalityArraySectionOffset;
|
||||||
|
+ uint32_t personalityArrayCount;
|
||||||
|
+ uint32_t indexSectionOffset;
|
||||||
|
+ uint32_t indexCount;
|
||||||
|
+ // compact_unwind_encoding_t[]
|
||||||
|
+ // uint32_t personalities[]
|
||||||
|
+ // unwind_info_section_header_index_entry[]
|
||||||
|
+ // unwind_info_section_header_lsda_index_entry[]
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+struct unwind_info_section_header_index_entry
|
||||||
|
+{
|
||||||
|
+ uint32_t functionOffset;
|
||||||
|
+ uint32_t secondLevelPagesSectionOffset; // section offset to start of regular or compress page
|
||||||
|
+ uint32_t lsdaIndexArraySectionOffset; // section offset to start of lsda_index array for this range
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+struct unwind_info_section_header_lsda_index_entry
|
||||||
|
+{
|
||||||
|
+ uint32_t functionOffset;
|
||||||
|
+ uint32_t lsdaOffset;
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+//
|
||||||
|
+// There are two kinds of second level index pages: regular and compressed.
|
||||||
|
+// A compressed page can hold up to 1021 entries, but it cannot be used
|
||||||
|
+// if too many different encoding types are used. The regular page holds
|
||||||
|
+// 511 entries.
|
||||||
|
+//
|
||||||
|
+
|
||||||
|
+struct unwind_info_regular_second_level_entry
|
||||||
|
+{
|
||||||
|
+ uint32_t functionOffset;
|
||||||
|
+ compact_unwind_encoding_t encoding;
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+#define UNWIND_SECOND_LEVEL_REGULAR 2
|
||||||
|
+struct unwind_info_regular_second_level_page_header
|
||||||
|
+{
|
||||||
|
+ uint32_t kind; // UNWIND_SECOND_LEVEL_REGULAR
|
||||||
|
+ uint16_t entryPageOffset;
|
||||||
|
+ uint16_t entryCount;
|
||||||
|
+ // entry array
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+#define UNWIND_SECOND_LEVEL_COMPRESSED 3
|
||||||
|
+struct unwind_info_compressed_second_level_page_header
|
||||||
|
+{
|
||||||
|
+ uint32_t kind; // UNWIND_SECOND_LEVEL_COMPRESSED
|
||||||
|
+ uint16_t entryPageOffset;
|
||||||
|
+ uint16_t entryCount;
|
||||||
|
+ uint16_t encodingsPageOffset;
|
||||||
|
+ uint16_t encodingsCount;
|
||||||
|
+ // 32-bit entry array
|
||||||
|
+ // encodings array
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+#define UNWIND_INFO_COMPRESSED_ENTRY_FUNC_OFFSET(entry) (entry & 0x00FFFFFF)
|
||||||
|
+#define UNWIND_INFO_COMPRESSED_ENTRY_ENCODING_INDEX(entry) ((entry >> 24) & 0xFF)
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
Binary file not shown.
BIN
SOURCES/lld-12.0.1.src.tar.xz.sig
Normal file
BIN
SOURCES/lld-12.0.1.src.tar.xz.sig
Normal file
Binary file not shown.
@ -1,7 +1,6 @@
|
|||||||
#%%global rc_ver 6
|
#%%global rc_ver 5
|
||||||
%global baserelease 1
|
|
||||||
%global lld_srcdir lld-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
%global lld_srcdir lld-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
%global maj_ver 11
|
%global maj_ver 12
|
||||||
%global min_ver 0
|
%global min_ver 0
|
||||||
%global patch_ver 1
|
%global patch_ver 1
|
||||||
|
|
||||||
@ -12,22 +11,25 @@
|
|||||||
%bcond_with ld_alternative
|
%bcond_with ld_alternative
|
||||||
|
|
||||||
Name: lld
|
Name: lld
|
||||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}
|
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
||||||
Release: %{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The LLVM Linker
|
Summary: The LLVM Linker
|
||||||
|
|
||||||
License: NCSA
|
License: NCSA
|
||||||
URL: http://llvm.org
|
URL: http://llvm.org
|
||||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{lld_srcdir}.tar.xz
|
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{lld_srcdir}.tar.xz
|
||||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{lld_srcdir}.tar.xz.sig
|
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{lld_srcdir}.tar.xz.sig
|
||||||
|
Source2: tstellar-gpg-key.asc
|
||||||
Source3: run-lit-tests
|
Source3: run-lit-tests
|
||||||
Source4: lit.lld-test.cfg.py
|
Source4: lit.lld-test.cfg.py
|
||||||
|
|
||||||
Patch0: 0001-CMake-Check-for-gtest-headers-even-if-lit.py-is-not-.patch
|
|
||||||
Patch1: 0001-Revert-lld-Initial-commit-for-new-Mach-O-backend.patch
|
|
||||||
|
|
||||||
ExcludeArch: s390x
|
ExcludeArch: s390x
|
||||||
|
|
||||||
|
Patch0: 0001-PATCH-lld-CMake-Check-for-gtest-headers-even-if-lit..patch
|
||||||
|
|
||||||
|
# Bundle libunwind header need during build for MachO support
|
||||||
|
Patch1: 0002-PATCH-lld-Import-compact_unwind_encoding.h-from-libu.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
@ -82,19 +84,17 @@ LLVM regression tests.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
|
|
||||||
%setup -q -n %{lld_srcdir}
|
%autosetup -n %{lld_srcdir} -p2
|
||||||
|
|
||||||
%patch0 -p1 -b .gtest-fix
|
|
||||||
# Remove the MachO backend since it doesn't seem to work on big-endian hosts.
|
|
||||||
%ifarch s390x
|
|
||||||
%patch1 -p2 -b .remove-MachO
|
|
||||||
%endif
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
mkdir %{_target_platform}
|
# Disable lto since it causes the COFF/libpath.test lit test to crash.
|
||||||
cd %{_target_platform}
|
%global _lto_cflags %{nil}
|
||||||
|
|
||||||
|
mkdir -p %{_vpath_builddir}
|
||||||
|
cd %{_vpath_builddir}
|
||||||
|
|
||||||
%cmake .. \
|
%cmake .. \
|
||||||
-GNinja \
|
-GNinja \
|
||||||
@ -113,10 +113,10 @@ cd %{_target_platform}
|
|||||||
-DLLVM_LIBDIR_SUFFIX=
|
-DLLVM_LIBDIR_SUFFIX=
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ninja_build
|
%cmake_build
|
||||||
|
|
||||||
# Build the unittests so we can install them.
|
# Build the unittests so we can install them.
|
||||||
%ninja_build lld-test-depends
|
%cmake_build --target lld-test-depends
|
||||||
|
|
||||||
%install
|
%install
|
||||||
|
|
||||||
@ -145,7 +145,7 @@ mv %{lit_unit_cfg} %{buildroot}%{_datadir}/lld/src/%{_arch}.Unit.site.cfg.py
|
|||||||
tar --sort=name --mtime='UTC 2020-01-01' -c test/ | gzip -n > %{buildroot}%{_datadir}/lld/src/test.tar.gz
|
tar --sort=name --mtime='UTC 2020-01-01' -c test/ | gzip -n > %{buildroot}%{_datadir}/lld/src/test.tar.gz
|
||||||
|
|
||||||
install -d %{buildroot}%{_libexecdir}/tests/lld
|
install -d %{buildroot}%{_libexecdir}/tests/lld
|
||||||
cp %{SOURCE3} %{buildroot}%{_libexecdir}/tests/lld
|
install -m 0755 %{SOURCE3} %{buildroot}%{_libexecdir}/tests/lld
|
||||||
|
|
||||||
# Install unit test binaries
|
# Install unit test binaries
|
||||||
install -d %{buildroot}%{_libdir}/lld/
|
install -d %{buildroot}%{_libdir}/lld/
|
||||||
@ -157,7 +157,10 @@ cp %{_target_platform}/%{_lib}/libgtest*so* %{buildroot}%{_libdir}/lld/
|
|||||||
|
|
||||||
# Install libraries and binaries
|
# Install libraries and binaries
|
||||||
cd %{_target_platform}
|
cd %{_target_platform}
|
||||||
%ninja_install
|
|
||||||
|
%cmake_install
|
||||||
|
# This is generated by Patch1 during build and (probably) must be removed afterward
|
||||||
|
rm %{buildroot}%{_includedir}/mach-o/compact_unwind_encoding.h
|
||||||
|
|
||||||
%if %{with ld_alternative}
|
%if %{with ld_alternative}
|
||||||
# Required when using update-alternatives:
|
# Required when using update-alternatives:
|
||||||
@ -175,9 +178,11 @@ fi
|
|||||||
|
|
||||||
%check
|
%check
|
||||||
|
|
||||||
|
cd %{_vpath_builddir}
|
||||||
|
|
||||||
# armv7lhl tests disabled because of arm issue, see https://koji.fedoraproject.org/koji/taskinfo?taskID=33660162
|
# armv7lhl tests disabled because of arm issue, see https://koji.fedoraproject.org/koji/taskinfo?taskID=33660162
|
||||||
%ifnarch %{arm}
|
%ifnarch %{arm}
|
||||||
%ninja_build -C %{_target_platform} %{?_smp_mflags} check-lld
|
%cmake_build --target check-lld
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ldconfig_scriptlets libs
|
%ldconfig_scriptlets libs
|
||||||
@ -190,6 +195,7 @@ fi
|
|||||||
%{_bindir}/lld*
|
%{_bindir}/lld*
|
||||||
%{_bindir}/ld.lld
|
%{_bindir}/ld.lld
|
||||||
%{_bindir}/ld64.lld
|
%{_bindir}/ld64.lld
|
||||||
|
%{_bindir}/ld64.lld.darwinnew
|
||||||
%{_bindir}/wasm-ld
|
%{_bindir}/wasm-ld
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
@ -209,8 +215,11 @@ fi
|
|||||||
%{_datadir}/lld/lit.lld-test.cfg.py
|
%{_datadir}/lld/lit.lld-test.cfg.py
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Sep 02 2021 Tom Stellard <tstellar@redhat.com> - 11.0.1-1
|
* Fri Jul 16 2021 sguelton@redhat.com - 12.0.1-1
|
||||||
- 11.0.1 Release
|
- 12.0.1 release
|
||||||
|
|
||||||
|
* Thu May 6 2021 sguelton@redhat.com - 12.0.0-1
|
||||||
|
- 12.0.0 release
|
||||||
|
|
||||||
* Mon Nov 09 2020 sguelton@redhat.com - 11.0.0-3
|
* Mon Nov 09 2020 sguelton@redhat.com - 11.0.0-3
|
||||||
- Exclude s390x, see rhbz#1894927
|
- Exclude s390x, see rhbz#1894927
|
||||||
|
Loading…
Reference in New Issue
Block a user