Fix CI test failure: gcc-compat-basic
This commit is contained in:
parent
221297270a
commit
6d38530d6f
39
0001-Add-back-ignored-option-no-add-needed.patch
Normal file
39
0001-Add-back-ignored-option-no-add-needed.patch
Normal file
@ -0,0 +1,39 @@
|
||||
From 6511aedea2259bd09facc410f6b30eca8dc89b3d Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Wed, 30 Mar 2022 21:26:09 -0700
|
||||
Subject: [PATCH] Add back ignored option --no-add-needed
|
||||
|
||||
This partially reverts commit 815a1207bfe121c8dcf3804a4f4638e580f63519.
|
||||
gcc 12.0.1 passes this option to the linker when compiling with -fuse-ld=lld.
|
||||
---
|
||||
lld/ELF/Options.td | 1 +
|
||||
lld/test/ELF/silent-ignore.test | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/lld/ELF/Options.td b/lld/ELF/Options.td
|
||||
index ca9fdcde791f..dedf5447d956 100644
|
||||
--- a/lld/ELF/Options.td
|
||||
+++ b/lld/ELF/Options.td
|
||||
@@ -695,6 +695,7 @@ def plugin_opt_eq : J<"plugin-opt=">;
|
||||
def: F<"detect-odr-violations">;
|
||||
def: Flag<["-"], "g">;
|
||||
def: F<"long-plt">;
|
||||
+def: F<"no-add-needed">;
|
||||
def: F<"no-copy-dt-needed-entries">;
|
||||
def: F<"no-ctors-in-init-array">;
|
||||
def: F<"no-keep-memory">;
|
||||
diff --git a/lld/test/ELF/silent-ignore.test b/lld/test/ELF/silent-ignore.test
|
||||
index 91b57434765f..2a4bf02ad95f 100644
|
||||
--- a/lld/test/ELF/silent-ignore.test
|
||||
+++ b/lld/test/ELF/silent-ignore.test
|
||||
@@ -2,6 +2,7 @@ RUN: ld.lld --version \
|
||||
RUN: -detect-odr-violations \
|
||||
RUN: -g \
|
||||
RUN: -long-plt \
|
||||
+RUN: -no-add-needed \
|
||||
RUN: -no-copy-dt-needed-entries \
|
||||
RUN: -no-ctors-in-init-array \
|
||||
RUN: -no-keep-memory \
|
||||
--
|
||||
2.27.0
|
||||
|
6
lld.spec
6
lld.spec
@ -12,7 +12,7 @@
|
||||
|
||||
Name: lld
|
||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: The LLVM Linker
|
||||
|
||||
License: NCSA
|
||||
@ -29,6 +29,7 @@ Patch0: 0001-PATCH-lld-CMake-Check-for-gtest-headers-even-if-lit..patch
|
||||
|
||||
# Bundle libunwind header need during build for MachO support
|
||||
Patch1: 0002-PATCH-lld-Import-compact_unwind_encoding.h-from-libu.patch
|
||||
Patch2: 0001-Add-back-ignored-option-no-add-needed.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -205,6 +206,9 @@ fi
|
||||
%{_datadir}/lld/lit.lld-test.cfg.py
|
||||
|
||||
%changelog
|
||||
* Thu Mar 31 2022 Tom Stellard <tstellar@redhat.com> - 14.0.0-2
|
||||
- Fix CI test failure: gcc-compat-basic
|
||||
|
||||
* Mon Feb 28 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0~rc1-1
|
||||
- Update to 14.0.0rc1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user