import UBI lld-17.0.6-1.module+el8.10.0+20808+e12784c0
This commit is contained in:
parent
902c5617fb
commit
63f37dc547
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,4 +1,2 @@
|
|||||||
SOURCES/cmake-16.0.6.src.tar.xz
|
SOURCES/lld-17.0.6.src.tar.xz
|
||||||
SOURCES/cmake-16.0.6.src.tar.xz.sig
|
SOURCES/lld-17.0.6.src.tar.xz.sig
|
||||||
SOURCES/lld-16.0.6.src.tar.xz
|
|
||||||
SOURCES/lld-16.0.6.src.tar.xz.sig
|
|
||||||
|
@ -1,4 +1,2 @@
|
|||||||
0de534cfef38697e115c3ae80634765f05e78e5b SOURCES/cmake-16.0.6.src.tar.xz
|
abe5d45ebea2b9994a5e6ed31268a2114f4fa14f SOURCES/lld-17.0.6.src.tar.xz
|
||||||
2db5c88fe9277bb0fa85f49b58e946e49ff235c2 SOURCES/cmake-16.0.6.src.tar.xz.sig
|
849136b25fe7afb56131cdb31ffb08593b6ed997 SOURCES/lld-17.0.6.src.tar.xz.sig
|
||||||
2d0fabd3ed583d1030cfe802a709292057761f87 SOURCES/lld-16.0.6.src.tar.xz
|
|
||||||
4f5ffbb0aa5f32456432e450721b2e51f35638e6 SOURCES/lld-16.0.6.src.tar.xz.sig
|
|
||||||
|
@ -1,37 +0,0 @@
|
|||||||
From 56464ba865b7df5bf3edb9be7dc3b6a0fbe21e21 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
|
|
||||||
Date: Mon, 13 Mar 2023 18:22:31 +0100
|
|
||||||
Subject: [PATCH] [lld] Use installed llvm_gtest in standalone builds
|
|
||||||
|
|
||||||
Use the installed llvm_gtest library instead of rebuilding it locally
|
|
||||||
when standalone builds are used. This change is now required
|
|
||||||
as otherwise the build fails due to duplicate llvm_gtest target.
|
|
||||||
This is based on 82169103958583d3320b3a9a1e6542e8d32ef8da in clang.
|
|
||||||
|
|
||||||
Differential Revision: https://reviews.llvm.org/D145964
|
|
||||||
---
|
|
||||||
lld/CMakeLists.txt | 8 +++-----
|
|
||||||
1 file changed, 3 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lld/CMakeLists.txt b/lld/CMakeLists.txt
|
|
||||||
index 3d6225646fe6..1e9e47393196 100644
|
|
||||||
--- a/lld/CMakeLists.txt
|
|
||||||
+++ b/lld/CMakeLists.txt
|
|
||||||
@@ -75,11 +75,9 @@ if(LLD_BUILT_STANDALONE)
|
|
||||||
set(LLVM_UTILS_PROVIDED ON)
|
|
||||||
set(LLD_TEST_DEPS FileCheck not)
|
|
||||||
endif()
|
|
||||||
- set(UNITTEST_DIR ${LLVM_THIRD_PARTY_DIR}/unittest)
|
|
||||||
- if(EXISTS ${UNITTEST_DIR}/googletest/include/gtest/gtest.h
|
|
||||||
- AND NOT EXISTS ${LLVM_LIBRARY_DIR}/${CMAKE_STATIC_LIBRARY_PREFIX}gtest${CMAKE_STATIC_LIBRARY_SUFFIX}
|
|
||||||
- AND EXISTS ${UNITTEST_DIR}/CMakeLists.txt)
|
|
||||||
- add_subdirectory(${UNITTEST_DIR} third-party/unittest)
|
|
||||||
+
|
|
||||||
+ if (NOT TARGET llvm_gtest)
|
|
||||||
+ message(FATAL_ERROR "llvm-gtest not found. Please install llvm-gtest or disable tests with -DLLVM_INCLUDE_TESTS=OFF")
|
|
||||||
endif()
|
|
||||||
else()
|
|
||||||
# Seek installed Lit.
|
|
||||||
--
|
|
||||||
2.39.2
|
|
||||||
|
|
@ -1,18 +1,17 @@
|
|||||||
From 43dfe54ce017c8d37eaec480a2f13a492bbc4203 Mon Sep 17 00:00:00 2001
|
From 9df81767571465ef1f2e7370299e21c64fe34f40 Mon Sep 17 00:00:00 2001
|
||||||
From: serge-sans-paille <sguelton@redhat.com>
|
From: serge-sans-paille <sguelton@redhat.com>
|
||||||
Date: Thu, 25 Feb 2021 14:24:14 +0100
|
Date: Thu, 25 Feb 2021 14:24:14 +0100
|
||||||
Subject: [PATCH 2/2] [PATCH][lld] Import compact_unwind_encoding.h from
|
Subject: [PATCH][lld] Import compact_unwind_encoding.h from libunwind
|
||||||
libunwind
|
|
||||||
|
|
||||||
This avoids an implicit cross package dependency
|
This avoids an implicit cross package dependency
|
||||||
---
|
---
|
||||||
lld/include/mach-o/compact_unwind_encoding.h | 477 +++++++++++++++++++++++++++
|
lld/include/mach-o/compact_unwind_encoding.h | 477 +++++++++++++++++++
|
||||||
1 file changed, 477 insertions(+)
|
1 file changed, 477 insertions(+)
|
||||||
create mode 100644 lld/include/mach-o/compact_unwind_encoding.h
|
create mode 100644 lld/include/mach-o/compact_unwind_encoding.h
|
||||||
|
|
||||||
diff --git a/lld/include/mach-o/compact_unwind_encoding.h b/lld/include/mach-o/compact_unwind_encoding.h
|
diff --git a/lld/include/mach-o/compact_unwind_encoding.h b/lld/include/mach-o/compact_unwind_encoding.h
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..5301b10
|
index 000000000000..5301b1055ef9
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/lld/include/mach-o/compact_unwind_encoding.h
|
+++ b/lld/include/mach-o/compact_unwind_encoding.h
|
||||||
@@ -0,0 +1,477 @@
|
@@ -0,0 +1,477 @@
|
||||||
@ -494,5 +493,5 @@ index 0000000..5301b10
|
|||||||
+#endif
|
+#endif
|
||||||
+
|
+
|
||||||
--
|
--
|
||||||
1.8.3.1
|
2.30.2
|
||||||
|
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
#Clear lld_tools_dir so we don't accidently pick up tools from somewhere else
|
|
||||||
config.lld_tools_dir = ""
|
|
||||||
|
|
||||||
if hasattr(config, 'have_zlib'):
|
|
||||||
# Regression tests write output to this directory, so we need to be able to specify
|
|
||||||
# a temp directory when invoking lit. e.g. lit -Dlld_obj_root=/tmp/lit
|
|
||||||
config.lld_obj_root = "%(lld_obj_root)s" % lit_config.params
|
|
||||||
lit_config.load_config(config, '%(lld_test_root)s/lit.cfg.py' % lit_config.params)
|
|
||||||
else:
|
|
||||||
# For unit tests, llvm_obj_root is used to find the unit test binaries.
|
|
||||||
config.lld_obj_root = '%(lld_unittest_bindir)s' % lit_config.params
|
|
||||||
lit_config.load_config(config, '%(lld_test_root)s/Unit/lit.cfg.py' % lit_config.params)
|
|
@ -1,67 +0,0 @@
|
|||||||
#!/bin/bash
|
|
||||||
|
|
||||||
usage() {
|
|
||||||
cat << EOF
|
|
||||||
usage: `basename $0` [OPTIONS]
|
|
||||||
--threads NUM The number of threads to use for running tests.
|
|
||||||
--multilib-arch ARCH Use this option to test 32-bit libs/binaries on
|
|
||||||
64-bit hosts.
|
|
||||||
EOF
|
|
||||||
}
|
|
||||||
|
|
||||||
threads_arg=''
|
|
||||||
|
|
||||||
while [ $# -gt 0 ]; do
|
|
||||||
case $1 in
|
|
||||||
--threads)
|
|
||||||
shift
|
|
||||||
threads_arg="--threads $1"
|
|
||||||
;;
|
|
||||||
--multilib-arch)
|
|
||||||
shift
|
|
||||||
ARCH=$1
|
|
||||||
;;
|
|
||||||
* )
|
|
||||||
echo "unknown option: $1"
|
|
||||||
echo ""
|
|
||||||
usage
|
|
||||||
exit 1
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
shift
|
|
||||||
done
|
|
||||||
|
|
||||||
if [ `whoami` = "root" ]; then
|
|
||||||
echo "error: lld tests do not support running as root."
|
|
||||||
exit 1
|
|
||||||
fi
|
|
||||||
|
|
||||||
set -xe
|
|
||||||
|
|
||||||
if [ -z "$ARCH" ]; then
|
|
||||||
ARCH=`rpm --eval '%_arch'`
|
|
||||||
fi
|
|
||||||
|
|
||||||
case $ARCH in
|
|
||||||
arm)
|
|
||||||
;&
|
|
||||||
i686)
|
|
||||||
LIB_DIR="/usr/lib/"
|
|
||||||
;;
|
|
||||||
*)
|
|
||||||
LIB_DIR="/usr/lib64/"
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
cd $(mktemp -d)
|
|
||||||
ln -s /usr/include include
|
|
||||||
tar -xzf /usr/share/lld/src/test.tar.gz
|
|
||||||
ln -s /usr/share/lld/src/$ARCH.site.cfg.py test/lit.site.cfg.py
|
|
||||||
ln -s /usr/share/lld/src/$ARCH.Unit.site.cfg.py test/Unit/lit.site.cfg.py
|
|
||||||
|
|
||||||
|
|
||||||
LD_LIBRARY_PATH=$LIB_DIR/lld:$LD_LIBRARY_PATH \
|
|
||||||
lit -v -s $threads_arg test \
|
|
||||||
-Dlld_obj_root=`pwd` \
|
|
||||||
-Dlld_test_root=`pwd`/test \
|
|
||||||
-Dlld_unittest_bindir=$LIB_DIR/lld
|
|
227
SPECS/lld.spec
227
SPECS/lld.spec
@ -1,48 +1,85 @@
|
|||||||
%bcond_without check
|
%bcond_with snapshot_build
|
||||||
|
|
||||||
#global rc_ver 4
|
%if %{with snapshot_build}
|
||||||
%global lld_srcdir lld-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
# Unlock LLVM Snapshot LUA functions
|
||||||
%global cmake_srcdir cmake-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
%{llvm_sb_verbose}
|
||||||
%global maj_ver 16
|
%{llvm_sb}
|
||||||
|
%endif
|
||||||
|
|
||||||
|
# Opt out of https://fedoraproject.org/wiki/Changes/fno-omit-frame-pointer
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=2158587
|
||||||
|
%undefine _include_frame_pointers
|
||||||
|
|
||||||
|
%bcond_without check
|
||||||
|
%bcond_with compat_build
|
||||||
|
|
||||||
|
%global maj_ver 17
|
||||||
%global min_ver 0
|
%global min_ver 0
|
||||||
%global patch_ver 6
|
%global patch_ver 6
|
||||||
|
#global rc_ver 4
|
||||||
|
|
||||||
# Don't include unittests in automatic generation of provides or requires.
|
%if %{with snapshot_build}
|
||||||
%global __provides_exclude_from ^%{_libdir}/lld/.*$
|
%undefine rc_ver
|
||||||
%global __requires_exclude ^libgtest.*$
|
%global maj_ver %{llvm_snapshot_version_major}
|
||||||
|
%global min_ver %{llvm_snapshot_version_minor}
|
||||||
|
%global patch_ver %{llvm_snapshot_version_patch}
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%global lld_version %{maj_ver}.%{min_ver}.%{patch_ver}
|
||||||
|
|
||||||
|
%global lld_srcdir lld-%{lld_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
|
|
||||||
|
%if %{with compat_build}
|
||||||
|
%global pkg_name lld%{maj_ver}
|
||||||
|
%global install_prefix %{_libdir}/llvm%{maj_ver}
|
||||||
|
%global install_includedir %{install_prefix}/include
|
||||||
|
%global install_libdir %{install_prefix}/lib
|
||||||
|
%global install_datadir %{install_prefix}/share
|
||||||
|
%else
|
||||||
|
%global pkg_name lld
|
||||||
|
%global install_prefix /usr
|
||||||
|
%global install_includedir %{_includedir}
|
||||||
|
%global install_libdir %{_libdir}
|
||||||
|
%global install_datadir %{_datadir}
|
||||||
|
%endif
|
||||||
|
|
||||||
%bcond_with ld_alternative
|
%bcond_with ld_alternative
|
||||||
%bcond_with testpkg
|
|
||||||
|
|
||||||
Name: lld
|
Name: %{pkg_name}
|
||||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
Version: %{lld_version}%{?rc_ver:~rc%{rc_ver}}%{?llvm_snapshot_version_suffix:~%{llvm_snapshot_version_suffix}}
|
||||||
Release: 1%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The LLVM Linker
|
Summary: The LLVM Linker
|
||||||
|
|
||||||
License: NCSA
|
License: NCSA
|
||||||
URL: http://llvm.org
|
URL: http://llvm.org
|
||||||
|
%if %{with snapshot_build}
|
||||||
|
Source0: %{llvm_snapshot_source_prefix}lld-%{llvm_snapshot_yyyymmdd}.src.tar.xz
|
||||||
|
%{llvm_snapshot_extra_source_tags}
|
||||||
|
%else
|
||||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{lld_srcdir}.tar.xz
|
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{lld_srcdir}.tar.xz
|
||||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{lld_srcdir}.tar.xz.sig
|
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{lld_srcdir}.tar.xz.sig
|
||||||
Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz
|
Source2: release-keys.asc
|
||||||
Source3: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz.sig
|
%endif
|
||||||
Source4: release-keys.asc
|
|
||||||
Source5: run-lit-tests
|
|
||||||
Source6: lit.lld-test.cfg.py
|
|
||||||
|
|
||||||
ExcludeArch: s390x
|
ExcludeArch: s390x
|
||||||
|
|
||||||
# Bundle libunwind header need during build for MachO support
|
# Bundle libunwind header need during build for MachO support
|
||||||
Patch1: 0002-PATCH-lld-Import-compact_unwind_encoding.h-from-libu.patch
|
Patch1: 0002-PATCH-lld-Import-compact_unwind_encoding.h-from-libu.patch
|
||||||
# Backport from LLVM 17.
|
|
||||||
Patch2: 0001-lld-Use-installed-llvm_gtest-in-standalone-builds.patch
|
|
||||||
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: ninja-build
|
BuildRequires: ninja-build
|
||||||
|
%if %{with compat_build}
|
||||||
|
BuildRequires: llvm%{maj_ver}-devel = %{version}
|
||||||
|
BuildRequires: llvm%{maj_ver}-cmake-utils = %{version}
|
||||||
|
%else
|
||||||
BuildRequires: llvm-devel = %{version}
|
BuildRequires: llvm-devel = %{version}
|
||||||
|
BuildRequires: llvm-cmake-utils = %{version}
|
||||||
BuildRequires: llvm-test = %{version}
|
BuildRequires: llvm-test = %{version}
|
||||||
|
BuildRequires: llvm-googletest = %{version}
|
||||||
|
%endif
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
@ -50,7 +87,6 @@ BuildRequires: python3-devel
|
|||||||
# For make check:
|
# For make check:
|
||||||
BuildRequires: python3-rpm-macros
|
BuildRequires: python3-rpm-macros
|
||||||
BuildRequires: python3-lit
|
BuildRequires: python3-lit
|
||||||
BuildRequires: llvm-googletest = %{version}
|
|
||||||
|
|
||||||
# For gpg source verification
|
# For gpg source verification
|
||||||
BuildRequires: gnupg2
|
BuildRequires: gnupg2
|
||||||
@ -60,17 +96,19 @@ Requires(post): %{_sbindir}/alternatives
|
|||||||
Requires(preun): %{_sbindir}/alternatives
|
Requires(preun): %{_sbindir}/alternatives
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Requires: lld-libs = %{version}-%{release}
|
Requires: %{name}-libs = %{version}-%{release}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The LLVM project linker.
|
The LLVM project linker.
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Libraries and header files for LLD
|
Summary: Libraries and header files for LLD
|
||||||
Requires: lld-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
|
%if %{without compat_build}
|
||||||
# lld tools are referenced in the cmake files, so we need to add lld as a
|
# lld tools are referenced in the cmake files, so we need to add lld as a
|
||||||
# dependency.
|
# dependency.
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
%endif
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
This package contains library and header files needed to develop new native
|
This package contains library and header files needed to develop new native
|
||||||
@ -82,107 +120,65 @@ Summary: LLD shared libraries
|
|||||||
%description libs
|
%description libs
|
||||||
Shared libraries for LLD.
|
Shared libraries for LLD.
|
||||||
|
|
||||||
%if %{with testpkg}
|
%prep
|
||||||
%package test
|
%if %{without snapshot_build}
|
||||||
Summary: LLD regression tests
|
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
|
||||||
Requires: python3-lit
|
|
||||||
Requires: llvm-test(major) = %{maj_ver}
|
|
||||||
Requires: lld-libs = %{version}-%{release}
|
|
||||||
|
|
||||||
%description test
|
|
||||||
LLVM regression tests.
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%prep
|
|
||||||
%{gpgverify} --keyring='%{SOURCE4}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
|
||||||
%{gpgverify} --keyring='%{SOURCE4}' --signature='%{SOURCE3}' --data='%{SOURCE2}'
|
|
||||||
%setup -T -q -b 2 -n %{cmake_srcdir}
|
|
||||||
# TODO: It would be more elegant to set -DLLVM_COMMON_CMAKE_UTILS=%{_builddir}/%{cmake_srcdir},
|
|
||||||
# but this is not a CACHED variable, so we can't actually set it externally :(
|
|
||||||
cd ..
|
|
||||||
mv %{cmake_srcdir} cmake
|
|
||||||
%autosetup -n %{lld_srcdir} -p2
|
%autosetup -n %{lld_srcdir} -p2
|
||||||
|
|
||||||
|
%if %{with compat_build}
|
||||||
|
# For compat builds, we don't want to build the actual lld binary. While there is an
|
||||||
|
# LLD_BUILD_TOOLS cmake option, it is incomplete in various ways (e.g. still leaves install
|
||||||
|
# targets and symlinks), so instead skip the tools/lld build entirely.
|
||||||
|
# We can't simply delete the binaries after the fact, because this would leave checks for
|
||||||
|
# their existence in the cmake exports.
|
||||||
|
sed 's/add_subdirectory(tools\/lld)//' -i CMakeLists.txt
|
||||||
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
# Disable lto since it causes the COFF/libpath.test lit test to crash.
|
%undefine __cmake_in_source_build
|
||||||
%global _lto_cflags %{nil}
|
|
||||||
|
|
||||||
mkdir -p %{_vpath_builddir}
|
%cmake \
|
||||||
cd %{_vpath_builddir}
|
|
||||||
|
|
||||||
%cmake .. \
|
|
||||||
-GNinja \
|
-GNinja \
|
||||||
|
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||||
|
-DCMAKE_INSTALL_PREFIX=%{install_prefix} \
|
||||||
-DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
|
-DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
|
||||||
-DLLVM_DYLIB_COMPONENTS="all" \
|
-DLLVM_DYLIB_COMPONENTS="all" \
|
||||||
|
-DLLVM_COMMON_CMAKE_UTILS=%{install_datadir}/llvm/cmake \
|
||||||
-DCMAKE_SKIP_RPATH:BOOL=ON \
|
-DCMAKE_SKIP_RPATH:BOOL=ON \
|
||||||
-DPYTHON_EXECUTABLE=%{__python3} \
|
-DPYTHON_EXECUTABLE=%{__python3} \
|
||||||
|
%if %{with compat_build}
|
||||||
|
-DLLVM_CMAKE_DIR=%{install_libdir}/cmake/llvm \
|
||||||
|
-DLLVM_INCLUDE_TESTS=OFF \
|
||||||
|
%else
|
||||||
-DLLVM_INCLUDE_TESTS=ON \
|
-DLLVM_INCLUDE_TESTS=ON \
|
||||||
-DLLVM_MAIN_SRC_DIR=%{_datadir}/llvm/src \
|
|
||||||
-DLLVM_EXTERNAL_LIT=%{_bindir}/lit \
|
-DLLVM_EXTERNAL_LIT=%{_bindir}/lit \
|
||||||
-DLLVM_LIT_ARGS="-sv \
|
-DLLVM_LIT_ARGS="-sv \
|
||||||
--path %{_libdir}/llvm" \
|
--path %{_libdir}/llvm" \
|
||||||
%if 0%{?__isa_bits} == 64
|
%if %{with snapshot_build}
|
||||||
-DLLVM_LIBDIR_SUFFIX=64
|
-DLLVM_VERSION_SUFFIX="%{llvm_snapshot_version_suffix}" \
|
||||||
%else
|
|
||||||
-DLLVM_LIBDIR_SUFFIX=
|
|
||||||
%endif
|
%endif
|
||||||
|
%if 0%{?__isa_bits} == 64
|
||||||
|
-DLLVM_LIBDIR_SUFFIX=64 \
|
||||||
|
%else
|
||||||
|
-DLLVM_LIBDIR_SUFFIX= \
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
|
-DLLVM_MAIN_SRC_DIR=%{_datadir}/llvm/src
|
||||||
|
|
||||||
%cmake_build
|
%cmake_build
|
||||||
|
|
||||||
%if %{with testpkg}
|
|
||||||
# Build the unittests so we can install them.
|
|
||||||
%cmake_build --target lld-test-depends
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%if %{with testpkg}
|
|
||||||
%global lit_cfg test/%{_arch}.site.cfg.py
|
|
||||||
%global lit_unit_cfg test/Unit/%{_arch}.site.cfg.py
|
|
||||||
%global lit_lld_test_cfg_install_path %{_datadir}/lld/lit.lld-test.cfg.py
|
|
||||||
|
|
||||||
# Generate lit config files. Strip off the last line that initiates the
|
|
||||||
# test run, so we can customize the configuration.
|
|
||||||
head -n -1 %{__cmake_builddir}/test/lit.site.cfg.py >> %{lit_cfg}
|
|
||||||
head -n -1 %{__cmake_builddir}/test/Unit/lit.site.cfg.py >> %{lit_unit_cfg}
|
|
||||||
|
|
||||||
# Patch lit config files to load custom config:
|
|
||||||
for f in %{lit_cfg} %{lit_unit_cfg}; do
|
|
||||||
echo "lit_config.load_config(config, '%{lit_lld_test_cfg_install_path}')" >> $f
|
|
||||||
done
|
|
||||||
|
|
||||||
# Install test files
|
|
||||||
install -d %{buildroot}%{_datadir}/lld/src
|
|
||||||
cp %{SOURCE4} %{buildroot}%{_datadir}/lld/
|
|
||||||
|
|
||||||
# The various tar options are there to make sur the archive is the same on 32 and 64 bit arch, i.e.
|
|
||||||
# the archive creation is reproducible. Move arch-specific content out of the tarball
|
|
||||||
mv %{lit_cfg} %{buildroot}%{_datadir}/lld/src/%{_arch}.site.cfg.py
|
|
||||||
mv %{lit_unit_cfg} %{buildroot}%{_datadir}/lld/src/%{_arch}.Unit.site.cfg.py
|
|
||||||
tar --sort=name --mtime='UTC 2020-01-01' -c test/ | gzip -n > %{buildroot}%{_datadir}/lld/src/test.tar.gz
|
|
||||||
|
|
||||||
install -d %{buildroot}%{_libexecdir}/tests/lld
|
|
||||||
install -m 0755 %{SOURCE3} %{buildroot}%{_libexecdir}/tests/lld
|
|
||||||
|
|
||||||
# Install unit test binaries
|
|
||||||
install -d %{buildroot}%{_libdir}/lld/
|
|
||||||
|
|
||||||
rm -rf `find %{buildroot}%{_libdir}/lld/ -iname '*make*'`
|
|
||||||
|
|
||||||
# Install gtest libraries
|
|
||||||
cp %{__cmake_builddir}/%{_lib}/libgtest*so* %{buildroot}%{_libdir}/lld/
|
|
||||||
%endif
|
|
||||||
|
|
||||||
# Install libraries and binaries
|
# Install libraries and binaries
|
||||||
pushd %{_vpath_builddir}
|
|
||||||
%cmake_install
|
%cmake_install
|
||||||
popd
|
|
||||||
|
|
||||||
|
|
||||||
# This is generated by Patch1 during build and (probably) must be removed afterward
|
# This is generated by Patch1 during build and (probably) must be removed afterward
|
||||||
rm %{buildroot}%{_includedir}/mach-o/compact_unwind_encoding.h
|
rm %{buildroot}%{install_includedir}/mach-o/compact_unwind_encoding.h
|
||||||
|
|
||||||
|
install -D -m 644 -t %{buildroot}%{_mandir}/man1/ docs/ld.lld.1
|
||||||
|
|
||||||
%if %{with ld_alternative}
|
%if %{with ld_alternative}
|
||||||
# Required when using update-alternatives:
|
# Required when using update-alternatives:
|
||||||
@ -199,17 +195,16 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%check
|
%check
|
||||||
cd %{_vpath_builddir}
|
|
||||||
|
|
||||||
# armv7lhl tests disabled because of arm issue, see https://koji.fedoraproject.org/koji/taskinfo?taskID=33660162
|
%if %{without compat_build}
|
||||||
%ifnarch %{arm}
|
|
||||||
%if %{with check}
|
%if %{with check}
|
||||||
%cmake_build --target check-lld
|
%cmake_build --target check-lld
|
||||||
%endif
|
%endif
|
||||||
%endif
|
|
||||||
|
|
||||||
%ldconfig_scriptlets libs
|
%ldconfig_scriptlets libs
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%if %{without compat_build}
|
||||||
%files
|
%files
|
||||||
%license LICENSE.TXT
|
%license LICENSE.TXT
|
||||||
%if %{with ld_alternative}
|
%if %{with ld_alternative}
|
||||||
@ -219,26 +214,24 @@ cd %{_vpath_builddir}
|
|||||||
%{_bindir}/ld.lld
|
%{_bindir}/ld.lld
|
||||||
%{_bindir}/ld64.lld
|
%{_bindir}/ld64.lld
|
||||||
%{_bindir}/wasm-ld
|
%{_bindir}/wasm-ld
|
||||||
|
%{_mandir}/man1/ld.lld.1*
|
||||||
%files devel
|
|
||||||
%{_includedir}/lld
|
|
||||||
%{_libdir}/liblld*.so
|
|
||||||
%{_libdir}/cmake/lld/
|
|
||||||
|
|
||||||
%files libs
|
|
||||||
%{_libdir}/liblld*.so.*
|
|
||||||
|
|
||||||
%if %{with testpkg}
|
|
||||||
%files test
|
|
||||||
%{_libexecdir}/tests/lld/
|
|
||||||
%{_libdir}/lld/
|
|
||||||
%{_datadir}/lld/src/test.tar.gz
|
|
||||||
%{_datadir}/lld/src/%{_arch}.site.cfg.py
|
|
||||||
%{_datadir}/lld/src/%{_arch}.Unit.site.cfg.py
|
|
||||||
%{_datadir}/lld/lit.lld-test.cfg.py
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{install_includedir}/lld
|
||||||
|
%{install_libdir}/liblld*.so
|
||||||
|
%{install_libdir}/cmake/lld/
|
||||||
|
|
||||||
|
%files libs
|
||||||
|
%{install_libdir}/liblld*.so.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 29 2023 Nikita Popov <npopov@redhat.com> - 17.0.6-1
|
||||||
|
- Update to LLVM 17.0.6
|
||||||
|
|
||||||
|
* Wed Oct 04 2023 Nikita Popov <npopov@redhat.com> - 17.0.2-1
|
||||||
|
- Update to LLVM 17.0.2
|
||||||
|
|
||||||
* Fri Jun 30 2023 Tom Stellard <tstellar@redhat.com> - 16.0.6-1
|
* Fri Jun 30 2023 Tom Stellard <tstellar@redhat.com> - 16.0.6-1
|
||||||
- 16.0.6 Release
|
- 16.0.6 Release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user