Update to LLVM 16.0.6
This commit is contained in:
parent
d6dd4e5bc9
commit
55c2266027
30
0001-lld-Pass-random.randint-stop-parameter-as-int.patch
Normal file
30
0001-lld-Pass-random.randint-stop-parameter-as-int.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From 015c43178f9d8531b6bcd1685dbf72b7d837cf5a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jacek Caban <jacek@codeweavers.com>
|
||||||
|
Date: Fri, 10 Mar 2023 21:54:14 -0500
|
||||||
|
Subject: [PATCH] [lld] Pass random.randint stop parameter as int.
|
||||||
|
|
||||||
|
It's required by Python 3.12, from https://docs.python.org/3.12/library/random.html "Changed in version 3.12: Automatic conversion of non-integer types is no longer supported."
|
||||||
|
|
||||||
|
Reviewed By: #lld-macho, int3
|
||||||
|
|
||||||
|
Differential Revision: https://reviews.llvm.org/D145826
|
||||||
|
---
|
||||||
|
lld/test/MachO/tools/generate-cfi-funcs.py | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/lld/test/MachO/tools/generate-cfi-funcs.py b/lld/test/MachO/tools/generate-cfi-funcs.py
|
||||||
|
index 3f22008349f4..e2b75d0cd9a5 100755
|
||||||
|
--- a/lld/test/MachO/tools/generate-cfi-funcs.py
|
||||||
|
+++ b/lld/test/MachO/tools/generate-cfi-funcs.py
|
||||||
|
@@ -23,7 +23,7 @@ def print_function(name):
|
||||||
|
global lsda_odds
|
||||||
|
have_lsda = (random.random() < lsda_odds)
|
||||||
|
frame_size = random.randint(4, 64) * 16
|
||||||
|
- frame_offset = -random.randint(0, (frame_size/16 - 4)) * 16
|
||||||
|
+ frame_offset = -random.randint(0, int(frame_size/16 - 4)) * 16
|
||||||
|
global func_size_low, func_size_high
|
||||||
|
func_size = random.randint(func_size_low, func_size_high) * 0x10
|
||||||
|
func_size_high += 1
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
14
lld.spec
14
lld.spec
@ -11,7 +11,7 @@
|
|||||||
%global lld_srcdir lld-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
%global lld_srcdir lld-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
%global maj_ver 16
|
%global maj_ver 16
|
||||||
%global min_ver 0
|
%global min_ver 0
|
||||||
%global patch_ver 5
|
%global patch_ver 6
|
||||||
|
|
||||||
%if %{with compat_build}
|
%if %{with compat_build}
|
||||||
%global pkg_name lld%{maj_ver}
|
%global pkg_name lld%{maj_ver}
|
||||||
@ -29,7 +29,7 @@
|
|||||||
|
|
||||||
Name: %{pkg_name}
|
Name: %{pkg_name}
|
||||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The LLVM Linker
|
Summary: The LLVM Linker
|
||||||
|
|
||||||
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
||||||
@ -40,11 +40,14 @@ Source2: release-keys.asc
|
|||||||
|
|
||||||
ExcludeArch: s390x
|
ExcludeArch: s390x
|
||||||
|
|
||||||
|
# Bundle libunwind header need during build for MachO support
|
||||||
|
Patch1: 0002-PATCH-lld-Import-compact_unwind_encoding.h-from-libu.patch
|
||||||
|
|
||||||
# Backport from LLVM 17.
|
# Backport from LLVM 17.
|
||||||
Patch2: 0001-lld-Use-installed-llvm_gtest-in-standalone-builds.patch
|
Patch2: 0001-lld-Use-installed-llvm_gtest-in-standalone-builds.patch
|
||||||
|
|
||||||
# Bundle libunwind header need during build for MachO support
|
# Backport from LLVM 17.
|
||||||
Patch1: 0002-PATCH-lld-Import-compact_unwind_encoding.h-from-libu.patch
|
Patch3: 0001-lld-Pass-random.randint-stop-parameter-as-int.patch
|
||||||
|
|
||||||
BuildRequires: clang
|
BuildRequires: clang
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
@ -191,6 +194,9 @@ fi
|
|||||||
%{install_libdir}/liblld*.so.*
|
%{install_libdir}/liblld*.so.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 10 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 16.0.6-1
|
||||||
|
- Update to LLVM 16.0.6
|
||||||
|
|
||||||
* Tue Jun 13 2023 Nikita Popov <npopov@redhat.com> - 16.0.5-2
|
* Tue Jun 13 2023 Nikita Popov <npopov@redhat.com> - 16.0.5-2
|
||||||
- Use llvm-cmake-utils package
|
- Use llvm-cmake-utils package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user