13.0.0-rc1 Release
This commit is contained in:
parent
91100a1f44
commit
2cb02d9e03
2
.gitignore
vendored
2
.gitignore
vendored
@ -77,3 +77,5 @@
|
||||
/lld-12.0.1rc3.src.tar.xz.sig
|
||||
/lld-12.0.1.src.tar.xz
|
||||
/lld-12.0.1.src.tar.xz.sig
|
||||
/lld-13.0.0rc1.src.tar.xz
|
||||
/lld-13.0.0rc1.src.tar.xz.sig
|
||||
|
@ -14,7 +14,7 @@ diff --git a/lld/CMakeLists.txt b/lld/CMakeLists.txt
|
||||
index d4e561b..a7406d1c 100644
|
||||
--- a/lld/CMakeLists.txt
|
||||
+++ b/lld/CMakeLists.txt
|
||||
@@ -65,6 +65,15 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
|
||||
@@ -68,6 +68,15 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
|
||||
set(LLVM_UTILS_PROVIDED ON)
|
||||
endif()
|
||||
|
||||
@ -30,7 +30,7 @@ index d4e561b..a7406d1c 100644
|
||||
if(EXISTS ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
|
||||
# Note: path not really used, except for checking if lit was found
|
||||
set(LLVM_LIT ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
|
||||
@@ -74,12 +83,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
|
||||
@@ -77,12 +86,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
|
||||
set(LLVM_UTILS_PROVIDED ON)
|
||||
set(LLD_TEST_DEPS FileCheck not)
|
||||
endif()
|
||||
|
20
lld.spec
20
lld.spec
@ -1,8 +1,8 @@
|
||||
#global rc_ver 3
|
||||
%global rc_ver 1
|
||||
%global lld_srcdir lld-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||
%global maj_ver 12
|
||||
%global maj_ver 13
|
||||
%global min_ver 0
|
||||
%global patch_ver 1
|
||||
%global patch_ver 0
|
||||
|
||||
# Don't include unittests in automatic generation of provides or requires.
|
||||
%global __provides_exclude_from ^%{_libdir}/lld/.*$
|
||||
@ -10,7 +10,7 @@
|
||||
|
||||
Name: lld
|
||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: The LLVM Linker
|
||||
|
||||
License: NCSA
|
||||
@ -120,8 +120,8 @@ LLVM regression tests.
|
||||
|
||||
# Generate lit config files. Strip off the last line that initiates the
|
||||
# test run, so we can customize the configuration.
|
||||
head -n -1 %{_target_platform}/test/lit.site.cfg.py >> %{lit_cfg}
|
||||
head -n -1 %{_target_platform}/test/Unit/lit.site.cfg.py >> %{lit_unit_cfg}
|
||||
head -n -1 %{__cmake_builddir}/test/lit.site.cfg.py >> %{lit_cfg}
|
||||
head -n -1 %{__cmake_builddir}/test/Unit/lit.site.cfg.py >> %{lit_unit_cfg}
|
||||
|
||||
# Patch lit config files to load custom config:
|
||||
for f in %{lit_cfg} %{lit_unit_cfg}; do
|
||||
@ -143,11 +143,11 @@ install -m 0755 %{SOURCE3} %{buildroot}%{_libexecdir}/tests/lld
|
||||
|
||||
# Install unit test binaries
|
||||
install -d %{buildroot}%{_libdir}/lld/
|
||||
cp -R %{_target_platform}/unittests %{buildroot}%{_libdir}/lld/
|
||||
cp -R %{__cmake_builddir}/unittests %{buildroot}%{_libdir}/lld/
|
||||
rm -rf `find %{buildroot}%{_libdir}/lld/ -iname '*make*'`
|
||||
|
||||
# Install gtest libraries
|
||||
cp %{_target_platform}/%{_lib}/libgtest*so* %{buildroot}%{_libdir}/lld/
|
||||
cp %{__cmake_builddir}/%{_lib}/libgtest*so* %{buildroot}%{_libdir}/lld/
|
||||
|
||||
# Install libraries and binaries
|
||||
%cmake_install
|
||||
@ -183,6 +183,7 @@ fi
|
||||
%{_bindir}/ld.lld
|
||||
%{_bindir}/ld64.lld
|
||||
%{_bindir}/ld64.lld.darwinnew
|
||||
%{_bindir}/ld64.lld.darwinold
|
||||
%{_bindir}/wasm-ld
|
||||
|
||||
%files devel
|
||||
@ -202,6 +203,9 @@ fi
|
||||
%{_datadir}/lld/lit.lld-test.cfg.py
|
||||
|
||||
%changelog
|
||||
* Fri Aug 06 2021 Tom Stellard <tstellar@redhat.com> - 13.0.0~rc1-1
|
||||
- 13.0.0-rc1 Release
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 12.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (lld-12.0.1.src.tar.xz) = 4292e45c54f61b8bf8b0a412f1423e062fb7c88ab3d143de3bccf010ea84fcf672ec432068a6adc461f605993d5c4e7e720e9b719d7bf8cbe670115f75e1fb2a
|
||||
SHA512 (lld-12.0.1.src.tar.xz.sig) = 3494fee1f706451e9e25558d9ee8c155967a7b2b725a0b8e2bd88f1020116e7d2cfc9c3fd7505494e158ac77161f457f847addea8ea13a3b7b01494eecf39d9c
|
||||
SHA512 (lld-13.0.0rc1.src.tar.xz) = 098cf60ee1edd3e7c2239276c5a71dd9a64b842eb6d7a0a280de7d4793a0fd47bbf260b51e175ebb79c7cd5ed6f647c70e8b98c917d665042325557a222b35ef
|
||||
SHA512 (lld-13.0.0rc1.src.tar.xz.sig) = 73abe9201bc606ba1e4e04bcb3c110173ff79f344f00107f89170681cff350a1d29aebe1edad324677c6ed6eaebf40632457b094d200bdffd0c2cfe643d1d406
|
||||
|
Loading…
Reference in New Issue
Block a user