9.0.0-rc3 Release
This commit is contained in:
parent
9214e08a1f
commit
1e4c7d8461
2
.gitignore
vendored
2
.gitignore
vendored
@ -17,3 +17,5 @@
|
|||||||
/lld-8.0.0rc3.src.tar.xz
|
/lld-8.0.0rc3.src.tar.xz
|
||||||
/lld-8.0.0rc4.src.tar.xz
|
/lld-8.0.0rc4.src.tar.xz
|
||||||
/lld-8.0.0.src.tar.xz
|
/lld-8.0.0.src.tar.xz
|
||||||
|
/lld-9.0.0rc2.src.tar.xz
|
||||||
|
/lld-9.0.0rc3.src.tar.xz
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
From 39ce39a20a0854380997df7912e739b6c348f8a1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tom Stellard <tstellar@redhat.com>
|
|
||||||
Date: Thu, 30 Aug 2018 14:59:06 -0700
|
|
||||||
Subject: [PATCH] [lld] Prefer using the newest installed python version rather
|
|
||||||
than 2.7
|
|
||||||
|
|
||||||
This only affects the lit tests, which seem to pass fine with python3.
|
|
||||||
---
|
|
||||||
CMakeLists.txt | 1 -
|
|
||||||
1 file changed, 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index 087377d..6e5f2a7 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -56,7 +56,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
|
|
||||||
include(HandleLLVMOptions)
|
|
||||||
|
|
||||||
if(LLVM_INCLUDE_TESTS)
|
|
||||||
- set(Python_ADDITIONAL_VERSIONS 2.7)
|
|
||||||
include(FindPythonInterp)
|
|
||||||
if(NOT PYTHONINTERP_FOUND)
|
|
||||||
message(FATAL_ERROR
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
11
lld.spec
11
lld.spec
@ -1,9 +1,10 @@
|
|||||||
#%%global rc_ver 4
|
%global rc_ver 3
|
||||||
|
%global baserelease 0.1
|
||||||
%global lld_srcdir lld-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
%global lld_srcdir lld-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
|
|
||||||
Name: lld
|
Name: lld
|
||||||
Version: 8.0.0
|
Version: 9.0.0
|
||||||
Release: 3%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
Release: %{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||||
Summary: The LLVM Linker
|
Summary: The LLVM Linker
|
||||||
|
|
||||||
License: NCSA
|
License: NCSA
|
||||||
@ -11,7 +12,6 @@ URL: http://llvm.org
|
|||||||
Source0: http://%{?rc_ver:pre}releases.llvm.org/%{version}/%{?rc_ver:rc%{rc_ver}}/%{lld_srcdir}.tar.xz
|
Source0: http://%{?rc_ver:pre}releases.llvm.org/%{version}/%{?rc_ver:rc%{rc_ver}}/%{lld_srcdir}.tar.xz
|
||||||
|
|
||||||
Patch0: 0001-CMake-Check-for-gtest-headers-even-if-lit.py-is-not-.patch
|
Patch0: 0001-CMake-Check-for-gtest-headers-even-if-lit.py-is-not-.patch
|
||||||
Patch1: 0001-lld-Prefer-using-the-newest-installed-python-version.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -115,6 +115,9 @@ make -C %{_target_platform} %{?_smp_mflags} check-lld
|
|||||||
%{_libdir}/liblld*.so.*
|
%{_libdir}/liblld*.so.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 22 2019 Tom Stellard <tstellar@redhat.com> - 9.0.0-0.1.rc3
|
||||||
|
- 9.0.0-rc3 Release
|
||||||
|
|
||||||
* Tue Aug 20 2019 Tom Stellard <tstellar@redhat.com> - 8.0.0-3
|
* Tue Aug 20 2019 Tom Stellard <tstellar@redhat.com> - 8.0.0-3
|
||||||
- touch /usr/bin/ld as required by the packaging guidelines for
|
- touch /usr/bin/ld as required by the packaging guidelines for
|
||||||
update-alternatives
|
update-alternatives
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (lld-8.0.0.src.tar.xz) = 43b671546f26a2293c27496584fcae43a99caabfffdbc7f72e06689e489005215b9a8607a4dc66a5469b3139d362486a46d1fbbdc2c657195fd3d3f1a72d2fa0
|
SHA512 (lld-9.0.0rc3.src.tar.xz) = e55d1c863b69193bb6d984b875998867fbc5b34c7f690d690a8f9c6c6d61bfbb2f15195aa55e77c46f48034da0b11e8da5ab5bf5276b7d92f0927b26f75679a0
|
||||||
|
Loading…
Reference in New Issue
Block a user