Update to LLVM 17.0.2
Resolves: RHEL-9028
This commit is contained in:
parent
ced177c2db
commit
084cb83be2
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,7 +1,6 @@
|
||||
SOURCES/lld-15.0.7.src.tar.xz
|
||||
SOURCES/release-keys.asc
|
||||
/lld-15.0.7.src.tar.xz
|
||||
/release-keys.asc
|
||||
/lld-16.0.0.src.tar.xz
|
||||
/lld-16.0.0.src.tar.xz.sig
|
||||
/cmake-16.0.0.src.tar.xz
|
||||
@ -10,3 +9,5 @@ SOURCES/release-keys.asc
|
||||
/lld-16.0.6.src.tar.xz.sig
|
||||
/cmake-16.0.6.src.tar.xz
|
||||
/cmake-16.0.6.src.tar.xz.sig
|
||||
/lld-17.0.2.src.tar.xz
|
||||
/lld-17.0.2.src.tar.xz.sig
|
||||
|
@ -1,49 +0,0 @@
|
||||
From 760568cd24acd6ae9083b0dfea2c7c0ea6f0adc2 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Thu, 30 Aug 2018 08:53:56 -0700
|
||||
Subject: [PATCH 1/2] [PATCH][lld] CMake: Check for gtest headers even if
|
||||
lit.py is not present
|
||||
|
||||
This makes it possible to build the unittests even withotu a full
|
||||
checkout of the llvm source tree.
|
||||
---
|
||||
lld/CMakeLists.txt | 15 +++++++++------
|
||||
1 file changed, 9 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/lld/CMakeLists.txt b/lld/CMakeLists.txt
|
||||
index d4e561b..a7406d1c 100644
|
||||
--- a/lld/CMakeLists.txt
|
||||
+++ b/lld/CMakeLists.txt
|
||||
@@ -68,6 +68,16 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
|
||||
set(LLVM_UTILS_PROVIDED ON)
|
||||
endif()
|
||||
|
||||
+ # Check for gtest
|
||||
+ set(UNITTEST_DIR ${LLVM_MAIN_SRC_DIR}/utils/unittest)
|
||||
+ if(EXISTS ${UNITTEST_DIR}/googletest/include/gtest/gtest.h
|
||||
+ AND NOT EXISTS ${LLVM_LIBRARY_DIR}/${CMAKE_STATIC_LIBRARY_PREFIX}gtest${CMAKE_STATIC_LIBRARY_SUFFIX}
|
||||
+ AND EXISTS ${UNITTEST_DIR}/CMakeLists.txt)
|
||||
+ set(HAVE_LIBPTHREAD ON)
|
||||
+ add_subdirectory(${UNITTEST_DIR} utils/unittest)
|
||||
+ endif()
|
||||
+
|
||||
+ # Check for lit
|
||||
if(EXISTS ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
|
||||
# Note: path not really used, except for checking if lit was found
|
||||
set(LLVM_LIT ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
|
||||
@@ -77,12 +86,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
|
||||
set(LLVM_UTILS_PROVIDED ON)
|
||||
set(LLD_TEST_DEPS FileCheck not)
|
||||
endif()
|
||||
- set(UNITTEST_DIR ${LLVM_MAIN_SRC_DIR}/utils/unittest)
|
||||
- if(EXISTS ${UNITTEST_DIR}/googletest/include/gtest/gtest.h
|
||||
- AND NOT EXISTS ${LLVM_LIBRARY_DIR}/${CMAKE_STATIC_LIBRARY_PREFIX}gtest${CMAKE_STATIC_LIBRARY_SUFFIX}
|
||||
- AND EXISTS ${UNITTEST_DIR}/CMakeLists.txt)
|
||||
- add_subdirectory(${UNITTEST_DIR} utils/unittest)
|
||||
- endif()
|
||||
else()
|
||||
# Seek installed Lit.
|
||||
find_program(LLVM_LIT
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,37 +0,0 @@
|
||||
From 56464ba865b7df5bf3edb9be7dc3b6a0fbe21e21 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
|
||||
Date: Mon, 13 Mar 2023 18:22:31 +0100
|
||||
Subject: [PATCH] [lld] Use installed llvm_gtest in standalone builds
|
||||
|
||||
Use the installed llvm_gtest library instead of rebuilding it locally
|
||||
when standalone builds are used. This change is now required
|
||||
as otherwise the build fails due to duplicate llvm_gtest target.
|
||||
This is based on 82169103958583d3320b3a9a1e6542e8d32ef8da in clang.
|
||||
|
||||
Differential Revision: https://reviews.llvm.org/D145964
|
||||
---
|
||||
lld/CMakeLists.txt | 8 +++-----
|
||||
1 file changed, 3 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/lld/CMakeLists.txt b/lld/CMakeLists.txt
|
||||
index 3d6225646fe6..1e9e47393196 100644
|
||||
--- a/lld/CMakeLists.txt
|
||||
+++ b/lld/CMakeLists.txt
|
||||
@@ -75,11 +75,9 @@ if(LLD_BUILT_STANDALONE)
|
||||
set(LLVM_UTILS_PROVIDED ON)
|
||||
set(LLD_TEST_DEPS FileCheck not)
|
||||
endif()
|
||||
- set(UNITTEST_DIR ${LLVM_THIRD_PARTY_DIR}/unittest)
|
||||
- if(EXISTS ${UNITTEST_DIR}/googletest/include/gtest/gtest.h
|
||||
- AND NOT EXISTS ${LLVM_LIBRARY_DIR}/${CMAKE_STATIC_LIBRARY_PREFIX}gtest${CMAKE_STATIC_LIBRARY_SUFFIX}
|
||||
- AND EXISTS ${UNITTEST_DIR}/CMakeLists.txt)
|
||||
- add_subdirectory(${UNITTEST_DIR} third-party/unittest)
|
||||
+
|
||||
+ if (NOT TARGET llvm_gtest)
|
||||
+ message(FATAL_ERROR "llvm-gtest not found. Please install llvm-gtest or disable tests with -DLLVM_INCLUDE_TESTS=OFF")
|
||||
endif()
|
||||
else()
|
||||
# Seek installed Lit.
|
||||
--
|
||||
2.39.2
|
||||
|
@ -1,18 +1,17 @@
|
||||
From 43dfe54ce017c8d37eaec480a2f13a492bbc4203 Mon Sep 17 00:00:00 2001
|
||||
From 9df81767571465ef1f2e7370299e21c64fe34f40 Mon Sep 17 00:00:00 2001
|
||||
From: serge-sans-paille <sguelton@redhat.com>
|
||||
Date: Thu, 25 Feb 2021 14:24:14 +0100
|
||||
Subject: [PATCH 2/2] [PATCH][lld] Import compact_unwind_encoding.h from
|
||||
libunwind
|
||||
Subject: [PATCH][lld] Import compact_unwind_encoding.h from libunwind
|
||||
|
||||
This avoids an implicit cross package dependency
|
||||
---
|
||||
lld/include/mach-o/compact_unwind_encoding.h | 477 +++++++++++++++++++++++++++
|
||||
lld/include/mach-o/compact_unwind_encoding.h | 477 +++++++++++++++++++
|
||||
1 file changed, 477 insertions(+)
|
||||
create mode 100644 lld/include/mach-o/compact_unwind_encoding.h
|
||||
|
||||
diff --git a/lld/include/mach-o/compact_unwind_encoding.h b/lld/include/mach-o/compact_unwind_encoding.h
|
||||
new file mode 100644
|
||||
index 0000000..5301b10
|
||||
index 000000000000..5301b1055ef9
|
||||
--- /dev/null
|
||||
+++ b/lld/include/mach-o/compact_unwind_encoding.h
|
||||
@@ -0,0 +1,477 @@
|
||||
@ -494,5 +493,5 @@ index 0000000..5301b10
|
||||
+#endif
|
||||
+
|
||||
--
|
||||
1.8.3.1
|
||||
2.30.2
|
||||
|
||||
|
@ -1,22 +0,0 @@
|
||||
diff -ruN lld-14.0.0.src.orig/ELF/Options.td lld-14.0.0.src/ELF/Options.td
|
||||
--- a/lld-14.0.0.src.orig/ELF/Options.td 2022-03-14 10:44:55.000000000 +0100
|
||||
+++ b/lld-14.0.0.src/ELF/Options.td 2022-05-05 13:27:06.029896421 +0200
|
||||
@@ -695,6 +695,7 @@
|
||||
def: F<"detect-odr-violations">;
|
||||
def: Flag<["-"], "g">;
|
||||
def: F<"long-plt">;
|
||||
+def: FF<"no-add-needed">;
|
||||
def: F<"no-copy-dt-needed-entries">;
|
||||
def: F<"no-ctors-in-init-array">;
|
||||
def: F<"no-keep-memory">;
|
||||
diff -ruN lld-14.0.0.src.orig/test/ELF/silent-ignore.test lld-14.0.0.src/test/ELF/silent-ignore.test
|
||||
--- a/lld-14.0.0.src.orig/test/ELF/silent-ignore.test 2022-03-14 10:44:55.000000000 +0100
|
||||
+++ b/lld-14.0.0.src/test/ELF/silent-ignore.test 2022-05-05 13:27:29.734085587 +0200
|
||||
@@ -2,6 +2,7 @@
|
||||
RUN: -detect-odr-violations \
|
||||
RUN: -g \
|
||||
RUN: -long-plt \
|
||||
+RUN: --no-add-needed \
|
||||
RUN: -no-copy-dt-needed-entries \
|
||||
RUN: -no-ctors-in-init-array \
|
||||
RUN: -no-keep-memory \
|
224
lld.spec
224
lld.spec
@ -1,48 +1,85 @@
|
||||
%bcond_with snapshot_build
|
||||
|
||||
%if %{with snapshot_build}
|
||||
# Unlock LLVM Snapshot LUA functions
|
||||
%{llvm_sb_verbose}
|
||||
%{llvm_sb}
|
||||
%endif
|
||||
|
||||
# Opt out of https://fedoraproject.org/wiki/Changes/fno-omit-frame-pointer
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2158587
|
||||
%undefine _include_frame_pointers
|
||||
|
||||
%bcond_without check
|
||||
%bcond_with compat_build
|
||||
|
||||
#global rc_ver 4
|
||||
%global lld_srcdir lld-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||
%global cmake_srcdir cmake-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||
%global maj_ver 16
|
||||
%global maj_ver 17
|
||||
%global min_ver 0
|
||||
%global patch_ver 6
|
||||
%global patch_ver 2
|
||||
#global rc_ver 4
|
||||
|
||||
# Don't include unittests in automatic generation of provides or requires.
|
||||
%global __provides_exclude_from ^%{_libdir}/lld/.*$
|
||||
%global __requires_exclude ^libgtest.*$
|
||||
%if %{with snapshot_build}
|
||||
%undefine rc_ver
|
||||
%global maj_ver %{llvm_snapshot_version_major}
|
||||
%global min_ver %{llvm_snapshot_version_minor}
|
||||
%global patch_ver %{llvm_snapshot_version_patch}
|
||||
%endif
|
||||
|
||||
%global lld_version %{maj_ver}.%{min_ver}.%{patch_ver}
|
||||
|
||||
%global lld_srcdir lld-%{lld_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
%if %{with compat_build}
|
||||
%global pkg_name lld%{maj_ver}
|
||||
%global install_prefix %{_libdir}/llvm%{maj_ver}
|
||||
%global install_includedir %{install_prefix}/include
|
||||
%global install_libdir %{install_prefix}/lib
|
||||
%global install_datadir %{install_prefix}/share
|
||||
%else
|
||||
%global pkg_name lld
|
||||
%global install_prefix /usr
|
||||
%global install_includedir %{_includedir}
|
||||
%global install_libdir %{_libdir}
|
||||
%global install_datadir %{_datadir}
|
||||
%endif
|
||||
|
||||
%bcond_with ld_alternative
|
||||
%bcond_with testpkg
|
||||
|
||||
Name: lld
|
||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
||||
Release: 1%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||
Name: %{pkg_name}
|
||||
Version: %{lld_version}%{?rc_ver:~rc%{rc_ver}}%{?llvm_snapshot_version_suffix:~%{llvm_snapshot_version_suffix}}
|
||||
Release: 1%{?dist}
|
||||
Summary: The LLVM Linker
|
||||
|
||||
License: NCSA
|
||||
URL: http://llvm.org
|
||||
%if %{with snapshot_build}
|
||||
Source0: %{llvm_snapshot_source_prefix}lld-%{llvm_snapshot_yyyymmdd}.src.tar.xz
|
||||
%{llvm_snapshot_extra_source_tags}
|
||||
%else
|
||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{lld_srcdir}.tar.xz
|
||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{lld_srcdir}.tar.xz.sig
|
||||
Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz
|
||||
Source3: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz.sig
|
||||
Source4: release-keys.asc
|
||||
Source5: run-lit-tests
|
||||
Source6: lit.lld-test.cfg.py
|
||||
Source2: release-keys.asc
|
||||
%endif
|
||||
|
||||
ExcludeArch: s390x
|
||||
|
||||
# Bundle libunwind header need during build for MachO support
|
||||
Patch1: 0002-PATCH-lld-Import-compact_unwind_encoding.h-from-libu.patch
|
||||
# Backport from LLVM 17.
|
||||
Patch2: 0001-lld-Use-installed-llvm_gtest-in-standalone-builds.patch
|
||||
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: cmake
|
||||
BuildRequires: ninja-build
|
||||
%if %{with compat_build}
|
||||
BuildRequires: llvm%{maj_ver}-devel = %{version}
|
||||
BuildRequires: llvm%{maj_ver}-cmake-utils = %{version}
|
||||
%else
|
||||
BuildRequires: llvm-devel = %{version}
|
||||
BuildRequires: llvm-cmake-utils = %{version}
|
||||
BuildRequires: llvm-test = %{version}
|
||||
BuildRequires: llvm-googletest = %{version}
|
||||
%endif
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: python3-devel
|
||||
@ -50,7 +87,6 @@ BuildRequires: python3-devel
|
||||
# For make check:
|
||||
BuildRequires: python3-rpm-macros
|
||||
BuildRequires: python3-lit
|
||||
BuildRequires: llvm-googletest = %{version}
|
||||
|
||||
# For gpg source verification
|
||||
BuildRequires: gnupg2
|
||||
@ -60,17 +96,19 @@ Requires(post): %{_sbindir}/alternatives
|
||||
Requires(preun): %{_sbindir}/alternatives
|
||||
%endif
|
||||
|
||||
Requires: lld-libs = %{version}-%{release}
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
|
||||
%description
|
||||
The LLVM project linker.
|
||||
|
||||
%package devel
|
||||
Summary: Libraries and header files for LLD
|
||||
Requires: lld-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
%if %{without compat_build}
|
||||
# lld tools are referenced in the cmake files, so we need to add lld as a
|
||||
# dependency.
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
%endif
|
||||
|
||||
%description devel
|
||||
This package contains library and header files needed to develop new native
|
||||
@ -82,107 +120,65 @@ Summary: LLD shared libraries
|
||||
%description libs
|
||||
Shared libraries for LLD.
|
||||
|
||||
%if %{with testpkg}
|
||||
%package test
|
||||
Summary: LLD regression tests
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: python3-lit
|
||||
Requires: llvm-test(major) = %{maj_ver}
|
||||
Requires: lld-libs = %{version}-%{release}
|
||||
|
||||
%description test
|
||||
LLVM regression tests.
|
||||
%prep
|
||||
%if %{without snapshot_build}
|
||||
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%{gpgverify} --keyring='%{SOURCE4}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||
%{gpgverify} --keyring='%{SOURCE4}' --signature='%{SOURCE3}' --data='%{SOURCE2}'
|
||||
%setup -T -q -b 2 -n %{cmake_srcdir}
|
||||
# TODO: It would be more elegant to set -DLLVM_COMMON_CMAKE_UTILS=%{_builddir}/%{cmake_srcdir},
|
||||
# but this is not a CACHED variable, so we can't actually set it externally :(
|
||||
cd ..
|
||||
mv %{cmake_srcdir} cmake
|
||||
%autosetup -n %{lld_srcdir} -p2
|
||||
|
||||
%if %{with compat_build}
|
||||
# For compat builds, we don't want to build the actual lld binary. While there is an
|
||||
# LLD_BUILD_TOOLS cmake option, it is incomplete in various ways (e.g. still leaves install
|
||||
# targets and symlinks), so instead skip the tools/lld build entirely.
|
||||
# We can't simply delete the binaries after the fact, because this would leave checks for
|
||||
# their existence in the cmake exports.
|
||||
sed 's/add_subdirectory(tools\/lld)//' -i CMakeLists.txt
|
||||
%endif
|
||||
|
||||
%build
|
||||
|
||||
# Disable lto since it causes the COFF/libpath.test lit test to crash.
|
||||
%global _lto_cflags %{nil}
|
||||
%undefine __cmake_in_source_build
|
||||
|
||||
mkdir -p %{_vpath_builddir}
|
||||
cd %{_vpath_builddir}
|
||||
|
||||
%cmake .. \
|
||||
%cmake \
|
||||
-GNinja \
|
||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
-DCMAKE_INSTALL_PREFIX=%{install_prefix} \
|
||||
-DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
|
||||
-DLLVM_DYLIB_COMPONENTS="all" \
|
||||
-DLLVM_COMMON_CMAKE_UTILS=%{install_datadir}/llvm/cmake \
|
||||
-DCMAKE_SKIP_RPATH:BOOL=ON \
|
||||
-DPYTHON_EXECUTABLE=%{__python3} \
|
||||
%if %{with compat_build}
|
||||
-DLLVM_CMAKE_DIR=%{install_libdir}/cmake/llvm \
|
||||
-DLLVM_INCLUDE_TESTS=OFF \
|
||||
%else
|
||||
-DLLVM_INCLUDE_TESTS=ON \
|
||||
-DLLVM_MAIN_SRC_DIR=%{_datadir}/llvm/src \
|
||||
-DLLVM_EXTERNAL_LIT=%{_bindir}/lit \
|
||||
-DLLVM_LIT_ARGS="-sv \
|
||||
--path %{_libdir}/llvm" \
|
||||
%if 0%{?__isa_bits} == 64
|
||||
-DLLVM_LIBDIR_SUFFIX=64
|
||||
%else
|
||||
-DLLVM_LIBDIR_SUFFIX=
|
||||
%if %{with snapshot_build}
|
||||
-DLLVM_VERSION_SUFFIX="%{llvm_snapshot_version_suffix}" \
|
||||
%endif
|
||||
%if 0%{?__isa_bits} == 64
|
||||
-DLLVM_LIBDIR_SUFFIX=64 \
|
||||
%else
|
||||
-DLLVM_LIBDIR_SUFFIX= \
|
||||
%endif
|
||||
%endif
|
||||
-DLLVM_MAIN_SRC_DIR=%{_datadir}/llvm/src
|
||||
|
||||
%cmake_build
|
||||
|
||||
%if %{with testpkg}
|
||||
# Build the unittests so we can install them.
|
||||
%cmake_build --target lld-test-depends
|
||||
%endif
|
||||
|
||||
%install
|
||||
%if %{with testpkg}
|
||||
%global lit_cfg test/%{_arch}.site.cfg.py
|
||||
%global lit_unit_cfg test/Unit/%{_arch}.site.cfg.py
|
||||
%global lit_lld_test_cfg_install_path %{_datadir}/lld/lit.lld-test.cfg.py
|
||||
|
||||
# Generate lit config files. Strip off the last line that initiates the
|
||||
# test run, so we can customize the configuration.
|
||||
head -n -1 %{__cmake_builddir}/test/lit.site.cfg.py >> %{lit_cfg}
|
||||
head -n -1 %{__cmake_builddir}/test/Unit/lit.site.cfg.py >> %{lit_unit_cfg}
|
||||
|
||||
# Patch lit config files to load custom config:
|
||||
for f in %{lit_cfg} %{lit_unit_cfg}; do
|
||||
echo "lit_config.load_config(config, '%{lit_lld_test_cfg_install_path}')" >> $f
|
||||
done
|
||||
|
||||
# Install test files
|
||||
install -d %{buildroot}%{_datadir}/lld/src
|
||||
cp %{SOURCE4} %{buildroot}%{_datadir}/lld/
|
||||
|
||||
# The various tar options are there to make sur the archive is the same on 32 and 64 bit arch, i.e.
|
||||
# the archive creation is reproducible. Move arch-specific content out of the tarball
|
||||
mv %{lit_cfg} %{buildroot}%{_datadir}/lld/src/%{_arch}.site.cfg.py
|
||||
mv %{lit_unit_cfg} %{buildroot}%{_datadir}/lld/src/%{_arch}.Unit.site.cfg.py
|
||||
tar --sort=name --mtime='UTC 2020-01-01' -c test/ | gzip -n > %{buildroot}%{_datadir}/lld/src/test.tar.gz
|
||||
|
||||
install -d %{buildroot}%{_libexecdir}/tests/lld
|
||||
install -m 0755 %{SOURCE3} %{buildroot}%{_libexecdir}/tests/lld
|
||||
|
||||
# Install unit test binaries
|
||||
install -d %{buildroot}%{_libdir}/lld/
|
||||
|
||||
rm -rf `find %{buildroot}%{_libdir}/lld/ -iname '*make*'`
|
||||
|
||||
# Install gtest libraries
|
||||
cp %{__cmake_builddir}/%{_lib}/libgtest*so* %{buildroot}%{_libdir}/lld/
|
||||
%endif
|
||||
|
||||
# Install libraries and binaries
|
||||
pushd %{_vpath_builddir}
|
||||
%cmake_install
|
||||
popd
|
||||
|
||||
|
||||
# This is generated by Patch1 during build and (probably) must be removed afterward
|
||||
rm %{buildroot}%{_includedir}/mach-o/compact_unwind_encoding.h
|
||||
rm %{buildroot}%{install_includedir}/mach-o/compact_unwind_encoding.h
|
||||
|
||||
install -D -m 644 -t %{buildroot}%{_mandir}/man1/ docs/ld.lld.1
|
||||
|
||||
%if %{with ld_alternative}
|
||||
# Required when using update-alternatives:
|
||||
@ -199,17 +195,16 @@ fi
|
||||
%endif
|
||||
|
||||
%check
|
||||
cd %{_vpath_builddir}
|
||||
|
||||
# armv7lhl tests disabled because of arm issue, see https://koji.fedoraproject.org/koji/taskinfo?taskID=33660162
|
||||
%ifnarch %{arm}
|
||||
%if %{without compat_build}
|
||||
%if %{with check}
|
||||
%cmake_build --target check-lld
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%ldconfig_scriptlets libs
|
||||
%endif
|
||||
|
||||
%if %{without compat_build}
|
||||
%files
|
||||
%license LICENSE.TXT
|
||||
%if %{with ld_alternative}
|
||||
@ -219,26 +214,21 @@ cd %{_vpath_builddir}
|
||||
%{_bindir}/ld.lld
|
||||
%{_bindir}/ld64.lld
|
||||
%{_bindir}/wasm-ld
|
||||
|
||||
%files devel
|
||||
%{_includedir}/lld
|
||||
%{_libdir}/liblld*.so
|
||||
%{_libdir}/cmake/lld/
|
||||
|
||||
%files libs
|
||||
%{_libdir}/liblld*.so.*
|
||||
|
||||
%if %{with testpkg}
|
||||
%files test
|
||||
%{_libexecdir}/tests/lld/
|
||||
%{_libdir}/lld/
|
||||
%{_datadir}/lld/src/test.tar.gz
|
||||
%{_datadir}/lld/src/%{_arch}.site.cfg.py
|
||||
%{_datadir}/lld/src/%{_arch}.Unit.site.cfg.py
|
||||
%{_datadir}/lld/lit.lld-test.cfg.py
|
||||
%{_mandir}/man1/ld.lld.1*
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%{install_includedir}/lld
|
||||
%{install_libdir}/liblld*.so
|
||||
%{install_libdir}/cmake/lld/
|
||||
|
||||
%files libs
|
||||
%{install_libdir}/liblld*.so.*
|
||||
|
||||
%changelog
|
||||
* Wed Oct 04 2023 Nikita Popov <npopov@redhat.com> - 17.0.2-1
|
||||
- Update to LLVM 17.0.2
|
||||
|
||||
* Fri Jun 30 2023 Tom Stellard <tstellar@redhat.com> - 16.0.6-1
|
||||
- 16.0.6 Release
|
||||
|
||||
|
@ -1,67 +0,0 @@
|
||||
#!/bin/bash
|
||||
|
||||
usage() {
|
||||
cat << EOF
|
||||
usage: `basename $0` [OPTIONS]
|
||||
--threads NUM The number of threads to use for running tests.
|
||||
--multilib-arch ARCH Use this option to test 32-bit libs/binaries on
|
||||
64-bit hosts.
|
||||
EOF
|
||||
}
|
||||
|
||||
threads_arg=''
|
||||
|
||||
while [ $# -gt 0 ]; do
|
||||
case $1 in
|
||||
--threads)
|
||||
shift
|
||||
threads_arg="--threads $1"
|
||||
;;
|
||||
--multilib-arch)
|
||||
shift
|
||||
ARCH=$1
|
||||
;;
|
||||
* )
|
||||
echo "unknown option: $1"
|
||||
echo ""
|
||||
usage
|
||||
exit 1
|
||||
;;
|
||||
esac
|
||||
shift
|
||||
done
|
||||
|
||||
if [ `whoami` = "root" ]; then
|
||||
echo "error: lld tests do not support running as root."
|
||||
exit 1
|
||||
fi
|
||||
|
||||
set -xe
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
ARCH=`rpm --eval '%_arch'`
|
||||
fi
|
||||
|
||||
case $ARCH in
|
||||
arm)
|
||||
;&
|
||||
i686)
|
||||
LIB_DIR="/usr/lib/"
|
||||
;;
|
||||
*)
|
||||
LIB_DIR="/usr/lib64/"
|
||||
;;
|
||||
esac
|
||||
|
||||
cd $(mktemp -d)
|
||||
ln -s /usr/include include
|
||||
tar -xzf /usr/share/lld/src/test.tar.gz
|
||||
ln -s /usr/share/lld/src/$ARCH.site.cfg.py test/lit.site.cfg.py
|
||||
ln -s /usr/share/lld/src/$ARCH.Unit.site.cfg.py test/Unit/lit.site.cfg.py
|
||||
|
||||
|
||||
LD_LIBRARY_PATH=$LIB_DIR/lld:$LD_LIBRARY_PATH \
|
||||
lit -v -s $threads_arg test \
|
||||
-Dlld_obj_root=`pwd` \
|
||||
-Dlld_test_root=`pwd`/test \
|
||||
-Dlld_unittest_bindir=$LIB_DIR/lld
|
6
sources
6
sources
@ -1,4 +1,2 @@
|
||||
SHA512 (lld-16.0.6.src.tar.xz) = 8df248785cd77e683f3daf9cab76a4a230305b881a7a844ef644b6a55fee366d5fcca23593ca09945ba8ddae0ae119042afe3f43547c106571e98004dbc7f1e6
|
||||
SHA512 (lld-16.0.6.src.tar.xz.sig) = a9daa6804e9029b6f3acb80f1d391c557494d395dec6d49f4f5c922500b69e3bb7358c99948c74732c6ce9c560860218159bb485b18a7065b260b088cfc792c7
|
||||
SHA512 (cmake-16.0.6.src.tar.xz) = 52ecd941d2d85a5b668caa5d0d40480cb6a97b3bf1174e634c2a93e9ef6d03670ca7e96abb0a60cb33ba537b93d5788754dab1f2f45c1f623f788162717d088b
|
||||
SHA512 (cmake-16.0.6.src.tar.xz.sig) = d20c5e51315aa476775e6ce886684b9f882ce283fc40aa6c1b8f03964c77a1e745e2e1fb00b3488dddfe1a04378e2bfd090350de28e58088525a5305ecb1bea6
|
||||
SHA512 (lld-17.0.2.src.tar.xz) = d1fa30003652d5312a226001e49c109fa2b9e48ef9408da8621bc87ffaa5f84476c10f0d8a35aeef688e7d9d106ea47e8d826de130bd8a6684fc4fbaeaba481f
|
||||
SHA512 (lld-17.0.2.src.tar.xz.sig) = f9dd5bce4f0621b73dd7522d01c346d394b967bc336518694e7c3c1a30ddead81b1314ec9494028865888c8bbae4d1879a6ff400dc182a13e9ba5a5e0c07b370
|
||||
|
Binary file not shown.
Loading…
Reference in New Issue
Block a user