import linux-firmware-20230310-133.el9_2

This commit is contained in:
CentOS Sources 2023-05-09 05:37:01 +00:00 committed by Stepan Oksanichenko
parent d5c2cc1ef2
commit a13932ef58
4 changed files with 306 additions and 22 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/linux-firmware-20220708.tar.xz
SOURCES/linux-firmware-20230310.tar.xz

View File

@ -1 +1 @@
d6575be4340c209fc2b00b91b6d94a50f96f2bcd SOURCES/linux-firmware-20220708.tar.xz
517f94e0a09a19839363447a52bbb7e6925b4802 SOURCES/linux-firmware-20230310.tar.xz

View File

@ -1,4 +1,4 @@
From 7eec2b56f54c778d5bd6e7aea49ee03e3b76e769 Mon Sep 17 00:00:00 2001
From bf432ba7d9d00c0848dfe7706b42b68f3dcd9012 Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Fri, 22 Jan 2021 20:36:23 +0000
Subject: [PATCH v2] Add support for compressing firmware in copy-firmware.sh
@ -8,7 +8,6 @@ At this stage the only supported compression methis is "xz -C crc32" but
this option brings significant benefits.
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
---
v2: quote filename for xz command
@ -16,25 +15,26 @@ Conflicts:
- Replace 'mkdir -p' with 'install -d' to apply after upstream eaee2dacc2be.
Signed-off-by: Patrick Talbert <ptalbert@redhat.com>
Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
---
Makefile | 4 ++++
copy-firmware.sh | 47 +++++++++++++++++++++++++++++++----------------
2 files changed, 35 insertions(+), 16 deletions(-)
diff --git a/Makefile b/Makefile
index e1c362f..9a48471 100644
index 83a0ec6..1edf4a6 100644
--- a/Makefile
+++ b/Makefile
@@ -11,3 +11,7 @@ check:
install:
install -d $(DESTDIR)$(FIRMWAREDIR)
install -d $(DESTDIR)$(FIRMWAREDIR)
./copy-firmware.sh $(DESTDIR)$(FIRMWAREDIR)
+
+installcompress:
+ install -d $(DESTDIR)$(FIRMWAREDIR)
+ ./copy-firmware.sh -C $(DESTDIR)$(FIRMWAREDIR)
diff --git a/copy-firmware.sh b/copy-firmware.sh
index 9b46b63..0dd2e5c 100755
index bbacb92..fc419a3 100755
--- a/copy-firmware.sh
+++ b/copy-firmware.sh
@@ -6,6 +6,7 @@
@ -124,5 +124,5 @@ index 9b46b63..0dd2e5c 100755
done
--
2.29.2
2.38.1

View File

@ -1,23 +1,21 @@
%global debug_package %{nil}
%global firmware_release 127
%global firmware_release 133
%global _firmwarepath /usr/lib/firmware
%define _binaries_in_noarch_packages_terminate_build 0
Name: linux-firmware
Version: 20220708
Version: 20230310
Release: %{firmware_release}%{?dist}
Summary: Firmware files used by the Linux kernel
License: GPL+ and GPLv2+ and MIT and Redistributable, no modification permitted
URL: http://www.kernel.org/
BuildArch: noarch
# The source below was edited to remove the liquidio/lio_23xx_vsw.bin file due
# missing sources for it (GPL violation), see bug 1959913. If you get a new
# tarball from upstream, make sure you remove the file above.
Source0: https://www.kernel.org/pub/linux/kernel/firmware/%{name}-%{version}.tar.xz
Patch1: 0001-Add-support-for-compressing-firmware-in-copy-firmwar.patch
BuildRequires: git-core
BuildRequires: make
Requires: linux-firmware-whence
Provides: kernel-firmware = %{version}
@ -264,14 +262,7 @@ Requires: linux-firmware-whence
Firmware for Netronome Smart NICs
%prep
%autosetup -p1
# Due GPL violation, we don't want to ship this file even in the src.rpm,
# which means instead of removing it here, the tarball should not have it
if [ -f "liquidio/lio_23xx_vsw.bin" ]; then
echo "Error: lio_23xx_vsw.bin found, please remove it from the source"
exit 1
fi
%autosetup -S git -p1
%build
@ -450,6 +441,299 @@ sed -e 's/^/%%dir /' linux-firmware.dirs >> linux-firmware.files
%{_firmwarepath}/netronome/*
%changelog
* Mon Mar 13 2023 Herton R. Krzesinski <herton@redhat.com> - 20230310-133
- Removed notices and check about the liquidio/lio_23xx_vsw.bin file: starting
with 20230310 release of linux-firmware, it was removed upstream as well.
- Update to upstream 20230310 release (rhbz 2029566).
Changes since the last update are noted on items below, copied from
the git changelog of upstream linux-firmware repository.
- qat: update licence text
- rtl_bt: Update RTL8822C BT USB firmware to 0x0CC6_D2E3
- rtl_bt: Update RTL8822C BT UART firmware to 0x05C6_D2E3
- WHENCE: remove duplicate File entries
- WHENCE: remove trailing white space
- linux-firmware: add fw for qat_4xxx
- Fix symlinks for Intel firmware
- linux-firmware: update firmware for mediatek bluetooth chip (MT7921)
- linux-firmware: update firmware for MT7921 WiFi device
- iwlwifi: update core69 and core72 firmwares for Ty device
- rtlwifi: Add firmware v16.0 for RTL8710BU aka RTL8188GU
- brcm: Add nvram for the Lenovo Yoga Book X90F / X90L convertible
- brcm: Fix Xiaomi Inc Mipad2 nvram/.txt file macaddr
- brcm: Add nvram for the Advantech MICA-071 tablet
- rtl_bt: Update RTL8852C BT USB firmware to 0xD7B8_FABF
- rtl_bt: Add firmware and config files for RTL8821CS
- rtw89: 8852b: update fw to v0.29.29.0
- rtw89: 8852b: update fw to v0.29.26.0
- liquidio: remove lio_23xx_vsw.bin
- intel: avs: Add AudioDSP base firmware for CNL-based platforms
- intel: avs: Add AudioDSP base firmware for APL-based platforms
- intel: avs: Add AudioDSP base firmware for SKL-based platforms
- ath11k: WCN6855 hw2.0: update to WLAN.HSP.1.1-03125-QCAHSPSWPL_V1_V2_SILICONZ_LITE-3.6510.23
- ath11k: WCN6855 hw2.0: update board-2.bin
- ath11k: WCN6750 hw1.0: update board-2.bin
- ath11k: IPQ5018 hw1.0: add to WLAN.HK.2.6.0.1-00861-QCAHKSWPL_SILICONZ-1
- ath11k: IPQ5018 hw1.0: add board-2.bin
- ath10k: QCA6174 hw3.0: update firmware-sdio-6.bin to version WLAN.RMH.4.4.1-00174
- ath10k: WCN3990 hw1.0: update board-2.bin
- cnm: update chips&media wave521c firmware.
- amdgpu: Update GC 11.0.1 firmware
- intel: catpt: Add AudioDSP base firmware for BDW platforms
* Thu Feb 16 2023 Herton R. Krzesinski <herton@redhat.com> - 20230210-132
- Update ath10k/ath11k firmware (rhbz 2169013):
ath11k: WCN6855 hw2.0: update to WLAN.HSP.1.1-03125-QCAHSPSWPL_V1_V2_SILICONZ_LITE-3.6510.23
ath11k: WCN6855 hw2.0: update board-2.bin
ath11k: WCN6750 hw1.0: update board-2.bin
ath11k: IPQ5018 hw1.0: add to WLAN.HK.2.6.0.1-00861-QCAHKSWPL_SILICONZ-1
ath11k: IPQ5018 hw1.0: add board-2.bin
ath10k: QCA6174 hw3.0: update firmware-sdio-6.bin to version WLAN.RMH.4.4.1-00174
ath10k: WCN3990 hw1.0: update board-2.bin
- Ship new firmware files using patch/git apply instead of as rpm sources.
* Tue Feb 14 2023 Herton R. Krzesinski <herton@redhat.com> - 20230210-131
- Update amdgpu/gc_11_0_1_rlc.bin file from the following linux-firmware commit:
commit c0a0bc2 - amdgpu: Update GC 11.0.1 firmware (rhbz 2047462).
* Mon Feb 13 2023 Herton R. Krzesinski <herton@redhat.com> - 20230210-130
- Update to upstream 20230210 release (rhbz 2047488).
Changes since the last update are noted on items below, copied from
the git changelog of upstream linux-firmware repository.
- linux-firmware: Update AMD cpu microcode
- brcm: revert firmware files for Cypress devices
- brcm: restore previous firmware file for BCM4329 device
- rtw88: 8822c: Update normal firmware to v9.9.14
- i915: Add DMC v2.11 for MTL
- linux-firmware: Add firmware for Cirrus CS35L41 on UM3402 ASUS Laptop
- linux-firmware: Add missing tuning files for HP Laptops using Cirrus Amps
- i915: Add DMC v2.18 for ADLP
- amdgpu: Add VCN 4.0.2 firmware
- amdgpu: Add PSP 13.0.4 firmware
- amdgpu: Add SDMA 6.0.1 fimware
- amdgpu: Add GC 11.0.1 firmware
- amdgpu: Add DCN 3.1.4 firmware
- iwlwifi: remove old intermediate 5.15+ firmwares
- iwlwifi: remove 5.10 and 5.15 intermediate old firmwares
- iwlwifi: remove 5.4 and 5.10 intermediate old firmwares
- iwlwifi: remove 4.19 and 5.4 intermediate old firmwares
- iwlwifi: remove old unsupported older than 4.14 LTS
- linux-firmware: update firmware for MT7921 WiFi device
- linux-firmware: update firmware for mediatek bluetooth chip (MT7921)
- amdgpu: update vangogh firmware
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX210
- linux-firmware: Update firmware file for Intel Bluetooth AX200
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth 9260
- brcm: add configuration files for CyberTan WC121
- qcom: add firmware files for Adreno A200
- rtw89: 8852c: update fw to v0.27.56.10
- QCA: Add Bluetooth firmware for QCA2066
- amdgpu: add VCN4.0.4 firmware from amd-5.4
- amdgpu: add SMU13.0.7 firmware from amd-5.4
- amdgpu: add SDMA6.0.2 firmware from amd-5.4
- amdgpu: add PSP13.0.7 firmware from amd-5.4
- amdgpu: add GC11.0.2 firmware from amd-5.4
- amdgpu: add DCN3.2.1 firmware from amd-5.4
- amdgpu: update VCN4.0.0 firmware from amd-5.4
- amdgpu: update SMU13.0.0 firmware from amd-5.4
- amdgpu: update SDMA6.0.0 firmware from amd-5.4
- amdgpu: update PSP13.0.0 firmware from amd-5.4
- amdgpu: update GC11.0.0 firmware from amd-5.4
- iwlwifi: add new FWs from core76-35 release
- iwlwifi: update cc/Qu/QuZ firmwares for core76-35 release
- iwlwifi: add new FWs from core75-47 release
- iwlwifi: update 9000-family firmwares to core75-47
- amdgpu: update renoir DMCUB firmware
- amdgpu: Update renoir PSP firmware
- amdgpu: update copyright date for LICENSE.amdgpu
- linux-firmware: update firmware for MT7921 WiFi device
- linux-firmware: update firmware for MT7922 WiFi device
- linux-firmware: update firmware for mediatek bluetooth chip (MT7922)
- cxgb4: Update firmware to revision 1.27.1.0
- qca: Update firmware files for BT chip WCN6750
- rtw89: 8852c: update fw to v0.27.56.9
- rtw89: 8852c: update fw to v0.27.56.8
* Thu Dec 15 2022 Herton R. Krzesinski <herton@redhat.com> - 20221214-129
- Update to upstream 20221012 release (rhbz 2153045, 2047484).
Changes since the last update are noted on items below, copied from
the git changelog of upstream linux-firmware repository.
- amdgpu: updated navi10 firmware for amd-5.4
- amdgpu: updated yellow carp firmware for amd-5.4
- amdgpu: updated raven2 firmware for amd-5.4
- amdgpu: updated raven firmware for amd-5.4
- amdgpu: updated PSP 13.0.8 firmware for amd-5.4
- amdgpu: updated GC 10.3.7 RLC firmware for amd-5.4
- amdgpu: updated vega20 firmware for amd-5.4
- amdgpu: updated PSP 13.0.5 firmware for amd-5.4
- amdgpu: add VCN 4.0.0 firmware for amd-5.4
- amdgpu: add SMU 13.0.0 firmware for amd-5.4
- amdgpu: Add SDMA 6.0.0 firmware for amd-5.4
- amdgpu: add PSP 13.0.0 firmware for amd-5.4
- amdgpu: add GC 11.0.0 firmware for amd-5.4
- amdgpu: add DCN 3.2.0 firmware for amd-5.4
- amdgpu: updated vega10 firmware for amd-5.4
- amdgpu: updated beige goby firmware for amd-5.4
- amdgpu: updated dimgrey cavefish firmware for amd-5.4
- amdgpu: updated vangogh firmware for amd-5.4
- amdgpu: updated picasso firmware for amd-5.4
- amdgpu: updated navy flounder firmware for amd-5.4
- amdgpu: updated green sardine firmware for amd-5.4
- amdgpu: updated sienna cichlid firmware for amd-5.4
- amdgpu: updated arcture firmware for amd-5.4
- amdgpu: updated navi14 firmware for amd-5.4
- amdgpu: updated renoir firmware for amd-5.4
- amdgpu: updated navi12 firmware for amd-5.4
- amdgpu: updated aldebaran firmware for amd-5.4
- sr150 : Add NXP SR150 UWB firmware
- brcm: add/update firmware files for brcmfmac driver
- rtl_bt: Update RTL8821C BT(USB I/F) FW to 0x75b8_f098
- amdgpu: update sdma_5.2.7 firmware
- QCA: Add Bluetooth firmware for WCN785x This adds required Bluetooth firmware
files for QCA WCN785x. The image version is 2.0.0-00515.
- linux-firmware: update firmware for MT7916
- linux-firmware: update firmware for MT7915
- i915: Add DMC v2.08 for DG2
- amdgpu: update green sardine DMCUB firmware
- i915: Add DMC v2.10 for MTL
- linux-firmware: update firmware for MT7986
- linux-firmware: update firmware for mediatek bluetooth chip (MT7921)
- linux-firmware: update firmware for MT7921 WiFi device
- linux-firmware: Update firmware file for Intel Bluetooth 9462
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX210
- linux-firmware: Update firmware file for Intel Bluetooth AX200
- amdgpu: update DMCUB firmware for DCN 3.1.6
- rtl_bt: Update RTL8822C BT UART firmware to 0xFFB8_ABD6
- rtl_bt: Update RTL8822C BT USB firmware to 0xFFB8_ABD3
- WHENCE: mrvl: prestera: Add WHENCE entries for newly updated 4.1 FW images
- mrvl: prestera: Update Marvell Prestera Switchdev FW to v4.1
- iwlwifi: add new FWs from core74_pv-60 release
- qcom: drop split a530_zap firmware file
- qcom/vpu-1.0: drop split firmware in favour of the mbn file
- qcom/venus-4.2: drop split firmware in favour of the mbn file
- qcom/venus-4.2: replace split firmware with the mbn file
- qcom/venus-1.8: replace split firmware with the mbn file
- linux-firmware: Add firmware for Cirrus CS35L41 on new ASUS Laptop
- iwlwifi: add new PNVM binaries from core74-44 release
- iwlwifi: add new FWs from core69-81 release
- qcom: update venus firmware files for VPU-2.0
- qcom: remove split SC7280 venus firmware images
- qcom: update venus firmware file for v5.4
- qcom: replace split SC7180 venus firmware images with symlink
- rtw89: 8852b: update fw to v0.27.32.1
- rtlwifi: update firmware for rtl8192eu to v35.7
- rtlwifi: Add firmware v4.0 for RTL8188FU
- i915: Add HuC 7.10.3 for DG2
- cnm: update chips&media wave521c firmware.
- brcm: add symlink for Pi Zero 2 W NVRAM file
- linux-firmware: Add firmware for Cirrus CS35L41 on ASUS Laptops
- linux-firmware: Add firmware for Cirrus CS35L41 on Lenovo Laptops
- linux-firmware: Add firmware for Cirrus CS35L41 on HP Laptops
- rtw89: 8852b: add initial fw v0.27.32.0
- iwlwifi: add new FWs from core72-129 release
- iwlwifi: update 9000-family firmwares to core72-129
* Wed Oct 26 2022 Frantisek Hrbata <fhrbata@redhat.com> - 20221012-128
- Update to upstream 20221012 release (rhbz 2121447).
Changes since the last update are noted on items below, copied from
the git changelog of upstream linux-firmware repository.
- rtl_bt: Update RTL8852C BT USB firmware to 0xD5B8_A40A
- amdgpu: update GC 10.3.6 RLC firmware
- amdgpu: update GC 10.3.7 RLC firmware
- amdgpu: update Yellow Carp RLC firmware
- amdgpu: update Beige Goby RLC firmware
- amdgpu: update Dimgrey Cavefish RLC firmware
- amdgpu: update Navy Flounder RLC firmware
- amdgpu: update Sienna Cichlid RLC firmware
- mediatek: Update mt8195 SOF firmware to v0.4.1
- qcom: add squashed version of a530 zap shader
- rtw89: 8852c: update fw to v0.27.56.1
- rtw89: 8852c: update fw to v0.27.56.0
- mediatek: Update mt8186 SCP firmware
- linux-firmware: Update AMD cpu microcode
- mediatek: mt8195: Update scp.img to v2.0.11956
- mediatek: Add new mt8195 SOF firmware
- mediatek: Update mt8186 SOF firmware to v0.2.1
- linux-firmware: update firmware for mediatek bluetooth chip (MT7922)
- rtl_bt: Update RTL8852A BT USB firmware to 0xD9B8_8207
- linux-firmware: update firmware for mediatek bluetooth chip (MT7921)
- linux-firmware: update firmware for MT7922 WiFi device
- linux-firmware: update firmware for MT7921 WiFi device
- cxgb4: Update firmware to revision 1.27.0.0
- i915: Add versionless HuC files for current platforms
- i915: Add GuC v70.5.1 for DG1, DG2, TGL and ADL-P
- qca: Update firmware files for BT chip WCN3991.
- Removing crnv32
- amdgpu: update yellow carp DMCUB firmware
- amdgpu: add firmware for VCN 3.1.2 IP block
- amdgpu: add firmware for SDMA 5.2.6 IP block
- amdgpu: add firmware for PSP 13.0.5 IP block
- amdgpu: add firmware for GC 10.3.6 IP block
- amdgpu: add firmware for DCN 3.1.5 IP block
- qcom: rename Lenovo ThinkPad X13s firmware paths
- rtw89: 8852c: update fw to v0.27.42.0
- rtw89: 8852c: update fw to v0.27.36.0
- Mellanox: Add new mlxsw_spectrum firmware xx.2010.3146
- amdgpu: update beige goby VCN firmware
- amdgpu: update dimgrey cavefish VCN firmware
- amdgpu: update navy flounder VCN firmware
- amdgpu: update sienna cichlid VCN firmware
- rtl_bt: Update RTL8852C BT USB firmware to 0xDFB8_5A33
- mediatek: reference the LICENCE file for MediaTek firmwares
- mediatek: Add new mt8186 SOF firmware
- ice: Update package to 1.3.30.0
- QCA: Update Bluetooth WCN685x 2.1 firmware to 2.1.0-00438
- brcm: Add nvram for Lenovo Yoga Tablet 2 830F/L and 1050F/L tablets
- brcm: Add nvram for the Xiaomi Mi Pad 2 tablet
- brcm: Add nvram for the Asus TF103C tablet
- Add amd-ucode README file
- qca: Update firmware files for BT chip WCN6750. This commit will update required firmware files for WCN6750.
- amdgpu: Update Yellow Carp VCN firmware
- linux-firmware: Update firmware file for Intel Bluetooth 9462
- linux-firmware: Update firmware file for Intel Bluetooth 9462
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX210
- linux-firmware: Update firmware file for Intel Bluetooth AX200
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- Mellanox: Add new mlxsw_spectrum firmware xx.2010.3020
- qcom: Add firmware for Lenovo ThinkPad X13s
- linux-firmware: Add firmware for Cirrus CS35L41
- i915: Add GuC v70.4.1 for DG2
- i915: Add DMC v2.07 for DG2
- amdgpu partially revert "amdgpu: update beige goby to release 22.20"
- mediatek: Update mt8183/mt8192/mt8195 SCP firmware
- amdgpu: update renoir to release 22.20
- amdgpu: update beige goby to release 22.20
- amdgpu: update yellow carp to release 22.20
- amdgpu: update dimgrey cavefish to release 22.20
- amdgpu: update vega20 to release 22.20
- amdgpu: update vega12 to release 22.20
- amdgpu: update raven to release 22.20
- amdgpu: update navy flounder to release 22.20
- amdgpu: update vega10 to release 22.20
- amdgpu: update sienna cichlid to release 22.20
- amdgpu: update navi14 to release 22.20
- amdgpu: update green sardine to release 22.20
- amdgpu: update vangogh to release 22.20
- amdgpu: update navi12 to release 22.20
- amdgpu: update navi10 to release 22.20
- amdgpu: update picasso to release 22.20
- amdgpu: update aldebaran to release 22.20
- amdgpu: update psp 13.0.8 TA firmware
- WHENCE: Fix the dangling symlinks fix
- amdgpu: update DMCUB firmware for DCN 3.1.6
- WHENCE: Correct dangling symlinks
* Mon Jul 11 2022 Patrick Talbert <ptalbert@redhat.com> - 20220708-127
- Update compressed firmware support patch for upstream changes
- Update to upstream 20220708 release (rhbz 2040281, 2045911, 2105392).