update to upstream 20230726 release
- Navi32 dGPU firmware (rhbz 2047486) - CVE-2023-20593 linux-firmware: hw: amd: Cross-Process Information Leak (rhbz 2227156) - Update to upstream 20230726 release. Changes since the last update are noted on items below, copied from the git changelog of upstream linux-firmware repository. - copy-firmware: Fix linking directories when using compression - copy-firmware: Fix test: unexpected operator - qcom: sc8280xp: LENOVO: remove directory sym link - qcom: sc8280xp: LENOVO: Remove execute bits - amdgpu: update VCN 4.0.0 firmware - amdgpu: add initial SMU 13.0.10 firmware - amdgpu: add initial SDMA 6.0.3 firmware - amdgpu: add initial PSP 13.0.10 firmware - amdgpu: add initial GC 11.0.3 firmware - linux-firmware: Update AMD fam17h cpu microcode - linux-firmware: Update AMD cpu microcode - amdgpu: update green sardine VCN firmware - amdgpu: update renoir VCN firmware - amdgpu: update raven VCN firmware - amdgpu: update raven2 VCN firmware - amdgpu: update Picasso VCN firmware - amdgpu: update DMCUB to v0.0.175.0 for various AMDGPU ASICs - Updated NXP SR150 UWB firmware - wfx: update to firmware 3.16.1 - mediatek: Update mt8195 SCP firmware to support 10bit mode - i915: update DG2 GuC to v70.8.0 - i915: update to GuC 70.8.0 and HuC 8.5.1 for MTL - cirrus: Add CS35L41 firmware for ASUS ROG 2023 Models - Partially revert "amdgpu: DMCUB updates for DCN 3.1.4 and 3.1.5" - linux-firmware: update firmware for mediatek bluetooth chip (MT7922) - linux-firmware: update firmware for MT7922 WiFi device - linux-firmware: Update firmware file for Intel Bluetooth AX203 - linux-firmware: Update firmware file for Intel Bluetooth AX203 - linux-firmware: Update firmware file for Intel Bluetooth AX211 - linux-firmware: Update firmware file for Intel Bluetooth AX211 - linux-firmware: Update firmware file for Intel Bluetooth AX210 - linux-firmware: Update firmware file for Intel Bluetooth AX200 - linux-firmware: Update firmware file for Intel Bluetooth AX201 - Fix qcom ASoC tglp WHENCE entry - check_whence: Check link targets are valid - iwlwifi: add new FWs from core80-39 release - iwlwifi: update cc/Qu/QuZ firmwares for core80-39 release - qcom: Add Audio firmware for SC8280XP X13s Resolves: rhbz#2047486, rhbz#2227156 Signed-off-by: Jan Stancek <jstancek@redhat.com>
This commit is contained in:
parent
c019edd513
commit
943f998073
29
0001-copy-firmware.sh-be-verbose.patch
Normal file
29
0001-copy-firmware.sh-be-verbose.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From d50d13a9d8c3863a847077e6357fdde2bf39a88f Mon Sep 17 00:00:00 2001
|
||||||
|
Message-Id: <d50d13a9d8c3863a847077e6357fdde2bf39a88f.1688365829.git.jstancek@redhat.com>
|
||||||
|
From: Jan Stancek <jstancek@redhat.com>
|
||||||
|
Date: Mon, 3 Jul 2023 08:30:14 +0200
|
||||||
|
Subject: [PATCH] copy-firmware.sh: be verbose
|
||||||
|
Content-type: text/plain
|
||||||
|
|
||||||
|
Signed-off-by: Jan Stancek <jstancek@redhat.com>
|
||||||
|
---
|
||||||
|
Makefile | 2 +-
|
||||||
|
copy-firmware.sh | 14 +++++++++++---
|
||||||
|
2 files changed, 12 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 50a4c29be5b4..a5480eee0730 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -14,7 +14,7 @@ install:
|
||||||
|
|
||||||
|
install-xz:
|
||||||
|
install -d $(DESTDIR)$(FIRMWAREDIR)
|
||||||
|
- ./copy-firmware.sh --xz $(DESTDIR)$(FIRMWAREDIR)
|
||||||
|
+ ./copy-firmware.sh -v --xz $(DESTDIR)$(FIRMWAREDIR)
|
||||||
|
|
||||||
|
install-zst:
|
||||||
|
install -d $(DESTDIR)$(FIRMWAREDIR)
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
@ -1,54 +0,0 @@
|
|||||||
From d50d13a9d8c3863a847077e6357fdde2bf39a88f Mon Sep 17 00:00:00 2001
|
|
||||||
Message-Id: <d50d13a9d8c3863a847077e6357fdde2bf39a88f.1688365829.git.jstancek@redhat.com>
|
|
||||||
From: Jan Stancek <jstancek@redhat.com>
|
|
||||||
Date: Mon, 3 Jul 2023 08:30:14 +0200
|
|
||||||
Subject: [PATCH] copy-firmware.sh: don't add compext to directory links
|
|
||||||
Content-type: text/plain
|
|
||||||
|
|
||||||
Signed-off-by: Jan Stancek <jstancek@redhat.com>
|
|
||||||
---
|
|
||||||
Makefile | 2 +-
|
|
||||||
copy-firmware.sh | 14 +++++++++++---
|
|
||||||
2 files changed, 12 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index 50a4c29be5b4..a5480eee0730 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -14,7 +14,7 @@ install:
|
|
||||||
|
|
||||||
install-xz:
|
|
||||||
install -d $(DESTDIR)$(FIRMWAREDIR)
|
|
||||||
- ./copy-firmware.sh --xz $(DESTDIR)$(FIRMWAREDIR)
|
|
||||||
+ ./copy-firmware.sh -v --xz $(DESTDIR)$(FIRMWAREDIR)
|
|
||||||
|
|
||||||
install-zst:
|
|
||||||
install -d $(DESTDIR)$(FIRMWAREDIR)
|
|
||||||
diff --git a/copy-firmware.sh b/copy-firmware.sh
|
|
||||||
index 58eb7e39ffb7..71f6be02d4cb 100755
|
|
||||||
--- a/copy-firmware.sh
|
|
||||||
+++ b/copy-firmware.sh
|
|
||||||
@@ -94,9 +94,17 @@ grep -E '^Link:' WHENCE | sed -e 's/^Link: *//g;s/-> //g' | while read f d; do
|
|
||||||
$verbose "WARNING: missing target for symlink $f"
|
|
||||||
fi
|
|
||||||
else
|
|
||||||
- install -d "$destdir/$(dirname "$f")"
|
|
||||||
- $verbose "creating link $f$compext -> $d$compext"
|
|
||||||
- ln -s "$d$compext" "$destdir/$f$compext"
|
|
||||||
+ mkdir -p $(dirname "$f")
|
|
||||||
+ if test -d $(dirname "$f")/"$d"; then
|
|
||||||
+ # don't add compression extension to directory symlinks
|
|
||||||
+ $verbose "creating dir link $f -> $d"
|
|
||||||
+ install -d $destdir/$(dirname "$f")
|
|
||||||
+ ln -sf "$d" "$destdir/$f"
|
|
||||||
+ else
|
|
||||||
+ $verbose "creating link $f$compext -> $d$compext"
|
|
||||||
+ install -d $destdir/$(dirname "$f$compext")
|
|
||||||
+ ln -sf "$d$compext" "$destdir/$f$compext"
|
|
||||||
+ fi
|
|
||||||
fi
|
|
||||||
done
|
|
||||||
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
@ -1,11 +1,11 @@
|
|||||||
%global debug_package %{nil}
|
%global debug_package %{nil}
|
||||||
%global firmware_release 137
|
%global firmware_release 138
|
||||||
|
|
||||||
%global _firmwarepath /usr/lib/firmware
|
%global _firmwarepath /usr/lib/firmware
|
||||||
%define _binaries_in_noarch_packages_terminate_build 0
|
%define _binaries_in_noarch_packages_terminate_build 0
|
||||||
|
|
||||||
Name: linux-firmware
|
Name: linux-firmware
|
||||||
Version: 20230625
|
Version: 20230726
|
||||||
Release: %{firmware_release}%{?dist}
|
Release: %{firmware_release}%{?dist}
|
||||||
Summary: Firmware files used by the Linux kernel
|
Summary: Firmware files used by the Linux kernel
|
||||||
License: GPL+ and GPLv2+ and MIT and Redistributable, no modification permitted
|
License: GPL+ and GPLv2+ and MIT and Redistributable, no modification permitted
|
||||||
@ -13,7 +13,7 @@ URL: http://www.kernel.org/
|
|||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
Source0: https://www.kernel.org/pub/linux/kernel/firmware/%{name}-%{version}.tar.xz
|
Source0: https://www.kernel.org/pub/linux/kernel/firmware/%{name}-%{version}.tar.xz
|
||||||
Patch1: 0001-copy-firmware.sh-don-t-add-compext-to-directory-link.patch
|
Patch1: 0001-copy-firmware.sh-be-verbose.patch
|
||||||
|
|
||||||
BuildRequires: git-core
|
BuildRequires: git-core
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
@ -441,6 +441,51 @@ sed -e 's/^/%%dir /' linux-firmware.dirs >> linux-firmware.files
|
|||||||
%{_firmwarepath}/netronome/*
|
%{_firmwarepath}/netronome/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 26 2023 Jan Stancek <jstancek@redhat.com> - 20230726-138
|
||||||
|
- Navi32 dGPU firmware (rhbz 2047486)
|
||||||
|
- CVE-2023-20593 linux-firmware: hw: amd: Cross-Process Information Leak (rhbz 2227156)
|
||||||
|
- Update to upstream 20230726 release.
|
||||||
|
Changes since the last update are noted on items below, copied from
|
||||||
|
the git changelog of upstream linux-firmware repository.
|
||||||
|
- copy-firmware: Fix linking directories when using compression
|
||||||
|
- copy-firmware: Fix test: unexpected operator
|
||||||
|
- qcom: sc8280xp: LENOVO: remove directory sym link
|
||||||
|
- qcom: sc8280xp: LENOVO: Remove execute bits
|
||||||
|
- amdgpu: update VCN 4.0.0 firmware
|
||||||
|
- amdgpu: add initial SMU 13.0.10 firmware
|
||||||
|
- amdgpu: add initial SDMA 6.0.3 firmware
|
||||||
|
- amdgpu: add initial PSP 13.0.10 firmware
|
||||||
|
- amdgpu: add initial GC 11.0.3 firmware
|
||||||
|
- linux-firmware: Update AMD fam17h cpu microcode
|
||||||
|
- linux-firmware: Update AMD cpu microcode
|
||||||
|
- amdgpu: update green sardine VCN firmware
|
||||||
|
- amdgpu: update renoir VCN firmware
|
||||||
|
- amdgpu: update raven VCN firmware
|
||||||
|
- amdgpu: update raven2 VCN firmware
|
||||||
|
- amdgpu: update Picasso VCN firmware
|
||||||
|
- amdgpu: update DMCUB to v0.0.175.0 for various AMDGPU ASICs
|
||||||
|
- Updated NXP SR150 UWB firmware
|
||||||
|
- wfx: update to firmware 3.16.1
|
||||||
|
- mediatek: Update mt8195 SCP firmware to support 10bit mode
|
||||||
|
- i915: update DG2 GuC to v70.8.0
|
||||||
|
- i915: update to GuC 70.8.0 and HuC 8.5.1 for MTL
|
||||||
|
- cirrus: Add CS35L41 firmware for ASUS ROG 2023 Models
|
||||||
|
- Partially revert "amdgpu: DMCUB updates for DCN 3.1.4 and 3.1.5"
|
||||||
|
- linux-firmware: update firmware for mediatek bluetooth chip (MT7922)
|
||||||
|
- linux-firmware: update firmware for MT7922 WiFi device
|
||||||
|
- linux-firmware: Update firmware file for Intel Bluetooth AX203
|
||||||
|
- linux-firmware: Update firmware file for Intel Bluetooth AX203
|
||||||
|
- linux-firmware: Update firmware file for Intel Bluetooth AX211
|
||||||
|
- linux-firmware: Update firmware file for Intel Bluetooth AX211
|
||||||
|
- linux-firmware: Update firmware file for Intel Bluetooth AX210
|
||||||
|
- linux-firmware: Update firmware file for Intel Bluetooth AX200
|
||||||
|
- linux-firmware: Update firmware file for Intel Bluetooth AX201
|
||||||
|
- Fix qcom ASoC tglp WHENCE entry
|
||||||
|
- check_whence: Check link targets are valid
|
||||||
|
- iwlwifi: add new FWs from core80-39 release
|
||||||
|
- iwlwifi: update cc/Qu/QuZ firmwares for core80-39 release
|
||||||
|
- qcom: Add Audio firmware for SC8280XP X13s
|
||||||
|
|
||||||
* Mon Jul 3 2023 Jan Stancek <jstancek@redhat.com> - 20230625-137
|
* Mon Jul 3 2023 Jan Stancek <jstancek@redhat.com> - 20230625-137
|
||||||
- Fix PSR-SU issues with kernel 6.2 or later (rhbz 2218668)
|
- Fix PSR-SU issues with kernel 6.2 or later (rhbz 2218668)
|
||||||
- Update to upstream 20230625 release.
|
- Update to upstream 20230625 release.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (linux-firmware-20230625.tar.xz) = 0b40334b7baaf7b24a849b97abb8aceaf042a514eaf519acd3b0e9a0c9db7a3a668312225c43c7427bcffa4c67bc0ec4e182cc2a9ffdd05227b183878088a288
|
SHA512 (linux-firmware-20230726.tar.xz) = 1ba7f8b802b9d18f5405a89c3f63b7752008c1da80143d1adf0051cfb427cb50beb74e4a9ccf7709dba038719c053b1c6be3aa12a27bb64065415411c8040ec5
|
||||||
|
Loading…
Reference in New Issue
Block a user