20230625 release
This commit is contained in:
parent
ead01369f5
commit
8cbbfc97e7
@ -1,123 +0,0 @@
|
|||||||
From 7eec2b56f54c778d5bd6e7aea49ee03e3b76e769 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Robinson <pbrobinson@gmail.com>
|
|
||||||
Date: Fri, 22 Jan 2021 20:36:23 +0000
|
|
||||||
Subject: [PATCH v2] Add support for compressing firmware in copy-firmware.sh
|
|
||||||
|
|
||||||
As of kernel 5.3 there's initial support for loading compressed firmware.
|
|
||||||
At this stage the only supported compression methis is "xz -C crc32" but
|
|
||||||
this option brings significant benefits.
|
|
||||||
|
|
||||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
|
||||||
---
|
|
||||||
|
|
||||||
v2: quote filename for xz command
|
|
||||||
|
|
||||||
Makefile | 4 ++++
|
|
||||||
copy-firmware.sh | 47 +++++++++++++++++++++++++++++++----------------
|
|
||||||
2 files changed, 35 insertions(+), 16 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index e1c362f..9a48471 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -11,3 +11,7 @@
|
|
||||||
install:
|
|
||||||
install -d $(DESTDIR)$(FIRMWAREDIR)
|
|
||||||
./copy-firmware.sh $(DESTDIR)$(FIRMWAREDIR)
|
|
||||||
+
|
|
||||||
+installcompress:
|
|
||||||
+ install -d $(DESTDIR)$(FIRMWAREDIR)
|
|
||||||
+ ./copy-firmware.sh -C $(DESTDIR)$(FIRMWAREDIR)
|
|
||||||
diff --git a/copy-firmware.sh b/copy-firmware.sh
|
|
||||||
index 9b46b63..0dd2e5c 100755
|
|
||||||
--- a/copy-firmware.sh
|
|
||||||
+++ b/copy-firmware.sh
|
|
||||||
@@ -6,6 +6,7 @@
|
|
||||||
|
|
||||||
verbose=:
|
|
||||||
prune=no
|
|
||||||
+compress=no
|
|
||||||
|
|
||||||
while test $# -gt 0; do
|
|
||||||
case $1 in
|
|
||||||
@@ -19,6 +20,11 @@ while test $# -gt 0; do
|
|
||||||
shift
|
|
||||||
;;
|
|
||||||
|
|
||||||
+ -C | --compress)
|
|
||||||
+ compress=yes
|
|
||||||
+ shift
|
|
||||||
+ ;;
|
|
||||||
+
|
|
||||||
*)
|
|
||||||
if test "x$destdir" != "x"; then
|
|
||||||
echo "ERROR: unknown command-line options: $@"
|
|
||||||
@@ -31,40 +37,49 @@ while test $# -gt 0; do
|
|
||||||
esac
|
|
||||||
done
|
|
||||||
|
|
||||||
+if test "x$compress" = "xyes"; then
|
|
||||||
+ cmpxtn=.xz
|
|
||||||
+ grep '^File:' WHENCE | sed -e's/^File: *//g' -e's/"//g' | while read f; do
|
|
||||||
+ test -f "$f" || continue
|
|
||||||
+ $verbose "compressing $f"
|
|
||||||
+ xz -C crc32 "$f"
|
|
||||||
+ done
|
|
||||||
+fi
|
|
||||||
+
|
|
||||||
grep '^File:' WHENCE | sed -e's/^File: *//g' -e's/"//g' | while read f; do
|
|
||||||
- test -f "$f" || continue
|
|
||||||
- $verbose "copying file $f"
|
|
||||||
- install -d $destdir/$(dirname "$f")
|
|
||||||
- cp -d "$f" $destdir/"$f"
|
|
||||||
+ test -f "$f$cmpxtn" || continue
|
|
||||||
+ $verbose "copying file $f$cmpxtn"
|
|
||||||
+ install -d $destdir/$(dirname "$f$cmpxtn")
|
|
||||||
+ cp -d "$f$cmpxtn" $destdir/"$f$cmpxtn"
|
|
||||||
done
|
|
||||||
|
|
||||||
grep -E '^Link:' WHENCE | sed -e's/^Link: *//g' -e's/-> //g' | while read f d; do
|
|
||||||
- if test -L "$f"; then
|
|
||||||
- test -f "$destdir/$f" && continue
|
|
||||||
- $verbose "copying link $f"
|
|
||||||
- install -d $destdir/$(dirname "$f")
|
|
||||||
+ if test -L "$f$cmpxtn"; then
|
|
||||||
+ test -f "$destdir/$f$cmpxtn" && continue
|
|
||||||
+ $verbose "copying link $f$cmpxtn"
|
|
||||||
+ install -d $destdir/$(dirname "$f$cmpxtn")
|
|
||||||
cp -d "$f" $destdir/"$f"
|
|
||||||
|
|
||||||
if test "x$d" != "x"; then
|
|
||||||
- target=`readlink "$f"`
|
|
||||||
+ target=`readlink "$f$cmpxtn"`
|
|
||||||
|
|
||||||
if test "x$target" != "x$d"; then
|
|
||||||
$verbose "WARNING: inconsistent symlink target: $target != $d"
|
|
||||||
else
|
|
||||||
if test "x$prune" != "xyes"; then
|
|
||||||
- $verbose "WARNING: unneeded symlink detected: $f"
|
|
||||||
+ $verbose "WARNING: unneeded symlink detected: $f$cmpxtn"
|
|
||||||
else
|
|
||||||
- $verbose "WARNING: pruning unneeded symlink $f"
|
|
||||||
- rm -f "$f"
|
|
||||||
+ $verbose "WARNING: pruning unneeded symlink $f$cmpxtn"
|
|
||||||
+ rm -f "$f$cmpxtn"
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
else
|
|
||||||
- $verbose "WARNING: missing target for symlink $f"
|
|
||||||
+ $verbose "WARNING: missing target for symlink $f$cmpxtn"
|
|
||||||
fi
|
|
||||||
else
|
|
||||||
- $verbose "creating link $f -> $d"
|
|
||||||
- install -d $destdir/$(dirname "$f")
|
|
||||||
- ln -sf "$d" "$destdir/$f"
|
|
||||||
+ $verbose "creating link $f$cmpxtn -> $d$cmpxtn"
|
|
||||||
+ install -d $destdir/$(dirname "$f$cmpxtn")
|
|
||||||
+ ln -sf "$d$cmpxtn" "$destdir/$f$cmpxtn"
|
|
||||||
fi
|
|
||||||
done
|
|
||||||
|
|
||||||
--
|
|
||||||
2.29.2
|
|
||||||
|
|
@ -4,7 +4,7 @@
|
|||||||
%define _binaries_in_noarch_packages_terminate_build 0
|
%define _binaries_in_noarch_packages_terminate_build 0
|
||||||
|
|
||||||
Name: linux-firmware
|
Name: linux-firmware
|
||||||
Version: 20230515
|
Version: 20230625
|
||||||
Release: 151%{?dist}
|
Release: 151%{?dist}
|
||||||
Summary: Firmware files used by the Linux kernel
|
Summary: Firmware files used by the Linux kernel
|
||||||
License: GPL+ and GPLv2+ and MIT and Redistributable, no modification permitted
|
License: GPL+ and GPLv2+ and MIT and Redistributable, no modification permitted
|
||||||
@ -12,13 +12,17 @@ URL: http://www.kernel.org/
|
|||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
Source0: https://www.kernel.org/pub/linux/kernel/firmware/%{name}-%{version}.tar.xz
|
Source0: https://www.kernel.org/pub/linux/kernel/firmware/%{name}-%{version}.tar.xz
|
||||||
Patch1: 0001-Add-support-for-compressing-firmware-in-copy-firmwar.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
|
|
||||||
Requires: linux-firmware-whence
|
Requires: linux-firmware-whence
|
||||||
Provides: kernel-firmware = %{version}
|
Provides: kernel-firmware = %{version}
|
||||||
Obsoletes: kernel-firmware < %{version}
|
Obsoletes: kernel-firmware < %{version}
|
||||||
Conflicts: microcode_ctl < 2.1-0
|
Conflicts: microcode_ctl < 2.1-0
|
||||||
|
|
||||||
|
Recommends: amd-gpu-firmware
|
||||||
|
Recommends: intel-gpu-firmware
|
||||||
|
Recommends: nvidia-gpu-firmware
|
||||||
%if 0%{?fedora} > 38
|
%if 0%{?fedora} > 38
|
||||||
Recommends: atheros-firmware
|
Recommends: atheros-firmware
|
||||||
Recommends: brcmfmac-firmware
|
Recommends: brcmfmac-firmware
|
||||||
@ -30,15 +34,6 @@ Requires: brcmfmac-firmware
|
|||||||
Requires: mt7xxx-firmware
|
Requires: mt7xxx-firmware
|
||||||
Requires: realtek-firmware
|
Requires: realtek-firmware
|
||||||
%endif
|
%endif
|
||||||
%if 0%{?fedora} > 36
|
|
||||||
Recommends: amd-gpu-firmware
|
|
||||||
Recommends: intel-gpu-firmware
|
|
||||||
Recommends: nvidia-gpu-firmware
|
|
||||||
%else
|
|
||||||
Requires: amd-gpu-firmware
|
|
||||||
Requires: intel-gpu-firmware
|
|
||||||
Requires: nvidia-gpu-firmware
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This package includes firmware files required for some devices to
|
This package includes firmware files required for some devices to
|
||||||
@ -246,7 +241,7 @@ mkdir -p %{buildroot}/%{_firmwarepath}
|
|||||||
mkdir -p %{buildroot}/%{_firmwarepath}/updates
|
mkdir -p %{buildroot}/%{_firmwarepath}/updates
|
||||||
|
|
||||||
%if 0%{?fedora} >= 34 || 0%{?rhel} >= 9
|
%if 0%{?fedora} >= 34 || 0%{?rhel} >= 9
|
||||||
make DESTDIR=%{buildroot}/ FIRMWAREDIR=%{_firmwarepath} installcompress
|
make DESTDIR=%{buildroot}/ FIRMWAREDIR=%{_firmwarepath} install-xz
|
||||||
%else
|
%else
|
||||||
make DESTDIR=%{buildroot}/ FIRMWAREDIR=%{_firmwarepath} install
|
make DESTDIR=%{buildroot}/ FIRMWAREDIR=%{_firmwarepath} install
|
||||||
%endif
|
%endif
|
||||||
@ -340,14 +335,11 @@ sed -e 's/^/%%dir /' linux-firmware.dirs >> linux-firmware.files
|
|||||||
# GPU firmwares
|
# GPU firmwares
|
||||||
%files -n amd-gpu-firmware
|
%files -n amd-gpu-firmware
|
||||||
%license LICENSE.radeon LICENSE.amdgpu
|
%license LICENSE.radeon LICENSE.amdgpu
|
||||||
%dir %{_firmwarepath}/amdgpu
|
|
||||||
%dir %{_firmwarepath}/radeon
|
|
||||||
%{_firmwarepath}/amdgpu/
|
%{_firmwarepath}/amdgpu/
|
||||||
%{_firmwarepath}/radeon/
|
%{_firmwarepath}/radeon/
|
||||||
|
|
||||||
%files -n intel-gpu-firmware
|
%files -n intel-gpu-firmware
|
||||||
%license LICENSE.i915
|
%license LICENSE.i915
|
||||||
%dir %{_firmwarepath}/i915
|
|
||||||
%{_firmwarepath}/i915/
|
%{_firmwarepath}/i915/
|
||||||
|
|
||||||
%files -n nvidia-gpu-firmware
|
%files -n nvidia-gpu-firmware
|
||||||
@ -363,12 +355,6 @@ sed -e 's/^/%%dir /' linux-firmware.dirs >> linux-firmware.files
|
|||||||
%license LICENSE.QualcommAtheros_ath10k
|
%license LICENSE.QualcommAtheros_ath10k
|
||||||
%license LICENCE.open-ath9k-htc-firmware
|
%license LICENCE.open-ath9k-htc-firmware
|
||||||
%license qca/NOTICE.txt
|
%license qca/NOTICE.txt
|
||||||
%dir %{_firmwarepath}/ar3k
|
|
||||||
%dir %{_firmwarepath}/ath6k
|
|
||||||
%dir %{_firmwarepath}/ath9k_htc
|
|
||||||
%dir %{_firmwarepath}/ath10k
|
|
||||||
%dir %{_firmwarepath}/ath11k
|
|
||||||
%dir %{_firmwarepath}/qca
|
|
||||||
%{_firmwarepath}/ar3k/
|
%{_firmwarepath}/ar3k/
|
||||||
%{_firmwarepath}/ath6k/
|
%{_firmwarepath}/ath6k/
|
||||||
%{_firmwarepath}/ath9k_htc/
|
%{_firmwarepath}/ath9k_htc/
|
||||||
@ -379,8 +365,6 @@ sed -e 's/^/%%dir /' linux-firmware.dirs >> linux-firmware.files
|
|||||||
%files -n brcmfmac-firmware
|
%files -n brcmfmac-firmware
|
||||||
%license LICENCE.broadcom_bcm43xx
|
%license LICENCE.broadcom_bcm43xx
|
||||||
%license LICENCE.cypress
|
%license LICENCE.cypress
|
||||||
%dir %{_firmwarepath}/brcm
|
|
||||||
%dir %{_firmwarepath}/cypress
|
|
||||||
%{_firmwarepath}/brcm/
|
%{_firmwarepath}/brcm/
|
||||||
%{_firmwarepath}/cypress/
|
%{_firmwarepath}/cypress/
|
||||||
|
|
||||||
@ -451,10 +435,6 @@ sed -e 's/^/%%dir /' linux-firmware.dirs >> linux-firmware.files
|
|||||||
|
|
||||||
%files -n realtek-firmware
|
%files -n realtek-firmware
|
||||||
%license LICENCE.rtlwifi_firmware.txt
|
%license LICENCE.rtlwifi_firmware.txt
|
||||||
%dir %{_firmwarepath}/rtl_bt
|
|
||||||
%dir %{_firmwarepath}/rtlwifi
|
|
||||||
%dir %{_firmwarepath}/rtw88
|
|
||||||
%dir %{_firmwarepath}/rtw89
|
|
||||||
%{_firmwarepath}/rtl_bt/
|
%{_firmwarepath}/rtl_bt/
|
||||||
%{_firmwarepath}/rtlwifi/
|
%{_firmwarepath}/rtlwifi/
|
||||||
%{_firmwarepath}/rtw88/
|
%{_firmwarepath}/rtw88/
|
||||||
@ -495,7 +475,35 @@ sed -e 's/^/%%dir /' linux-firmware.dirs >> linux-firmware.files
|
|||||||
%{_firmwarepath}/v4l-cx2*
|
%{_firmwarepath}/v4l-cx2*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Fri May 26 2023 Herton R. Krzesinski <herton@redhat.com> - 20230515-151
|
* Sun Jul 02 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 20230625-151
|
||||||
|
- Update to upstream 20230625 release
|
||||||
|
- Move to upstreamed compression support
|
||||||
|
- Minor spec cleanups
|
||||||
|
- wilc1000: update WILC1000 firmware to v16.0
|
||||||
|
- ice: update ice DDP wireless_edge package to 1.3.10.0
|
||||||
|
- amdgpu: DMCUB updates for DCN 3.1.4 and 3.1.5
|
||||||
|
- amdgpu: update DMCUB to v0.0.172.0 for various AMDGPU ASICs
|
||||||
|
- qcom: Update the microcode files for Adreno a630 GPUs.
|
||||||
|
- qcom: sdm845: rename the modem firmware
|
||||||
|
- qcom: sdm845: update remoteproc firmware
|
||||||
|
- rtl_bt: Update RTL8852A BT USB firmware to 0xDAC7_480D
|
||||||
|
- rtl_bt: Update RTL8852C BT USB firmware to 0x040D_7225
|
||||||
|
- update firmware for MT7921/MT7922 WiFi device
|
||||||
|
- update firmware for mediatek MT7921/MT7922 bluetooth chip (MT7922)
|
||||||
|
- i915: Add HuC v8.5.0 for MTL
|
||||||
|
- mediatek: Update mt8195 SCP firmware to support hevc
|
||||||
|
- qcom: apq8016: add Dragonboard 410c WiFi and modem firmware
|
||||||
|
- cirrus: Add firmware for new Asus ROG Laptops
|
||||||
|
- brcm: Add symlinks from Pine64 devices to AW-CM256SM.txt
|
||||||
|
- amdgpu: Update GC 11.0.1 and 11.0.4
|
||||||
|
- rtw89: 8851b: add firmware v0.29.41.0
|
||||||
|
- amdgpu: various firmware updates for amd.5.5 release
|
||||||
|
- ice: update ice DDP comms package to 1.3.40.0
|
||||||
|
- rtlwifi: Add firmware v6.0 for RTL8192FU
|
||||||
|
- rtlwifi: Update firmware for RTL8188EU to v28.0
|
||||||
|
- cxgb4: Update firmware to revision 1.27.3.0
|
||||||
|
|
||||||
|
* Fri May 26 2023 Herton R. Krzesinski <herton@redhat.com>
|
||||||
- Join iwl3945-firmware and iwl4965-firmware into iwlegacy-firmware package.
|
- Join iwl3945-firmware and iwl4965-firmware into iwlegacy-firmware package.
|
||||||
- Create iwlwifi-dvm-firmware subpackage and fold some subpackages into it.
|
- Create iwlwifi-dvm-firmware subpackage and fold some subpackages into it.
|
||||||
- Create iwlwifi-mvm-firmware subpackage and fold some subpackages into it.
|
- Create iwlwifi-mvm-firmware subpackage and fold some subpackages into it.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (linux-firmware-20230515.tar.xz) = 9060dde164203516fb01d4920ce245acf17f33b5e707093bd5cfbc18193fd6e91e4a9b721fe46d12420c499254d287d5c1e211ae7c576e450820e8e085d646bd
|
SHA512 (linux-firmware-20230625.tar.xz) = 0e48aa7f63495485426d37491c7cb61843165625bd47f912c5d83628c6de871759f1a78be3af3d651f7c396bd87dff07e21ba7afc47896c1c143106d5f16d351
|
||||||
|
Loading…
Reference in New Issue
Block a user