Update to upstream 20220708 release
- Update to upstream 20220708 release (rhbz 2040281, 2045911, 2105392) - Update compressed firmware support patch for upstream changes Upstream is using 'install -d' instead of 'mkdir -p' now so this patch needs updating to apply. Resolves: rhbz#2040281, rhbz#2045911, rhbz#2105392 Signed-off-by: Patrick Talbert <ptalbert@redhat.com>
This commit is contained in:
parent
208867077c
commit
6db66eb4dd
@ -12,6 +12,11 @@ Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
|
||||
v2: quote filename for xz command
|
||||
|
||||
Conflicts:
|
||||
- Replace 'mkdir -p' with 'install -d' to apply after upstream eaee2dacc2be.
|
||||
|
||||
Signed-off-by: Patrick Talbert <ptalbert@redhat.com>
|
||||
|
||||
Makefile | 4 ++++
|
||||
copy-firmware.sh | 47 +++++++++++++++++++++++++++++++----------------
|
||||
2 files changed, 35 insertions(+), 16 deletions(-)
|
||||
@ -22,11 +27,11 @@ index e1c362f..9a48471 100644
|
||||
+++ b/Makefile
|
||||
@@ -11,3 +11,7 @@ check:
|
||||
install:
|
||||
mkdir -p $(DESTDIR)$(FIRMWAREDIR)
|
||||
install -d $(DESTDIR)$(FIRMWAREDIR)
|
||||
./copy-firmware.sh $(DESTDIR)$(FIRMWAREDIR)
|
||||
+
|
||||
+installcompress:
|
||||
+ mkdir -p $(DESTDIR)$(FIRMWAREDIR)
|
||||
+ install -d $(DESTDIR)$(FIRMWAREDIR)
|
||||
+ ./copy-firmware.sh -C $(DESTDIR)$(FIRMWAREDIR)
|
||||
diff --git a/copy-firmware.sh b/copy-firmware.sh
|
||||
index 9b46b63..0dd2e5c 100755
|
||||
@ -68,11 +73,11 @@ index 9b46b63..0dd2e5c 100755
|
||||
grep '^File:' WHENCE | sed -e's/^File: *//g' -e's/"//g' | while read f; do
|
||||
- test -f "$f" || continue
|
||||
- $verbose "copying file $f"
|
||||
- mkdir -p $destdir/$(dirname "$f")
|
||||
- install -d $destdir/$(dirname "$f")
|
||||
- cp -d "$f" $destdir/"$f"
|
||||
+ test -f "$f$cmpxtn" || continue
|
||||
+ $verbose "copying file $f$cmpxtn"
|
||||
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
|
||||
+ install -d $destdir/$(dirname "$f$cmpxtn")
|
||||
+ cp -d "$f$cmpxtn" $destdir/"$f$cmpxtn"
|
||||
done
|
||||
|
||||
@ -80,11 +85,11 @@ index 9b46b63..0dd2e5c 100755
|
||||
- if test -L "$f"; then
|
||||
- test -f "$destdir/$f" && continue
|
||||
- $verbose "copying link $f"
|
||||
- mkdir -p $destdir/$(dirname "$f")
|
||||
- install -d $destdir/$(dirname "$f")
|
||||
+ if test -L "$f$cmpxtn"; then
|
||||
+ test -f "$destdir/$f$cmpxtn" && continue
|
||||
+ $verbose "copying link $f$cmpxtn"
|
||||
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
|
||||
+ install -d $destdir/$(dirname "$f$cmpxtn")
|
||||
cp -d "$f" $destdir/"$f"
|
||||
|
||||
if test "x$d" != "x"; then
|
||||
@ -110,10 +115,10 @@ index 9b46b63..0dd2e5c 100755
|
||||
fi
|
||||
else
|
||||
- $verbose "creating link $f -> $d"
|
||||
- mkdir -p $destdir/$(dirname "$f")
|
||||
- install -d $destdir/$(dirname "$f")
|
||||
- ln -sf "$d" "$destdir/$f"
|
||||
+ $verbose "creating link $f$cmpxtn -> $d$cmpxtn"
|
||||
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
|
||||
+ install -d $destdir/$(dirname "$f$cmpxtn")
|
||||
+ ln -sf "$d$cmpxtn" "$destdir/$f$cmpxtn"
|
||||
fi
|
||||
done
|
||||
|
@ -1,11 +1,11 @@
|
||||
%global debug_package %{nil}
|
||||
%global firmware_release 126
|
||||
%global firmware_release 127
|
||||
|
||||
%global _firmwarepath /usr/lib/firmware
|
||||
%define _binaries_in_noarch_packages_terminate_build 0
|
||||
|
||||
Name: linux-firmware
|
||||
Version: 20220509
|
||||
Version: 20220708
|
||||
Release: %{firmware_release}%{?dist}
|
||||
Summary: Firmware files used by the Linux kernel
|
||||
License: GPL+ and GPLv2+ and MIT and Redistributable, no modification permitted
|
||||
@ -450,6 +450,95 @@ sed -e 's/^/%%dir /' linux-firmware.dirs >> linux-firmware.files
|
||||
%{_firmwarepath}/netronome/*
|
||||
|
||||
%changelog
|
||||
* Mon Jul 11 2022 Patrick Talbert <ptalbert@redhat.com> - 20220708-127
|
||||
- Update compressed firmware support patch for upstream changes
|
||||
- Update to upstream 20220708 release (rhbz 2040281, 2045911, 2105392).
|
||||
Changes since the last update are noted on items below, copied from
|
||||
the git changelog of upstream linux-firmware repository.
|
||||
- Correct WHENCE entry for wfx firmware
|
||||
- bnx2: Drop unsupported Broadcom NetXtremeII firmware
|
||||
- bnx2: drop unsupported firmwares
|
||||
- bnx2: sort firmware names in filesystem order
|
||||
- Remove old Broadcom Everest (bnx2x) v4/5 firmware
|
||||
- drop Token Ring network firmwares
|
||||
- Drop TDA7706 radio firmware
|
||||
- Drop Intel WiMax firmware
|
||||
- Drop Computone IntelliPort Plus serial firmware
|
||||
- Drop ATM Ambassador devices firmware
|
||||
- brocade: drop old unsupported firmware revs
|
||||
- amdgpu: update yellow carp DMCUB firmware
|
||||
- linux-firmware: update firmware for MT7622 WiFi device
|
||||
- linux-firmware: update firmware for MT7922 WiFi device
|
||||
- linux-firmware: update firmware for mediatek bluetooth chip (MT7922)
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth 9462
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth 9462
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth 9560
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth 9560
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX201
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX201
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX211
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX211
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX210
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX200
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX201
|
||||
- mediatek: Add SCP firmware for MT8186
|
||||
- rtw88: 8822c: Update normal firmware to v9.9.13
|
||||
- rtw88: 8822c: Update normal firmware to v9.9.12
|
||||
- amdgpu: update Yellow Carp VCN firmware
|
||||
- linux-firmware: update firmware for MT7921 WiFi device
|
||||
- linux-firmware: update firmware for mediatek bluetooth chip (MT7921)
|
||||
- qed: update 8.59.1.0 firmware
|
||||
- Link some devices that ship with the AW-CM256SM
|
||||
- Add initial AzureWave AW-CM256SM NVRAM file
|
||||
- Remove the Pine64 Quartz copy of the RPi NVRAM
|
||||
- qca: Update firmware files for BT chip WCN6750.
|
||||
- QCA: Update Bluetooth WCN685x 2.1 firmware to 2.1.0-00409
|
||||
- WHENCE: add symlinks for StarFive based boards
|
||||
- linux-firmware: wilc1000: update WILC1000 firmware to v15.6
|
||||
- brcm: Add NVRAM file 43455 based Wifi/BT module as used on the Quartz64 Model B from Pine64. This file is based on the existing "brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt" NVRAM file.
|
||||
- iwlwifi: add new FWs from core70-87 release
|
||||
- iwlwifi: update 9000-family firmwares to core70-87
|
||||
- rtl_bt: Update RTL8852A BT USB firmware to 0xDFB8_0634
|
||||
- Makefile: replace mkdir by install
|
||||
- iwlwifi: remove old unsupported 3160/7260/7265/8000/8265 firmware
|
||||
- ath11k: WCN6855 hw2.0: update to WLAN.HSP.1.1-03125-QCAHSPSWPL_V1_V2_SILICONZ_LITE-3.6510.9
|
||||
- WHENCE: ath11k: move regdb.bin before board-2.bin
|
||||
- ath10k: QCA9984 hw1.0: update firmware-5.bin to 10.4-3.9.0.2-00157
|
||||
- ath10k: QCA9888 hw2.0: update board-2.bin
|
||||
- ath10k: QCA9888 hw2.0: update firmware-5.bin to 10.4-3.9.0.2-00157
|
||||
- ath10k: QCA4019 hw1.0: update board-2.bin
|
||||
- ath10k: WCN3990 hw1.0: add board-2.bin
|
||||
- amdgpu: update beige goby firmware for 22.10
|
||||
- amdgpu: update renoir firmware for 22.10
|
||||
- amdgpu: update dimgrey cavefish firmware for 22.10
|
||||
- amdgpu: update vega20 firmware for 22.10
|
||||
- amdgpu: update yellow carp firmware for 22.10
|
||||
- amdgpu: update vega12 firmware for 22.10
|
||||
- amdgpu: update navy flounder firmware for 22.10
|
||||
- amdgpu: update vega10 firmware for 22.10
|
||||
- amdgpu: update raven2 firmware for 22.10
|
||||
- amdgpu: update raven firmware for 22.10
|
||||
- amdgpu: update sienna cichlid firmware for 22.10
|
||||
- amdgpu: update green sardine firmware for 22.10
|
||||
- amdgpu: update PCO firmware for 22.10
|
||||
- amdgpu: update vangogh firmware for 22.10
|
||||
- amdgpu: update navi14 firmware for 22.10
|
||||
- amdgpu: update navi12 firmware for 22.10
|
||||
- amdgpu: update navi10 firmware for 22.10
|
||||
- amdgpu: update aldebaran firmware for 22.10
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth 9462
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth 9462
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth 9560
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth 9560
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX201
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX201
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX211
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX211
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX210
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX200
|
||||
- linux-firmware: Update firmware file for Intel Bluetooth AX201
|
||||
- mediatek: Update mt8192 SCP firmware
|
||||
|
||||
* Wed May 11 2022 Patrick Talbert <ptalbert@redhat.com> - 20220509-126
|
||||
- Update to upstream 20220509 release (rhbz 2081548, 2081550, 2068137).
|
||||
Changes since the last update are noted on items below, copied from
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (linux-firmware-20220509.tar.xz) = 944661df910c3dc014509d191a55ce939f3af15dd667a78004bdf5bec2b6a6b7d24110e4243818b0fee319a29c4c64f081d86d2a9b9dbe38a9c6c7e44a1a3978
|
||||
SHA512 (linux-firmware-20220708.tar.xz) = d15a36b8fbbb3680d3bdfa42589fa0db48f6fabfeb943473527482200447125389edf8cb47fe6ad579b005c2636b3a25a2d068c5a7a903a4488625569917bc56
|
||||
|
Loading…
Reference in New Issue
Block a user