import linux-firmware-20220708-127.el9

This commit is contained in:
CentOS Sources 2022-09-27 09:51:18 -04:00 committed by Stepan Oksanichenko
parent 39bfd1efef
commit 68842f5834
4 changed files with 247 additions and 12 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/linux-firmware-20220209.tar.xz
SOURCES/linux-firmware-20220708.tar.xz

View File

@ -1 +1 @@
8a1bb0d65a05f0111a7c741e4454e81c414a2a25 SOURCES/linux-firmware-20220209.tar.xz
d6575be4340c209fc2b00b91b6d94a50f96f2bcd SOURCES/linux-firmware-20220708.tar.xz

View File

@ -12,6 +12,11 @@ Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
v2: quote filename for xz command
Conflicts:
- Replace 'mkdir -p' with 'install -d' to apply after upstream eaee2dacc2be.
Signed-off-by: Patrick Talbert <ptalbert@redhat.com>
Makefile | 4 ++++
copy-firmware.sh | 47 +++++++++++++++++++++++++++++++----------------
2 files changed, 35 insertions(+), 16 deletions(-)
@ -22,11 +27,11 @@ index e1c362f..9a48471 100644
+++ b/Makefile
@@ -11,3 +11,7 @@ check:
install:
mkdir -p $(DESTDIR)$(FIRMWAREDIR)
install -d $(DESTDIR)$(FIRMWAREDIR)
./copy-firmware.sh $(DESTDIR)$(FIRMWAREDIR)
+
+installcompress:
+ mkdir -p $(DESTDIR)$(FIRMWAREDIR)
+ install -d $(DESTDIR)$(FIRMWAREDIR)
+ ./copy-firmware.sh -C $(DESTDIR)$(FIRMWAREDIR)
diff --git a/copy-firmware.sh b/copy-firmware.sh
index 9b46b63..0dd2e5c 100755
@ -68,11 +73,11 @@ index 9b46b63..0dd2e5c 100755
grep '^File:' WHENCE | sed -e's/^File: *//g' -e's/"//g' | while read f; do
- test -f "$f" || continue
- $verbose "copying file $f"
- mkdir -p $destdir/$(dirname "$f")
- install -d $destdir/$(dirname "$f")
- cp -d "$f" $destdir/"$f"
+ test -f "$f$cmpxtn" || continue
+ $verbose "copying file $f$cmpxtn"
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
+ install -d $destdir/$(dirname "$f$cmpxtn")
+ cp -d "$f$cmpxtn" $destdir/"$f$cmpxtn"
done
@ -80,11 +85,11 @@ index 9b46b63..0dd2e5c 100755
- if test -L "$f"; then
- test -f "$destdir/$f" && continue
- $verbose "copying link $f"
- mkdir -p $destdir/$(dirname "$f")
- install -d $destdir/$(dirname "$f")
+ if test -L "$f$cmpxtn"; then
+ test -f "$destdir/$f$cmpxtn" && continue
+ $verbose "copying link $f$cmpxtn"
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
+ install -d $destdir/$(dirname "$f$cmpxtn")
cp -d "$f" $destdir/"$f"
if test "x$d" != "x"; then
@ -110,10 +115,10 @@ index 9b46b63..0dd2e5c 100755
fi
else
- $verbose "creating link $f -> $d"
- mkdir -p $destdir/$(dirname "$f")
- install -d $destdir/$(dirname "$f")
- ln -sf "$d" "$destdir/$f"
+ $verbose "creating link $f$cmpxtn -> $d$cmpxtn"
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
+ install -d $destdir/$(dirname "$f$cmpxtn")
+ ln -sf "$d$cmpxtn" "$destdir/$f$cmpxtn"
fi
done

View File

@ -1,11 +1,11 @@
%global debug_package %{nil}
%global firmware_release 125
%global firmware_release 127
%global _firmwarepath /usr/lib/firmware
%define _binaries_in_noarch_packages_terminate_build 0
Name: linux-firmware
Version: 20220209
Version: 20220708
Release: %{firmware_release}%{?dist}
Summary: Firmware files used by the Linux kernel
License: GPL+ and GPLv2+ and MIT and Redistributable, no modification permitted
@ -450,6 +450,236 @@ sed -e 's/^/%%dir /' linux-firmware.dirs >> linux-firmware.files
%{_firmwarepath}/netronome/*
%changelog
* Mon Jul 11 2022 Patrick Talbert <ptalbert@redhat.com> - 20220708-127
- Update compressed firmware support patch for upstream changes
- Update to upstream 20220708 release (rhbz 2040281, 2045911, 2105392).
Changes since the last update are noted on items below, copied from
the git changelog of upstream linux-firmware repository.
- Correct WHENCE entry for wfx firmware
- bnx2: Drop unsupported Broadcom NetXtremeII firmware
- bnx2: drop unsupported firmwares
- bnx2: sort firmware names in filesystem order
- Remove old Broadcom Everest (bnx2x) v4/5 firmware
- drop Token Ring network firmwares
- Drop TDA7706 radio firmware
- Drop Intel WiMax firmware
- Drop Computone IntelliPort Plus serial firmware
- Drop ATM Ambassador devices firmware
- brocade: drop old unsupported firmware revs
- amdgpu: update yellow carp DMCUB firmware
- linux-firmware: update firmware for MT7622 WiFi device
- linux-firmware: update firmware for MT7922 WiFi device
- linux-firmware: update firmware for mediatek bluetooth chip (MT7922)
- linux-firmware: Update firmware file for Intel Bluetooth 9462
- linux-firmware: Update firmware file for Intel Bluetooth 9462
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX210
- linux-firmware: Update firmware file for Intel Bluetooth AX200
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- mediatek: Add SCP firmware for MT8186
- rtw88: 8822c: Update normal firmware to v9.9.13
- rtw88: 8822c: Update normal firmware to v9.9.12
- amdgpu: update Yellow Carp VCN firmware
- linux-firmware: update firmware for MT7921 WiFi device
- linux-firmware: update firmware for mediatek bluetooth chip (MT7921)
- qed: update 8.59.1.0 firmware
- Link some devices that ship with the AW-CM256SM
- Add initial AzureWave AW-CM256SM NVRAM file
- Remove the Pine64 Quartz copy of the RPi NVRAM
- qca: Update firmware files for BT chip WCN6750.
- QCA: Update Bluetooth WCN685x 2.1 firmware to 2.1.0-00409
- WHENCE: add symlinks for StarFive based boards
- linux-firmware: wilc1000: update WILC1000 firmware to v15.6
- brcm: Add NVRAM file 43455 based Wifi/BT module as used on the Quartz64 Model B from Pine64. This file is based on the existing "brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt" NVRAM file.
- iwlwifi: add new FWs from core70-87 release
- iwlwifi: update 9000-family firmwares to core70-87
- rtl_bt: Update RTL8852A BT USB firmware to 0xDFB8_0634
- Makefile: replace mkdir by install
- iwlwifi: remove old unsupported 3160/7260/7265/8000/8265 firmware
- ath11k: WCN6855 hw2.0: update to WLAN.HSP.1.1-03125-QCAHSPSWPL_V1_V2_SILICONZ_LITE-3.6510.9
- WHENCE: ath11k: move regdb.bin before board-2.bin
- ath10k: QCA9984 hw1.0: update firmware-5.bin to 10.4-3.9.0.2-00157
- ath10k: QCA9888 hw2.0: update board-2.bin
- ath10k: QCA9888 hw2.0: update firmware-5.bin to 10.4-3.9.0.2-00157
- ath10k: QCA4019 hw1.0: update board-2.bin
- ath10k: WCN3990 hw1.0: add board-2.bin
- amdgpu: update beige goby firmware for 22.10
- amdgpu: update renoir firmware for 22.10
- amdgpu: update dimgrey cavefish firmware for 22.10
- amdgpu: update vega20 firmware for 22.10
- amdgpu: update yellow carp firmware for 22.10
- amdgpu: update vega12 firmware for 22.10
- amdgpu: update navy flounder firmware for 22.10
- amdgpu: update vega10 firmware for 22.10
- amdgpu: update raven2 firmware for 22.10
- amdgpu: update raven firmware for 22.10
- amdgpu: update sienna cichlid firmware for 22.10
- amdgpu: update green sardine firmware for 22.10
- amdgpu: update PCO firmware for 22.10
- amdgpu: update vangogh firmware for 22.10
- amdgpu: update navi14 firmware for 22.10
- amdgpu: update navi12 firmware for 22.10
- amdgpu: update navi10 firmware for 22.10
- amdgpu: update aldebaran firmware for 22.10
- linux-firmware: Update firmware file for Intel Bluetooth 9462
- linux-firmware: Update firmware file for Intel Bluetooth 9462
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX210
- linux-firmware: Update firmware file for Intel Bluetooth AX200
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- mediatek: Update mt8192 SCP firmware
* Wed May 11 2022 Patrick Talbert <ptalbert@redhat.com> - 20220509-126
- Update to upstream 20220509 release (rhbz 2081548, 2081550, 2068137).
Changes since the last update are noted on items below, copied from
the git changelog of upstream linux-firmware repository.
- mediatek: Update mt8183 SCP firmware
- ice: Update package to 1.3.28.0
- i915: Add DMC v2.06 for DG2
- rtl_bt: Update RTL8852A BT USB firmware to 0xDBB7_C1D9
- amdgpu: update psp_13_0_8 firmware
- amdgpu: update gc_10_3_7_rlc firmware
- amdgpu: update dcn_3_1_6_dmcub firmware
- ath11k: QCA6390 hw2.0: update to WLAN.HST.1.0.1-05266-QCAHSTSWPLZ_V2_TO_X86-1
- qcom: add firmware files for Adreno a420 & related generations
- qcom: add firmware files for Adreno a330
- qcom: add firmware files for Adreno a220
- i915: Add GuC v70.1.2 for DG2
- rtw89: 8852c: add new firmware v0.27.20.0 for RTL8852C
- Mellanox: Add lc_ini_bundle for xx.2010.1006
- Mellanox: xx.2010.1502: Distribute non-xz-compressed lc_ini_bundle
- ath10k: QCA9984 hw1.0: update board-2.bin
- ath10k: QCA9984 hw1.0: update firmware-5.bin to 10.4-3.9.0.2-00156
- ath10k: QCA9888 hw2.0: update board-2.bin
- ath10k: QCA9888 hw2.0: update firmware-5.bin to 10.4-3.9.0.2-00156
- ath10k: QCA6174 hw3.0: update board-2.bin
- ath10k: QCA6174 hw3.0: update firmware-6.bin to WLAN.RM.4.4.1-00288-QCARMSWPZ-1
- ath10k: QCA4019 hw1.0: update board-2.bin
- ath10k: QCA99X0 hw2.0: add board-2.bin
- ath11k: WCN6855 hw2.0: update to WLAN.HSP.1.1-03125-QCAHSPSWPL_V1_V2_SILICONZ_LITE-3.6510.7
- ath11k: WCN6750 hw1.0: add to WLAN.MSL.1.0.1-00887-QCAMSLSWPLZ-1
- ath11k: WCN6750 hw1.0: add board-2.bin
- ath11k: QCN9074 hw1.0: add to WLAN.HK.2.5.0.1-01208-QCAHKSWPL_SILICONZ-1
- ath11k: QCN9074 hw1.0: add board-2.bin
- ath11k: QCA6390 hw2.0: update board-2.bin
- ath11k: IPQ8074 hw2.0: update to WLAN.HK.2.5.0.1-01208-QCAHKSWPL_SILICONZ-1
- ath11k: IPQ8074 hw2.0: update board-2.bin
- ath11k: IPQ6018 hw1.0: update to WLAN.HK.2.5.0.1-01208-QCAHKSWPL_SILICONZ-1
- ath11k: IPQ6018 hw1.0: update board-2.bin
- Mellanox: Add new mlxsw_spectrum firmware xx.2010.1502
- amdgpu: update yellow carp DMCUB firmware
- linux-firmware: update firmware for mediatek bluetooth chip (MT7922)
- linux-firmware: update firmware for MT7922 WiFi device
- mediatek: Add mt8195 SCP firmware
- qcom: apq8096: add modem firmware
- qcom: apq8096: add aDSP firmware
- rtl_bt: Add firmware and config files for RTL8852C
- mediatek: Add mt8192 SCP firmware
- linux-firmware: Update AMD cpu microcode
- nvidia: add GA102/GA103/GA104/GA106/GA107 signed firmware
- brcm: rename Rock960 NVRAM to AP6356S and link devices to it
- linux-firmware: Update firmware file for Intel Bluetooth 9462
- linux-firmware: Update firmware file for Intel Bluetooth 9462
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX210
- linux-firmware: Update firmware file for Intel Bluetooth AX200
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth 9260
- amdgpu: update green sardine VCN firmware
- amdgpu: update renoir VCN firmware
- amdgpu: update navi14 VCN firmware
- amdgpu: update navi12 VCN firmware
- amdgpu: update navi10 VCN firmware
- linux-firmware: update firmware for MT7921 WiFi device
- linux-firmware: update firmware for mediatek bluetooth chip (MT7921)
- i915: Add GuC v70.1.1 for all platforms
- rtw88: 8821c: Update normal firmware to v24.11.00
- ice: Add wireless edge file for Intel E800 series driver
- ice: update ice DDP comms package to 1.3.31.0
- amdgpu: update PSP 13.0.8 firmware
- amdgpu: update GC 10.3.7 firmware
- rtl_bt: Add firmware and config files for RTL8852B
- iwlwifi: add new FWs from core68-60 release
- ath11k: add links for WCN6855 hw2.1
- ath11k: WCN6855 hw2.0: add WLAN.HSP.1.1-03125-QCAHSPSWPL_V1_V2_SILICONZ_LITE-3
- ath11k: WCN6855 hw2.0: add board-2.bin and regdb.bin
- ath10k/ath11k: mark notice.txt as "File:"
- linux-firmware: add firmware for MT7986
- amdgpu: add firmware for SDMA 5.2.7 IP block
- amdgpu: add firmware for PSP 13.0.8 IP block
- amdgpu: add firmware for DCN 3.1.6 IP block
- amdgpu: add firmware for GC 10.3.7 IP block
- rtw89: 8852a: update fw to v0.13.36.0
- iwlwifi: update 9000-family firmwares to core68-60
- amdgpu: update raven2 VCN firmware
- amdgpu: update raven VCN firmware
- amdgpu: update picasso VCN firmware
- linux-firmware: Update firmware file for Intel Bluetooth 9462
- linux-firmware: Update firmware file for Intel Bluetooth 9462
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX211
- linux-firmware: Update firmware file for Intel Bluetooth AX210
- linux-firmware: Update firmware file for Intel Bluetooth AX200
- linux-firmware: Update firmware file for Intel Bluetooth AX201
- linux-firmware: Update firmware file for Intel Bluetooth 9560
- linux-firmware: Update firmware file for Intel Bluetooth 9260
- linux-firmware: Update AMD SEV firmware
- rtw89: 8852a: update fw to v0.13.35.0
- Mellanox: Add new mlxsw_spectrum firmware xx.2010.1406
- wfx: update to firmware 3.14
- wfx: add antenna configuration files
- wfx: rename silabs/ into wfx/
- linux-firmware: update firmware for mediatek bluetooth chip(MT7921)
- linux-firmware: Update firmware patch for Intel Bluetooth 8260
- linux-firmware: Update firmware file for Intel Bluetooth 8265
- linux-firmware: Intel BT 7265: Fix Security Issues
- rtl_bt: Update RTL8852A BT USB firmware to 0xDFB7_6D7A
- rtl_bt: Update RTL8822C BT USB firmware to 0x19B7_6D7D
- rtl_bt: Update RTL8822C BT UART firmware to 0x15B7_6D7D
- amdgpu: Update yellow carp firmware from 21.50
- amdgpu: Update vega20 firmware from 21.50
- amdgpu: Update vega12 firmware from 21.50
- amdgpu: Update vega10 firmware from 21.50
- amdgpu: Update vangogh firmware from 21.50
- amdgpu: Update renoir firmware from 21.50
- amdgpu: Update raven2 firmware from 21.50
- amdgpu: Update raven firmware from 21.50
- amdgpu: Update picasso firmware from 21.50
- amdgpu: Update beige goby firmware from 21.50
- amdgpu: Update dimgrey cavefish firmware from 21.50
- amdgpu: Update navy flounder firmware from 21.50
- amdgpu: Update sienna cichlid firmware from 21.50
- amdgpu: Update navi14 firmware from 21.50
- amdgpu: Update navi12 firmware from 21.50
- amdgpu: Update navi10 firmware from 21.50
- amdgpu: Update cyan skillfish2 firmware from 21.50
- amdgpu: Update green sardine firmware from 21.50
- amdgpu: Update arcturus firmware from 21.50
- amdgpu: Add aldebaran firmware from 21.50
- LICENSE.amdgpu: update copyright date
- linux-firmware: Update AMD cpu microcode
- linux-firmware: update firmware for MT7921 WiFi device
* Thu Feb 10 2022 Herton R. Krzesinski <herton@redhat.com> - 20220209-125
- Update to upstream 20220209 release (rhbz 1967151, 2031174). Changes
since the last update are noted on items below, copied from the git