import linux-firmware-20220209-126.el9_0
This commit is contained in:
commit
1425e501de
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/linux-firmware-20220209.tar.xz
|
1
.linux-firmware.metadata
Normal file
1
.linux-firmware.metadata
Normal file
@ -0,0 +1 @@
|
||||
8a1bb0d65a05f0111a7c741e4454e81c414a2a25 SOURCES/linux-firmware-20220209.tar.xz
|
@ -0,0 +1,123 @@
|
||||
From 7eec2b56f54c778d5bd6e7aea49ee03e3b76e769 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Fri, 22 Jan 2021 20:36:23 +0000
|
||||
Subject: [PATCH v2] Add support for compressing firmware in copy-firmware.sh
|
||||
|
||||
As of kernel 5.3 there's initial support for loading compressed firmware.
|
||||
At this stage the only supported compression methis is "xz -C crc32" but
|
||||
this option brings significant benefits.
|
||||
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
|
||||
v2: quote filename for xz command
|
||||
|
||||
Makefile | 4 ++++
|
||||
copy-firmware.sh | 47 +++++++++++++++++++++++++++++++----------------
|
||||
2 files changed, 35 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index e1c362f..9a48471 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -11,3 +11,7 @@ check:
|
||||
install:
|
||||
mkdir -p $(DESTDIR)$(FIRMWAREDIR)
|
||||
./copy-firmware.sh $(DESTDIR)$(FIRMWAREDIR)
|
||||
+
|
||||
+installcompress:
|
||||
+ mkdir -p $(DESTDIR)$(FIRMWAREDIR)
|
||||
+ ./copy-firmware.sh -C $(DESTDIR)$(FIRMWAREDIR)
|
||||
diff --git a/copy-firmware.sh b/copy-firmware.sh
|
||||
index 9b46b63..0dd2e5c 100755
|
||||
--- a/copy-firmware.sh
|
||||
+++ b/copy-firmware.sh
|
||||
@@ -6,6 +6,7 @@
|
||||
|
||||
verbose=:
|
||||
prune=no
|
||||
+compress=no
|
||||
|
||||
while test $# -gt 0; do
|
||||
case $1 in
|
||||
@@ -19,6 +20,11 @@ while test $# -gt 0; do
|
||||
shift
|
||||
;;
|
||||
|
||||
+ -C | --compress)
|
||||
+ compress=yes
|
||||
+ shift
|
||||
+ ;;
|
||||
+
|
||||
*)
|
||||
if test "x$destdir" != "x"; then
|
||||
echo "ERROR: unknown command-line options: $@"
|
||||
@@ -31,40 +37,49 @@ while test $# -gt 0; do
|
||||
esac
|
||||
done
|
||||
|
||||
+if test "x$compress" = "xyes"; then
|
||||
+ cmpxtn=.xz
|
||||
+ grep '^File:' WHENCE | sed -e's/^File: *//g' -e's/"//g' | while read f; do
|
||||
+ test -f "$f" || continue
|
||||
+ $verbose "compressing $f"
|
||||
+ xz -C crc32 "$f"
|
||||
+ done
|
||||
+fi
|
||||
+
|
||||
grep '^File:' WHENCE | sed -e's/^File: *//g' -e's/"//g' | while read f; do
|
||||
- test -f "$f" || continue
|
||||
- $verbose "copying file $f"
|
||||
- mkdir -p $destdir/$(dirname "$f")
|
||||
- cp -d "$f" $destdir/"$f"
|
||||
+ test -f "$f$cmpxtn" || continue
|
||||
+ $verbose "copying file $f$cmpxtn"
|
||||
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
|
||||
+ cp -d "$f$cmpxtn" $destdir/"$f$cmpxtn"
|
||||
done
|
||||
|
||||
grep -E '^Link:' WHENCE | sed -e's/^Link: *//g' -e's/-> //g' | while read f d; do
|
||||
- if test -L "$f"; then
|
||||
- test -f "$destdir/$f" && continue
|
||||
- $verbose "copying link $f"
|
||||
- mkdir -p $destdir/$(dirname "$f")
|
||||
+ if test -L "$f$cmpxtn"; then
|
||||
+ test -f "$destdir/$f$cmpxtn" && continue
|
||||
+ $verbose "copying link $f$cmpxtn"
|
||||
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
|
||||
cp -d "$f" $destdir/"$f"
|
||||
|
||||
if test "x$d" != "x"; then
|
||||
- target=`readlink "$f"`
|
||||
+ target=`readlink "$f$cmpxtn"`
|
||||
|
||||
if test "x$target" != "x$d"; then
|
||||
$verbose "WARNING: inconsistent symlink target: $target != $d"
|
||||
else
|
||||
if test "x$prune" != "xyes"; then
|
||||
- $verbose "WARNING: unneeded symlink detected: $f"
|
||||
+ $verbose "WARNING: unneeded symlink detected: $f$cmpxtn"
|
||||
else
|
||||
- $verbose "WARNING: pruning unneeded symlink $f"
|
||||
- rm -f "$f"
|
||||
+ $verbose "WARNING: pruning unneeded symlink $f$cmpxtn"
|
||||
+ rm -f "$f$cmpxtn"
|
||||
fi
|
||||
fi
|
||||
else
|
||||
- $verbose "WARNING: missing target for symlink $f"
|
||||
+ $verbose "WARNING: missing target for symlink $f$cmpxtn"
|
||||
fi
|
||||
else
|
||||
- $verbose "creating link $f -> $d"
|
||||
- mkdir -p $destdir/$(dirname "$f")
|
||||
- ln -sf "$d" "$destdir/$f"
|
||||
+ $verbose "creating link $f$cmpxtn -> $d$cmpxtn"
|
||||
+ mkdir -p $destdir/$(dirname "$f$cmpxtn")
|
||||
+ ln -sf "$d$cmpxtn" "$destdir/$f$cmpxtn"
|
||||
fi
|
||||
done
|
||||
|
||||
--
|
||||
2.29.2
|
||||
|
125
SOURCES/0002-ath10k-ath11k-mark-notice.txt-as-File.patch
Normal file
125
SOURCES/0002-ath10k-ath11k-mark-notice.txt-as-File.patch
Normal file
@ -0,0 +1,125 @@
|
||||
From 4e3fc4d69b34cd4d5373b862a02f19ebaaf1d21e Mon Sep 17 00:00:00 2001
|
||||
From: Kalle Valo <kvalo@qca.qualcomm.com>
|
||||
Date: Mon, 7 Mar 2022 19:00:57 +0200
|
||||
Subject: [PATCH 2/5] ath10k/ath11k: mark notice.txt as "File:"
|
||||
|
||||
This way there's no confusion between the actual license file and notice.txt.
|
||||
|
||||
Discussion:
|
||||
|
||||
https://lore.kernel.org/all/CA+5PVA6R6F=VqAZRf=xDwGcC+cpqLY1kStkoHck53XiLURVyaw@mail.gmail.com/
|
||||
|
||||
Signed-off-by: Kalle Valo <kvalo@qca.qualcomm.com>
|
||||
---
|
||||
WHENCE | 36 ++++++++++++++++++------------------
|
||||
1 file changed, 18 insertions(+), 18 deletions(-)
|
||||
|
||||
diff --git a/WHENCE b/WHENCE
|
||||
index 423f0d8..0a08f87 100644
|
||||
--- a/WHENCE
|
||||
+++ b/WHENCE
|
||||
@@ -3568,62 +3568,62 @@ Driver: ath10k - Qualcomm Atheros support for QCA988x family of chips
|
||||
File: ath10k/QCA988X/hw2.0/board.bin
|
||||
File: ath10k/QCA988X/hw2.0/firmware-4.bin
|
||||
Version: 10.2.4.45
|
||||
-Licence: ath10k/QCA988X/hw2.0/notice_ath10k_firmware-4.txt
|
||||
+File: ath10k/QCA988X/hw2.0/notice_ath10k_firmware-4.txt
|
||||
File: ath10k/QCA988X/hw2.0/firmware-5.bin
|
||||
Version: 10.2.4-1.0-00047
|
||||
-Licence: ath10k/QCA988X/hw2.0/notice_ath10k_firmware-5.txt
|
||||
+File: ath10k/QCA988X/hw2.0/notice_ath10k_firmware-5.txt
|
||||
File: ath10k/QCA6174/hw2.1/board.bin
|
||||
File: ath10k/QCA6174/hw2.1/board-2.bin
|
||||
File: ath10k/QCA6174/hw2.1/firmware-5.bin
|
||||
Version: SW_RM.1.1.1-00157-QCARMSWPZ-1
|
||||
-Licence: ath10k/QCA6174/hw2.1/notice_ath10k_firmware-5.txt
|
||||
+File: ath10k/QCA6174/hw2.1/notice_ath10k_firmware-5.txt
|
||||
File: ath10k/QCA6174/hw3.0/board.bin
|
||||
File: ath10k/QCA6174/hw3.0/board-2.bin
|
||||
File: ath10k/QCA6174/hw3.0/firmware-4.bin
|
||||
Version: WLAN.RM.2.0-00180-QCARMSWPZ-1
|
||||
-Licence: ath10k/QCA6174/hw3.0/notice_ath10k_firmware-4.txt
|
||||
+File: ath10k/QCA6174/hw3.0/notice_ath10k_firmware-4.txt
|
||||
File: ath10k/QCA6174/hw3.0/firmware-6.bin
|
||||
Version: WLAN.RM.4.4.1-00157-QCARMSWPZ-1
|
||||
-Licence: ath10k/QCA6174/hw3.0/notice_ath10k_firmware-6.txt
|
||||
+File: ath10k/QCA6174/hw3.0/notice_ath10k_firmware-6.txt
|
||||
File: ath10k/QCA6174/hw3.0/firmware-sdio-6.bin
|
||||
Version: WLAN.RMH.4.4.1-00077
|
||||
-Licence: ath10k/QCA6174/hw3.0/notice_ath10k_firmware-sdio-6.txt
|
||||
+File: ath10k/QCA6174/hw3.0/notice_ath10k_firmware-sdio-6.txt
|
||||
File: ath10k/QCA9377/hw1.0/board.bin
|
||||
File: ath10k/QCA9377/hw1.0/board-2.bin
|
||||
File: ath10k/QCA9377/hw1.0/firmware-5.bin
|
||||
Version: WLAN.TF.1.0-00002-QCATFSWPZ-5
|
||||
-Licence: ath10k/QCA9377/hw1.0/notice_ath10k_firmware-5.txt
|
||||
+File: ath10k/QCA9377/hw1.0/notice_ath10k_firmware-5.txt
|
||||
File: ath10k/QCA9377/hw1.0/firmware-sdio-5.bin
|
||||
Version: WLAN.TF.1.1.1-00061-QCATFSWPZ-1
|
||||
-Licence: ath10k/QCA9377/hw1.0/notice_ath10k_firmware-sdio-5.txt
|
||||
+File: ath10k/QCA9377/hw1.0/notice_ath10k_firmware-sdio-5.txt
|
||||
File: ath10k/QCA99X0/hw2.0/board.bin
|
||||
File: ath10k/QCA99X0/hw2.0/firmware-5.bin
|
||||
Version: 10.4.1.00030-1
|
||||
-Licence: ath10k/QCA99X0/hw2.0/notice_ath10k_firmware-5.txt
|
||||
+File: ath10k/QCA99X0/hw2.0/notice_ath10k_firmware-5.txt
|
||||
File: ath10k/QCA4019/hw1.0/board-2.bin
|
||||
File: ath10k/QCA4019/hw1.0/firmware-5.bin
|
||||
Version: 10.4-3.6-00140
|
||||
-Licence: ath10k/QCA4019/hw1.0/notice_ath10k_firmware-5.txt
|
||||
+File: ath10k/QCA4019/hw1.0/notice_ath10k_firmware-5.txt
|
||||
File: ath10k/QCA9887/hw1.0/board.bin
|
||||
File: ath10k/QCA9887/hw1.0/firmware-5.bin
|
||||
Version: 10.2.4-1.0-00047
|
||||
-Licence: ath10k/QCA9887/hw1.0/notice_ath10k_firmware-5.txt
|
||||
+File: ath10k/QCA9887/hw1.0/notice_ath10k_firmware-5.txt
|
||||
File: ath10k/QCA9888/hw2.0/board-2.bin
|
||||
File: ath10k/QCA9888/hw2.0/firmware-5.bin
|
||||
Version: 10.4-3.9.0.2-00131
|
||||
-Licence: ath10k/QCA9888/hw2.0/notice_ath10k_firmware-5.txt
|
||||
+File: ath10k/QCA9888/hw2.0/notice_ath10k_firmware-5.txt
|
||||
File: ath10k/QCA9984/hw1.0/board-2.bin
|
||||
File: ath10k/QCA9984/hw1.0/firmware-5.bin
|
||||
Version: 10.4-3.9.0.2-00131
|
||||
-Licence: ath10k/QCA9984/hw1.0/notice_ath10k_firmware-5.txt
|
||||
+File: ath10k/QCA9984/hw1.0/notice_ath10k_firmware-5.txt
|
||||
File: ath10k/QCA9377/hw1.0/firmware-6.bin
|
||||
Version: WLAN.TF.2.1-00021-QCARMSWP-1
|
||||
-Licence: ath10k/QCA9377/hw1.0/notice_ath10k_firmware-6.txt
|
||||
+File: ath10k/QCA9377/hw1.0/notice_ath10k_firmware-6.txt
|
||||
File: ath10k/WCN3990/hw1.0/firmware-5.bin
|
||||
File: ath10k/WCN3990/hw1.0/wlanmdsp.mbn
|
||||
Link: qcom/sdm845/wlanmdsp.mbn -> ../../ath10k/WCN3990/hw1.0/wlanmdsp.mbn
|
||||
Version: WLAN.HL.2.0-01387-QCAHLSWMTPLZ-1
|
||||
-Licence: ath10k/WCN3990/hw1.0/notice.txt_wlanmdsp
|
||||
+File: ath10k/WCN3990/hw1.0/notice.txt_wlanmdsp
|
||||
|
||||
Licence: Redistributable. See LICENSE.QualcommAtheros_ath10k for details
|
||||
|
||||
@@ -3648,7 +3648,7 @@ File: ath11k/IPQ6018/hw1.0/q6_fw.b08
|
||||
File: ath11k/IPQ6018/hw1.0/q6_fw.flist
|
||||
File: ath11k/IPQ6018/hw1.0/q6_fw.mdt
|
||||
Version: WLAN.HK.2.1.0.1-01238-QCAHKSWPL_SILICONZ-2
|
||||
-Licence: ath11k/IPQ6018/hw1.0/Notice.txt
|
||||
+File: ath11k/IPQ6018/hw1.0/Notice.txt
|
||||
File: ath11k/IPQ8074/hw2.0/board-2.bin
|
||||
File: ath11k/IPQ8074/hw2.0/m3_fw.b00
|
||||
File: ath11k/IPQ8074/hw2.0/m3_fw.b01
|
||||
@@ -3666,12 +3666,12 @@ File: ath11k/IPQ8074/hw2.0/q6_fw.b08
|
||||
File: ath11k/IPQ8074/hw2.0/q6_fw.flist
|
||||
File: ath11k/IPQ8074/hw2.0/q6_fw.mdt
|
||||
Version: WLAN.HK.2.1.0.1-01238-QCAHKSWPL_SILICONZ-2
|
||||
-Licence: ath11k/IPQ8074/hw2.0/Notice.txt
|
||||
+File: ath11k/IPQ8074/hw2.0/Notice.txt
|
||||
File: ath11k/QCA6390/hw2.0/board-2.bin
|
||||
File: ath11k/QCA6390/hw2.0/amss.bin
|
||||
File: ath11k/QCA6390/hw2.0/m3.bin
|
||||
Version: WLAN.HST.1.0.1-01740-QCAHSTSWPLZ_V2_TO_X86-1
|
||||
-Licence: ath11k/QCA6390/hw2.0/Notice.txt
|
||||
+File: ath11k/QCA6390/hw2.0/Notice.txt
|
||||
|
||||
Licence: Redistributable. See LICENSE.QualcommAtheros_ath10k for details
|
||||
|
||||
--
|
||||
2.35.1
|
||||
|
File diff suppressed because it is too large
Load Diff
48575
SOURCES/0004-ath11k-WCN6855-hw2.0-add-WLAN.HSP.1.1-03125-QCAHSPSW.patch
Normal file
48575
SOURCES/0004-ath11k-WCN6855-hw2.0-add-WLAN.HSP.1.1-03125-QCAHSPSW.patch
Normal file
File diff suppressed because it is too large
Load Diff
30
SOURCES/0005-ath11k-add-links-for-WCN6855-hw2.1.patch
Normal file
30
SOURCES/0005-ath11k-add-links-for-WCN6855-hw2.1.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From e8bc0db413b4ab7f8e540ffa17991ff61252de9c Mon Sep 17 00:00:00 2001
|
||||
From: Kalle Valo <kvalo@qca.qualcomm.com>
|
||||
Date: Mon, 7 Mar 2022 19:18:22 +0200
|
||||
Subject: [PATCH 5/5] ath11k: add links for WCN6855 hw2.1
|
||||
|
||||
At the moment WCN6855 hw2.1 uses the same firmware files as hw2.0 so add links for them.
|
||||
|
||||
Signed-off-by: Kalle Valo <kvalo@qca.qualcomm.com>
|
||||
---
|
||||
WHENCE | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/WHENCE b/WHENCE
|
||||
index b4c127f..1778ca1 100644
|
||||
--- a/WHENCE
|
||||
+++ b/WHENCE
|
||||
@@ -3678,6 +3678,10 @@ File: ath11k/WCN6855/hw2.0/amss.bin
|
||||
File: ath11k/WCN6855/hw2.0/m3.bin
|
||||
Version: WLAN.HSP.1.1-03125-QCAHSPSWPL_V1_V2_SILICONZ_LITE-3
|
||||
File: ath11k/WCN6855/hw2.0/Notice.txt
|
||||
+Link: ath11k/WCN6855/hw2.1/board-2.bin -> ../hw2.0/board-2.bin
|
||||
+Link: ath11k/WCN6855/hw2.1/regdb.bin -> ../hw2.0/regdb.bin
|
||||
+Link: ath11k/WCN6855/hw2.1/amss.bin -> ../hw2.0/amss.bin
|
||||
+Link: ath11k/WCN6855/hw2.1/m3.bin -> ../hw2.0/m3.bin
|
||||
|
||||
Licence: Redistributable. See LICENSE.QualcommAtheros_ath10k for details
|
||||
|
||||
--
|
||||
2.35.1
|
||||
|
1287
SPECS/linux-firmware.spec
Normal file
1287
SPECS/linux-firmware.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user