diff --git a/SPECS/linux-firmware-raspberrypi.spec b/SPECS/linux-firmware-raspberrypi.spec
index 01845fb..7356f0c 100644
--- a/SPECS/linux-firmware-raspberrypi.spec
+++ b/SPECS/linux-firmware-raspberrypi.spec
@@ -1,5 +1,5 @@
%global _firmwarepath /usr/lib/firmware
-%global fn_commit 995129a86915fa3165a24d0a29419f6349f8f36b
+%global fn_commit 223ccf3a3ddb11b3ea829749fbbba4d65b380897
%global fn_shortcommit %(c=%{commit}; echo ${c:0:7})
%global bz_commit d9d4741caba7314d6500f588b1eaa5ab387a4ff5
%global bz_shortcommit %(c=%{bz_commit}; echo ${c:0:7})
@@ -7,7 +7,7 @@
%global bz_srcdir bluez-firmware-%{bz_commit}
Name: linux-firmware-raspberrypi
-Version: 20231117
+Version: 20240528
Release: 1%{?dist}
Summary: Supplemental firmware used by Linux kernel for some Raspberry Pi models
BuildArch: noarch
@@ -39,7 +39,7 @@ install -c -m 644 debian/config/brcm80211/brcm/brcmfmac43456-sdio.bin %{buildroo
install -c -m 644 debian/config/brcm80211/brcm/brcmfmac43456-sdio.clm_blob %{buildroot}%{_firmwarepath}/brcm/
# Bluetooth for RPi Zero 2W
install -c -m 644 %{bz_srcdir}/debian/firmware/broadcom/BCM43430B0.hcd %{buildroot}%{_firmwarepath}/brcm/
-# Bluetooth for RPi 3B+
+# Bluetooth for RPi 3B+, 4, 5
install -c -m 644 %{bz_srcdir}/debian/firmware/broadcom/BCM43430A1.hcd %{buildroot}%{_firmwarepath}/brcm/
install -c -m 644 %{bz_srcdir}/debian/firmware/broadcom/BCM4345C0.hcd %{buildroot}%{_firmwarepath}/brcm/
# Bluetooth for RPi 400
@@ -53,14 +53,24 @@ xz -C crc32 %{buildroot}%{_firmwarepath}/brcm/BCM43430B0.hcd
xz -C crc32 %{buildroot}%{_firmwarepath}/brcm/BCM4345C0.hcd
xz -C crc32 %{buildroot}%{_firmwarepath}/brcm/BCM4345C5.hcd
# Create model-specific symlinks
+# Raspberry Pi 400
ln -s brcmfmac43456-sdio.bin.xz %{buildroot}%{_firmwarepath}/brcm/brcmfmac43456-sdio.raspberrypi,400.bin.xz
ln -s brcmfmac43456-sdio.clm_blob.xz %{buildroot}%{_firmwarepath}/brcm/brcmfmac43456-sdio.raspberrypi,400.clm_blob.xz
ln -s brcmfmac43456-sdio.txt.xz %{buildroot}%{_firmwarepath}/brcm/brcmfmac43456-sdio.raspberrypi,400.txt.xz
+# Raspberry Pi 5
+ln -s BCM4345C0.hcd.xz %{buildroot}%{_firmwarepath}/brcm/BCM4345C0.raspberrypi,5-model-b.hcd.xz
+ln -s brcmfmac43455-sdio.bin.xz %{buildroot}%{_firmwarepath}/brcm/brcmfmac43455-sdio.raspberrypi,5-model-b.bin.xz
+ln -s brcmfmac43455-sdio.clm_blob.xz %{buildroot}%{_firmwarepath}/brcm/brcmfmac43455-sdio.raspberrypi,5-model-b.clm_blob.xz
+ln -s brcmfmac43455-sdio.txt.xz %{buildroot}%{_firmwarepath}/brcm/brcmfmac43456-sdio.raspberrypi,5-model-b.txt.xz
%files
%{_firmwarepath}/brcm/*
%changelog
+* Fri Nov 17 2023 Koichiro Iwao - 20240528-1
+- Update firmware-nonfree to 223ccf3
+- Add symlink for RPi 5
+
* Fri Nov 17 2023 Koichiro Iwao - 20231117-1
- Add firmware to support Bluetooth for RPi 3B+, Zero 2 W and 400