libyami package is retired on c9s for CS-362

This commit is contained in:
Troy Dawson 2022-04-14 12:44:32 -07:00
parent f5e84ee01f
commit cbaa632da4
7 changed files with 1 additions and 184 deletions

1
.gitignore vendored
View File

@ -1 +0,0 @@
libyami-*.tar.gz

View File

@ -1,3 +0,0 @@
# libyami
The libyami package

1
dead.package Normal file
View File

@ -0,0 +1 @@
libyami package is retired on c9s for CS-362

View File

@ -1,21 +0,0 @@
diff -up libyami-edd1ad15e383d32c8d67bdc9198c834b6acebca5/encoder/vaapiencoder_base.cpp.init libyami-edd1ad15e383d32c8d67bdc9198c834b6acebca5/encoder/vaapiencoder_base.cpp
--- libyami-edd1ad15e383d32c8d67bdc9198c834b6acebca5/encoder/vaapiencoder_base.cpp.init 2020-01-30 04:35:19.000000000 +0100
+++ libyami-edd1ad15e383d32c8d67bdc9198c834b6acebca5/encoder/vaapiencoder_base.cpp 2020-02-06 20:46:24.670371008 +0100
@@ -678,7 +678,7 @@ YamiStatus VaapiEncoderBase::checkCodecD
#ifndef __BUILD_GET_MV__
YamiStatus VaapiEncoderBase::getOutput(VideoEncOutputBuffer* outBuffer, bool withWait)
{
- bool isEmpty;
+ bool isEmpty = true;
PicturePtr picture;
YamiStatus ret;
FUNC_ENTER();
@@ -703,7 +703,7 @@ YamiStatus VaapiEncoderBase::getOutput(V
{
void *data = NULL;
uint32_t mappedSize;
- bool isEmpty;
+ bool isEmpty = true;
PicturePtr picture;
YamiStatus ret;
FUNC_ENTER();

View File

@ -1,13 +0,0 @@
diff -up libyami-40fa32e79f12c3c85c360532be00b7e4f9a35920/configure.ac.obs libyami-40fa32e79f12c3c85c360532be00b7e4f9a35920/configure.ac
--- libyami-40fa32e79f12c3c85c360532be00b7e4f9a35920/configure.ac.obs 2018-03-08 12:46:30.000000000 +0100
+++ libyami-40fa32e79f12c3c85c360532be00b7e4f9a35920/configure.ac 2018-03-09 17:30:04.515833627 +0100
@@ -417,8 +417,7 @@ AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
-AC_PROG_LIBTOOL
-#LT_INIT
+LT_INIT
# Checks for libraries.
# Checks for header files.

View File

@ -1,145 +0,0 @@
%global commit0 edd1ad15e383d32c8d67bdc9198c834b6acebca5
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
%global commitdate0 20200125
Name: libyami
Version: 1.3.2
Release: 4.%{commitdate0}git%{shortcommit0}%{?dist}
Summary: Yet Another Media Infrastructure
License: ASL 2.0 and BSD
URL: https://github.com/intel/libyami
Source0: %{url}/archive/%{commit0}/%{name}-%{shortcommit0}.tar.gz
Patch0: libyami-libtool-macro.patch
Patch1: libyami-init-bool.patch
BuildRequires: libtool
BuildRequires: gcc-c++
BuildRequires: libva-devel
BuildRequires: pkgconfig(libdrm)
BuildRequires: pkgconfig(x11)
%{?_with_tests:
BuildRequires: gtest-devel
BuildRequires: make
}
%description
It is YUMMY to your video experience on Linux like platform.
Yami is a core building block for media solutions. It parses video streams
and decodes them leveraging hardware acceleration.
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%prep
%autosetup -p1 -n libyami-%{commit0}
autoreconf -vif
%build
%configure \
--disable-static \
--enable-dmabuf \
--enable-wayland \
--enable-mpeg2dec \
--enable-vp9dec \
--enable-vc1dec \
--enable-fakedec \
--enable-jpegenc \
--enable-vp8svct \
--enable-vp9enc \
--enable-h265enc \
%{?_with_tests:--enable-tests}
%make_build V=1
%install
%make_install
find %{buildroot} -name '*.la' -exec rm -f {} ';'
%{?_with_tests:
%check
# Some tests require a va-api backend (and X11 server)
make check
}
%ldconfig_scriptlets
%files
%license LICENSE.md
%license codecparsers/dboolhuff.LICENSE codecparsers/vp9quant.LICENSE
%doc NEWS README.md
%{_libdir}/*.so.1*
%files devel
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/pkgconfig/libyami.pc
%changelog
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.3.2-4.20200125gitedd1ad1
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.2-3.20200125gitedd1ad1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.2-2.20200125gitedd1ad1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Thu Feb 06 2020 Nicolas Chauvet <kwizart@gmail.com> - 1.3.2-1.20200125gitedd1ad1
- Update to 1.3.2
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-6.20190612gitb0ba3b1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-5.20190612gitb0ba3b1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Tue Jul 02 2019 Nicolas Chauvet <kwizart@gmail.com> - 1.3.1-4.20190612gitb0ba3b1
- Update snapshot
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-3.20180918gitfb48083
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Fri Oct 05 2018 Nicolas Chauvet <kwizart@gmail.com> - 1.3.1-2.20180918gitfb48083
- Update commit0
* Fri Oct 05 2018 Nicolas Chauvet <kwizart@gmail.com> - 1.3.1-1.20180510git0067a64
- Update to 1.3.1
* Sun Aug 05 2018 Nicolas Chauvet <kwizart@gmail.com> - 1.3.0-6.20180510git0067a64
- Update to 20180510 git snapshot
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-5.20180228git40fa32e
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Fri Mar 16 2018 Nicolas Chauvet <kwizart@gmail.com> - 1.3.0-4.20180228git40fa32e
- Switch to --with tests (opt-in)
* Fri Mar 09 2018 Nicolas Chauvet <kwizart@gmail.com> - 1.3.0-3.20180228git40fa32e
- Improve dist tag with commitdate0
- Correct license
- Disable obsolete libtool macro
* Thu Mar 08 2018 Nicolas Chauvet <kwizart@gmail.com> - 1.3.0-2.git40fa32e
- Switch to current git
- Improve descrition
- Enable more parsers
- Enable make check (unless gcc8 and 32bit)
* Wed Jan 24 2018 Nicolas Chauvet <kwizart@gmail.com> - 1.3.0-1
- Initial spec file

View File

@ -1 +0,0 @@
SHA512 (libyami-edd1ad1.tar.gz) = b1980cd646f874ae9c2efe268b2084da3e13da9335e6e49bc30c991059428d4fee36cf98a785445a66365e838c02b5019bdbdece9b6e71484b5a07a6f7394294