diff --git a/key.patch b/key.patch
index d79936e..5502031 100644
--- a/key.patch
+++ b/key.patch
@@ -215,3 +215,50 @@ Index: libxslt/pattern.c
doc_info_mismatch:
xsltTransformError(ctxt, NULL, ctxt->inst,
+--- python/libxslt-py.c.orig 2008-04-28 17:25:21.000000000 +0200
++++ python/libxslt-py.c 2008-04-08 19:18:45.000000000 +0200
+@@ -1639,6 +1639,22 @@ libxslt_xsltRegisterTmpRVT(PyObject *sel
+ }
+
+ PyObject *
++libxslt_xsltInitAllDocKeys(PyObject *self ATTRIBUTE_UNUSED, PyObject *args) {
++ PyObject *py_retval;
++ int c_retval;
++ xsltTransformContextPtr ctxt;
++ PyObject *pyobj_ctxt;
++
++ if (!PyArg_ParseTuple(args, (char *)"O:xsltInitAllDocKeys", &pyobj_ctxt))
++ return(NULL);
++ ctxt = (xsltTransformContextPtr) PytransformCtxt_Get(pyobj_ctxt);
++
++ c_retval = xsltInitAllDocKeys(ctxt);
++ py_retval = libxml_intWrap((int) c_retval);
++ return(py_retval);
++}
++
++PyObject *
+ libxslt_xsltPrintErrorContext(PyObject *self ATTRIBUTE_UNUSED, PyObject *args) {
+ xsltTransformContextPtr ctxt;
+ PyObject *pyobj_ctxt;
+--- doc/libxslt-api.xml.orig 2008-04-28 17:24:55.000000000 +0200
++++ doc/libxslt-api.xml 2008-04-08 19:18:48.000000000 +0200
+@@ -529,6 +529,7 @@
+
+
+
++
+
+
+
+@@ -2337,6 +2338,11 @@ exits'/>
+ Initializes the processor (e.g. registers built-in extensions, etc.)
+
+
++
++ INTERNAL ROUTINE ONLY Check if any keys on the current document need to be computed
++
++
++
+
+ Initialize the set of modules with registered stylesheet data
+
diff --git a/libxslt.spec b/libxslt.spec
index c545d89..a49f00c 100644
--- a/libxslt.spec
+++ b/libxslt.spec
@@ -1,7 +1,7 @@
Summary: Library providing the Gnome XSLT engine
Name: libxslt
Version: 1.1.23
-Release: 2%{?dist}%{?extra_release}
+Release: 3%{?dist}%{?extra_release}
License: MIT
Group: Development/Libraries
Source: ftp://xmlsoft.org/XSLT/libxslt-%{version}.tar.gz
@@ -124,6 +124,10 @@ rm -fr %{buildroot}
%doc python/tests/*.xsl
%changelog
+* Mon Apr 28 2008 Daniel Veillard 1.1.23-3.fc10
+- and the previous patch was incomplte breaking the python bindings
+ see 444317 and 444455
+
* Tue Apr 22 2008 Daniel Veillard 1.1.23-2.fc10
- revert a key initialization patch from 1.1.23 which seems broken
see rhbz#442097