Update to 2.11.5 (#2190441)
This commit is contained in:
parent
4e29a82cfa
commit
b581484e98
1
.gitignore
vendored
1
.gitignore
vendored
@ -49,3 +49,4 @@ libxml2-2.7.7.tar.gz
|
||||
/libxml2-2.10.2.tar.xz
|
||||
/libxml2-2.10.3.tar.xz
|
||||
/libxml2-2.10.4.tar.xz
|
||||
/libxml2-2.11.5.tar.xz
|
||||
|
@ -1,8 +1,12 @@
|
||||
Index: libxml2-2.9.5/python/libxml.c
|
||||
---
|
||||
python/libxml.c | 11 ++++++++++-
|
||||
1 file changed, 10 insertions(+), 1 deletion(-)
|
||||
|
||||
Index: libxml2-2.11.1/python/libxml.c
|
||||
===================================================================
|
||||
--- libxml2-2.9.5.orig/python/libxml.c
|
||||
+++ libxml2-2.9.5/python/libxml.c
|
||||
@@ -1620,6 +1620,7 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU
|
||||
--- libxml2-2.11.1.orig/python/libxml.c
|
||||
+++ libxml2-2.11.1/python/libxml.c
|
||||
@@ -1606,6 +1606,7 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU
|
||||
PyObject *message;
|
||||
PyObject *result;
|
||||
char str[1000];
|
||||
@ -10,7 +14,7 @@ Index: libxml2-2.9.5/python/libxml.c
|
||||
|
||||
#ifdef DEBUG_ERROR
|
||||
printf("libxml_xmlErrorFuncHandler(%p, %s, ...) called\n", ctx, msg);
|
||||
@@ -1636,12 +1637,20 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU
|
||||
@@ -1622,12 +1623,20 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU
|
||||
str[999] = 0;
|
||||
va_end(ap);
|
||||
|
||||
@ -26,7 +30,7 @@ Index: libxml2-2.9.5/python/libxml.c
|
||||
- message = libxml_charPtrConstWrap(str);
|
||||
+ message = libxml_charPtrConstWrap(ptr);
|
||||
PyTuple_SetItem(list, 1, message);
|
||||
result = PyEval_CallObject(libxml_xmlPythonErrorFuncHandler, list);
|
||||
result = PyObject_CallObject(libxml_xmlPythonErrorFuncHandler, list);
|
||||
+ /* Forget any errors caused in the error handler. */
|
||||
+ PyErr_Clear();
|
||||
Py_XDECREF(list);
|
14
libxml2.spec
14
libxml2.spec
@ -1,15 +1,15 @@
|
||||
Name: libxml2
|
||||
Version: 2.10.4
|
||||
Release: 3%{?dist}
|
||||
Version: 2.11.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Library providing XML and HTML support
|
||||
|
||||
License: MIT
|
||||
URL: http://xmlsoft.org/
|
||||
Source0: https://download.gnome.org/sources/%{name}/2.10/%{name}-%{version}.tar.xz
|
||||
Source0: https://download.gnome.org/sources/%{name}/2.11/%{name}-%{version}.tar.xz
|
||||
Patch0: libxml2-multilib.patch
|
||||
# Patch from openSUSE.
|
||||
# See: https://bugzilla.gnome.org/show_bug.cgi?id=789714
|
||||
Patch1: libxml2-2.9.8-python3-unicode-errors.patch
|
||||
Patch1: libxml2-2.11.1-python3-unicode-errors.patch
|
||||
|
||||
BuildRequires: cmake-rpm-macros
|
||||
BuildRequires: gcc
|
||||
@ -106,7 +106,7 @@ gzip -9 -c doc/libxml2-api.xml > doc/libxml2-api.xml.gz
|
||||
|
||||
%files
|
||||
%license Copyright
|
||||
%doc NEWS README.md TODO
|
||||
%doc NEWS README.md
|
||||
%{_libdir}/libxml2.so.2*
|
||||
%{_bindir}/xmllint
|
||||
%{_mandir}/man1/xmllint.1*
|
||||
@ -133,7 +133,6 @@ gzip -9 -c doc/libxml2-api.xml > doc/libxml2-api.xml.gz
|
||||
%{_libdir}/libxml2.a
|
||||
|
||||
%files -n python3-%{name}
|
||||
%doc python/TODO
|
||||
%doc doc/*.py
|
||||
%{python3_sitearch}/libxml2mod.so
|
||||
%{python3_sitelib}/libxml2.py
|
||||
@ -142,6 +141,9 @@ gzip -9 -c doc/libxml2-api.xml > doc/libxml2-api.xml.gz
|
||||
%{python3_sitelib}/__pycache__/drv_libxml2.*
|
||||
|
||||
%changelog
|
||||
* Wed Aug 16 2023 David King <amigadave@amigadave.com> - 2.11.5-1
|
||||
- Update to 2.11.5 (#2190441)
|
||||
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libxml2-2.10.4.tar.xz) = 792c1dceb098cd353a7eca4c46d31cce6310b2553d97fd3918cf0b94d93b2480759202036511bde36c24166236bd4616f57e79959eea9afe3f60614bdfe13094
|
||||
SHA512 (libxml2-2.11.5.tar.xz) = 8f087cdaf61957567f04280facc70211c09ca131a532fd13ed4bfc38ddec50e44b1f842b108e635bd4205232036a3e1097904ac016f1fd135bacd17aebb04272
|
||||
|
Loading…
Reference in New Issue
Block a user