Update to 2.9.4.
Apply very hacky patch that removes the no longer in python-3.6 PyVerify_fd symbol.
This commit is contained in:
parent
cc4ca23d03
commit
05bd5b911b
1
.gitignore
vendored
1
.gitignore
vendored
@ -33,3 +33,4 @@ libxml2-2.7.7.tar.gz
|
||||
/libxml2-2.9.1.tar.gz
|
||||
/libxml2-2.9.2.tar.gz
|
||||
/libxml2-2.9.3.tar.gz
|
||||
/libxml2-2.9.4.tar.gz
|
||||
|
12
libxml2-2.9.4-remove-pyverify_fd.patch
Normal file
12
libxml2-2.9.4-remove-pyverify_fd.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nur libxml2-2.9.4.orig/python/types.c libxml2-2.9.4/python/types.c
|
||||
--- libxml2-2.9.4.orig/python/types.c 2016-02-09 03:17:33.000000000 -0700
|
||||
+++ libxml2-2.9.4/python/types.c 2016-12-21 12:34:06.755650986 -0700
|
||||
@@ -31,8 +31,6 @@
|
||||
const char *mode;
|
||||
|
||||
fd = PyObject_AsFileDescriptor(f);
|
||||
- if (!_PyVerify_fd(fd))
|
||||
- return(NULL);
|
||||
/*
|
||||
* Get the flags on the fd to understand how it was opened
|
||||
*/
|
12
libxml2.spec
12
libxml2.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Library providing XML and HTML support
|
||||
Name: libxml2
|
||||
Version: 2.9.3
|
||||
Release: 5%{?dist}%{?extra_release}
|
||||
Version: 2.9.4
|
||||
Release: 1%{?dist}%{?extra_release}
|
||||
License: MIT
|
||||
Group: Development/Libraries
|
||||
Source: ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
|
||||
@ -18,6 +18,9 @@ BuildRequires: xz-devel
|
||||
URL: http://xmlsoft.org/
|
||||
Patch0: libxml2-multilib.patch
|
||||
Patch1: libxml2-2.9.0-do-not-check-crc.patch
|
||||
# In python3.6 _PyVerify_fd is no more
|
||||
# http://bugs.python.org/issue23524
|
||||
Patch2: libxml2-2.9.4-remove-pyverify_fd.patch
|
||||
|
||||
%description
|
||||
This library allows to manipulate XML files. It includes support
|
||||
@ -100,6 +103,7 @@ at parse time or later once the document has been modified.
|
||||
%patch0 -p1
|
||||
# workaround for #877567 - Very weird bug gzip decompression bug in "recent" libxml2 versions
|
||||
%patch1 -p1 -b .do-not-check-crc
|
||||
%patch2 -p1
|
||||
|
||||
mkdir py3doc
|
||||
cp doc/*.py py3doc
|
||||
@ -211,6 +215,10 @@ rm -fr %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 21 2016 Kevin Fenzi <kevin@scrye.com> - 2.9.4-1
|
||||
- Update to 2.9.4.
|
||||
- Apply very hacky patch that removes the no longer in python-3.6 PyVerify_fd symbol.
|
||||
|
||||
* Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.9.3-5
|
||||
- Rebuild for Python 3.6
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user