Don't use -Werror

This commit is contained in:
Matthias Clasen 2005-02-01 16:27:31 +00:00
parent bcedaca938
commit c5c37810fa
2 changed files with 24 additions and 0 deletions

View File

@ -0,0 +1,22 @@
--- libxklavier-1.14/libxklavier/Makefile.am.werror 2005-02-01 11:24:34.684925000 -0500
+++ libxklavier-1.14/libxklavier/Makefile.am 2005-02-01 11:24:44.044556000 -0500
@@ -14,7 +14,7 @@
ENABLE_XMM_SUPPORT_CFLAG = -DDISABLE_XMM_SUPPORT=1
endif
-AM_CFLAGS=-Wall -Werror -DDATA_DIR=\"$(datadir)/$(PACKAGE)\" \
+AM_CFLAGS=-Wall -DDATA_DIR=\"$(datadir)/$(PACKAGE)\" \
-I. -I$(includedir) $(XML_CFLAGS) -I$(x_includes) -I$(top_srcdir) \
$(XKB_HEADERS_PRESENT_CFLAG) \
$(ENABLE_XKB_SUPPORT_CFLAG) \
--- libxklavier-1.14/libxklavier/Makefile.in.werror 2005-02-01 11:25:24.981578000 -0500
+++ libxklavier-1.14/libxklavier/Makefile.in 2005-02-01 11:25:35.528023000 -0500
@@ -205,7 +205,7 @@
@ENABLE_XKB_SUPPORT_TRUE@ENABLE_XKB_SUPPORT_CFLAG = -DENABLE_XKB_SUPPORT=1
@ENABLE_XMM_SUPPORT_FALSE@ENABLE_XMM_SUPPORT_CFLAG = -DDISABLE_XMM_SUPPORT=1
@ENABLE_XMM_SUPPORT_TRUE@ENABLE_XMM_SUPPORT_CFLAG = -DENABLE_XMM_SUPPORT=1
-AM_CFLAGS = -Wall -Werror -DDATA_DIR=\"$(datadir)/$(PACKAGE)\" \
+AM_CFLAGS = -Wall -DDATA_DIR=\"$(datadir)/$(PACKAGE)\" \
-I. -I$(includedir) $(XML_CFLAGS) -I$(x_includes) -I$(top_srcdir) \
$(XKB_HEADERS_PRESENT_CFLAG) \
$(ENABLE_XKB_SUPPORT_CFLAG) \

View File

@ -9,6 +9,7 @@ BuildRequires: doxygen
Source: http://gswitchit.sourceforge.net/%{name}-%{version}.tar.gz
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
Patch0: libxklavier-1.14-werror.patch
%description
libxklavier is a library providing high-level API for X Keyboard Extension
@ -26,6 +27,7 @@ Libraries, include files, etc you can use to develop libxklavier applications.
%prep
%setup -q
%patch0 -p1 -b .werror
%build