Drop patches included in new release

This commit is contained in:
Björn Esser 2019-01-24 20:39:56 +01:00
parent 2392d72d5f
commit d2740d7f05
No known key found for this signature in database
GPG Key ID: F52E98007594C21D
4 changed files with 0 additions and 195 deletions

View File

@ -1,112 +0,0 @@
From a32ce8344554128320ba3a7757260c8632db8b3e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
Date: Mon, 21 Jan 2019 14:55:34 +0100
Subject: [PATCH] Add generated C++-guards to <xcrypt.h>.
---
.gitignore | 1 +
Makefile.am | 32 ++++++++++++++++++++------------
NEWS | 1 +
xcrypt.h => xcrypt.h.in | 4 ++++
4 files changed, 26 insertions(+), 12 deletions(-)
rename xcrypt.h => xcrypt.h.in (98%)
diff --git a/Makefile.am b/Makefile.am
index 907e80e..2a53aaa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,9 +19,10 @@ TEST_EXTENSIONS = .sh
EXTRA_DIST = \
LICENSING THANKS \
- crypt.h.in.in libcrypt.map.in libcrypt.minver \
- gen-map.awk gen-vers.awk gen-crypt-h.awk \
- gen-hashes.awk sel-hashes.awk hashes.lst
+ crypt.h.in.in xcrypt.h.in libcrypt.map.in \
+ libcrypt.minver gen-map.awk gen-vers.awk \
+ gen-crypt-h.awk gen-hashes.awk sel-hashes.awk \
+ hashes.lst
notrans_dist_man3_MANS = \
crypt.3 crypt_r.3 crypt_ra.3 crypt_rn.3 \
@@ -40,9 +41,9 @@ noinst_HEADERS = \
crypt-obsolete.h crypt-port.h test-des-cases.h
if ENABLE_XCRYPT_COMPAT_FILES
-include_HEADERS = xcrypt.h
+nodist_include_HEADERS += xcrypt.h
else
-noinst_HEADERS += xcrypt.h
+nodist_noinst_HEADERS += xcrypt.h
endif
@@ -98,12 +99,13 @@ CLEANFILES = Makefile.deps.T Makefile.deps \
libcrypt.map libcrypt.map.T \
crypt-symbol-vers.h crypt-symbol-vers.h.T \
crypt-hashes.h crypt-hashes.h.T \
- crypt.h crypt.h.T *.gcda *.gcno
+ crypt.h crypt.h.T xcrypt.h xcrypt.h.T \
+ *.gcda *.gcno
DISTCLEANFILES = .deps/*.Plo
# Empty target to have needed headers pre-generated before any other target.
-Makefile.deps: crypt.h
+Makefile.deps: xcrypt.h
$(AM_V_GEN)LC_ALL=C echo "# Deps" > Makefile.deps.T
$(AM_V_at)mv -f Makefile.deps.T Makefile.deps
@@ -115,6 +117,12 @@ libcrypt.map: libcrypt.map.in gen-map.awk Makefile
-f $(srcdir)/gen-map.awk $(srcdir)/libcrypt.map.in > libcrypt.map.T
$(AM_V_at)mv -f libcrypt.map.T libcrypt.map
+crypt-hashes.h: hashes.lst gen-hashes.awk Makefile
+ $(AM_V_GEN)LC_ALL=C $(AWK) -f $(srcdir)/gen-hashes.awk \
+ -v ENABLED_HASHES=$(hashes_enabled) \
+ $(srcdir)/hashes.lst > crypt-hashes.h.T
+ $(AM_V_at)mv -f crypt-hashes.h.T crypt-hashes.h
+
crypt-symbol-vers.h: libcrypt.map.in gen-vers.awk Makefile
$(AM_V_GEN)LC_ALL=C $(AWK) \
-v SYMVER_MIN=$(SYMVER_MIN) \
@@ -134,11 +142,11 @@ crypt.h: crypt.h.in crypt-hashes.h crypt-symbol-vers.h gen-crypt-h.awk config.h
$(SED) -i -e "s/@DEFAULT_PREFIX_ENABLED@/0/g" crypt.h.T
$(AM_V_at)mv -f crypt.h.T crypt.h
-crypt-hashes.h: hashes.lst gen-hashes.awk Makefile
- $(AM_V_GEN)LC_ALL=C $(AWK) -f $(srcdir)/gen-hashes.awk \
- -v ENABLED_HASHES=$(hashes_enabled) \
- $(srcdir)/hashes.lst > crypt-hashes.h.T
- $(AM_V_at)mv -f crypt-hashes.h.T crypt-hashes.h
+xcrypt.h: crypt.h
+ $(AM_V_GEN)LC_ALL=C $(AWK) \
+ -f $(srcdir)/gen-crypt-h.awk config.h $(srcdir)/xcrypt.h.in \
+ > xcrypt.h.T
+ $(AM_V_at)mv -f xcrypt.h.T xcrypt.h
install_exec_hook_targets =
diff --git a/xcrypt.h b/xcrypt.h.in
similarity index 98%
rename from xcrypt.h
rename to xcrypt.h.in
index f1d4d48..332722c 100644
--- a/xcrypt.h
+++ b/xcrypt.h.in
@@ -22,6 +22,8 @@
#include <crypt.h>
+/*HEADER*/
+
/* Those are kept for code compatibility with older versions
(v3.1.1 and earlier) of libxcrypt.
We intentionally declare these functions using macros here,
@@ -52,4 +54,6 @@ extern char * __REDIRECT_NTH (xcrypt_gensalt_r, (const char *__prefix,
# endif
#endif
+/*TRAILER*/
+
#endif /* xcrypt.h */

View File

@ -1,48 +0,0 @@
From 6ab065482c8fa2893dcf6cdef2be0d87bdf3f224 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
Date: Mon, 21 Jan 2019 16:07:37 +0100
Subject: [PATCH] crypt-port: Declare strong_alias explicitly __THROW.
Closes: #76.
---
crypt-port.h | 26 +++++++++++++++++++-------
1 file changed, 19 insertions(+), 7 deletions(-)
diff --git a/crypt-port.h b/crypt-port.h
index 2beb558..379a76b 100644
--- a/crypt-port.h
+++ b/crypt-port.h
@@ -165,14 +165,26 @@ _crypt_strcpy_or_abort (void *, const size_t, const void *);
#define strong_alias(name, aliasname) _strong_alias(name, aliasname)
/* Darwin doesn't support alias attributes. */
-#ifndef __APPLE__
-# define _strong_alias(name, aliasname) \
- extern __typeof (name) aliasname __attribute__ ((alias (#name)))
+#ifdef __cplusplus
+# ifndef __APPLE__
+# define _strong_alias(name, aliasname) \
+ extern __typeof (name) aliasname __THROW __attribute__ ((alias (#name)))
+# else
+# define _strong_alias(name, aliasname) \
+ __THROW __asm__(".globl _" #aliasname); \
+ __THROW __asm__(".set _" #aliasname ", _" #name); \
+ extern __typeof(name) aliasname __THROW
+# endif
#else
-# define _strong_alias(name, aliasname) \
- __asm__(".globl _" #aliasname); \
- __asm__(".set _" #aliasname ", _" #name); \
- extern __typeof(name) aliasname
+# ifndef __APPLE__
+# define _strong_alias(name, aliasname) \
+ extern __typeof (name) aliasname __attribute__ ((alias (#name))) __THROW
+# else
+# define _strong_alias(name, aliasname) \
+ __asm__(".globl _" #aliasname) __THROW; \
+ __asm__(".set _" #aliasname ", _" #name) __THROW; \
+ extern __typeof(name) aliasname __THROW
+# endif
#endif
/* Set the symbol version for EXTNAME, which uses INTNAME as its

View File

@ -1,32 +0,0 @@
From ec2078568431d65aec3b878cc871e10ad11a9d50 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
Date: Mon, 21 Jan 2019 16:15:42 +0100
Subject: [PATCH] test-crypt-bcrypt: Fix -Werror=format-overflow.
---
test-crypt-bcrypt.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/test-crypt-bcrypt.c b/test-crypt-bcrypt.c
index 947639f..249b1af 100644
--- a/test-crypt-bcrypt.c
+++ b/test-crypt-bcrypt.c
@@ -189,6 +189,7 @@ main (void)
int ok = !setting || hash[0] != '*';
char s_buf[30];
char o_buf[sizeof (struct crypt_data)];
+ const struct crypt_data *o_buf_ptr = (void *) o_buf;
int errnm, match;
if (!setting)
@@ -243,8 +244,8 @@ main (void)
{
printf ("FAIL: %d/crypt_rn: key=%s setting=%s: "
"xhash=%s xmagic=%s xerr=%d, p=%s obuf=%s err=%s\n",
- i, key, setting, hash, x, !ok, p, o_buf,
- strerror (errnm));
+ i, key, setting, hash, x, !ok, p,
+ o_buf_ptr->output, strerror (errnm));
status = 1;
continue;
}

View File

@ -120,9 +120,6 @@ URL: https://github.com/besser82/%{name}
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
# Patch 0000 - 2999: Backported patches from upstream.
Patch0000: %{url}/commit/a32ce8344554128320ba3a7757260c8632db8b3e.patch#/%{name}-4.4.2-cxx_guard_in_xcrypt_h.patch
Patch0001: %{url}/commit/6ab065482c8fa2893dcf6cdef2be0d87bdf3f224.patch#/%{name}-4.4.2-gcc9_declare_strong_alias_explicitly___THROW.patch
Patch0002: %{url}/commit/ec2078568431d65aec3b878cc871e10ad11a9d50.patch#/%{name}-4.4.2-gcc9_fix_Werror_format-overflow.patch
# Patch 3000 - 5999: Backported patches from pull requests.