libxcb/libxcb-1.3-to-git-e06955.patch
Adam Jackson fedfe4e323 - libxcb 1.3
- List DSO versions explicitly.
- Don't package any xprint bits. Seriously, no.
2009-07-14 17:10:59 +00:00

27 lines
1020 B
Diff

diff --git a/src/Makefile.am b/src/Makefile.am
index e13092a..5de3b09 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -75,7 +75,7 @@ EXTSOURCES += randr.c
EXTENSION_XML += randr.xml
if BUILD_RANDR
lib_LTLIBRARIES += libxcb-randr.la
-libxcb_randr_la_LDFLAGS = -version-info 1:0:0
+libxcb_randr_la_LDFLAGS = -version-info 1:0:1
libxcb_randr_la_LIBADD = $(XCB_LIBS)
nodist_libxcb_randr_la_SOURCES = randr.c randr.h
endif
diff --git a/src/xcb_out.c b/src/xcb_out.c
index 4c6ab13..b3050fe 100644
--- a/src/xcb_out.c
+++ b/src/xcb_out.c
@@ -242,7 +242,7 @@ unsigned int xcb_send_request(xcb_connection_t *c, int flags, struct iovec *vect
vector[1].iov_base = (uint32_t *) vector[1].iov_base + 1;
vector[1].iov_len -= sizeof(uint32_t);
}
- vector[0].iov_len = sizeof(uint32_t) * (prefix[0] ? 1 : 0 | prefix[2] ? 2 : 0);
+ vector[0].iov_len = sizeof(uint32_t) * ((prefix[0] ? 1 : 0) + (prefix[2] ? 2 : 0));
vector[0].iov_base = prefix + !prefix[0];
}