libxcb 1.11

This commit is contained in:
Adam Jackson 2014-10-01 16:45:49 -04:00
parent 7a45b5cdc1
commit 88c12336c8
4 changed files with 7 additions and 115 deletions

1
.gitignore vendored
View File

@ -9,3 +9,4 @@ libxcb-1.7.tar.bz2
/libxcb-1.9.tar.bz2 /libxcb-1.9.tar.bz2
/libxcb-1.9.1.tar.bz2 /libxcb-1.9.1.tar.bz2
/libxcb-1.10.tar.bz2 /libxcb-1.10.tar.bz2
/libxcb-1.11.tar.bz2

View File

@ -1,108 +0,0 @@
From 3b72a2c9d1d656c74c691a45689e1d637f669e3a Mon Sep 17 00:00:00 2001
From: Kenneth Graunke <kenneth@whitecape.org>
Date: Fri, 3 Jan 2014 15:08:33 -0800
Subject: [PATCH] Force XCB event structures with 64-bit extended fields to be
packed.
With the advent of the Present extension, some events (such as
PresentCompleteNotify) now use native 64-bit types on the wire.
For XGE events, we insert an extra "uint32_t full_sequence" field
immediately after the first 32 bytes of data. Normally, this causes
the subsequent fields to be shifted over by 4 bytes, and the structure
to grow in size by 4 bytes. Everything works fine.
However, if event contains 64-bit extended fields, this may result in
the compiler adding an extra 4 bytes of padding so that those fields
remain aligned on 64-bit boundaries. This causes the structure to grow
by 8 bytes, not 4. Unfortunately, XCB doesn't realize this, and
always believes that the length only increased by 4. read_packet()
then fails to malloc enough memory to hold the event, and the event
processing code uses the wrong offsets.
To fix this, mark any event structures containing 64-bit extended
fields with __attribute__((__packed__)).
v2: Use any(...) instead of True in (...), as suggested by
Daniel Martin.
v3 (Alan Coopersmith): Fix build with Solaris Studio 12.3 by moving the
attribute to after the structure definition.
Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
Reviewed-by: Keith Packard <keithp@keithp.com> [v1]
Reviewed-by: Josh Triplett <josh@joshtriplett.org> [v1]
Reviewed-by: Daniel Martin <consume.noise@gmail.com>
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
---
src/c_client.py | 12 +++++++++---
src/xcb.h | 2 ++
2 files changed, 11 insertions(+), 3 deletions(-)
diff --git a/src/c_client.py b/src/c_client.py
index 99fd307..45de544 100644
--- a/src/c_client.py
+++ b/src/c_client.py
@@ -1762,7 +1762,7 @@ def c_simple(self, name):
# Iterator
_c_iterator(self, name)
-def _c_complex(self):
+def _c_complex(self, force_packed = False):
'''
Helper function for handling all structure types.
Called for all structs, requests, replies, events, errors.
@@ -1817,7 +1817,7 @@ def _c_complex(self):
if b.type.has_name:
_h(' } %s;', b.c_field_name)
- _h('} %s;', self.c_type)
+ _h('} %s%s;', 'XCB_PACKED ' if force_packed else '', self.c_type)
def c_struct(self, name):
'''
@@ -2902,6 +2902,7 @@ def c_event(self, name):
# events while generating the structure for them. Otherwise we would read
# garbage (the internal full_sequence) when accessing normal event fields
# there.
+ force_packed = False
if hasattr(self, 'is_ge_event') and self.is_ge_event and self.name == name:
event_size = 0
for field in self.fields:
@@ -2911,6 +2912,11 @@ def c_event(self, name):
full_sequence = Field(tcard32, tcard32.name, 'full_sequence', False, True, True)
idx = self.fields.index(field)
self.fields.insert(idx + 1, full_sequence)
+
+ # If the event contains any 64-bit extended fields, they need
+ # to remain aligned on a 64-bit boundary. Adding full_sequence
+ # would normally break that; force the struct to be packed.
+ force_packed = any(f.type.size == 8 and f.type.is_simple for f in self.fields[(idx+1):])
break
_c_type_setup(self, name, ('event',))
@@ -2920,7 +2926,7 @@ def c_event(self, name):
if self.name == name:
# Structure definition
- _c_complex(self)
+ _c_complex(self, force_packed)
else:
# Typedef
_h('')
diff --git a/src/xcb.h b/src/xcb.h
index e62c985..73c77a3 100644
--- a/src/xcb.h
+++ b/src/xcb.h
@@ -51,6 +51,8 @@ extern "C" {
* @file xcb.h
*/
+#define XCB_PACKED __attribute__((__packed__))
+
/**
* @defgroup XCB_Core_API XCB Core API
* @brief Core API of the XCB library.
--
1.8.4.2

View File

@ -1,8 +1,8 @@
%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}} %{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
Name: libxcb Name: libxcb
Version: 1.10 Version: 1.11
Release: 3%{?dist} Release: 1%{?dist}
Summary: A C binding to the X11 protocol Summary: A C binding to the X11 protocol
Group: System Environment/Libraries Group: System Environment/Libraries
@ -16,9 +16,6 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# the pkgconfig file so libs that link against libxcb know this... # the pkgconfig file so libs that link against libxcb know this...
Source1: pthread-stubs.pc.in Source1: pthread-stubs.pc.in
# http://cgit.freedesktop.org/xcb/libxcb/patch/?id=3b72a2c9d1d656c74c691a45689e1d637f669e3a
Patch0: 0001-Force-XCB-event-structures-with-64-bit-extended-fiel.patch
BuildRequires: autoconf automake libtool pkgconfig BuildRequires: autoconf automake libtool pkgconfig
BuildRequires: doxygen BuildRequires: doxygen
BuildRequires: graphviz BuildRequires: graphviz
@ -53,7 +50,6 @@ The %{name}-doc package contains documentation for the %{name} library.
%prep %prep
%setup -q %setup -q
%patch0 -p1
%build %build
sed -i 's/pthread-stubs //' configure.ac sed -i 's/pthread-stubs //' configure.ac
@ -116,6 +112,9 @@ rm -rf $RPM_BUILD_ROOT
%{_pkgdocdir} %{_pkgdocdir}
%changelog %changelog
* Wed Oct 01 2014 Adam Jackson <ajax@redhat.com> 1.11-1
- libxcb 1.11
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10-3 * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild

View File

@ -1 +1 @@
074c335cc4453467eeb234e3dadda700 libxcb-1.10.tar.bz2 5a873ebd383d1a60612dd6ec6b42c781 libxcb-1.11.tar.bz2