libxcb 1.1

This commit is contained in:
Adam Jackson 2007-11-12 15:36:24 +00:00
parent b6f56cd794
commit 3bf595970b
6 changed files with 29 additions and 28 deletions

View File

@ -1 +1 @@
libxcb-1.0.tar.bz2
libxcb-1.1.tar.bz2

View File

@ -1,12 +0,0 @@
diff -up libxcb-1.0/configure.ac.jx libxcb-1.0/configure.ac
--- libxcb-1.0/configure.ac.jx 2006-11-23 10:33:01.000000000 -0500
+++ libxcb-1.0/configure.ac 2007-06-29 15:06:00.000000000 -0400
@@ -31,7 +31,7 @@ AC_SUBST(HTML_CHECK_RESULT)
# Checks for pkg-config packages
PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.0)
-NEEDED="xau pthread-stubs"
+NEEDED="xau"
PKG_CHECK_MODULES(NEEDED, $NEEDED)
PKG_CHECK_MODULES(XDMCP, xdmcp,

View File

@ -1,13 +1,11 @@
diff -up libxcb-1.0/src/xcb_util.c.jx libxcb-1.0/src/xcb_util.c
--- libxcb-1.0/src/xcb_util.c.jx 2006-11-21 23:20:15.000000000 -0500
+++ libxcb-1.0/src/xcb_util.c 2007-08-24 14:02:08.000000000 -0400
@@ -213,14 +213,23 @@ static int _xcb_open_tcp(char *host, con
static int _xcb_open_unix(const char *file)
{
int fd;
- struct sockaddr_un addr = { AF_UNIX };
diff -up libxcb-1.1/src/xcb_util.c.abstract libxcb-1.1/src/xcb_util.c
--- libxcb-1.1/src/xcb_util.c.abstract 2007-10-23 12:44:59.000000000 -0400
+++ libxcb-1.1/src/xcb_util.c 2007-11-12 10:32:37.000000000 -0500
@@ -249,13 +249,22 @@ static int _xcb_open_unix(char *protocol
if (protocol && strcmp("unix",protocol))
return -1;
- strcpy(addr.sun_path, file);
+ struct sockaddr_un addr;
+ memset(&addr, 0, sizeof(addr));
+ addr.sun_family = AF_UNIX;

View File

@ -0,0 +1,12 @@
diff -up libxcb-1.1/configure.ac.pthread-stubs libxcb-1.1/configure.ac
--- libxcb-1.1/configure.ac.pthread-stubs 2007-11-04 18:17:11.000000000 -0500
+++ libxcb-1.1/configure.ac 2007-11-12 10:27:06.000000000 -0500
@@ -31,7 +31,7 @@ AC_SUBST(HTML_CHECK_RESULT)
# Checks for pkg-config packages
PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.1)
-NEEDED="pthread-stubs xau >= 0.99.2"
+NEEDED="xau >= 0.99.2"
PKG_CHECK_MODULES(NEEDED, $NEEDED)
have_xdmcp="no"

View File

@ -1,6 +1,6 @@
Name: libxcb
Version: 1.0
Release: 3%{?dist}
Version: 1.1
Release: 1%{?dist}
Summary: A C binding to the X11 protocol
Group: System Environment/Libraries
@ -9,15 +9,15 @@ URL: http://xcb.freedesktop.org/
Source0: http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Patch0: libxcb-1.0-no-pthread-stubs.patch
Patch1: libxcb-1.0-abstract-socket.patch
Patch0: libxcb-1.1-no-pthread-stubs.patch
Patch1: libxcb-1.1-abstract-socket.patch
BuildRequires: autoconf automake libtool pkgconfig
BuildRequires: doxygen
BuildRequires: graphviz
BuildRequires: libXau-devel
BuildRequires: libxslt
BuildRequires: xcb-proto
BuildRequires: xcb-proto >= 1.1
BuildRequires: xorg-x11-proto-devel
BuildRequires: xorg-x11-util-macros
@ -80,6 +80,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/doc/%{name}-%{version}
%changelog
* Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
- libxcb 1.1
* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
- libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
abstract-namespace unix sockets to filesystem-bound sockets.

View File

@ -1 +1 @@
0eb951fd0fa9542dbe4fc3530b81a3b6 libxcb-1.0.tar.bz2
9310b02433273d75d42f10da3c7455aa libxcb-1.1.tar.bz2