new upstream release 0.10.2
This commit is contained in:
parent
7eb59c2257
commit
16c86a63f1
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
||||
/libwpd-0.9.9.tar.xz
|
||||
/libwpd-0.10.0.tar.xz
|
||||
/libwpd-0.10.1.tar.xz
|
||||
/libwpd-0.10.2.tar.xz
|
||||
|
@ -1,42 +0,0 @@
|
||||
--- libwpd/src/lib/WP5StylesListener.cpp
|
||||
+++ libwpd/src/lib/WP5StylesListener.cpp
|
||||
@@ -85,8 +85,9 @@
|
||||
m_currentPage = WPXPageSpan(m_pageList.back(), 0.0, 0.0);
|
||||
m_currentPage.setPageSpan(1);
|
||||
|
||||
- for (std::vector<WPXHeaderFooter>::const_iterator HFiter = (m_nextPage.getHeaderFooterList()).begin();
|
||||
- HFiter != (m_nextPage.getHeaderFooterList()).end(); ++HFiter)
|
||||
+ std::vector<WPXHeaderFooter> headerFooterList = m_nextPage.getHeaderFooterList();
|
||||
+ for (std::vector<WPXHeaderFooter>::const_iterator HFiter = headerFooterList.begin();
|
||||
+ HFiter != headerFooterList.end(); ++HFiter)
|
||||
{
|
||||
if ((*HFiter).getOccurrence() != NEVER)
|
||||
{
|
||||
--- libwpd/src/lib/WP42StylesListener.cpp
|
||||
+++ libwpd/src/lib/WP42StylesListener.cpp
|
||||
@@ -84,8 +84,9 @@
|
||||
m_currentPage = WPXPageSpan(m_pageList.back(), 0.0, 0.0);
|
||||
m_currentPage.setPageSpan(1);
|
||||
|
||||
- for (std::vector<WPXHeaderFooter>::const_iterator HFiter = (m_nextPage.getHeaderFooterList()).begin();
|
||||
- HFiter != (m_nextPage.getHeaderFooterList()).end(); ++HFiter)
|
||||
+ std::vector<WPXHeaderFooter> headerFooterList = m_nextPage.getHeaderFooterList();
|
||||
+ for (std::vector<WPXHeaderFooter>::const_iterator HFiter = headerFooterList.begin();
|
||||
+ HFiter != headerFooterList.end(); ++HFiter)
|
||||
{
|
||||
if ((*HFiter).getOccurrence() != NEVER)
|
||||
{
|
||||
--- libwpd/src/lib/WP1StylesListener.cpp
|
||||
+++ libwpd/src/lib/WP1StylesListener.cpp
|
||||
@@ -83,8 +83,9 @@
|
||||
m_currentPage = WPXPageSpan(m_pageList.back(), 0.0, 0.0);
|
||||
m_currentPage.setPageSpan(1);
|
||||
|
||||
- for (std::vector<WPXHeaderFooter>::const_iterator HFiter = (m_nextPage.getHeaderFooterList()).begin();
|
||||
- HFiter != (m_nextPage.getHeaderFooterList()).end(); ++HFiter)
|
||||
+ std::vector<WPXHeaderFooter> headerFooterList = m_nextPage.getHeaderFooterList();
|
||||
+ for (std::vector<WPXHeaderFooter>::const_iterator HFiter = headerFooterList.begin();
|
||||
+ HFiter != headerFooterList.end(); ++HFiter)
|
||||
{
|
||||
if ((*HFiter).getOccurrence() != NEVER)
|
||||
{
|
10
libwpd.spec
10
libwpd.spec
@ -2,19 +2,18 @@
|
||||
|
||||
Name: libwpd
|
||||
Summary: A library for import of WordPerfect documents
|
||||
Version: 0.10.1
|
||||
Release: 8%{?dist}
|
||||
Version: 0.10.2
|
||||
Release: 1%{?dist}
|
||||
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
|
||||
URL: http://libwpd.sf.net/
|
||||
License: LGPLv2+ or MPLv2.0
|
||||
|
||||
BuildRequires: boost-devel
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: help2man
|
||||
BuildRequires: pkgconfig(librevenge-0.0)
|
||||
BuildRequires: pkgconfig(zlib)
|
||||
|
||||
Patch0: libwpd-tdf112269.patch
|
||||
|
||||
%description
|
||||
%{name} is a library for import of WordPerfect documents.
|
||||
|
||||
@ -92,6 +91,9 @@ install -m 0644 wpd2*.1 %{buildroot}/%{_mandir}/man1
|
||||
%doc docs/%{name}.png
|
||||
|
||||
%changelog
|
||||
* Tue Sep 12 2017 David Tardon <dtardon@redhat.com> - 0.10.2-1
|
||||
- new upstream release
|
||||
|
||||
* Thu Sep 07 2017 Caolán McNamara <caolanm@redhat.com> - 0.10.1-8
|
||||
- Related: rhbz#1489337 extend to earlier file format version
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user