new upstream release 0.10.3
This commit is contained in:
parent
e42834b844
commit
080055a44f
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
||||
/libwpd-0.10.0.tar.xz
|
||||
/libwpd-0.10.1.tar.xz
|
||||
/libwpd-0.10.2.tar.xz
|
||||
/libwpd-0.10.3.tar.xz
|
||||
|
@ -1,29 +0,0 @@
|
||||
diff -ru libwpd-0.10.2/src/lib/WP6ContentListener.cpp libwpd-0.10.2.new/src/lib/WP6ContentListener.cpp
|
||||
--- libwpd-0.10.2/src/lib/WP6ContentListener.cpp 2017-09-08 18:04:25.000000000 +0100
|
||||
+++ libwpd-0.10.2.new/src/lib/WP6ContentListener.cpp 2018-10-30 10:54:22.326697162 +0000
|
||||
@@ -1311,7 +1311,10 @@
|
||||
m_ps->m_tableDefinition.m_columnsProperties.clear();
|
||||
|
||||
// pull a table definition off of our stack
|
||||
- m_parseState->m_currentTable = m_parseState->m_tableList[m_parseState->m_nextTableIndice++];
|
||||
+ auto index = m_parseState->m_nextTableIndice++;
|
||||
+ if (index >= m_parseState->m_tableList.size())
|
||||
+ throw ParseException();
|
||||
+ m_parseState->m_currentTable = m_parseState->m_tableList[index];
|
||||
if (!m_parseState->m_currentTable)
|
||||
throw ParseException();
|
||||
m_parseState->m_currentTable->makeBordersConsistent();
|
||||
diff -ru libwpd-0.10.2/src/lib/WPXTable.h libwpd-0.10.2.new/src/lib/WPXTable.h
|
||||
--- libwpd-0.10.2/src/lib/WPXTable.h 2015-12-30 08:27:30.000000000 +0000
|
||||
+++ libwpd-0.10.2.new/src/lib/WPXTable.h 2018-10-30 10:55:41.264362182 +0000
|
||||
@@ -92,6 +92,10 @@
|
||||
{
|
||||
m_tableList->push_back(table);
|
||||
}
|
||||
+ size_t size() const
|
||||
+ {
|
||||
+ return m_tableList->size();
|
||||
+ }
|
||||
|
||||
private:
|
||||
void release();
|
11
libwpd.spec
11
libwpd.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Name: libwpd
|
||||
Summary: A library for import of WordPerfect documents
|
||||
Version: 0.10.2
|
||||
Release: 4%{?dist}
|
||||
Version: 0.10.3
|
||||
Release: 1%{?dist}
|
||||
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
|
||||
URL: http://libwpd.sf.net/
|
||||
License: LGPLv2+ or MPLv2.0
|
||||
@ -17,8 +17,6 @@ BuildRequires: pkgconfig(librevenge-generators-0.0)
|
||||
BuildRequires: pkgconfig(librevenge-stream-0.0)
|
||||
BuildRequires: pkgconfig(zlib)
|
||||
|
||||
Patch0: 0001-Resolves-rhbz-1643752-bounds-check-m_currentTable-ac.patch
|
||||
|
||||
%description
|
||||
%{name} is a library for import of WordPerfect documents.
|
||||
|
||||
@ -48,7 +46,7 @@ The %{name}-doc package contains API documentation for %{name}.
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
%configure --disable-static --disable-werror --disable-silent-rules
|
||||
%configure --disable-static --disable-silent-rules
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
make %{?_smp_mflags}
|
||||
@ -96,6 +94,9 @@ install -m 0644 wpd2*.1 %{buildroot}/%{_mandir}/man1
|
||||
%doc docs/%{name}.png
|
||||
|
||||
%changelog
|
||||
* Sat Dec 29 2018 David Tardon <dtardon@redhat.com> - 0.10.3-1
|
||||
- new upstream release
|
||||
|
||||
* Tue Oct 30 2018 Caolán McNamara <caolanm@redhat.com> - 0.10.2-4
|
||||
- Resolves: rhbz#1643752 crash in specific wpd file
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libwpd-0.10.2.tar.xz) = 821dbc0535ebd4fa41bcf984e344e11176862676c66abebe45cf4284f8de6e6cc7629f8a605b169d034a5c2f3e2461513d61e11e549ca73b8328eb66ac3bdd79
|
||||
SHA512 (libwpd-0.10.3.tar.xz) = df14f11e885a583218afdb0aafe8a15d01890289af8b316cd1d225e4a83996c82907fbfdde83257dc71d99bfbc5b21b2c96536f5a783748388659155dbdb8949
|
||||
|
Loading…
Reference in New Issue
Block a user